source: projects/specs/trunk/k/kdegames/kdegames-vl.spec @ 7105

Revision 7105, 17.6 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.3, etc

Line 
1Name: kdegames
2Summary: KDE Games
3Summary(ja): KDE ゲーム集
4Version: 4.9.3
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Games
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: desktop-file-utils
15BuildRequires: ggz-client-libs-devel
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libsndfile-devel
18BuildRequires: libXpm-devel
19BuildRequires: openal-soft-devel
20BuildRequires: qca2-devel
21BuildRequires: qhull-devel
22BuildRequires: python-devel
23BuildRequires: PyQt4-devel
24BuildRequires: PyKDE4-devel
25BuildRequires: sqlite3-devel
26BuildRequires: python-twisted
27
28Requires: %{name}-libs = %{version}-%{release}
29Requires: PyKDE4
30Requires: python-twisted
31Requires(post): ggz-client-libs
32Requires(post): desktop-file-utils
33Requires(preun): ggz-client-libs
34Requires(postun): desktop-file-utils
35
36Obsoletes: kdegames4 < %{version}-%{release}
37Provides:  kdegames4 = %{version}-%{release}
38
39Obsoletes: ksudoku < 0.5-1
40Provides:  ksudoku = 0.5-1
41
42Obsoletes: ksirk < %{version}-%{release}
43Provides:  ksirk = %{version}-%{release}
44
45%description
46Games for the K Desktop Environment 4, including:
47* bomber
48* bovo
49* kapman
50* katomic
51* kblackbox
52* kblocks
53* kbounce
54* kbreakout
55* kdiamond
56* kfourinline
57* kgoldrunner
58* killbots
59* kiriki
60* kjumpingcube
61* klines
62* klickety
63* kmahjongg
64* kmines
65* knetwalk
66* kolf
67* kollision
68* konquest
69* kpat
70* kreversi
71* ksame
72* kshisen
73* ksinkships
74* ksirk
75* kspaceduel
76* ksquares
77* ksudoku
78* ktuberling
79* kubrick
80* lskat
81
82%package libs
83Summary: Runtime libraries for %{name}
84Summary(ja): %{name} のランタイムライブラリ
85Group:   System Environment/Libraries
86
87%description libs
88%{summary}.
89
90%package devel
91Summary: Development files for %{name}
92Summary(ja): %{name} の開発用ファイル
93Group: Development/Libraries
94Requires: %{name}-libs = %{version}-%{release}
95Requires: kdelibs4-devel
96Obsoletes: kdegames4-devel < %{version}-%{release}
97Provides:  kdegames4-devel = %{version}-%{release}
98
99%description devel
100Development files for the KDE gaming libraries.
101Install kdegames-devel if you wish to develop or compile games for the
102KDE desktop.
103
104%prep
105%setup -q -n kdegames-%{version}
106
107%build
108mkdir -p %{_target_platform}
109pushd %{_target_platform}
110%cmake \
111    -DCMAKE_BUILD_TYPE=release \
112    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
113    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
114    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
115    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
116    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
117    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
118    -DINSTALL_KAJONGG=TRUE \
119    -DSKIP_GGZCONFIG=1 \
120    ..
121popd
122
123make %{?_smp_mflags} -C %{_target_platform}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
128
129# move devel symlinks
130mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
131pushd $RPM_BUILD_ROOT%{_libdir}
132for i in lib*.so
133do
134  case "$i" in
135# conflicts with kdegames3
136    libkdegames.so )
137      linktarget=`readlink "$i"`
138      rm -f "$i"
139      ln -sf "../../$linktarget" "kde4/devel/$i"
140      ;;
141  esac
142done
143popd
144
145
146%check
147for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
148  desktop-file-validate $f
149done
150
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
157touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
158touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
159update-mime-database %{_datadir}/mime &> /dev/null || :
160
161%posttrans
162gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
163gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
164gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
165update-desktop-database -q &> /dev/null ||:
166
167%postun
168update-mime-database %{_datadir}/mime &> /dev/null || :
169if [ $1 -eq 0 ] ; then
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
171    touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
172    touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
173    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
174    gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
175    gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
176    update-desktop-database -q &> /dev/null ||:
177fi
178
179%post libs -p /sbin/ldconfig
180
181%postun libs -p /sbin/ldconfig
182
183%files
184%defattr(-,root,root)
185%doc AUTHORS README
186%{_bindir}/*
187%{_datadir}/kde4/apps/*
188%{_datadir}/config/*
189%{_datadir}/sounds/*.ogg
190%{_datadir}/sounds/kshisen/*.ogg
191%{_datadir}/sounds/kapman/
192%{_datadir}/applications/kde4/*
193%{_datadir}/config.kcfg/*
194%{_datadir}/kde4/services/kbattleship.protocol
195%{_datadir}/kde4/services/ServiceMenus/palapeli_servicemenu.desktop
196%{_datadir}/kde4/services/pala*.desktop
197%{_datadir}/kde4/servicetypes/libpala-slicerplugin.desktop
198%doc %{_docdir}/HTML/en/*
199%{_datadir}/icons/hicolor/*/*/*
200%{_datadir}/icons/locolor/*/*/*
201%{_datadir}/icons/oxygen/*/*/*
202%{_libdir}/libkcardgame.so
203%{_libdir}/kde4/pala*.so
204%{_datadir}/mime/packages/kpatience.xml
205%{_datadir}/mime/packages/palapeli-mimetypes.xml
206#{_sysconfdir}/ggz.modules.d/kdegames
207
208%files libs
209%defattr(-,root,root,-)
210%doc COPYING
211%{_libdir}/lib*.so.*
212
213%files devel
214%defattr(-,root,root)
215%{_includedir}/kde4/*
216%{_libdir}/lib*.so
217%exclude %{_libdir}/libkcardgame.so
218%{_libdir}/kde4/devel/lib*.so
219%dir %{_libdir}/libpala/
220%{_libdir}/libpala/*.cmake
221%{_libdir}/cmake/KDEGames
222
223%changelog
224* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
225- new upstream release
226
227* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
228- new upstream release
229
230* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
231- new upstream release
232
233* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
234- new upstream release
235- add BuildRequires: python-devel, PyQt4-devel, PyKDE4-devel, sqlite3-devel, python-twisted
236
237* Thu Aug  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
238- new upstream release
239
240* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
241- new upstream release
242
243* Mon Mar 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
244- new upstream release
245
246* Tue Mar  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
247- added BR: libXpm-devel
248
249* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
250- new upstream release
251- added BR: openal-soft-devel, qhull-devel
252
253* Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
254- new upstream release
255
256* Tue Jul  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
257- new upstream release
258- added Conflict: kdegames3
259
260* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
261- new upstream release
262
263* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
264- new upstream release
265- built with new toolchain
266
267* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
268- new upstream release
269
270* Mon Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
271- new upstream release
272
273* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
274- new upstream release
275
276* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
277- new upstream release
278
279* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
280- applied new versioning policy, spec in UTF-8
281
282* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
283- rebuild for VineSeed
284
285* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
286- new upstream release
287
288* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
289- rebuild for VineSeed
290
291* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
292- new upstream release
293
294* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
295- new upstream release
296
297* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
298- added --with-qt-libraries and --enable-libsuffix option
299
300* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
301- rebuild for VineSeed
302
303* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
304- new upstream release
305
306* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
307- changed Group to Applications/Games
308- added Japanese summary
309
310* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
311- rebuild for VineSeed
312
313* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
314- new upstream release
315
316* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
317- rebuild for VineSeed
318
319* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
320- new upstream release
321
322* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
323- rebuild for VineSeed
324
325* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
326- new upstream release
327
328* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
329- rebuild for VineSeed
330
331* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
332- new upstream release
333
334* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
335- rebuild for VineSeed
336
337* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
338- new upstream release
339
340* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
341- new upstream release
342
343* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
344- new upstream release
345
346* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
347- new upstream release
348
349* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
350- rebuild for VineSeed
351
352* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
353- new upstream release
354
355* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
356- build for VineSeed
357- add --disable-rpath to configure option
358
359* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
360- new upstream release
361- use %%{?_smp_mflags} for make option
362
363* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
364- rebuild for VineSeed
365
366* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
367- new upstream release
368
369* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
370- new upstream release (3.4.0-rc1)
371- update %%files
372
373* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
374- rebuild for VineSeed
375
376* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
377- source upgrade
378- build for Vine Linux 3.1
379
380* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
381- source upgrade
382
383* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
384- rebuild with qt32
385
386* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
387- source upgrade
388- remove lines about vine26
389- add URL: http://www.kde.org/
390
391* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
392- source upgrade
393
394* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
395- move *.so to main package
396
397* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
398- source upgrade
399
400* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
401- source upgrade
402
403* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
404- rebuild for VineSeedPlus
405
406* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
407- source upgrade
408- build for VinePlus/2.6
409- (VinePlus/2.6) BuildPrereq: autoconf258
410
411* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
412- build for VineSeed with new toolchain and qt-3.2.3
413
414* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
415- rebuild with qt-3.2.1-0.26vl3
416
417* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
418- rebuild with qt-3.2.1-0vl3
419
420* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
421- source upgrade
422- build with gcc-3.2.3
423
424* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
425- source upgrade
426- change spec to build with gcc295
427- change make option for SMP and add script
428
429* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
430- change spec to build with g++-2.95.3
431
432* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
433- source upgrade
434- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
435
436* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
437- source upgrade
438- change spec to build both VineSeed and Vine2.5/2.6
439
440* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
441- source upgrade to 3.1-stable
442
443* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
444- source upgrade to 3.1rc7
445- stop using objprelink2, it does not work with gcc3
446- change spec to make monolithic package only
447- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
448- add %{_libdir}/kde3/*
449- cleanup spec
450
451* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
452- source upgrade
453
454* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
455- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
456- add Prereq: ldconfig
457- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
458- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
459
460* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
461- source upgrade
462- BuildPrereq: autoconf253 objprelink2
463
464* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
465- source upgrade
466
467* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
468- source upgrade
469
470* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
471- source update to 3.0.1
472
473* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
474- source update to 3.0
475- add configure option `--with-xinerama --enable-final'
476- add kbounce
477
478* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
479- merged with rawhide 3.0.0-0.cvs20020306.1
480- source update to cvs-20020329
481- add BuildPrereq: autoconf252 automake15
482- There is Vine's previous changes, hacked for Vine
483 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
484  - update to 2.2.2
485 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
486  - Delete Epoch
487  - Change BuildRequires and Requires
488  - objprelink (i386 only)
489  - Build for VineSeed
490
491* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
492- Fix packaging glitch in monolithic version
493
494* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
495- Make splits a buildtime option (off by default) on request
496
497* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
498- Update to work with latest kdelibs changes
499
500* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
501- Update
502- Add missing %{_bindir}/kbattleship
503
504* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
505- Update
506- Split into several packages (one package per game)
507
508* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
509- Update
510- Work around ia64 breakages
511- Add build requirements (#48977)
512
513* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
514- Fix problem when changing the card type (Bug #28824)
515
516* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
517- 2.1-respin
518
519* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
520- 2.1
521
522* Sun Feb 11 2001 Than Ngo <than@redhat.com>
523- don't use make -j CPU, it's broken
524
525* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
526- Run ldconfig in %%post and %%postun to make libkdegames happy
527- Replace absolute symlinks with relative symlinks (#24787)
528
529* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
530- Update
531- includedir=/usr/include/kde,
532  now that libkdegames installs kcarddeck.h
533
534* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
535- Get rid of the gcc bug workaround, it's no longer needed
536
537* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
538- Update
539- Don't exclude ia64
540
541* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- Update to HEAD
543
544* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
546
547* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- 2.0 final
549
550* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
551- 2.0
552
553* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
554- new CVS
555- work around g++ bugs (in kjumpingcube)
556
557* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
558- 1.93
559
560* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
561- new version
562
563* Wed Jul 19 2000 Than Ngo <than@redhat.de>
564- fix docdir
565- rebuild 16 July snapshot
566
567* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
568- SMPify
569- don't hardcode QTDIR
570
571* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
572- use gcc 2.96
573- new snapshot
574
575* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
576- new snapshot
577- ExcludeArch ia64 for now
578
579* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
580- new snapshot
581- move it to /usr, where it belongs
582
583* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
584- 2.0 snapshot
585
586* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
587- mark doc files as such
588
589* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
590- 1.1.2 release.
591
592* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
593- snapshot, includes kde 1.1.1 + fixes
594
595* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
596- last snapshot before release
597- ripped out asteroids and sirtet
598
599* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
600- latest stable snapshot
601
602* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
603- Injected new description and group.
604
605* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
606- upgraded to KDE 1.1 final.
607
608* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
609- rebuilt for new libstdc++ etc.
610
611* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
612- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
613
Note: See TracBrowser for help on using the repository browser.