source: projects/specs/trunk/k/kdegames/kdegames-vl.spec @ 6797

Revision 6797, 17.5 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.1

Line 
1Name: kdegames
2Summary: KDE Games
3Summary(ja): KDE ゲーム集
4Version: 4.9.1
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Games
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: desktop-file-utils
15BuildRequires: ggz-client-libs-devel
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libsndfile-devel
18BuildRequires: libXpm-devel
19BuildRequires: openal-soft-devel
20BuildRequires: qca2-devel
21BuildRequires: qhull-devel
22BuildRequires: python-devel
23BuildRequires: PyQt4-devel
24BuildRequires: PyKDE4-devel
25BuildRequires: sqlite3-devel
26BuildRequires: python-twisted
27
28Requires: %{name}-libs = %{version}-%{release}
29Requires: PyKDE4
30Requires: python-twisted
31Requires(post): ggz-client-libs
32Requires(post): desktop-file-utils
33Requires(preun): ggz-client-libs
34Requires(postun): desktop-file-utils
35
36Obsoletes: kdegames4 < %{version}-%{release}
37Provides:  kdegames4 = %{version}-%{release}
38
39Obsoletes: ksudoku < 0.5-1
40Provides:  ksudoku = 0.5-1
41
42Obsoletes: ksirk < %{version}-%{release}
43Provides:  ksirk = %{version}-%{release}
44
45%description
46Games for the K Desktop Environment 4, including:
47* bomber
48* bovo
49* kapman
50* katomic
51* kblackbox
52* kblocks
53* kbounce
54* kbreakout
55* kdiamond
56* kfourinline
57* kgoldrunner
58* killbots
59* kiriki
60* kjumpingcube
61* klines
62* klickety
63* kmahjongg
64* kmines
65* knetwalk
66* kolf
67* kollision
68* konquest
69* kpat
70* kreversi
71* ksame
72* kshisen
73* ksinkships
74* ksirk
75* kspaceduel
76* ksquares
77* ksudoku
78* ktuberling
79* kubrick
80* lskat
81
82%package libs
83Summary: Runtime libraries for %{name}
84Summary(ja): %{name} のランタイムライブラリ
85Group:   System Environment/Libraries
86
87%description libs
88%{summary}.
89
90%package devel
91Summary: Development files for %{name}
92Summary(ja): %{name} の開発用ファイル
93Group: Development/Libraries
94Requires: %{name}-libs = %{version}-%{release}
95Requires: kdelibs4-devel
96Obsoletes: kdegames4-devel < %{version}-%{release}
97Provides:  kdegames4-devel = %{version}-%{release}
98
99%description devel
100Development files for the KDE gaming libraries.
101Install kdegames-devel if you wish to develop or compile games for the
102KDE desktop.
103
104%prep
105%setup -q -n kdegames-%{version}
106
107%build
108mkdir -p %{_target_platform}
109pushd %{_target_platform}
110%cmake \
111    -DCMAKE_BUILD_TYPE=release \
112    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
113    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
114    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
115    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
116    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
117    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
118    -DINSTALL_KAJONGG=TRUE \
119    -DSKIP_GGZCONFIG=1 \
120    ..
121popd
122
123make %{?_smp_mflags} -C %{_target_platform}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
128
129# move devel symlinks
130mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
131pushd $RPM_BUILD_ROOT%{_libdir}
132for i in lib*.so
133do
134  case "$i" in
135# conflicts with kdegames3
136    libkdegames.so )
137      linktarget=`readlink "$i"`
138      rm -f "$i"
139      ln -sf "../../$linktarget" "kde4/devel/$i"
140      ;;
141  esac
142done
143popd
144
145
146%check
147for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
148  desktop-file-validate $f
149done
150
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
157touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
158touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
159update-mime-database %{_datadir}/mime &> /dev/null || :
160
161%posttrans
162gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
163gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
164gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
165update-desktop-database -q &> /dev/null ||:
166
167%postun
168update-mime-database %{_datadir}/mime &> /dev/null || :
169if [ $1 -eq 0 ] ; then
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
171    touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
172    touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
173    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
174    gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
175    gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
176    update-desktop-database -q &> /dev/null ||:
177fi
178
179%post libs -p /sbin/ldconfig
180
181%postun libs -p /sbin/ldconfig
182
183%files
184%defattr(-,root,root)
185%doc AUTHORS README
186%{_bindir}/*
187%{_datadir}/kde4/apps/*
188%{_datadir}/config/*
189%{_datadir}/sounds/*.ogg
190%{_datadir}/sounds/kshisen/*.ogg
191%{_datadir}/sounds/kapman/
192%{_datadir}/applications/kde4/*
193%{_datadir}/config.kcfg/*
194%{_datadir}/kde4/services/kbattleship.protocol
195%{_datadir}/kde4/services/ServiceMenus/palapeli_servicemenu.desktop
196%{_datadir}/kde4/services/pala*.desktop
197%{_datadir}/kde4/servicetypes/libpala-slicerplugin.desktop
198%doc %{_docdir}/HTML/en/*
199%{_datadir}/icons/hicolor/*/*/*
200%{_datadir}/icons/locolor/*/*/*
201%{_datadir}/icons/oxygen/*/*/*
202%{_libdir}/libkcardgame.so
203%{_libdir}/kde4/pala*.so
204%{_datadir}/mime/packages/kpatience.xml
205%{_datadir}/mime/packages/palapeli-mimetypes.xml
206#{_sysconfdir}/ggz.modules.d/kdegames
207
208%files libs
209%defattr(-,root,root,-)
210%doc COPYING
211%{_libdir}/lib*.so.*
212
213%files devel
214%defattr(-,root,root)
215%{_includedir}/kde4/*
216%{_libdir}/lib*.so
217%exclude %{_libdir}/libkcardgame.so
218%{_libdir}/kde4/devel/lib*.so
219%dir %{_libdir}/libpala/
220%{_libdir}/libpala/*.cmake
221%{_libdir}/cmake/KDEGames
222
223%changelog
224* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
225- new upstream release
226
227* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
228- new upstream release
229- add BuildRequires: python-devel, PyQt4-devel, PyKDE4-devel, sqlite3-devel, python-twisted
230
231* Thu Aug  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
232- new upstream release
233
234* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
235- new upstream release
236
237* Mon Mar 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
238- new upstream release
239
240* Tue Mar  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
241- added BR: libXpm-devel
242
243* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
244- new upstream release
245- added BR: openal-soft-devel, qhull-devel
246
247* Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
248- new upstream release
249
250* Tue Jul  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
251- new upstream release
252- added Conflict: kdegames3
253
254* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
255- new upstream release
256
257* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
258- new upstream release
259- built with new toolchain
260
261* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
262- new upstream release
263
264* Mon Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
265- new upstream release
266
267* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
268- new upstream release
269
270* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
271- new upstream release
272
273* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
274- applied new versioning policy, spec in UTF-8
275
276* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
277- rebuild for VineSeed
278
279* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
280- new upstream release
281
282* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
283- rebuild for VineSeed
284
285* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
286- new upstream release
287
288* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
289- new upstream release
290
291* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
292- added --with-qt-libraries and --enable-libsuffix option
293
294* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
295- rebuild for VineSeed
296
297* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
298- new upstream release
299
300* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
301- changed Group to Applications/Games
302- added Japanese summary
303
304* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
305- rebuild for VineSeed
306
307* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
308- new upstream release
309
310* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
311- rebuild for VineSeed
312
313* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
314- new upstream release
315
316* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
317- rebuild for VineSeed
318
319* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
320- new upstream release
321
322* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
323- rebuild for VineSeed
324
325* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
326- new upstream release
327
328* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
329- rebuild for VineSeed
330
331* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
332- new upstream release
333
334* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
335- new upstream release
336
337* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
338- new upstream release
339
340* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
341- new upstream release
342
343* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
344- rebuild for VineSeed
345
346* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
347- new upstream release
348
349* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
350- build for VineSeed
351- add --disable-rpath to configure option
352
353* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
354- new upstream release
355- use %%{?_smp_mflags} for make option
356
357* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
358- rebuild for VineSeed
359
360* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
361- new upstream release
362
363* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
364- new upstream release (3.4.0-rc1)
365- update %%files
366
367* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
368- rebuild for VineSeed
369
370* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
371- source upgrade
372- build for Vine Linux 3.1
373
374* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
375- source upgrade
376
377* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
378- rebuild with qt32
379
380* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
381- source upgrade
382- remove lines about vine26
383- add URL: http://www.kde.org/
384
385* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
386- source upgrade
387
388* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
389- move *.so to main package
390
391* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
392- source upgrade
393
394* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
395- source upgrade
396
397* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
398- rebuild for VineSeedPlus
399
400* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
401- source upgrade
402- build for VinePlus/2.6
403- (VinePlus/2.6) BuildPrereq: autoconf258
404
405* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
406- build for VineSeed with new toolchain and qt-3.2.3
407
408* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
409- rebuild with qt-3.2.1-0.26vl3
410
411* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
412- rebuild with qt-3.2.1-0vl3
413
414* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
415- source upgrade
416- build with gcc-3.2.3
417
418* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
419- source upgrade
420- change spec to build with gcc295
421- change make option for SMP and add script
422
423* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
424- change spec to build with g++-2.95.3
425
426* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
427- source upgrade
428- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
429
430* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
431- source upgrade
432- change spec to build both VineSeed and Vine2.5/2.6
433
434* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
435- source upgrade to 3.1-stable
436
437* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
438- source upgrade to 3.1rc7
439- stop using objprelink2, it does not work with gcc3
440- change spec to make monolithic package only
441- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
442- add %{_libdir}/kde3/*
443- cleanup spec
444
445* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
446- source upgrade
447
448* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
449- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
450- add Prereq: ldconfig
451- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
452- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
453
454* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
455- source upgrade
456- BuildPrereq: autoconf253 objprelink2
457
458* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
459- source upgrade
460
461* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
462- source upgrade
463
464* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
465- source update to 3.0.1
466
467* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
468- source update to 3.0
469- add configure option `--with-xinerama --enable-final'
470- add kbounce
471
472* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
473- merged with rawhide 3.0.0-0.cvs20020306.1
474- source update to cvs-20020329
475- add BuildPrereq: autoconf252 automake15
476- There is Vine's previous changes, hacked for Vine
477 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
478  - update to 2.2.2
479 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
480  - Delete Epoch
481  - Change BuildRequires and Requires
482  - objprelink (i386 only)
483  - Build for VineSeed
484
485* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
486- Fix packaging glitch in monolithic version
487
488* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
489- Make splits a buildtime option (off by default) on request
490
491* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
492- Update to work with latest kdelibs changes
493
494* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
495- Update
496- Add missing %{_bindir}/kbattleship
497
498* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
499- Update
500- Split into several packages (one package per game)
501
502* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
503- Update
504- Work around ia64 breakages
505- Add build requirements (#48977)
506
507* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
508- Fix problem when changing the card type (Bug #28824)
509
510* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
511- 2.1-respin
512
513* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
514- 2.1
515
516* Sun Feb 11 2001 Than Ngo <than@redhat.com>
517- don't use make -j CPU, it's broken
518
519* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
520- Run ldconfig in %%post and %%postun to make libkdegames happy
521- Replace absolute symlinks with relative symlinks (#24787)
522
523* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
524- Update
525- includedir=/usr/include/kde,
526  now that libkdegames installs kcarddeck.h
527
528* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
529- Get rid of the gcc bug workaround, it's no longer needed
530
531* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
532- Update
533- Don't exclude ia64
534
535* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
536- Update to HEAD
537
538* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
539- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
540
541* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- 2.0 final
543
544* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- 2.0
546
547* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- new CVS
549- work around g++ bugs (in kjumpingcube)
550
551* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
552- 1.93
553
554* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
555- new version
556
557* Wed Jul 19 2000 Than Ngo <than@redhat.de>
558- fix docdir
559- rebuild 16 July snapshot
560
561* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
562- SMPify
563- don't hardcode QTDIR
564
565* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
566- use gcc 2.96
567- new snapshot
568
569* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
570- new snapshot
571- ExcludeArch ia64 for now
572
573* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
574- new snapshot
575- move it to /usr, where it belongs
576
577* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
578- 2.0 snapshot
579
580* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
581- mark doc files as such
582
583* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
584- 1.1.2 release.
585
586* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
587- snapshot, includes kde 1.1.1 + fixes
588
589* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
590- last snapshot before release
591- ripped out asteroids and sirtet
592
593* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
594- latest stable snapshot
595
596* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
597- Injected new description and group.
598
599* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
600- upgraded to KDE 1.1 final.
601
602* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
603- rebuilt for new libstdc++ etc.
604
605* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
606- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
607
Note: See TracBrowser for help on using the repository browser.