source: projects/specs/trunk/k/kdegames/kdegames-vl.spec @ 6725

Revision 6725, 17.4 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name: kdegames
2Summary: KDE Games
3Summary(ja): KDE ゲーム集
4Version: 4.9.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8Group: Applications/Games
9URL: http://www.kde.org/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: desktop-file-utils
15BuildRequires: ggz-client-libs-devel
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: libsndfile-devel
18BuildRequires: libXpm-devel
19BuildRequires: openal-soft-devel
20BuildRequires: qca2-devel
21BuildRequires: qhull-devel
22BuildRequires: python-devel
23BuildRequires: PyQt4-devel
24BuildRequires: PyKDE4-devel
25BuildRequires: sqlite3-devel
26BuildRequires: python-twisted
27
28Requires: %{name}-libs = %{version}-%{release}
29Requires: PyKDE4
30Requires: python-twisted
31Requires(post): ggz-client-libs
32Requires(post): desktop-file-utils
33Requires(preun): ggz-client-libs
34Requires(postun): desktop-file-utils
35
36Obsoletes: kdegames4 < %{version}-%{release}
37Provides:  kdegames4 = %{version}-%{release}
38
39Obsoletes: ksudoku < 0.5-1
40Provides:  ksudoku = 0.5-1
41
42Obsoletes: ksirk < %{version}-%{release}
43Provides:  ksirk = %{version}-%{release}
44
45%description
46Games for the K Desktop Environment 4, including:
47* bomber
48* bovo
49* kapman
50* katomic
51* kblackbox
52* kblocks
53* kbounce
54* kbreakout
55* kdiamond
56* kfourinline
57* kgoldrunner
58* killbots
59* kiriki
60* kjumpingcube
61* klines
62* klickety
63* kmahjongg
64* kmines
65* knetwalk
66* kolf
67* kollision
68* konquest
69* kpat
70* kreversi
71* ksame
72* kshisen
73* ksinkships
74* ksirk
75* kspaceduel
76* ksquares
77* ksudoku
78* ktuberling
79* kubrick
80* lskat
81
82%package libs
83Summary: Runtime libraries for %{name}
84Summary(ja): %{name} のランタイムライブラリ
85Group:   System Environment/Libraries
86
87%description libs
88%{summary}.
89
90%package devel
91Summary: Development files for %{name}
92Summary(ja): %{name} の開発用ファイル
93Group: Development/Libraries
94Requires: %{name}-libs = %{version}-%{release}
95Requires: kdelibs4-devel
96Obsoletes: kdegames4-devel < %{version}-%{release}
97Provides:  kdegames4-devel = %{version}-%{release}
98
99%description devel
100Development files for the KDE gaming libraries.
101Install kdegames-devel if you wish to develop or compile games for the
102KDE desktop.
103
104%prep
105%setup -q -n kdegames-%{version}
106
107%build
108mkdir -p %{_target_platform}
109pushd %{_target_platform}
110%cmake \
111    -DCMAKE_BUILD_TYPE=release \
112    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
113    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
114    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
115    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
116    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
117    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
118    -DINSTALL_KAJONGG=TRUE \
119    -DSKIP_GGZCONFIG=1 \
120    ..
121popd
122
123make %{?_smp_mflags} -C %{_target_platform}
124
125%install
126rm -rf $RPM_BUILD_ROOT
127make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
128
129# move devel symlinks
130mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
131pushd $RPM_BUILD_ROOT%{_libdir}
132for i in lib*.so
133do
134  case "$i" in
135# conflicts with kdegames3
136    libkdegames.so )
137      linktarget=`readlink "$i"`
138      rm -f "$i"
139      ln -sf "../../$linktarget" "kde4/devel/$i"
140      ;;
141  esac
142done
143popd
144
145
146%check
147for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
148  desktop-file-validate $f
149done
150
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
157touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
158touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
159update-mime-database %{_datadir}/mime &> /dev/null || :
160
161%posttrans
162gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
163gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
164gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
165update-desktop-database -q &> /dev/null ||:
166
167%postun
168update-mime-database %{_datadir}/mime &> /dev/null || :
169if [ $1 -eq 0 ] ; then
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
171    touch --no-create %{_datadir}/icons/locolor &> /dev/null || :
172    touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
173    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
174    gtk-update-icon-cache %{_datadir}/icons/locolor &> /dev/null || :
175    gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
176    update-desktop-database -q &> /dev/null ||:
177fi
178
179%post libs -p /sbin/ldconfig
180
181%postun libs -p /sbin/ldconfig
182
183%files
184%defattr(-,root,root)
185%doc AUTHORS README
186%{_bindir}/*
187%{_datadir}/kde4/apps/*
188%{_datadir}/config/*
189%{_datadir}/sounds/*.ogg
190%{_datadir}/sounds/kshisen/*.ogg
191%{_datadir}/sounds/kapman/
192%{_datadir}/applications/kde4/*
193%{_datadir}/config.kcfg/*
194%{_datadir}/kde4/services/kbattleship.protocol
195%{_datadir}/kde4/services/ServiceMenus/palapeli_servicemenu.desktop
196%{_datadir}/kde4/services/pala*.desktop
197%{_datadir}/kde4/servicetypes/libpala-slicerplugin.desktop
198%doc %{_docdir}/HTML/en/*
199%{_datadir}/icons/hicolor/*/*/*
200%{_datadir}/icons/locolor/*/*/*
201%{_datadir}/icons/oxygen/*/*/*
202%{_libdir}/libkcardgame.so
203%{_libdir}/kde4/pala*.so
204%{_datadir}/mime/packages/kpatience.xml
205%{_datadir}/mime/packages/palapeli-mimetypes.xml
206#{_sysconfdir}/ggz.modules.d/kdegames
207
208%files libs
209%defattr(-,root,root,-)
210%doc COPYING
211%{_libdir}/lib*.so.*
212
213%files devel
214%defattr(-,root,root)
215%{_includedir}/kde4/*
216%{_libdir}/lib*.so
217%exclude %{_libdir}/libkcardgame.so
218%{_libdir}/kde4/devel/lib*.so
219%dir %{_libdir}/libpala/
220%{_libdir}/libpala/*.cmake
221%{_libdir}/cmake/KDEGames
222
223%changelog
224* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
225- new upstream release
226- add BuildRequires: python-devel, PyQt4-devel, PyKDE4-devel, sqlite3-devel, python-twisted
227
228* Thu Aug  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
229- new upstream release
230
231* Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
232- new upstream release
233
234* Mon Mar 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
235- new upstream release
236
237* Tue Mar  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
238- added BR: libXpm-devel
239
240* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
241- new upstream release
242- added BR: openal-soft-devel, qhull-devel
243
244* Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
245- new upstream release
246
247* Tue Jul  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
248- new upstream release
249- added Conflict: kdegames3
250
251* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
252- new upstream release
253
254* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
255- new upstream release
256- built with new toolchain
257
258* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
259- new upstream release
260
261* Mon Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
262- new upstream release
263
264* Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
265- new upstream release
266
267* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
268- new upstream release
269
270* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
271- applied new versioning policy, spec in UTF-8
272
273* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
274- rebuild for VineSeed
275
276* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
277- new upstream release
278
279* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
280- rebuild for VineSeed
281
282* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
283- new upstream release
284
285* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
286- new upstream release
287
288* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
289- added --with-qt-libraries and --enable-libsuffix option
290
291* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
292- rebuild for VineSeed
293
294* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
295- new upstream release
296
297* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
298- changed Group to Applications/Games
299- added Japanese summary
300
301* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
302- rebuild for VineSeed
303
304* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
305- new upstream release
306
307* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
308- rebuild for VineSeed
309
310* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
311- new upstream release
312
313* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
314- rebuild for VineSeed
315
316* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
317- new upstream release
318
319* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
320- rebuild for VineSeed
321
322* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
323- new upstream release
324
325* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
326- rebuild for VineSeed
327
328* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
329- new upstream release
330
331* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
332- new upstream release
333
334* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
335- new upstream release
336
337* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
338- new upstream release
339
340* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
341- rebuild for VineSeed
342
343* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
344- new upstream release
345
346* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
347- build for VineSeed
348- add --disable-rpath to configure option
349
350* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
351- new upstream release
352- use %%{?_smp_mflags} for make option
353
354* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
355- rebuild for VineSeed
356
357* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
358- new upstream release
359
360* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
361- new upstream release (3.4.0-rc1)
362- update %%files
363
364* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
365- rebuild for VineSeed
366
367* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
368- source upgrade
369- build for Vine Linux 3.1
370
371* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
372- source upgrade
373
374* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
375- rebuild with qt32
376
377* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
378- source upgrade
379- remove lines about vine26
380- add URL: http://www.kde.org/
381
382* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
383- source upgrade
384
385* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
386- move *.so to main package
387
388* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
389- source upgrade
390
391* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
392- source upgrade
393
394* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
395- rebuild for VineSeedPlus
396
397* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
398- source upgrade
399- build for VinePlus/2.6
400- (VinePlus/2.6) BuildPrereq: autoconf258
401
402* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
403- build for VineSeed with new toolchain and qt-3.2.3
404
405* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
406- rebuild with qt-3.2.1-0.26vl3
407
408* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
409- rebuild with qt-3.2.1-0vl3
410
411* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
412- source upgrade
413- build with gcc-3.2.3
414
415* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
416- source upgrade
417- change spec to build with gcc295
418- change make option for SMP and add script
419
420* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
421- change spec to build with g++-2.95.3
422
423* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
424- source upgrade
425- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
426
427* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
428- source upgrade
429- change spec to build both VineSeed and Vine2.5/2.6
430
431* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
432- source upgrade to 3.1-stable
433
434* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
435- source upgrade to 3.1rc7
436- stop using objprelink2, it does not work with gcc3
437- change spec to make monolithic package only
438- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
439- add %{_libdir}/kde3/*
440- cleanup spec
441
442* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
443- source upgrade
444
445* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
446- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
447- add Prereq: ldconfig
448- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
449- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
450
451* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
452- source upgrade
453- BuildPrereq: autoconf253 objprelink2
454
455* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
456- source upgrade
457
458* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
459- source upgrade
460
461* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
462- source update to 3.0.1
463
464* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
465- source update to 3.0
466- add configure option `--with-xinerama --enable-final'
467- add kbounce
468
469* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
470- merged with rawhide 3.0.0-0.cvs20020306.1
471- source update to cvs-20020329
472- add BuildPrereq: autoconf252 automake15
473- There is Vine's previous changes, hacked for Vine
474 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
475  - update to 2.2.2
476 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
477  - Delete Epoch
478  - Change BuildRequires and Requires
479  - objprelink (i386 only)
480  - Build for VineSeed
481
482* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
483- Fix packaging glitch in monolithic version
484
485* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
486- Make splits a buildtime option (off by default) on request
487
488* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
489- Update to work with latest kdelibs changes
490
491* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
492- Update
493- Add missing %{_bindir}/kbattleship
494
495* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
496- Update
497- Split into several packages (one package per game)
498
499* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
500- Update
501- Work around ia64 breakages
502- Add build requirements (#48977)
503
504* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
505- Fix problem when changing the card type (Bug #28824)
506
507* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
508- 2.1-respin
509
510* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
511- 2.1
512
513* Sun Feb 11 2001 Than Ngo <than@redhat.com>
514- don't use make -j CPU, it's broken
515
516* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
517- Run ldconfig in %%post and %%postun to make libkdegames happy
518- Replace absolute symlinks with relative symlinks (#24787)
519
520* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
521- Update
522- includedir=/usr/include/kde,
523  now that libkdegames installs kcarddeck.h
524
525* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
526- Get rid of the gcc bug workaround, it's no longer needed
527
528* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
529- Update
530- Don't exclude ia64
531
532* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
533- Update to HEAD
534
535* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
536- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
537
538* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
539- 2.0 final
540
541* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
542- 2.0
543
544* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
545- new CVS
546- work around g++ bugs (in kjumpingcube)
547
548* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
549- 1.93
550
551* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
552- new version
553
554* Wed Jul 19 2000 Than Ngo <than@redhat.de>
555- fix docdir
556- rebuild 16 July snapshot
557
558* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
559- SMPify
560- don't hardcode QTDIR
561
562* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
563- use gcc 2.96
564- new snapshot
565
566* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
567- new snapshot
568- ExcludeArch ia64 for now
569
570* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
571- new snapshot
572- move it to /usr, where it belongs
573
574* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
575- 2.0 snapshot
576
577* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
578- mark doc files as such
579
580* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
581- 1.1.2 release.
582
583* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
584- snapshot, includes kde 1.1.1 + fixes
585
586* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
587- last snapshot before release
588- ripped out asteroids and sirtet
589
590* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
591- latest stable snapshot
592
593* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
594- Injected new description and group.
595
596* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
597- upgraded to KDE 1.1 final.
598
599* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
600- rebuilt for new libstdc++ etc.
601
602* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
603- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
604
Note: See TracBrowser for help on using the repository browser.