source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 9222

Revision 9222, 28.8 KB checked in by Takemikaduchi, 9 years ago (diff)

R: rebuild
openbabel: add BR
k3b: new upstream release
others: KDE-4.14.3

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.14.3
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstreamable patches
33# make installdbgsymbols.sh use pkexec instead of su
34# increase some timeouts in an effort to see (some) errors before close
35Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
36
37## upstream patches
38
39
40Provides:  kdebase4-runtime = %{version}-%{release}
41Provides:  kde-runtime = %{version}-%{release}
42Obsoletes: kdebase4-runtime < %{version}-%{release}
43
44Obsoletes: nepomukcontroller
45Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
46
47# knotify4 provides dbus service org.freedesktop.Notifications too
48Provides: desktop-notification-daemon
49
50BuildRoot:     %{_tmppath}/%{name}-%{version}-root
51BuildRequires: alsa-lib-devel
52BuildRequires: attica-devel >= 0.1.4
53BuildRequires: bzip2-devel
54BuildRequires: chrpath
55BuildRequires: clucene-core-devel
56BuildRequires: doxygen
57BuildRequires: exiv2-devel >= 0.12
58BuildRequires: glib2-devel
59BuildRequires: gpgme-devel
60BuildRequires: kdelibs-devel >= %{version}
61BuildRequires: kdepimlibs-devel >= %{version}
62BuildRequires: kactivities-devel
63BuildRequires: libXpm-devel
64BuildRequires: libXScrnSaver-devel
65BuildRequires: libcanberra-devel
66BuildRequires: libgcrypt-devel
67BuildRequires: libsmbclient-devel
68BuildRequires: libssh-devel >= 0.4.2
69BuildRequires: libwebp-devel
70BuildRequires: NetworkManager-devel
71BuildRequires: nepomuk-core
72BuildRequires: nepomuk-core-devel
73BuildRequires: OpenEXR-devel
74BuildRequires: openslp-devel
75BuildRequires: openssl-devel
76BuildRequires: pkgconfig
77BuildRequires: polkit-qt-devel
78BuildRequires: pulseaudio-libs-devel
79BuildRequires: qca2-devel
80BuildRequires: qimageblitz-devel
81BuildRequires: shared-mime-info >= 0.40
82BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
83BuildRequires: soprano-devel >= 2.6.50
84BuildRequires: xine-lib-devel libxcb-devel
85BuildRequires: xorg-x11-font-utils
86BuildRequires: xorg-x11-proto-devel
87BuildRequires: xz-devel
88BuildRequires: zlib-devel
89
90Requires: eject
91Requires: %{name}-libs = %{version}-%{release}
92Requires: %{name}-flags = %{version}-%{release}
93# KHelpcenter requires htdig for building search indices
94Requires: htdig
95# ensure default/fallback icon theme present
96# beware of bootstrapping, there be dragons
97Requires: oxygen-icon-theme >= %{version}
98
99# some items moved -workspace -> -runtime
100Conflicts: kdebase-workspace < 4.5.80
101
102Vendor: Project Vine
103Distribution: Vine Linux
104
105%description
106Core runtime for KDE 4.
107
108%description -l ja
109KDE 4 の中心となるランタイム部分です.
110
111%package devel
112Summary:  Developer files for %{name}
113Summary(ja): %{name} の開発用ファイル
114Group:    Development/Libraries
115Requires: %{name}-libs = %{version}-%{release}
116
117%description devel
118%{summary}.
119
120%description -l ja devel
121%{name} の開発用ファイルです.
122
123%package libs
124Summary: Runtime libraries for %{name}
125Summary(ja): %{name} のランタイムライブラリ
126Group:   System Environment/Libraries
127Requires: kdelibs4 >= %{version}
128Requires: kdepimlibs >= %{version}
129# cagibi is runtime dep, a dbus service
130Requires: cagibi
131
132%description libs
133%{summary}.
134
135%description -l ja libs
136%{name} のランタイムライブラリです.
137
138%package flags
139Summary: Geopolitical flags
140Group: User Interface/Desktops
141Requires: %{name}-libs = %{version}-%{release}
142BuildArch: noarch
143
144%description flags
145%{summary}.
146
147
148%prep
149%setup -q -n kde-runtime-%{version}
150
151%patch1 -p1 -b .searchproviders-shortcuts
152%patch6 -p1 -b .home_onlyshowin_kde
153%patch7 -p1 -b .htsearch
154%patch8 -p1 -b .config
155%patch9 -p1 -b .man-overrides
156%patch51 -p1 -b .installdgbsymbols
157
158
159%build
160mkdir -p %{_target_platform}
161pushd %{_target_platform}
162%cmake \
163    -DCMAKE_BUILD_TYPE=release \
164    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
165    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
166    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
167    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
168    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
169    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
170    ..
171popd
172
173make %{?_smp_mflags} -C %{_target_platform}
174
175
176%install
177rm -rf $RPM_BUILD_ROOT
178
179make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
180
181# kdesu symlink
182ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
183
184# omit hicolor index.theme, use one from hicolor-icon-theme
185rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
186
187# remove country flags because some people/countries forbid some other
188# people/countries' flags :-(
189%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
190
191# install this service for KDE 3 applications too
192mkdir $RPM_BUILD_ROOT%{_datadir}/services
193ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
194      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
195
196# FIXME: -devel type files, omit for now
197rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
198
199# rpaths
200# use chrpath hammer for now, find better patching solutions later -- Rex
201chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
202chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
203
204%clean
205rm -rf $RPM_BUILD_ROOT
206
207%post
208touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209
210%posttrans
211gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
212update-desktop-database -q &> /dev/null ||:
213update-mime-database %{_datadir}/mime &> /dev/null
214
215%postun
216if [ $1 -eq 0 ] ; then
217    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
218    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
219    update-desktop-database -q &> /dev/null ||:
220    update-mime-database %{_datadir}/mime &> /dev/null
221fi
222
223%post libs -p /sbin/ldconfig
224%postun libs -p /sbin/ldconfig
225
226
227%files
228%defattr(-,root,root,-)
229%{_sysconfdir}/dbus-1/system.d/*
230%{_sysconfdir}/xdg/menus/kde-information.menu
231%{_bindir}/*
232# omit ksvgtopng which kdelibs3 includes
233%{_datadir}/kde4/apps/*
234%exclude %{_datadir}/kde4/apps/cmake/
235%{_datadir}/config/*.knsrc
236%{_datadir}/config.kcfg/
237%{_datadir}/dbus-1/interfaces/*
238%{_datadir}/dbus-1/services/*
239%{_datadir}/dbus-1/system-services/*
240%{_datadir}/icons/default.kde4
241%{_datadir}/kde4/services/*
242%{_datadir}/kde4/servicetypes/*
243%{_datadir}/mime/packages/network.xml
244%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
245%{_datadir}/sounds/*
246%{_libdir}/kconf_update_bin/*
247%{_libdir}/libkdeinit4_*.so
248%{_libdir}/kde4/kcm_*.so
249%{_libdir}/kde4/kded_*.so
250%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
251%{_libexecdir}/kde4/drkonqi
252#{_libexecdir}/kde4/installdbgsymbols.sh
253%{_libexecdir}/kde4/kcmremotewidgetshelper
254%{_libexecdir}/kde4/kdeeject
255%{_libexecdir}/kde4/kdesu
256%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
257%{_libexecdir}/kde4/kdontchangethehostname
258%{_libexecdir}/kde4/khc_docbookdig.pl
259%{_libexecdir}/kde4/khc_htdig.pl
260%{_libexecdir}/kde4/khc_htsearch.pl
261%{_libexecdir}/kde4/khc_indexbuilder
262%{_libexecdir}/kde4/khc_mansearch.pl
263%{_libexecdir}/kde4/kioexec
264%{_libexecdir}/kde4/knetattach
265%{_mandir}/man1/*
266%{_datadir}/icons/hicolor/*/*/*
267%{_docdir}/HTML/en/*
268%{_datadir}/applications/kde4/Help.desktop
269%{_datadir}/applications/kde4/knetattach.desktop
270%{_datadir}/config/kshorturifilterrc
271%{_datadir}/desktop-directories/*.directory
272%{_datadir}/emoticons/kde4/
273%{_datadir}/locale/l10n/
274%{_datadir}/locale/currency/
275%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
276%{_datadir}/services/khelpcenter.desktop
277%{_datadir}/mime/packages/webp.xml
278
279%files devel
280%defattr(-,root,root,-)
281%{_includedir}/*
282%{_datadir}/kde4/apps/cmake/modules/*.cmake
283
284%files libs
285%defattr(-,root,root,-)
286%{_libdir}/attica_kde.so
287%{_libdir}/libknotifyplugin.so
288%{_libdir}/libkwalletbackend.so.*
289%{_libdir}/libmolletnetwork.so.*
290%{_libdir}/kde4/*.so
291%{_libdir}/kde4/imports/
292# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
293%exclude %{_libdir}/kde4/kcm_*.so
294%exclude %{_libdir}/kde4/kded_*.so
295%{_libdir}/kde4/plugins/phonon_platform/
296%{_libdir}/kde4/plugins/imageformats/kimg_webp.so
297
298%files flags
299%defattr(-,root,root,-)
300%{_datadir}/locale/l10n/*/flag.png
301
302
303%changelog
304* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
305- new upstream release
306- add BuildRequires: libgcrypt-devel
307
308* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-2
309- rebuilt with OpenEXR 2.2.0
310- added BR: libwebp-devel
311
312* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
313- new upstream release
314
315* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
316- new upstream release
317- add BuildRequires: gpgme-devel
318
319* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-2
320- rebuild with ilmbase-2.1.0 & OpenEXR-2.1.0
321
322* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
323- new upstream release
324
325* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
326- new upstream release
327- remove Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
328
329* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
330- new upstream release
331
332* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
333- new upstream release
334- add patches from fedora
335  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
336  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
337
338* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
339- new upstream release
340
341* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
342- new upstream release
343
344* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
345- new upstream release
346
347* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
348- rebuild with attica-0.4.1
349
350* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
351- new upstream release
352- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
353- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
354
355* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
356- rebuild with exiv2-0.23
357
358* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
359- rebuild with exiv2-0.22
360
361* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
362- rebuilt without libqzeitgeist
363
364* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
365- new upstream release
366
367* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
368- new upstream release
369
370* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
371- new upstream release
372- built with exiv2-0.21.1
373
374* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
375- new upstream release
376
377* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
378- rebuilt with libsmbclient-3.5.8
379
380* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
381- new upstream release
382
383* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
384- added BR: libXpm-devel
385
386* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
387- new upstream release
388- added devel subpackage
389
390* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
391- new upstream release
392- updated summary
393- dropt Patch100
394
395* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
396- new upstream release
397- added Patch100 from Fedora
398  - backport to fix the freeze of kded on first use of the network:/kio-slave
399
400* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
401- new upstream release
402- added Conflicts: kdebase3 at Vine Linux 5
403
404* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
405- new upstream release
406
407* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
408- rebuilt with exiv2-0.19
409
410* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
411- new upstream release
412
413* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
414- new upstream release
415
416* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
417- new upstream release
418- built with new toolchain
419
420* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
421- new upstream release
422
423* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
424- new upstream release
425
426* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
427- new upstream release
428- used %%cmake macro
429
430* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
431- Initial build for Vine Linux
432
433* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
434- respin
435
436* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
437- 4.3.0
438
439* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
440- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
441
442* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
443- 4.3rc3
444
445* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
446- respin (soprano-2.3.0)
447- License: LGPLv2+
448
449* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
450- 4.3rc2
451
452* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
453- drop unneeded BR: ImageMagick (#509241)
454
455* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
456- don't start nepomuk server unconditionally (#487322)
457
458* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
459- 4.3rc1
460
461* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
462- KDE-4.3 beta2 (4.2.90)
463
464* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
465- Drop old Fedora < 8 conditionals
466
467* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
468- file conflicts with kdepim
469
470* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
471- KDE 4.3 beta 1
472
473* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
474- fix persistent systray notifications (#485796)
475
476* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
477- -flags subpkg
478- koji/noarch hacks dropped
479
480* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
481- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
482
483* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
484- KDE 4.2.2
485
486* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
487- flags subpkg (not enabled)
488- optimize scriptlets
489
490* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
491- fix PulseAudio cmake detection
492
493* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
494- 4.2.1
495
496* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
497- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
498
499* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
500- #486059 -  missing dependency on htdig
501
502* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
503- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
504
505* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
506- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
507
508* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
509- own %%_kde4_datadir/locale/l10n/
510
511* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
512- respun tarball
513
514* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
515- Files not trashed to the correct location in Dolphin/Konqueror
516  (#481598, kdebug#178479)
517- omit --with-samba crud
518
519* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
520- 4.2.0
521- +BR: pulseaudio-libs-devel xine-lib-devel
522- -BR: giflib-devel pcre-devel
523
524* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
525- tarball respin
526- drop extraneous deps (that are in kdelibs)
527
528* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
529- 4.2rc1
530
531* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
532- include %%_bindir/kdesu symlink
533
534* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
535- 4.2beta2
536
537* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
538- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
539  and should be in a -devel package if it gets shipped)
540
541* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
542- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
543
544* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
545- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
546
547* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
548- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
549
550* Wed Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
551- 4.1.80
552- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
553- BR cmake >= 2.6.2
554- Use 'make install/fast'
555- Drop subpkg phonon-backend-xine and related file entries: this has to be
556  part of phonon now that it moved there
557- Drop xine-lib-devel BR
558- Add libkwalletbackend to files list
559- Drop _default_patch_fuzz 2
560
561* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
562- apply upstream patch to fix X crash when disabling compositing
563
564* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
565- 4.1.3
566
567* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
568- apply upstream patch, kioexec processes never terminate
569
570* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
571- fix broken audio-backend-jack.svgz
572
573* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
574- add missing icons
575
576* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
577- make VERBOSE=1
578- respin against new(er) kde-filesystem
579- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
580
581* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
582- 4.1.2
583
584* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
585- fix inherit issue in iconthemes, preview icons
586  do not show
587
588* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
589- fix #460710, knetattach is kio_remote's wizard program, don't show
590  it in the menu.
591
592* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
593- 4.1.1
594
595* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
596- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
597
598* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
599- crash fix when stopping a service that is not yet initialized
600
601* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
602- don't remove autostart directory on F8- (does not conflict, fixes build
603  failure due to nepomukserver.desktop listed in filelist but not found)
604
605* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
606- 4.1.0
607
608* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
609- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
610
611* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
612- 4.0.99
613
614* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
615- respin
616
617* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
618- -phonon-backend-xine: new subpkg
619
620* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
621- 4.0.98
622
623* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
624- 4.0.85
625
626* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
627- 4.0.84
628
629* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
630- 4.0.83 (beta2)
631
632* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
633- 4.0.82
634
635* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
636- add searchproviders-shortcuts for redhat bugzilla
637
638* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
639- 4.1 beta 1
640
641* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
642- BR new minimum version of soprano-devel
643
644* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
645- update to 4.0.72 (4.1 alpha 1)
646- drop upstreamed deinterlace-crash patch
647- drop khelpcenter patch (fixed upstream)
648- update Phonon PulseAudio patch
649- drop Fedora 7 support
650- update file list
651
652* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
653- omit conflicting icons (kde3_desktop=1 case)
654
655* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
656- oxygen-icon-theme: build noarch
657
658* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
659- %%post/%%postun: hicolor icon theme scriptlets
660
661* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
662- only omit hicolor index.theme (#439374)
663
664* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
665- fix khelpcenter, search plugins/settings in correct path (#443016)
666
667* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
668- respin (at f13's request)
669
670* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
671- pulseaudio patch (use as default, if available)
672
673* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
674- don't crash if we don't have deinterlacing support in xine-lib (#440299)
675
676* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
677- rebuild for the new %%{_kde4_buildtype}
678
679* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
680- update file list for _kde4_libexecdir
681
682* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
683- 4.0.3
684
685* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
686- don't own %%_kde4_docdir/HTML/en/
687
688* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
689- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
690- include noarch build hooks (not enabled)
691
692* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
693- BR libxcb-devel everywhere (including F7)
694
695* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
696- if building for a KDE 4 desktop, include the khelpcenter.desktop service
697  description for KDE 3 here so help works in KDE 3 apps
698
699* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
700- 4.0.2
701
702* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
703- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
704
705* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
706- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
707  (kio_smb itself is already GPLv2+)
708
709* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
710- 4.0.1
711
712* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
713- respun tarball
714
715* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
716- update to 4.0.0
717- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
718
719* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
720- kde-3.97.0
721
722* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
723- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
724
725* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
726- build without libxcb in F7 as we STILL don't have it (see #373361)
727
728* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
729- no longer set kde3_desktop on F9
730- update file list for !kde3_desktop (Sebastian Vahl)
731- don't ship country flags even for full version (as in kdebase 3)
732
733* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
734- kde-3.96.2
735
736* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
737- kde-3.96.1
738
739* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
740- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
741
742* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
743- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
744
745* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
746- kde-3.96.0
747
748* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
749- kdebase-runtime-3.95.2
750
751* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
752- kdebase-runtime-3.95.0
753
754* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
755- Provides: oxygen-icon-theme ...
756
757* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
758- patch dolphin.desktop to get Dolphin to start from the menu
759
760* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
761- update to 3.94.0
762
763* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
764- don't make this the default kdebase on F9 yet
765- drop ExcludeArch: ppc64 (#300601)
766
767* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
768- ExcludeArch: ppc64 (#300601)
769- update description
770
771* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
772- add missing BR alsa-lib-devel
773
774* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
775- remove files which conflict with KDE 3
776- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
777- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
778
779* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
780- update to 3.93.0
781- drop kde4home patch (no longer applied)
782- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
783- remove kdebase-kdm Obsoletes/Provides (for the same reason)
784- remove KDM (and KDM session) setup code (for the same reason)
785- remove rss-glx conflict (Plasma is now in kdebase-workspace)
786- remove redhat-startkde patch (startkde is now in kdebase-workspace)
787- remove kde4-opt.sh (all the code in it is commented out)
788- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
789- remove bogus BRs on automake and libtool
790- remove workspace-only BRs
791- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
792- remove workspace files and directories
793- handle icons (moved from kdelibs4)
794- add mkdir %%{buildroot} in %%install
795
796* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
797- use macros.kde4
798- License: GPLv2
799
800* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
801- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
802- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
803- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
804
805* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
806- consolekit_kdm patch (#228111, kde#147790)
807- update startkde patch
808
809* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
810- kde-3.92 (kde-4-beta1)
811
812* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
813- fix startkde
814- add env/shutdown directory
815
816* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
817- kde4.desktop: fix session Name
818
819* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
820- cleanup/fix kde4.desktop
821- kdepimlibs4->kdepimlibs
822
823* Fri Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
824- fix %%_sysconfdir for %%_prefix != /usr case.
825
826* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
827- updated kde4home.diff
828- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
829
830* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
831- kde-3.91.0
832- CMAKE_BUILD_TYPE=debug
833
834* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
835- specfile cleanup (%%prefix issues mostly)
836
837* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
838- update to 3.90.1
839- bump cmake BR to 2.4.5 as required upstream now
840- don't set execute bits by hand anymore, cmake has been fixed
841- use multilibs in /opt/kde4
842- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
843- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
844  in case we want to drop the Rs on these from kdelibs4-devel
845- consistently add all BRs as -devel Rs, not just almost all, until we can
846  figure out which, if any, are really needed
847- BR libsmbclient-devel instead of samba on F>=7, EL>=6
848
849* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
850- restore minimum version requirement for cmake
851- build against libxklavier on EL5
852- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
853
854* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
855- +eXecute perms for %%{_prefix}/lib/*
856
857* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
858- rebuild for patched FindKDE4Internal.cmake
859
860* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
861- update to 3.80.3
862- update and improve parallel-installability patch
863- drop obsolete joydevice.h patch
864- remove translations of "KDE" without the "4" from kde4.desktop
865- resync BR and -devel Requires
866- don't set LD_LIBRARY_PATH
867- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
868- fix missing underscore in _datadir
869- install kde4.desktop in install, not prep
870- fix invalid syntax in kde4.desktop
871
872* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
873- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
874- compiling with QA_RPATHS=0x0003; export QA_RPATHS
875
876* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
877- parallel build support
878- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
879- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
880- spec file cleanups and added clean up in %%install
881- fixed PATH for libkdecore.so.5; cannot open shared object file;
882- added Logitech mouse support
883- added dbus-devel, hal-devel and more as BR
884- fixed broken joydevice.h - Kevin Kofler
885- added file kde4.desktop
886
887* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
888- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
889- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.