source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 7728

Revision 7728, 28.4 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.10.5

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.10.5
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstreamable patches
33# make nepomuk menu items (with oxygen-only icons atm) OnlyShowIn=KDE;
34Patch50: kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch
35
36# make installdbgsymbols.sh use pkexec instead of su
37# increase some timeouts in an effort to see (some) errors before close
38Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
39
40## upstream patches
41
42
43Provides:  kdebase4-runtime = %{version}-%{release}
44Provides:  kde-runtime = %{version}-%{release}
45Obsoletes: kdebase4-runtime < %{version}-%{release}
46
47Obsoletes: nepomukcontroller
48Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
49
50# knotify4 provides dbus service org.freedesktop.Notifications too
51Provides: desktop-notification-daemon
52
53BuildRoot:     %{_tmppath}/%{name}-%{version}-root
54BuildRequires: alsa-lib-devel
55BuildRequires: attica-devel >= 0.1.4
56BuildRequires: bzip2-devel
57BuildRequires: chrpath
58BuildRequires: clucene-core-devel
59BuildRequires: doxygen
60BuildRequires: exiv2-devel >= 0.12
61BuildRequires: glib2-devel
62BuildRequires: kdelibs4-devel >= %{version}
63BuildRequires: kdepimlibs-devel >= %{version}
64BuildRequires: kactivities-devel >= %{version}
65BuildRequires: libcanberra-devel
66#BuildRequires: libqzeitgeist-devel
67BuildRequires: libsmbclient-devel
68BuildRequires: libssh-devel >= 0.4.2
69BuildRequires: libXpm-devel
70BuildRequires: libXScrnSaver-devel
71BuildRequires: NetworkManager-devel
72BuildRequires: nepomuk-core
73BuildRequires: nepomuk-core-devel
74BuildRequires: OpenEXR-devel
75BuildRequires: openslp-devel
76BuildRequires: openssl-devel
77BuildRequires: pkgconfig
78BuildRequires: polkit-qt-devel
79BuildRequires: pulseaudio-libs-devel
80BuildRequires: qca2-devel
81BuildRequires: qimageblitz-devel
82BuildRequires: shared-mime-info >= 0.40
83BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
84BuildRequires: soprano-devel >= 2.6.50
85BuildRequires: xine-lib-devel libxcb-devel
86BuildRequires: xorg-x11-font-utils
87BuildRequires: xorg-x11-proto-devel
88BuildRequires: xz-devel
89BuildRequires: zlib-devel
90
91Requires: eject
92Requires: %{name}-libs = %{version}-%{release}
93Requires: %{name}-flags = %{version}-%{release}
94# KHelpcenter requires htdig for building search indices
95Requires: htdig
96# ensure default/fallback icon theme present
97# beware of bootstrapping, there be dragons
98Requires: oxygen-icon-theme >= %{version}
99
100# some items moved -workspace -> -runtime
101Conflicts: kdebase-workspace < 4.5.80
102
103%description
104Core runtime for KDE 4.
105
106%description -l ja
107KDE 4 の中心となるランタイム部分です.
108
109%package devel
110Summary:  Developer files for %{name}
111Summary(ja): %{name} の開発用ファイル
112Group:    Development/Libraries
113Requires: %{name}-libs = %{version}-%{release}
114
115%description devel
116%{summary}.
117
118%description -l ja devel
119%{name} の開発用ファイルです.
120
121%package libs
122Summary: Runtime libraries for %{name}
123Summary(ja): %{name} のランタイムライブラリ
124Group:   System Environment/Libraries
125Requires: kdelibs4 >= %{version}
126Requires: kdepimlibs >= %{version}
127# cagibi is runtime dep, a dbus service
128Requires: cagibi
129
130%description libs
131%{summary}.
132
133%description -l ja libs
134%{name} のランタイムライブラリです.
135
136%package flags
137Summary: Geopolitical flags
138Group: User Interface/Desktops
139Requires: %{name}-libs = %{version}-%{release}
140BuildArch: noarch
141
142%description flags
143%{summary}.
144
145
146%prep
147%setup -q -n kde-runtime-%{version}
148
149%patch1 -p1 -b .searchproviders-shortcuts
150%patch6 -p1 -b .home_onlyshowin_kde
151%patch7 -p1 -b .htsearch
152%patch8 -p1 -b .config
153%patch9 -p1 -b .man-overrides
154%patch50 -p1 -b .nepomuk_onlyshowin_kde
155%patch51 -p1 -b .installdgbsymbols
156
157
158%build
159mkdir -p %{_target_platform}
160pushd %{_target_platform}
161%cmake \
162    -DCMAKE_BUILD_TYPE=release \
163    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
164    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
165    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
166    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
167    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
168    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
169    ..
170popd
171
172make %{?_smp_mflags} -C %{_target_platform}
173
174
175%install
176rm -rf $RPM_BUILD_ROOT
177
178make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
179
180# kdesu symlink
181ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
182
183# omit hicolor index.theme, use one from hicolor-icon-theme
184rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
185
186# remove country flags because some people/countries forbid some other
187# people/countries' flags :-(
188%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
189
190# install this service for KDE 3 applications too
191mkdir $RPM_BUILD_ROOT%{_datadir}/services
192ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
193      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
194
195# FIXME: -devel type files, omit for now
196rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
197
198# rpaths
199# use chrpath hammer for now, find better patching solutions later -- Rex
200chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
201chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
202
203%clean
204rm -rf $RPM_BUILD_ROOT
205
206%post
207touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
208touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209
210%posttrans
211gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
212gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
213update-desktop-database -q &> /dev/null ||:
214update-mime-database %{_datadir}/mime &> /dev/null
215
216%postun
217if [ $1 -eq 0 ] ; then
218    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
219    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
220    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
221    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
222    update-desktop-database -q &> /dev/null ||:
223    update-mime-database %{_datadir}/mime &> /dev/null
224fi
225
226%post libs -p /sbin/ldconfig
227%postun libs -p /sbin/ldconfig
228
229
230%files
231%defattr(-,root,root,-)
232%{_sysconfdir}/dbus-1/system.d/*
233%{_sysconfdir}/xdg/menus/kde-information.menu
234%{_bindir}/*
235# omit ksvgtopng which kdelibs3 includes
236%{_datadir}/kde4/apps/*
237%exclude %{_datadir}/kde4/apps/cmake/
238%{_datadir}/config/*.knsrc
239%{_datadir}/autostart/nepomukcontroller.desktop
240%{_datadir}/config.kcfg/
241%{_datadir}/dbus-1/interfaces/*
242%{_datadir}/dbus-1/services/*
243%{_datadir}/dbus-1/system-services/*
244%{_datadir}/icons/default.kde4
245%{_datadir}/kde4/services/*
246%{_datadir}/kde4/servicetypes/*
247%{_datadir}/mime/packages/network.xml
248%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
249%{_datadir}/sounds/*
250%{_libdir}/kconf_update_bin/*
251%{_libdir}/libkdeinit4_*.so
252%{_libdir}/kde4/kcm_*.so
253%{_libdir}/kde4/kded_*.so
254%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
255%{_libexecdir}/kde4/drkonqi
256#{_libexecdir}/kde4/installdbgsymbols.sh
257%{_libexecdir}/kde4/kcmremotewidgetshelper
258%{_libexecdir}/kde4/kdeeject
259%{_libexecdir}/kde4/kdesu
260%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
261%{_libexecdir}/kde4/kdontchangethehostname
262%{_libexecdir}/kde4/khc_docbookdig.pl
263%{_libexecdir}/kde4/khc_htdig.pl
264%{_libexecdir}/kde4/khc_htsearch.pl
265%{_libexecdir}/kde4/khc_indexbuilder
266%{_libexecdir}/kde4/khc_mansearch.pl
267%{_libexecdir}/kde4/kioexec
268%{_libexecdir}/kde4/knetattach
269%{_mandir}/man1/*
270%{_mandir}/man8/*
271%{_datadir}/icons/hicolor/*/*/*
272%{_docdir}/HTML/en/*
273%{_datadir}/applications/kde4/Help.desktop
274%{_datadir}/applications/kde4/knetattach.desktop
275%{_datadir}/applications/kde4/nepomukcontroller.desktop
276%{_datadir}/config/kshorturifilterrc
277%{_datadir}/desktop-directories/*.directory
278%{_datadir}/emoticons/kde4/
279%{_datadir}/locale/l10n/
280%{_datadir}/locale/currency/
281%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
282%{_datadir}/services/khelpcenter.desktop
283
284%files devel
285%defattr(-,root,root,-)
286%{_includedir}/*
287%{_datadir}/kde4/apps/cmake/modules/*.cmake
288
289%files libs
290%defattr(-,root,root,-)
291%{_libdir}/attica_kde.so
292%{_libdir}/libknotifyplugin.so
293%{_libdir}/libkwalletbackend.so.*
294%{_libdir}/libmolletnetwork.so.*
295%{_libdir}/kde4/*.so
296%{_libdir}/kde4/imports/
297# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
298%exclude %{_libdir}/kde4/kcm_*.so
299%exclude %{_libdir}/kde4/kded_*.so
300%{_libdir}/kde4/plugins/phonon_platform/
301
302%files flags
303%defattr(-,root,root,-)
304%{_datadir}/locale/l10n/*/flag.png
305
306
307%changelog
308* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
309- new upstream release
310
311* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
312- new upstream release
313- add patches from fedora
314  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
315  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
316
317* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
318- new upstream release
319
320* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
321- new upstream release
322
323* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
324- new upstream release
325
326* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
327- rebuild with attica-0.4.1
328
329* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
330- new upstream release
331- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
332- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
333
334* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
335- rebuild with exiv2-0.23
336
337* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
338- rebuild with exiv2-0.22
339
340* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
341- rebuilt without libqzeitgeist
342
343* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
344- new upstream release
345
346* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
347- new upstream release
348
349* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
350- new upstream release
351- built with exiv2-0.21.1
352
353* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
354- new upstream release
355
356* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
357- rebuilt with libsmbclient-3.5.8
358
359* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
360- new upstream release
361
362* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
363- added BR: libXpm-devel
364
365* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
366- new upstream release
367- added devel subpackage
368
369* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
370- new upstream release
371- updated summary
372- dropt Patch100
373
374* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
375- new upstream release
376- added Patch100 from Fedora
377  - backport to fix the freeze of kded on first use of the network:/kio-slave
378
379* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
380- new upstream release
381- added Conflicts: kdebase3 at Vine Linux 5
382
383* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
384- new upstream release
385
386* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
387- rebuilt with exiv2-0.19
388
389* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
390- new upstream release
391
392* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
393- new upstream release
394
395* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
396- new upstream release
397- built with new toolchain
398
399* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
400- new upstream release
401
402* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
403- new upstream release
404
405* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
406- new upstream release
407- used %%cmake macro
408
409* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
410- Initial build for Vine Linux
411
412* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
413- respin
414
415* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
416- 4.3.0
417
418* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
419- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
420
421* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
422- 4.3rc3
423
424* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
425- respin (soprano-2.3.0)
426- License: LGPLv2+
427
428* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
429- 4.3rc2
430
431* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
432- drop unneeded BR: ImageMagick (#509241)
433
434* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
435- don't start nepomuk server unconditionally (#487322)
436
437* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
438- 4.3rc1
439
440* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
441- KDE-4.3 beta2 (4.2.90)
442
443* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
444- Drop old Fedora < 8 conditionals
445
446* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
447- file conflicts with kdepim
448
449* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
450- KDE 4.3 beta 1
451
452* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
453- fix persistent systray notifications (#485796)
454
455* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
456- -flags subpkg
457- koji/noarch hacks dropped
458
459* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
460- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
461
462* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
463- KDE 4.2.2
464
465* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
466- flags subpkg (not enabled)
467- optimize scriptlets
468
469* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
470- fix PulseAudio cmake detection
471
472* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
473- 4.2.1
474
475* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
476- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
477
478* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
479- #486059 -  missing dependency on htdig
480
481* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
482- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
483
484* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
485- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
486
487* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
488- own %%_kde4_datadir/locale/l10n/
489
490* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
491- respun tarball
492
493* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
494- Files not trashed to the correct location in Dolphin/Konqueror
495  (#481598, kdebug#178479)
496- omit --with-samba crud
497
498* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
499- 4.2.0
500- +BR: pulseaudio-libs-devel xine-lib-devel
501- -BR: giflib-devel pcre-devel
502
503* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
504- tarball respin
505- drop extraneous deps (that are in kdelibs)
506
507* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
508- 4.2rc1
509
510* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
511- include %%_bindir/kdesu symlink
512
513* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
514- 4.2beta2
515
516* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
517- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
518  and should be in a -devel package if it gets shipped)
519
520* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
521- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
522
523* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
524- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
525
526* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
527- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
528
529* Wed Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
530- 4.1.80
531- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
532- BR cmake >= 2.6.2
533- Use 'make install/fast'
534- Drop subpkg phonon-backend-xine and related file entries: this has to be
535  part of phonon now that it moved there
536- Drop xine-lib-devel BR
537- Add libkwalletbackend to files list
538- Drop _default_patch_fuzz 2
539
540* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
541- apply upstream patch to fix X crash when disabling compositing
542
543* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
544- 4.1.3
545
546* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
547- apply upstream patch, kioexec processes never terminate
548
549* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
550- fix broken audio-backend-jack.svgz
551
552* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
553- add missing icons
554
555* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
556- make VERBOSE=1
557- respin against new(er) kde-filesystem
558- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
559
560* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
561- 4.1.2
562
563* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
564- fix inherit issue in iconthemes, preview icons
565  do not show
566
567* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
568- fix #460710, knetattach is kio_remote's wizard program, don't show
569  it in the menu.
570
571* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
572- 4.1.1
573
574* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
575- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
576
577* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
578- crash fix when stopping a service that is not yet initialized
579
580* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
581- don't remove autostart directory on F8- (does not conflict, fixes build
582  failure due to nepomukserver.desktop listed in filelist but not found)
583
584* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
585- 4.1.0
586
587* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
588- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
589
590* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
591- 4.0.99
592
593* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
594- respin
595
596* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
597- -phonon-backend-xine: new subpkg
598
599* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
600- 4.0.98
601
602* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
603- 4.0.85
604
605* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
606- 4.0.84
607
608* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
609- 4.0.83 (beta2)
610
611* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
612- 4.0.82
613
614* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
615- add searchproviders-shortcuts for redhat bugzilla
616
617* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
618- 4.1 beta 1
619
620* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
621- BR new minimum version of soprano-devel
622
623* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
624- update to 4.0.72 (4.1 alpha 1)
625- drop upstreamed deinterlace-crash patch
626- drop khelpcenter patch (fixed upstream)
627- update Phonon PulseAudio patch
628- drop Fedora 7 support
629- update file list
630
631* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
632- omit conflicting icons (kde3_desktop=1 case)
633
634* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
635- oxygen-icon-theme: build noarch
636
637* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
638- %%post/%%postun: hicolor icon theme scriptlets
639
640* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
641- only omit hicolor index.theme (#439374)
642
643* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
644- fix khelpcenter, search plugins/settings in correct path (#443016)
645
646* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
647- respin (at f13's request)
648
649* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
650- pulseaudio patch (use as default, if available)
651
652* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
653- don't crash if we don't have deinterlacing support in xine-lib (#440299)
654
655* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
656- rebuild for the new %%{_kde4_buildtype}
657
658* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
659- update file list for _kde4_libexecdir
660
661* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
662- 4.0.3
663
664* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
665- don't own %%_kde4_docdir/HTML/en/
666
667* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
668- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
669- include noarch build hooks (not enabled)
670
671* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
672- BR libxcb-devel everywhere (including F7)
673
674* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
675- if building for a KDE 4 desktop, include the khelpcenter.desktop service
676  description for KDE 3 here so help works in KDE 3 apps
677
678* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
679- 4.0.2
680
681* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
682- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
683
684* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
685- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
686  (kio_smb itself is already GPLv2+)
687
688* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
689- 4.0.1
690
691* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
692- respun tarball
693
694* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
695- update to 4.0.0
696- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
697
698* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
699- kde-3.97.0
700
701* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
702- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
703
704* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
705- build without libxcb in F7 as we STILL don't have it (see #373361)
706
707* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
708- no longer set kde3_desktop on F9
709- update file list for !kde3_desktop (Sebastian Vahl)
710- don't ship country flags even for full version (as in kdebase 3)
711
712* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
713- kde-3.96.2
714
715* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
716- kde-3.96.1
717
718* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
719- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
720
721* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
722- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
723
724* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
725- kde-3.96.0
726
727* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
728- kdebase-runtime-3.95.2
729
730* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
731- kdebase-runtime-3.95.0
732
733* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
734- Provides: oxygen-icon-theme ...
735
736* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
737- patch dolphin.desktop to get Dolphin to start from the menu
738
739* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
740- update to 3.94.0
741
742* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
743- don't make this the default kdebase on F9 yet
744- drop ExcludeArch: ppc64 (#300601)
745
746* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
747- ExcludeArch: ppc64 (#300601)
748- update description
749
750* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
751- add missing BR alsa-lib-devel
752
753* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
754- remove files which conflict with KDE 3
755- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
756- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
757
758* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
759- update to 3.93.0
760- drop kde4home patch (no longer applied)
761- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
762- remove kdebase-kdm Obsoletes/Provides (for the same reason)
763- remove KDM (and KDM session) setup code (for the same reason)
764- remove rss-glx conflict (Plasma is now in kdebase-workspace)
765- remove redhat-startkde patch (startkde is now in kdebase-workspace)
766- remove kde4-opt.sh (all the code in it is commented out)
767- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
768- remove bogus BRs on automake and libtool
769- remove workspace-only BRs
770- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
771- remove workspace files and directories
772- handle icons (moved from kdelibs4)
773- add mkdir %%{buildroot} in %%install
774
775* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
776- use macros.kde4
777- License: GPLv2
778
779* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
780- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
781- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
782- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
783
784* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
785- consolekit_kdm patch (#228111, kde#147790)
786- update startkde patch
787
788* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
789- kde-3.92 (kde-4-beta1)
790
791* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
792- fix startkde
793- add env/shutdown directory
794
795* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
796- kde4.desktop: fix session Name
797
798* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
799- cleanup/fix kde4.desktop
800- kdepimlibs4->kdepimlibs
801
802* Fri Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
803- fix %%_sysconfdir for %%_prefix != /usr case.
804
805* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
806- updated kde4home.diff
807- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
808
809* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
810- kde-3.91.0
811- CMAKE_BUILD_TYPE=debug
812
813* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
814- specfile cleanup (%%prefix issues mostly)
815
816* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
817- update to 3.90.1
818- bump cmake BR to 2.4.5 as required upstream now
819- don't set execute bits by hand anymore, cmake has been fixed
820- use multilibs in /opt/kde4
821- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
822- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
823  in case we want to drop the Rs on these from kdelibs4-devel
824- consistently add all BRs as -devel Rs, not just almost all, until we can
825  figure out which, if any, are really needed
826- BR libsmbclient-devel instead of samba on F>=7, EL>=6
827
828* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
829- restore minimum version requirement for cmake
830- build against libxklavier on EL5
831- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
832
833* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
834- +eXecute perms for %%{_prefix}/lib/*
835
836* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
837- rebuild for patched FindKDE4Internal.cmake
838
839* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
840- update to 3.80.3
841- update and improve parallel-installability patch
842- drop obsolete joydevice.h patch
843- remove translations of "KDE" without the "4" from kde4.desktop
844- resync BR and -devel Requires
845- don't set LD_LIBRARY_PATH
846- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
847- fix missing underscore in _datadir
848- install kde4.desktop in install, not prep
849- fix invalid syntax in kde4.desktop
850
851* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
852- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
853- compiling with QA_RPATHS=0x0003; export QA_RPATHS
854
855* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
856- parallel build support
857- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
858- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
859- spec file cleanups and added clean up in %%install
860- fixed PATH for libkdecore.so.5; cannot open shared object file;
861- added Logitech mouse support
862- added dbus-devel, hal-devel and more as BR
863- fixed broken joydevice.h - Kevin Kofler
864- added file kde4.desktop
865
866* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
867- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
868- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.