source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 7294

Revision 7294, 28.3 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.9.5
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstreamable patches
33# make nepomuk menu items (with oxygen-only icons atm) OnlyShowIn=KDE;
34Patch50: kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch
35
36# make installdbgsymbols.sh use pkexec instead of su
37# increase some timeouts in an effort to see (some) errors before close
38Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
39
40## upstream patches
41
42
43Provides:  kdebase4-runtime = %{version}-%{release}
44Provides:  kde-runtime = %{version}-%{release}
45Obsoletes: kdebase4-runtime < %{version}-%{release}
46
47Obsoletes: nepomukcontroller
48Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
49
50# knotify4 provides dbus service org.freedesktop.Notifications too
51Provides: desktop-notification-daemon
52
53BuildRoot:     %{_tmppath}/%{name}-%{version}-root
54BuildRequires: alsa-lib-devel
55BuildRequires: attica-devel >= 0.1.4
56BuildRequires: bzip2-devel
57BuildRequires: chrpath
58BuildRequires: clucene-core-devel
59BuildRequires: doxygen
60BuildRequires: exiv2-devel >= 0.12
61BuildRequires: glib2-devel
62BuildRequires: kdelibs4-devel >= %{version}
63BuildRequires: kdepimlibs-devel >= %{version}
64BuildRequires: kactivities-devel >= %{version}
65BuildRequires: libcanberra-devel
66#BuildRequires: libqzeitgeist-devel
67BuildRequires: libsmbclient-devel
68BuildRequires: libssh-devel >= 0.4.2
69BuildRequires: libXpm-devel
70BuildRequires: libXScrnSaver-devel
71BuildRequires: NetworkManager-devel
72BuildRequires: nepomuk-core
73BuildRequires: nepomuk-core-devel
74BuildRequires: OpenEXR-devel
75BuildRequires: openslp-devel
76BuildRequires: openssl-devel
77BuildRequires: pkgconfig
78BuildRequires: polkit-qt-devel
79BuildRequires: pulseaudio-libs-devel
80BuildRequires: qca2-devel
81BuildRequires: qimageblitz-devel
82BuildRequires: shared-mime-info >= 0.40
83BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
84BuildRequires: soprano-devel >= 2.6.50
85BuildRequires: xine-lib-devel libxcb-devel
86BuildRequires: xorg-x11-font-utils
87BuildRequires: xorg-x11-proto-devel
88BuildRequires: xz-devel
89BuildRequires: zlib-devel
90
91Requires: eject
92Requires: %{name}-libs = %{version}-%{release}
93Requires: %{name}-flags = %{version}-%{release}
94# KHelpcenter requires htdig for building search indices
95Requires: htdig
96# ensure default/fallback icon theme present
97# beware of bootstrapping, there be dragons
98Requires: oxygen-icon-theme >= %{version}
99
100# some items moved -workspace -> -runtime
101Conflicts: kdebase-workspace < 4.5.80
102
103%description
104Core runtime for KDE 4.
105
106%description -l ja
107KDE 4 の中心となるランタイム部分です.
108
109%package devel
110Summary:  Developer files for %{name}
111Summary(ja): %{name} の開発用ファイル
112Group:    Development/Libraries
113Requires: %{name}-libs = %{version}-%{release}
114
115%description devel
116%{summary}.
117
118%description -l ja devel
119%{name} の開発用ファイルです.
120
121%package libs
122Summary: Runtime libraries for %{name}
123Summary(ja): %{name} のランタイムライブラリ
124Group:   System Environment/Libraries
125Requires: kdelibs4 >= %{version}
126Requires: kdepimlibs >= %{version}
127# cagibi is runtime dep, a dbus service
128Requires: cagibi
129
130%description libs
131%{summary}.
132
133%description -l ja libs
134%{name} のランタイムライブラリです.
135
136%package flags
137Summary: Geopolitical flags
138Group: User Interface/Desktops
139Requires: %{name}-libs = %{version}-%{release}
140BuildArch: noarch
141
142%description flags
143%{summary}.
144
145
146%prep
147%setup -q -n kde-runtime-%{version}
148
149%patch1 -p1 -b .searchproviders-shortcuts
150%patch6 -p1 -b .home_onlyshowin_kde
151%patch7 -p1 -b .htsearch
152%patch8 -p1 -b .config
153%patch9 -p1 -b .man-overrides
154%patch50 -p1 -b .nepomuk_onlyshowin_kde
155%patch51 -p1 -b .installdgbsymbols
156
157
158%build
159mkdir -p %{_target_platform}
160pushd %{_target_platform}
161%cmake \
162    -DCMAKE_BUILD_TYPE=release \
163    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
164    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
165    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
166    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
167    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
168    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
169    ..
170popd
171
172make %{?_smp_mflags} -C %{_target_platform}
173
174
175%install
176rm -rf $RPM_BUILD_ROOT
177
178make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
179
180# kdesu symlink
181ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
182
183# omit hicolor index.theme, use one from hicolor-icon-theme
184rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
185
186# remove country flags because some people/countries forbid some other
187# people/countries' flags :-(
188%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
189
190# install this service for KDE 3 applications too
191mkdir $RPM_BUILD_ROOT%{_datadir}/services
192ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
193      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
194
195# FIXME: -devel type files, omit for now
196rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
197
198# rpaths
199# use chrpath hammer for now, find better patching solutions later -- Rex
200chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
201chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
202
203%clean
204rm -rf $RPM_BUILD_ROOT
205
206%post
207touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
208touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
209
210%posttrans
211gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
212gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
213update-desktop-database -q &> /dev/null ||:
214update-mime-database %{_datadir}/mime &> /dev/null
215
216%postun
217if [ $1 -eq 0 ] ; then
218    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
219    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
220    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
221    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
222    update-desktop-database -q &> /dev/null ||:
223    update-mime-database %{_datadir}/mime &> /dev/null
224fi
225
226%post libs -p /sbin/ldconfig
227%postun libs -p /sbin/ldconfig
228
229
230%files
231%defattr(-,root,root,-)
232%{_sysconfdir}/dbus-1/system.d/*
233%{_sysconfdir}/xdg/menus/kde-information.menu
234%{_bindir}/*
235# omit ksvgtopng which kdelibs3 includes
236%{_datadir}/kde4/apps/*
237%exclude %{_datadir}/kde4/apps/cmake/
238%{_datadir}/config/*.knsrc
239%{_datadir}/autostart/nepomukcontroller.desktop
240%{_datadir}/config.kcfg/
241%{_datadir}/dbus-1/interfaces/*
242%{_datadir}/dbus-1/services/*
243%{_datadir}/dbus-1/system-services/*
244%{_datadir}/icons/default.kde4
245%{_datadir}/kde4/services/*
246%{_datadir}/kde4/servicetypes/*
247%{_datadir}/mime/packages/network.xml
248%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
249%{_datadir}/sounds/*
250%{_libdir}/kconf_update_bin/*
251%{_libdir}/libkdeinit4_*.so
252%{_libdir}/kde4/kcm_*.so
253%{_libdir}/kde4/kded_*.so
254%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
255%{_libexecdir}/kde4/drkonqi
256#{_libexecdir}/kde4/installdbgsymbols.sh
257%{_libexecdir}/kde4/kcmremotewidgetshelper
258%{_libexecdir}/kde4/kdeeject
259%{_libexecdir}/kde4/kdesu
260%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
261%{_libexecdir}/kde4/kdontchangethehostname
262%{_libexecdir}/kde4/khc_docbookdig.pl
263%{_libexecdir}/kde4/khc_htdig.pl
264%{_libexecdir}/kde4/khc_htsearch.pl
265%{_libexecdir}/kde4/khc_indexbuilder
266%{_libexecdir}/kde4/khc_mansearch.pl
267%{_libexecdir}/kde4/kioexec
268%{_libexecdir}/kde4/knetattach
269%{_mandir}/man1/*
270%{_mandir}/man8/*
271%{_datadir}/icons/hicolor/*/*/*
272%{_docdir}/HTML/en/*
273%{_datadir}/applications/kde4/Help.desktop
274%{_datadir}/applications/kde4/knetattach.desktop
275%{_datadir}/applications/kde4/nepomukcontroller.desktop
276%{_datadir}/config/kshorturifilterrc
277%{_datadir}/desktop-directories/*.directory
278%{_datadir}/emoticons/kde4/
279%{_datadir}/locale/l10n/
280%{_datadir}/locale/currency/
281%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
282%{_datadir}/services/khelpcenter.desktop
283
284%files devel
285%defattr(-,root,root,-)
286%{_includedir}/*
287%{_datadir}/kde4/apps/cmake/modules/*.cmake
288
289%files libs
290%defattr(-,root,root,-)
291%{_libdir}/attica_kde.so
292%{_libdir}/libknotifyplugin.so
293%{_libdir}/libkwalletbackend.so.*
294%{_libdir}/libmolletnetwork.so.*
295%{_libdir}/kde4/*.so
296%{_libdir}/kde4/imports/
297# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
298%exclude %{_libdir}/kde4/kcm_*.so
299%exclude %{_libdir}/kde4/kded_*.so
300%{_libdir}/kde4/plugins/phonon_platform/
301
302%files flags
303%defattr(-,root,root,-)
304%{_datadir}/locale/l10n/*/flag.png
305
306
307%changelog
308* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
309- new upstream release
310- add patches from fedora
311  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
312  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
313
314* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
315- new upstream release
316
317* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
318- new upstream release
319
320* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
321- new upstream release
322
323* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
324- rebuild with attica-0.4.1
325
326* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
327- new upstream release
328- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
329- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
330
331* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
332- rebuild with exiv2-0.23
333
334* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
335- rebuild with exiv2-0.22
336
337* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
338- rebuilt without libqzeitgeist
339
340* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
341- new upstream release
342
343* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
344- new upstream release
345
346* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
347- new upstream release
348- built with exiv2-0.21.1
349
350* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
351- new upstream release
352
353* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
354- rebuilt with libsmbclient-3.5.8
355
356* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
357- new upstream release
358
359* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
360- added BR: libXpm-devel
361
362* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
363- new upstream release
364- added devel subpackage
365
366* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
367- new upstream release
368- updated summary
369- dropt Patch100
370
371* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
372- new upstream release
373- added Patch100 from Fedora
374  - backport to fix the freeze of kded on first use of the network:/kio-slave
375
376* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
377- new upstream release
378- added Conflicts: kdebase3 at Vine Linux 5
379
380* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
381- new upstream release
382
383* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
384- rebuilt with exiv2-0.19
385
386* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
387- new upstream release
388
389* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
390- new upstream release
391
392* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
393- new upstream release
394- built with new toolchain
395
396* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
397- new upstream release
398
399* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
400- new upstream release
401
402* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
403- new upstream release
404- used %%cmake macro
405
406* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
407- Initial build for Vine Linux
408
409* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
410- respin
411
412* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
413- 4.3.0
414
415* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
416- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
417
418* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
419- 4.3rc3
420
421* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
422- respin (soprano-2.3.0)
423- License: LGPLv2+
424
425* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
426- 4.3rc2
427
428* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
429- drop unneeded BR: ImageMagick (#509241)
430
431* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
432- don't start nepomuk server unconditionally (#487322)
433
434* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
435- 4.3rc1
436
437* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
438- KDE-4.3 beta2 (4.2.90)
439
440* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
441- Drop old Fedora < 8 conditionals
442
443* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
444- file conflicts with kdepim
445
446* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
447- KDE 4.3 beta 1
448
449* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
450- fix persistent systray notifications (#485796)
451
452* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
453- -flags subpkg
454- koji/noarch hacks dropped
455
456* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
457- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
458
459* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
460- KDE 4.2.2
461
462* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
463- flags subpkg (not enabled)
464- optimize scriptlets
465
466* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
467- fix PulseAudio cmake detection
468
469* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
470- 4.2.1
471
472* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
473- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
474
475* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
476- #486059 -  missing dependency on htdig
477
478* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
479- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
480
481* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
482- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
483
484* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
485- own %%_kde4_datadir/locale/l10n/
486
487* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
488- respun tarball
489
490* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
491- Files not trashed to the correct location in Dolphin/Konqueror
492  (#481598, kdebug#178479)
493- omit --with-samba crud
494
495* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
496- 4.2.0
497- +BR: pulseaudio-libs-devel xine-lib-devel
498- -BR: giflib-devel pcre-devel
499
500* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
501- tarball respin
502- drop extraneous deps (that are in kdelibs)
503
504* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
505- 4.2rc1
506
507* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
508- include %%_bindir/kdesu symlink
509
510* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
511- 4.2beta2
512
513* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
514- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
515  and should be in a -devel package if it gets shipped)
516
517* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
518- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
519
520* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
521- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
522
523* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
524- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
525
526* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
527- 4.1.80
528- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
529- BR cmake >= 2.6.2
530- Use 'make install/fast'
531- Drop subpkg phonon-backend-xine and related file entries: this has to be
532  part of phonon now that it moved there
533- Drop xine-lib-devel BR
534- Add libkwalletbackend to files list
535- Drop _default_patch_fuzz 2
536
537* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
538- apply upstream patch to fix X crash when disabling compositing
539
540* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
541- 4.1.3
542
543* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
544- apply upstream patch, kioexec processes never terminate
545
546* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
547- fix broken audio-backend-jack.svgz
548
549* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
550- add missing icons
551
552* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
553- make VERBOSE=1
554- respin against new(er) kde-filesystem
555- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
556
557* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
558- 4.1.2
559
560* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
561- fix inherit issue in iconthemes, preview icons
562  do not show
563
564* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
565- fix #460710, knetattach is kio_remote's wizard program, don't show
566  it in the menu.
567
568* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
569- 4.1.1
570
571* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
572- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
573
574* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
575- crash fix when stopping a service that is not yet initialized
576
577* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
578- don't remove autostart directory on F8- (does not conflict, fixes build
579  failure due to nepomukserver.desktop listed in filelist but not found)
580
581* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
582- 4.1.0
583
584* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
585- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
586
587* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
588- 4.0.99
589
590* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
591- respin
592
593* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
594- -phonon-backend-xine: new subpkg
595
596* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
597- 4.0.98
598
599* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
600- 4.0.85
601
602* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
603- 4.0.84
604
605* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
606- 4.0.83 (beta2)
607
608* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
609- 4.0.82
610
611* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
612- add searchproviders-shortcuts for redhat bugzilla
613
614* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
615- 4.1 beta 1
616
617* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
618- BR new minimum version of soprano-devel
619
620* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
621- update to 4.0.72 (4.1 alpha 1)
622- drop upstreamed deinterlace-crash patch
623- drop khelpcenter patch (fixed upstream)
624- update Phonon PulseAudio patch
625- drop Fedora 7 support
626- update file list
627
628* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
629- omit conflicting icons (kde3_desktop=1 case)
630
631* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
632- oxygen-icon-theme: build noarch
633
634* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
635- %%post/%%postun: hicolor icon theme scriptlets
636
637* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
638- only omit hicolor index.theme (#439374)
639
640* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
641- fix khelpcenter, search plugins/settings in correct path (#443016)
642
643* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
644- respin (at f13's request)
645
646* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
647- pulseaudio patch (use as default, if available)
648
649* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
650- don't crash if we don't have deinterlacing support in xine-lib (#440299)
651
652* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
653- rebuild for the new %%{_kde4_buildtype}
654
655* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
656- update file list for _kde4_libexecdir
657
658* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
659- 4.0.3
660
661* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
662- don't own %%_kde4_docdir/HTML/en/
663
664* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
665- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
666- include noarch build hooks (not enabled)
667
668* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
669- BR libxcb-devel everywhere (including F7)
670
671* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
672- if building for a KDE 4 desktop, include the khelpcenter.desktop service
673  description for KDE 3 here so help works in KDE 3 apps
674
675* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
676- 4.0.2
677
678* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
679- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
680
681* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
682- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
683  (kio_smb itself is already GPLv2+)
684
685* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
686- 4.0.1
687
688* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
689- respun tarball
690
691* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
692- update to 4.0.0
693- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
694
695* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
696- kde-3.97.0
697
698* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
699- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
700
701* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
702- build without libxcb in F7 as we STILL don't have it (see #373361)
703
704* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
705- no longer set kde3_desktop on F9
706- update file list for !kde3_desktop (Sebastian Vahl)
707- don't ship country flags even for full version (as in kdebase 3)
708
709* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
710- kde-3.96.2
711
712* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
713- kde-3.96.1
714
715* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
716- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
717
718* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
719- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
720
721* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
722- kde-3.96.0
723
724* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
725- kdebase-runtime-3.95.2
726
727* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
728- kdebase-runtime-3.95.0
729
730* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
731- Provides: oxygen-icon-theme ...
732
733* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
734- patch dolphin.desktop to get Dolphin to start from the menu
735
736* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
737- update to 3.94.0
738
739* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
740- don't make this the default kdebase on F9 yet
741- drop ExcludeArch: ppc64 (#300601)
742
743* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
744- ExcludeArch: ppc64 (#300601)
745- update description
746
747* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
748- add missing BR alsa-lib-devel
749
750* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
751- remove files which conflict with KDE 3
752- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
753- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
754
755* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
756- update to 3.93.0
757- drop kde4home patch (no longer applied)
758- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
759- remove kdebase-kdm Obsoletes/Provides (for the same reason)
760- remove KDM (and KDM session) setup code (for the same reason)
761- remove rss-glx conflict (Plasma is now in kdebase-workspace)
762- remove redhat-startkde patch (startkde is now in kdebase-workspace)
763- remove kde4-opt.sh (all the code in it is commented out)
764- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
765- remove bogus BRs on automake and libtool
766- remove workspace-only BRs
767- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
768- remove workspace files and directories
769- handle icons (moved from kdelibs4)
770- add mkdir %%{buildroot} in %%install
771
772* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
773- use macros.kde4
774- License: GPLv2
775
776* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
777- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
778- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
779- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
780
781* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
782- consolekit_kdm patch (#228111, kde#147790)
783- update startkde patch
784
785* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
786- kde-3.92 (kde-4-beta1)
787
788* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
789- fix startkde
790- add env/shutdown directory
791
792* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
793- kde4.desktop: fix session Name
794
795* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
796- cleanup/fix kde4.desktop
797- kdepimlibs4->kdepimlibs
798
799* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
800- fix %%_sysconfdir for %%_prefix != /usr case.
801
802* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
803- updated kde4home.diff
804- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
805
806* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
807- kde-3.91.0
808- CMAKE_BUILD_TYPE=debug
809
810* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
811- specfile cleanup (%%prefix issues mostly)
812
813* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
814- update to 3.90.1
815- bump cmake BR to 2.4.5 as required upstream now
816- don't set execute bits by hand anymore, cmake has been fixed
817- use multilibs in /opt/kde4
818- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
819- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
820  in case we want to drop the Rs on these from kdelibs4-devel
821- consistently add all BRs as -devel Rs, not just almost all, until we can
822  figure out which, if any, are really needed
823- BR libsmbclient-devel instead of samba on F>=7, EL>=6
824
825* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
826- restore minimum version requirement for cmake
827- build against libxklavier on EL5
828- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
829
830* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
831- +eXecute perms for %%{_prefix}/lib/*
832
833* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
834- rebuild for patched FindKDE4Internal.cmake
835
836* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
837- update to 3.80.3
838- update and improve parallel-installability patch
839- drop obsolete joydevice.h patch
840- remove translations of "KDE" without the "4" from kde4.desktop
841- resync BR and -devel Requires
842- don't set LD_LIBRARY_PATH
843- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
844- fix missing underscore in _datadir
845- install kde4.desktop in install, not prep
846- fix invalid syntax in kde4.desktop
847
848* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
849- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
850- compiling with QA_RPATHS=0x0003; export QA_RPATHS
851
852* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
853- parallel build support
854- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
855- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
856- spec file cleanups and added clean up in %%install
857- fixed PATH for libkdecore.so.5; cannot open shared object file;
858- added Logitech mouse support
859- added dbus-devel, hal-devel and more as BR
860- fixed broken joydevice.h - Kevin Kofler
861- added file kde4.desktop
862
863* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
864- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
865- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.