source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 6899

Revision 6899, 27.6 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.2

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.9.2
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstream patches
33
34Provides:  kdebase4-runtime = %{version}-%{release}
35Provides:  kde-runtime = %{version}-%{release}
36Obsoletes: kdebase4-runtime < %{version}-%{release}
37
38Obsoletes: nepomukcontroller
39Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
40
41# knotify4 provides dbus service org.freedesktop.Notifications too
42Provides: desktop-notification-daemon
43
44BuildRoot:     %{_tmppath}/%{name}-%{version}-root
45BuildRequires: alsa-lib-devel
46BuildRequires: attica-devel >= 0.1.4
47BuildRequires: bzip2-devel
48BuildRequires: chrpath
49BuildRequires: clucene-core-devel
50BuildRequires: doxygen
51BuildRequires: exiv2-devel >= 0.12
52BuildRequires: glib2-devel
53BuildRequires: kdelibs4-devel >= %{version}
54BuildRequires: kdepimlibs-devel >= %{version}
55BuildRequires: kactivities-devel >= %{version}
56BuildRequires: libcanberra-devel
57#BuildRequires: libqzeitgeist-devel
58BuildRequires: libsmbclient-devel
59BuildRequires: libssh-devel >= 0.4.2
60BuildRequires: libXpm-devel
61BuildRequires: libXScrnSaver-devel
62BuildRequires: NetworkManager-devel
63BuildRequires: nepomuk-core
64BuildRequires: nepomuk-core-devel
65BuildRequires: OpenEXR-devel
66BuildRequires: openslp-devel
67BuildRequires: openssl-devel
68BuildRequires: pkgconfig
69BuildRequires: polkit-qt-devel
70BuildRequires: pulseaudio-libs-devel
71BuildRequires: qca2-devel
72BuildRequires: qimageblitz-devel
73BuildRequires: shared-mime-info >= 0.40
74BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
75BuildRequires: soprano-devel >= 2.6.50
76BuildRequires: xine-lib-devel libxcb-devel
77BuildRequires: xorg-x11-font-utils
78BuildRequires: xorg-x11-proto-devel
79BuildRequires: xz-devel
80BuildRequires: zlib-devel
81
82Requires: eject
83Requires: %{name}-libs = %{version}-%{release}
84Requires: %{name}-flags = %{version}-%{release}
85# KHelpcenter requires htdig for building search indices
86Requires: htdig
87# ensure default/fallback icon theme present
88# beware of bootstrapping, there be dragons
89Requires: oxygen-icon-theme >= %{version}
90
91# some items moved -workspace -> -runtime
92Conflicts: kdebase-workspace < 4.5.80
93
94%description
95Core runtime for KDE 4.
96
97%description -l ja
98KDE 4 の中心となるランタイム部分です.
99
100%package devel
101Summary:  Developer files for %{name}
102Summary(ja): %{name} の開発用ファイル
103Group:    Development/Libraries
104Requires: %{name}-libs = %{version}-%{release}
105
106%description devel
107%{summary}.
108
109%description -l ja devel
110%{name} の開発用ファイルです.
111
112%package libs
113Summary: Runtime libraries for %{name}
114Summary(ja): %{name} のランタイムライブラリ
115Group:   System Environment/Libraries
116Requires: kdelibs4 >= %{version}
117Requires: kdepimlibs >= %{version}
118# cagibi is runtime dep, a dbus service
119Requires: cagibi
120
121%description libs
122%{summary}.
123
124%description -l ja libs
125%{name} のランタイムライブラリです.
126
127%package flags
128Summary: Geopolitical flags
129Group: User Interface/Desktops
130Requires: %{name}-libs = %{version}-%{release}
131BuildArch: noarch
132
133%description flags
134%{summary}.
135
136
137%prep
138%setup -q -n kde-runtime-%{version}
139
140%patch1 -p1 -b .searchproviders-shortcuts
141%patch6 -p1 -b .home_onlyshowin_kde
142%patch7 -p1 -b .htsearch
143%patch8 -p1 -b .config
144%patch9 -p1 -b .man-overrides
145
146%build
147mkdir -p %{_target_platform}
148pushd %{_target_platform}
149%cmake \
150    -DCMAKE_BUILD_TYPE=release \
151    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
152    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
153    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
154    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
155    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
156    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
157    ..
158popd
159
160make %{?_smp_mflags} -C %{_target_platform}
161
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
167
168# kdesu symlink
169ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
170
171# omit hicolor index.theme, use one from hicolor-icon-theme
172rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
173
174# remove country flags because some people/countries forbid some other
175# people/countries' flags :-(
176%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
177
178# install this service for KDE 3 applications too
179mkdir $RPM_BUILD_ROOT%{_datadir}/services
180ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
181      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
182
183# FIXME: -devel type files, omit for now
184rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
185
186# rpaths
187# use chrpath hammer for now, find better patching solutions later -- Rex
188chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
189chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
196touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
197
198%posttrans
199gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
200gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
201update-desktop-database -q &> /dev/null ||:
202update-mime-database %{_datadir}/mime &> /dev/null
203
204%postun
205if [ $1 -eq 0 ] ; then
206    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
207    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
208    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
209    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
210    update-desktop-database -q &> /dev/null ||:
211    update-mime-database %{_datadir}/mime &> /dev/null
212fi
213
214%post libs -p /sbin/ldconfig
215%postun libs -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root,-)
220%{_sysconfdir}/dbus-1/system.d/*
221%{_sysconfdir}/xdg/menus/kde-information.menu
222%{_bindir}/*
223# omit ksvgtopng which kdelibs3 includes
224%{_datadir}/kde4/apps/*
225%exclude %{_datadir}/kde4/apps/cmake/
226%{_datadir}/config/*.knsrc
227%{_datadir}/autostart/nepomukcontroller.desktop
228%{_datadir}/config.kcfg/
229%{_datadir}/dbus-1/interfaces/*
230%{_datadir}/dbus-1/services/*
231%{_datadir}/dbus-1/system-services/*
232%{_datadir}/icons/default.kde4
233%{_datadir}/kde4/services/*
234%{_datadir}/kde4/servicetypes/*
235%{_datadir}/mime/packages/network.xml
236%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
237%{_datadir}/sounds/*
238%{_libdir}/kconf_update_bin/*
239%{_libdir}/libkdeinit4_*.so
240%{_libdir}/kde4/kcm_*.so
241%{_libdir}/kde4/kded_*.so
242%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
243%{_libexecdir}/kde4/drkonqi
244#{_libexecdir}/kde4/installdbgsymbols.sh
245%{_libexecdir}/kde4/kcmremotewidgetshelper
246%{_libexecdir}/kde4/kdeeject
247%{_libexecdir}/kde4/kdesu
248%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
249%{_libexecdir}/kde4/kdontchangethehostname
250%{_libexecdir}/kde4/khc_docbookdig.pl
251%{_libexecdir}/kde4/khc_htdig.pl
252%{_libexecdir}/kde4/khc_htsearch.pl
253%{_libexecdir}/kde4/khc_indexbuilder
254%{_libexecdir}/kde4/khc_mansearch.pl
255%{_libexecdir}/kde4/kioexec
256%{_libexecdir}/kde4/knetattach
257%{_mandir}/man1/*
258%{_mandir}/man8/*
259%{_datadir}/icons/hicolor/*/*/*
260%{_docdir}/HTML/en/*
261%{_datadir}/applications/kde4/Help.desktop
262%{_datadir}/applications/kde4/knetattach.desktop
263%{_datadir}/applications/kde4/nepomukcontroller.desktop
264%{_datadir}/config/kshorturifilterrc
265%{_datadir}/desktop-directories/*.directory
266%{_datadir}/emoticons/kde4/
267%{_datadir}/locale/l10n/
268%{_datadir}/locale/currency/
269%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
270%{_datadir}/services/khelpcenter.desktop
271
272%files devel
273%defattr(-,root,root,-)
274%{_includedir}/*
275%{_datadir}/kde4/apps/cmake/modules/*.cmake
276
277%files libs
278%defattr(-,root,root,-)
279%{_libdir}/attica_kde.so
280%{_libdir}/libknotifyplugin.so
281%{_libdir}/libkwalletbackend.so.*
282%{_libdir}/libmolletnetwork.so.*
283%{_libdir}/kde4/*.so
284%{_libdir}/kde4/imports/
285# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
286%exclude %{_libdir}/kde4/kcm_*.so
287%exclude %{_libdir}/kde4/kded_*.so
288%{_libdir}/kde4/plugins/phonon_platform/
289
290%files flags
291%defattr(-,root,root,-)
292%{_datadir}/locale/l10n/*/flag.png
293
294
295%changelog
296* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
297- new upstream release
298
299* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
300- new upstream release
301
302* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
303- rebuild with attica-0.4.1
304
305* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
306- new upstream release
307- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
308- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
309
310* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
311- rebuild with exiv2-0.23
312
313* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
314- rebuild with exiv2-0.22
315
316* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
317- rebuilt without libqzeitgeist
318
319* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
320- new upstream release
321
322* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
323- new upstream release
324
325* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
326- new upstream release
327- built with exiv2-0.21.1
328
329* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
330- new upstream release
331
332* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
333- rebuilt with libsmbclient-3.5.8
334
335* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
336- new upstream release
337
338* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
339- added BR: libXpm-devel
340
341* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
342- new upstream release
343- added devel subpackage
344
345* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
346- new upstream release
347- updated summary
348- dropt Patch100
349
350* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
351- new upstream release
352- added Patch100 from Fedora
353  - backport to fix the freeze of kded on first use of the network:/kio-slave
354
355* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
356- new upstream release
357- added Conflicts: kdebase3 at Vine Linux 5
358
359* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
360- new upstream release
361
362* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
363- rebuilt with exiv2-0.19
364
365* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
366- new upstream release
367
368* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
369- new upstream release
370
371* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
372- new upstream release
373- built with new toolchain
374
375* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
376- new upstream release
377
378* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
379- new upstream release
380
381* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
382- new upstream release
383- used %%cmake macro
384
385* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
386- Initial build for Vine Linux
387
388* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
389- respin
390
391* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
392- 4.3.0
393
394* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
395- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
396
397* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
398- 4.3rc3
399
400* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
401- respin (soprano-2.3.0)
402- License: LGPLv2+
403
404* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
405- 4.3rc2
406
407* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
408- drop unneeded BR: ImageMagick (#509241)
409
410* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
411- don't start nepomuk server unconditionally (#487322)
412
413* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
414- 4.3rc1
415
416* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
417- KDE-4.3 beta2 (4.2.90)
418
419* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
420- Drop old Fedora < 8 conditionals
421
422* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
423- file conflicts with kdepim
424
425* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
426- KDE 4.3 beta 1
427
428* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
429- fix persistent systray notifications (#485796)
430
431* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
432- -flags subpkg
433- koji/noarch hacks dropped
434
435* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
436- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
437
438* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
439- KDE 4.2.2
440
441* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
442- flags subpkg (not enabled)
443- optimize scriptlets
444
445* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
446- fix PulseAudio cmake detection
447
448* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
449- 4.2.1
450
451* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
452- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
453
454* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
455- #486059 -  missing dependency on htdig
456
457* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
458- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
459
460* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
461- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
462
463* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
464- own %%_kde4_datadir/locale/l10n/
465
466* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
467- respun tarball
468
469* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
470- Files not trashed to the correct location in Dolphin/Konqueror
471  (#481598, kdebug#178479)
472- omit --with-samba crud
473
474* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
475- 4.2.0
476- +BR: pulseaudio-libs-devel xine-lib-devel
477- -BR: giflib-devel pcre-devel
478
479* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
480- tarball respin
481- drop extraneous deps (that are in kdelibs)
482
483* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
484- 4.2rc1
485
486* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
487- include %%_bindir/kdesu symlink
488
489* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
490- 4.2beta2
491
492* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
493- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
494  and should be in a -devel package if it gets shipped)
495
496* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
497- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
498
499* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
500- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
501
502* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
503- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
504
505* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
506- 4.1.80
507- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
508- BR cmake >= 2.6.2
509- Use 'make install/fast'
510- Drop subpkg phonon-backend-xine and related file entries: this has to be
511  part of phonon now that it moved there
512- Drop xine-lib-devel BR
513- Add libkwalletbackend to files list
514- Drop _default_patch_fuzz 2
515
516* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
517- apply upstream patch to fix X crash when disabling compositing
518
519* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
520- 4.1.3
521
522* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
523- apply upstream patch, kioexec processes never terminate
524
525* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
526- fix broken audio-backend-jack.svgz
527
528* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
529- add missing icons
530
531* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
532- make VERBOSE=1
533- respin against new(er) kde-filesystem
534- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
535
536* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
537- 4.1.2
538
539* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
540- fix inherit issue in iconthemes, preview icons
541  do not show
542
543* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
544- fix #460710, knetattach is kio_remote's wizard program, don't show
545  it in the menu.
546
547* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
548- 4.1.1
549
550* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
551- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
552
553* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
554- crash fix when stopping a service that is not yet initialized
555
556* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
557- don't remove autostart directory on F8- (does not conflict, fixes build
558  failure due to nepomukserver.desktop listed in filelist but not found)
559
560* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
561- 4.1.0
562
563* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
564- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
565
566* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
567- 4.0.99
568
569* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
570- respin
571
572* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
573- -phonon-backend-xine: new subpkg
574
575* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
576- 4.0.98
577
578* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
579- 4.0.85
580
581* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
582- 4.0.84
583
584* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
585- 4.0.83 (beta2)
586
587* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
588- 4.0.82
589
590* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
591- add searchproviders-shortcuts for redhat bugzilla
592
593* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
594- 4.1 beta 1
595
596* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
597- BR new minimum version of soprano-devel
598
599* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
600- update to 4.0.72 (4.1 alpha 1)
601- drop upstreamed deinterlace-crash patch
602- drop khelpcenter patch (fixed upstream)
603- update Phonon PulseAudio patch
604- drop Fedora 7 support
605- update file list
606
607* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
608- omit conflicting icons (kde3_desktop=1 case)
609
610* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
611- oxygen-icon-theme: build noarch
612
613* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
614- %%post/%%postun: hicolor icon theme scriptlets
615
616* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
617- only omit hicolor index.theme (#439374)
618
619* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
620- fix khelpcenter, search plugins/settings in correct path (#443016)
621
622* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
623- respin (at f13's request)
624
625* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
626- pulseaudio patch (use as default, if available)
627
628* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
629- don't crash if we don't have deinterlacing support in xine-lib (#440299)
630
631* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
632- rebuild for the new %%{_kde4_buildtype}
633
634* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
635- update file list for _kde4_libexecdir
636
637* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
638- 4.0.3
639
640* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
641- don't own %%_kde4_docdir/HTML/en/
642
643* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
644- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
645- include noarch build hooks (not enabled)
646
647* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
648- BR libxcb-devel everywhere (including F7)
649
650* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
651- if building for a KDE 4 desktop, include the khelpcenter.desktop service
652  description for KDE 3 here so help works in KDE 3 apps
653
654* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
655- 4.0.2
656
657* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
658- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
659
660* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
661- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
662  (kio_smb itself is already GPLv2+)
663
664* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
665- 4.0.1
666
667* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
668- respun tarball
669
670* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
671- update to 4.0.0
672- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
673
674* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
675- kde-3.97.0
676
677* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
678- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
679
680* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
681- build without libxcb in F7 as we STILL don't have it (see #373361)
682
683* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
684- no longer set kde3_desktop on F9
685- update file list for !kde3_desktop (Sebastian Vahl)
686- don't ship country flags even for full version (as in kdebase 3)
687
688* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
689- kde-3.96.2
690
691* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
692- kde-3.96.1
693
694* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
695- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
696
697* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
698- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
699
700* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
701- kde-3.96.0
702
703* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
704- kdebase-runtime-3.95.2
705
706* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
707- kdebase-runtime-3.95.0
708
709* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
710- Provides: oxygen-icon-theme ...
711
712* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
713- patch dolphin.desktop to get Dolphin to start from the menu
714
715* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
716- update to 3.94.0
717
718* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
719- don't make this the default kdebase on F9 yet
720- drop ExcludeArch: ppc64 (#300601)
721
722* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
723- ExcludeArch: ppc64 (#300601)
724- update description
725
726* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
727- add missing BR alsa-lib-devel
728
729* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
730- remove files which conflict with KDE 3
731- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
732- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
733
734* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
735- update to 3.93.0
736- drop kde4home patch (no longer applied)
737- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
738- remove kdebase-kdm Obsoletes/Provides (for the same reason)
739- remove KDM (and KDM session) setup code (for the same reason)
740- remove rss-glx conflict (Plasma is now in kdebase-workspace)
741- remove redhat-startkde patch (startkde is now in kdebase-workspace)
742- remove kde4-opt.sh (all the code in it is commented out)
743- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
744- remove bogus BRs on automake and libtool
745- remove workspace-only BRs
746- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
747- remove workspace files and directories
748- handle icons (moved from kdelibs4)
749- add mkdir %%{buildroot} in %%install
750
751* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
752- use macros.kde4
753- License: GPLv2
754
755* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
756- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
757- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
758- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
759
760* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
761- consolekit_kdm patch (#228111, kde#147790)
762- update startkde patch
763
764* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
765- kde-3.92 (kde-4-beta1)
766
767* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
768- fix startkde
769- add env/shutdown directory
770
771* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
772- kde4.desktop: fix session Name
773
774* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
775- cleanup/fix kde4.desktop
776- kdepimlibs4->kdepimlibs
777
778* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
779- fix %%_sysconfdir for %%_prefix != /usr case.
780
781* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
782- updated kde4home.diff
783- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
784
785* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
786- kde-3.91.0
787- CMAKE_BUILD_TYPE=debug
788
789* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
790- specfile cleanup (%%prefix issues mostly)
791
792* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
793- update to 3.90.1
794- bump cmake BR to 2.4.5 as required upstream now
795- don't set execute bits by hand anymore, cmake has been fixed
796- use multilibs in /opt/kde4
797- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
798- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
799  in case we want to drop the Rs on these from kdelibs4-devel
800- consistently add all BRs as -devel Rs, not just almost all, until we can
801  figure out which, if any, are really needed
802- BR libsmbclient-devel instead of samba on F>=7, EL>=6
803
804* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
805- restore minimum version requirement for cmake
806- build against libxklavier on EL5
807- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
808
809* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
810- +eXecute perms for %%{_prefix}/lib/*
811
812* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
813- rebuild for patched FindKDE4Internal.cmake
814
815* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
816- update to 3.80.3
817- update and improve parallel-installability patch
818- drop obsolete joydevice.h patch
819- remove translations of "KDE" without the "4" from kde4.desktop
820- resync BR and -devel Requires
821- don't set LD_LIBRARY_PATH
822- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
823- fix missing underscore in _datadir
824- install kde4.desktop in install, not prep
825- fix invalid syntax in kde4.desktop
826
827* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
828- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
829- compiling with QA_RPATHS=0x0003; export QA_RPATHS
830
831* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
832- parallel build support
833- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
834- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
835- spec file cleanups and added clean up in %%install
836- fixed PATH for libkdecore.so.5; cannot open shared object file;
837- added Logitech mouse support
838- added dbus-devel, hal-devel and more as BR
839- fixed broken joydevice.h - Kevin Kofler
840- added file kde4.desktop
841
842* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
843- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
844- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.