source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 6725

Revision 6725, 27.3 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.9.0
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
20Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
21
22# correct path for htsearch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24
25# Launch compiz via compiz-manager so we get window decorations and
26# other such decadent luxuries (AdamW 2011/01)
27Patch8:        kdebase-runtime-4.5.95-compiz.patch
28
29# add overrides in default manpath
30Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
31
32## upstream patches
33
34Provides:  kdebase4-runtime = %{version}-%{release}
35Provides:  kde-runtime = %{version}-%{release}
36Obsoletes: kdebase4-runtime < %{version}-%{release}
37
38Obsoletes: nepomukcontroller
39Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
40
41# knotify4 provides dbus service org.freedesktop.Notifications too
42Provides: desktop-notification-daemon
43
44BuildRoot:     %{_tmppath}/%{name}-%{version}-root
45BuildRequires: alsa-lib-devel
46BuildRequires: attica-devel >= 0.1.4
47BuildRequires: bzip2-devel
48BuildRequires: chrpath
49BuildRequires: clucene-core-devel
50BuildRequires: doxygen
51BuildRequires: exiv2-devel >= 0.12
52BuildRequires: glib2-devel
53BuildRequires: kdelibs4-devel >= %{version}
54BuildRequires: kdepimlibs-devel >= %{version}
55BuildRequires: kactivities-devel >= %{version}
56BuildRequires: libcanberra-devel
57#BuildRequires: libqzeitgeist-devel
58BuildRequires: libsmbclient-devel
59BuildRequires: libssh-devel >= 0.4.2
60BuildRequires: libXpm-devel
61BuildRequires: libXScrnSaver-devel
62BuildRequires: NetworkManager-devel
63BuildRequires: nepomuk-core
64BuildRequires: nepomuk-core-devel
65BuildRequires: OpenEXR-devel
66BuildRequires: openslp-devel
67BuildRequires: openssl-devel
68BuildRequires: pkgconfig
69BuildRequires: polkit-qt-devel
70BuildRequires: pulseaudio-libs-devel
71BuildRequires: qca2-devel
72BuildRequires: qimageblitz-devel
73BuildRequires: shared-mime-info >= 0.40
74BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
75BuildRequires: soprano-devel >= 2.6.50
76BuildRequires: xine-lib-devel libxcb-devel
77BuildRequires: xorg-x11-font-utils
78BuildRequires: xorg-x11-proto-devel
79BuildRequires: xz-devel
80BuildRequires: zlib-devel
81
82Requires: eject
83Requires: %{name}-libs = %{version}-%{release}
84Requires: %{name}-flags = %{version}-%{release}
85# KHelpcenter requires htdig for building search indices
86Requires: htdig
87# ensure default/fallback icon theme present
88# beware of bootstrapping, there be dragons
89Requires: oxygen-icon-theme >= %{version}
90
91# some items moved -workspace -> -runtime
92Conflicts: kdebase-workspace < 4.5.80
93
94%description
95Core runtime for KDE 4.
96
97%description -l ja
98KDE 4 の中心となるランタイム部分です.
99
100%package devel
101Summary:  Developer files for %{name}
102Summary(ja): %{name} の開発用ファイル
103Group:    Development/Libraries
104Requires: %{name}-libs = %{version}-%{release}
105
106%description devel
107%{summary}.
108
109%description -l ja devel
110%{name} の開発用ファイルです.
111
112%package libs
113Summary: Runtime libraries for %{name}
114Summary(ja): %{name} のランタイムライブラリ
115Group:   System Environment/Libraries
116Requires: kdelibs4 >= %{version}
117Requires: kdepimlibs >= %{version}
118# cagibi is runtime dep, a dbus service
119Requires: cagibi
120
121%description libs
122%{summary}.
123
124%description -l ja libs
125%{name} のランタイムライブラリです.
126
127%package flags
128Summary: Geopolitical flags
129Group: User Interface/Desktops
130Requires: %{name}-libs = %{version}-%{release}
131BuildArch: noarch
132
133%description flags
134%{summary}.
135
136
137%prep
138%setup -q -n kde-runtime-%{version}
139
140%patch1 -p1 -b .searchproviders-shortcuts
141%patch6 -p1 -b .home_onlyshowin_kde
142%patch7 -p1 -b .htsearch
143%patch8 -p1 -b .config
144%patch9 -p1 -b .man-overrides
145
146%build
147mkdir -p %{_target_platform}
148pushd %{_target_platform}
149%cmake \
150    -DCMAKE_BUILD_TYPE=release \
151    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
152    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
153    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
154    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
155    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
156    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
157    ..
158popd
159
160make %{?_smp_mflags} -C %{_target_platform}
161
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
167
168# kdesu symlink
169ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
170
171# omit hicolor index.theme, use one from hicolor-icon-theme
172rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
173
174# remove country flags because some people/countries forbid some other
175# people/countries' flags :-(
176%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
177
178# install this service for KDE 3 applications too
179mkdir $RPM_BUILD_ROOT%{_datadir}/services
180ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
181      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
182
183# FIXME: -devel type files, omit for now
184rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
185
186# rpaths
187# use chrpath hammer for now, find better patching solutions later -- Rex
188chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
189chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
196touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
197
198%posttrans
199gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
200gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
201update-desktop-database -q &> /dev/null ||:
202update-mime-database %{_datadir}/mime &> /dev/null
203
204%postun
205if [ $1 -eq 0 ] ; then
206    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
207    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
208    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
209    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
210    update-desktop-database -q &> /dev/null ||:
211    update-mime-database %{_datadir}/mime &> /dev/null
212fi
213
214%post libs -p /sbin/ldconfig
215%postun libs -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root,-)
220%{_sysconfdir}/dbus-1/system.d/*
221%{_sysconfdir}/xdg/menus/kde-information.menu
222%{_bindir}/*
223# omit ksvgtopng which kdelibs3 includes
224%{_datadir}/kde4/apps/*
225%exclude %{_datadir}/kde4/apps/cmake/
226%{_datadir}/config/*.knsrc
227%{_datadir}/autostart/nepomukcontroller.desktop
228%{_datadir}/config.kcfg/
229%{_datadir}/dbus-1/interfaces/*
230%{_datadir}/dbus-1/services/*
231%{_datadir}/dbus-1/system-services/*
232%{_datadir}/icons/default.kde4
233%{_datadir}/kde4/services/*
234%{_datadir}/kde4/servicetypes/*
235%{_datadir}/mime/packages/network.xml
236%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
237%{_datadir}/sounds/*
238%{_libdir}/kconf_update_bin/*
239%{_libdir}/libkdeinit4_*.so
240%{_libdir}/kde4/kcm_*.so
241%{_libdir}/kde4/kded_*.so
242%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
243%{_libexecdir}/kde4/drkonqi
244#{_libexecdir}/kde4/installdbgsymbols.sh
245%{_libexecdir}/kde4/kcmremotewidgetshelper
246%{_libexecdir}/kde4/kdeeject
247%{_libexecdir}/kde4/kdesu
248%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
249%{_libexecdir}/kde4/kdontchangethehostname
250%{_libexecdir}/kde4/khc_docbookdig.pl
251%{_libexecdir}/kde4/khc_htdig.pl
252%{_libexecdir}/kde4/khc_htsearch.pl
253%{_libexecdir}/kde4/khc_indexbuilder
254%{_libexecdir}/kde4/khc_mansearch.pl
255%{_libexecdir}/kde4/kioexec
256%{_libexecdir}/kde4/knetattach
257%{_mandir}/man1/*
258%{_mandir}/man8/*
259%{_datadir}/icons/hicolor/*/*/*
260%{_docdir}/HTML/en/*
261%{_datadir}/applications/kde4/Help.desktop
262%{_datadir}/applications/kde4/knetattach.desktop
263%{_datadir}/applications/kde4/nepomukcontroller.desktop
264%{_datadir}/config/kshorturifilterrc
265%{_datadir}/desktop-directories/*.directory
266%{_datadir}/emoticons/kde4/
267%{_datadir}/locale/l10n/
268%{_datadir}/locale/currency/
269%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
270%{_datadir}/services/khelpcenter.desktop
271
272%files devel
273%defattr(-,root,root,-)
274%{_includedir}/*
275%{_datadir}/kde4/apps/cmake/modules/*.cmake
276
277%files libs
278%defattr(-,root,root,-)
279%{_libdir}/attica_kde.so
280%{_libdir}/libknotifyplugin.so
281%{_libdir}/libkwalletbackend.so.*
282%{_libdir}/libmolletnetwork.so.*
283%{_libdir}/kde4/*.so
284%{_libdir}/kde4/imports/
285# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
286%exclude %{_libdir}/kde4/kcm_*.so
287%exclude %{_libdir}/kde4/kded_*.so
288%{_libdir}/kde4/plugins/phonon_platform/
289
290%files flags
291%defattr(-,root,root,-)
292%{_datadir}/locale/l10n/*/flag.png
293
294
295%changelog
296* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
297- new upstream release
298- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
299- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
300
301* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
302- rebuild with exiv2-0.23
303
304* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
305- rebuild with exiv2-0.22
306
307* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
308- rebuilt without libqzeitgeist
309
310* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
311- new upstream release
312
313* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
314- new upstream release
315
316* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
317- new upstream release
318- built with exiv2-0.21.1
319
320* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
321- new upstream release
322
323* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
324- rebuilt with libsmbclient-3.5.8
325
326* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
327- new upstream release
328
329* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
330- added BR: libXpm-devel
331
332* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
333- new upstream release
334- added devel subpackage
335
336* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
337- new upstream release
338- updated summary
339- dropt Patch100
340
341* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
342- new upstream release
343- added Patch100 from Fedora
344  - backport to fix the freeze of kded on first use of the network:/kio-slave
345
346* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
347- new upstream release
348- added Conflicts: kdebase3 at Vine Linux 5
349
350* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
351- new upstream release
352
353* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
354- rebuilt with exiv2-0.19
355
356* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
357- new upstream release
358
359* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
360- new upstream release
361
362* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
363- new upstream release
364- built with new toolchain
365
366* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
367- new upstream release
368
369* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
370- new upstream release
371
372* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
373- new upstream release
374- used %%cmake macro
375
376* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
377- Initial build for Vine Linux
378
379* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
380- respin
381
382* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
383- 4.3.0
384
385* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
386- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
387
388* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
389- 4.3rc3
390
391* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
392- respin (soprano-2.3.0)
393- License: LGPLv2+
394
395* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
396- 4.3rc2
397
398* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
399- drop unneeded BR: ImageMagick (#509241)
400
401* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
402- don't start nepomuk server unconditionally (#487322)
403
404* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
405- 4.3rc1
406
407* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
408- KDE-4.3 beta2 (4.2.90)
409
410* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
411- Drop old Fedora < 8 conditionals
412
413* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
414- file conflicts with kdepim
415
416* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
417- KDE 4.3 beta 1
418
419* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
420- fix persistent systray notifications (#485796)
421
422* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
423- -flags subpkg
424- koji/noarch hacks dropped
425
426* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
427- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
428
429* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
430- KDE 4.2.2
431
432* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
433- flags subpkg (not enabled)
434- optimize scriptlets
435
436* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
437- fix PulseAudio cmake detection
438
439* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
440- 4.2.1
441
442* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
443- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
444
445* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
446- #486059 -  missing dependency on htdig
447
448* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
449- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
450
451* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
452- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
453
454* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
455- own %%_kde4_datadir/locale/l10n/
456
457* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
458- respun tarball
459
460* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
461- Files not trashed to the correct location in Dolphin/Konqueror
462  (#481598, kdebug#178479)
463- omit --with-samba crud
464
465* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
466- 4.2.0
467- +BR: pulseaudio-libs-devel xine-lib-devel
468- -BR: giflib-devel pcre-devel
469
470* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
471- tarball respin
472- drop extraneous deps (that are in kdelibs)
473
474* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
475- 4.2rc1
476
477* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
478- include %%_bindir/kdesu symlink
479
480* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
481- 4.2beta2
482
483* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
484- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
485  and should be in a -devel package if it gets shipped)
486
487* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
488- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
489
490* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
491- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
492
493* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
494- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
495
496* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
497- 4.1.80
498- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
499- BR cmake >= 2.6.2
500- Use 'make install/fast'
501- Drop subpkg phonon-backend-xine and related file entries: this has to be
502  part of phonon now that it moved there
503- Drop xine-lib-devel BR
504- Add libkwalletbackend to files list
505- Drop _default_patch_fuzz 2
506
507* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
508- apply upstream patch to fix X crash when disabling compositing
509
510* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
511- 4.1.3
512
513* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
514- apply upstream patch, kioexec processes never terminate
515
516* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
517- fix broken audio-backend-jack.svgz
518
519* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
520- add missing icons
521
522* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
523- make VERBOSE=1
524- respin against new(er) kde-filesystem
525- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
526
527* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
528- 4.1.2
529
530* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
531- fix inherit issue in iconthemes, preview icons
532  do not show
533
534* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
535- fix #460710, knetattach is kio_remote's wizard program, don't show
536  it in the menu.
537
538* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
539- 4.1.1
540
541* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
542- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
543
544* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
545- crash fix when stopping a service that is not yet initialized
546
547* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
548- don't remove autostart directory on F8- (does not conflict, fixes build
549  failure due to nepomukserver.desktop listed in filelist but not found)
550
551* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
552- 4.1.0
553
554* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
555- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
556
557* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
558- 4.0.99
559
560* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
561- respin
562
563* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
564- -phonon-backend-xine: new subpkg
565
566* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
567- 4.0.98
568
569* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
570- 4.0.85
571
572* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
573- 4.0.84
574
575* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
576- 4.0.83 (beta2)
577
578* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
579- 4.0.82
580
581* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
582- add searchproviders-shortcuts for redhat bugzilla
583
584* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
585- 4.1 beta 1
586
587* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
588- BR new minimum version of soprano-devel
589
590* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
591- update to 4.0.72 (4.1 alpha 1)
592- drop upstreamed deinterlace-crash patch
593- drop khelpcenter patch (fixed upstream)
594- update Phonon PulseAudio patch
595- drop Fedora 7 support
596- update file list
597
598* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
599- omit conflicting icons (kde3_desktop=1 case)
600
601* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
602- oxygen-icon-theme: build noarch
603
604* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
605- %%post/%%postun: hicolor icon theme scriptlets
606
607* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
608- only omit hicolor index.theme (#439374)
609
610* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
611- fix khelpcenter, search plugins/settings in correct path (#443016)
612
613* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
614- respin (at f13's request)
615
616* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
617- pulseaudio patch (use as default, if available)
618
619* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
620- don't crash if we don't have deinterlacing support in xine-lib (#440299)
621
622* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
623- rebuild for the new %%{_kde4_buildtype}
624
625* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
626- update file list for _kde4_libexecdir
627
628* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
629- 4.0.3
630
631* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
632- don't own %%_kde4_docdir/HTML/en/
633
634* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
635- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
636- include noarch build hooks (not enabled)
637
638* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
639- BR libxcb-devel everywhere (including F7)
640
641* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
642- if building for a KDE 4 desktop, include the khelpcenter.desktop service
643  description for KDE 3 here so help works in KDE 3 apps
644
645* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
646- 4.0.2
647
648* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
649- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
650
651* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
652- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
653  (kio_smb itself is already GPLv2+)
654
655* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
656- 4.0.1
657
658* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
659- respun tarball
660
661* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
662- update to 4.0.0
663- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
664
665* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
666- kde-3.97.0
667
668* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
669- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
670
671* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
672- build without libxcb in F7 as we STILL don't have it (see #373361)
673
674* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
675- no longer set kde3_desktop on F9
676- update file list for !kde3_desktop (Sebastian Vahl)
677- don't ship country flags even for full version (as in kdebase 3)
678
679* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
680- kde-3.96.2
681
682* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
683- kde-3.96.1
684
685* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
686- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
687
688* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
689- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
690
691* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
692- kde-3.96.0
693
694* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
695- kdebase-runtime-3.95.2
696
697* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
698- kdebase-runtime-3.95.0
699
700* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
701- Provides: oxygen-icon-theme ...
702
703* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
704- patch dolphin.desktop to get Dolphin to start from the menu
705
706* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
707- update to 3.94.0
708
709* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
710- don't make this the default kdebase on F9 yet
711- drop ExcludeArch: ppc64 (#300601)
712
713* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
714- ExcludeArch: ppc64 (#300601)
715- update description
716
717* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
718- add missing BR alsa-lib-devel
719
720* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
721- remove files which conflict with KDE 3
722- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
723- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
724
725* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
726- update to 3.93.0
727- drop kde4home patch (no longer applied)
728- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
729- remove kdebase-kdm Obsoletes/Provides (for the same reason)
730- remove KDM (and KDM session) setup code (for the same reason)
731- remove rss-glx conflict (Plasma is now in kdebase-workspace)
732- remove redhat-startkde patch (startkde is now in kdebase-workspace)
733- remove kde4-opt.sh (all the code in it is commented out)
734- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
735- remove bogus BRs on automake and libtool
736- remove workspace-only BRs
737- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
738- remove workspace files and directories
739- handle icons (moved from kdelibs4)
740- add mkdir %%{buildroot} in %%install
741
742* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
743- use macros.kde4
744- License: GPLv2
745
746* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
747- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
748- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
749- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
750
751* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
752- consolekit_kdm patch (#228111, kde#147790)
753- update startkde patch
754
755* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
756- kde-3.92 (kde-4-beta1)
757
758* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
759- fix startkde
760- add env/shutdown directory
761
762* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
763- kde4.desktop: fix session Name
764
765* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
766- cleanup/fix kde4.desktop
767- kdepimlibs4->kdepimlibs
768
769* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
770- fix %%_sysconfdir for %%_prefix != /usr case.
771
772* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
773- updated kde4home.diff
774- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
775
776* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
777- kde-3.91.0
778- CMAKE_BUILD_TYPE=debug
779
780* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
781- specfile cleanup (%%prefix issues mostly)
782
783* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
784- update to 3.90.1
785- bump cmake BR to 2.4.5 as required upstream now
786- don't set execute bits by hand anymore, cmake has been fixed
787- use multilibs in /opt/kde4
788- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
789- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
790  in case we want to drop the Rs on these from kdelibs4-devel
791- consistently add all BRs as -devel Rs, not just almost all, until we can
792  figure out which, if any, are really needed
793- BR libsmbclient-devel instead of samba on F>=7, EL>=6
794
795* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
796- restore minimum version requirement for cmake
797- build against libxklavier on EL5
798- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
799
800* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
801- +eXecute perms for %%{_prefix}/lib/*
802
803* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
804- rebuild for patched FindKDE4Internal.cmake
805
806* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
807- update to 3.80.3
808- update and improve parallel-installability patch
809- drop obsolete joydevice.h patch
810- remove translations of "KDE" without the "4" from kde4.desktop
811- resync BR and -devel Requires
812- don't set LD_LIBRARY_PATH
813- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
814- fix missing underscore in _datadir
815- install kde4.desktop in install, not prep
816- fix invalid syntax in kde4.desktop
817
818* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
819- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
820- compiling with QA_RPATHS=0x0003; export QA_RPATHS
821
822* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
823- parallel build support
824- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
825- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
826- spec file cleanups and added clean up in %%install
827- fixed PATH for libkdecore.so.5; cannot open shared object file;
828- added Logitech mouse support
829- added dbus-devel, hal-devel and more as BR
830- fixed broken joydevice.h - Kevin Kofler
831- added file kde4.desktop
832
833* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
834- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
835- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.