source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 6152

Revision 6152, 27.3 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.7.4
7Release:       3%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.bz2
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# make icontheme inherit working, https://bugs.kde.org/59901
20Patch3:        kdebase-runtime-4.6.90-iconthemes-inherit.patch
21
22# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
23Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
24
25# correct path for htsearch
26Patch7:        kdebase-runtime-4.5.3-htsearch.patch
27
28# Launch compiz via compiz-manager so we get window decorations and
29# other such decadent luxuries (AdamW 2011/01)
30Patch8:        kdebase-runtime-4.5.95-compiz.patch
31
32# add overrides in default manpath
33Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
34
35## upstream patches
36
37Provides:  kdebase4-runtime = %{version}-%{release}
38Provides:  kde-runtime = %{version}-%{release}
39Obsoletes: kdebase4-runtime < %{version}-%{release}
40
41Obsoletes: nepomukcontroller
42Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
43
44# knotify4 provides dbus service org.freedesktop.Notifications too
45Provides: desktop-notification-daemon
46
47BuildRoot:     %{_tmppath}/%{name}-%{version}-root
48BuildRequires: alsa-lib-devel
49BuildRequires: attica-devel >= 0.1.4
50BuildRequires: bzip2-devel
51BuildRequires: chrpath
52BuildRequires: clucene-core-devel
53BuildRequires: doxygen
54BuildRequires: exiv2-devel >= 0.12
55BuildRequires: glib2-devel
56BuildRequires: kdelibs4-devel >= %{version}
57BuildRequires: kdepimlibs-devel >= %{version}
58BuildRequires: libcanberra-devel
59#BuildRequires: libqzeitgeist-devel
60BuildRequires: libsmbclient-devel
61BuildRequires: libssh-devel >= 0.4.2
62BuildRequires: libXpm-devel
63BuildRequires: libXScrnSaver-devel
64BuildRequires: NetworkManager-devel
65BuildRequires: OpenEXR-devel
66BuildRequires: openslp-devel
67BuildRequires: openssl-devel
68BuildRequires: pkgconfig
69BuildRequires: polkit-qt-devel
70BuildRequires: pulseaudio-libs-devel
71BuildRequires: qimageblitz-devel
72BuildRequires: shared-mime-info >= 0.40
73BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
74BuildRequires: soprano-devel >= 2.6.50
75BuildRequires: xine-lib-devel libxcb-devel
76BuildRequires: xorg-x11-font-utils
77BuildRequires: xorg-x11-proto-devel
78BuildRequires: xz-devel
79BuildRequires: zlib-devel
80
81Requires: eject
82Requires: %{name}-libs = %{version}-%{release}
83Requires: %{name}-flags = %{version}-%{release}
84# KHelpcenter requires htdig for building search indices
85Requires: htdig
86# ensure default/fallback icon theme present
87# beware of bootstrapping, there be dragons
88Requires: oxygen-icon-theme >= %{version}
89
90# some items moved -workspace -> -runtime
91Conflicts: kdebase-workspace < 4.5.80
92
93%description
94Core runtime for KDE 4.
95
96%description -l ja
97KDE 4 の中心となるランタイム部分です.
98
99%package devel
100Summary:  Developer files for %{name}
101Summary(ja): %{name} の開発用ファイル
102Group:    Development/Libraries
103Requires: %{name}-libs = %{version}-%{release}
104
105%description devel
106%{summary}.
107
108%description -l ja devel
109%{name} の開発用ファイルです.
110
111%package libs
112Summary: Runtime libraries for %{name}
113Summary(ja): %{name} のランタイムライブラリ
114Group:   System Environment/Libraries
115Requires: kdelibs4 >= %{version}
116Requires: kdepimlibs >= %{version}
117# cagibi is runtime dep, a dbus service
118Requires: cagibi
119
120%description libs
121%{summary}.
122
123%description -l ja libs
124%{name} のランタイムライブラリです.
125
126%package flags
127Summary: Geopolitical flags
128Group: User Interface/Desktops
129Requires: %{name}-libs = %{version}-%{release}
130BuildArch: noarch
131
132%description flags
133%{summary}.
134
135
136%prep
137%setup -q -n kde-runtime-%{version}
138
139%patch1 -p1 -b .searchproviders-shortcuts
140%patch3 -p1 -b .iconthemes-inherit
141%patch6 -p1 -b .home_onlyshowin_kde
142%patch7 -p1 -b .htsearch
143%patch8 -p1 -b .config
144%patch9 -p1 -b .man-overrides
145
146%build
147mkdir -p %{_target_platform}
148pushd %{_target_platform}
149%cmake \
150    -DCMAKE_BUILD_TYPE=release \
151    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
152    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
153    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
154    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
155    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
156    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
157    ..
158popd
159
160make %{?_smp_mflags} -C %{_target_platform}
161
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
167
168# kdesu symlink
169ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
170
171# omit hicolor index.theme, use one from hicolor-icon-theme
172rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
173
174# remove country flags because some people/countries forbid some other
175# people/countries' flags :-(
176%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
177
178# install this service for KDE 3 applications too
179mkdir $RPM_BUILD_ROOT%{_datadir}/services
180ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
181      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
182
183# FIXME: -devel type files, omit for now
184rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
185
186# rpaths
187# use chrpath hammer for now, find better patching solutions later -- Rex
188chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
189chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
196touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
197
198%posttrans
199gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
200gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
201update-desktop-database -q &> /dev/null ||:
202update-mime-database %{_datadir}/mime &> /dev/null
203
204%postun
205if [ $1 -eq 0 ] ; then
206    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
207    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
208    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
209    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
210    update-desktop-database -q &> /dev/null ||:
211    update-mime-database %{_datadir}/mime &> /dev/null
212fi
213
214%post libs -p /sbin/ldconfig
215%postun libs -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root,-)
220%{_sysconfdir}/dbus-1/system.d/*
221%{_sysconfdir}/xdg/menus/kde-information.menu
222%{_bindir}/*
223# omit ksvgtopng which kdelibs3 includes
224%if %{?_dist_release} == "vl5"
225%exclude %{_bindir}/ksvgtopng
226%endif
227%{_datadir}/kde4/apps/*
228%exclude %{_datadir}/kde4/apps/cmake/
229%{_datadir}/config/*.knsrc
230%{_datadir}/autostart/nepomukcontroller.desktop
231%{_datadir}/autostart/nepomukserver.desktop
232%{_datadir}/config.kcfg/
233%{_datadir}/dbus-1/interfaces/*
234%{_datadir}/dbus-1/services/*
235%{_datadir}/dbus-1/system-services/*
236%{_datadir}/icons/default.kde4
237%{_datadir}/kde4/services/*
238%{_datadir}/kde4/servicetypes/*
239%{_datadir}/mime/packages/network.xml
240%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
241%{_datadir}/sounds/*
242%{_libdir}/kconf_update_bin/*
243%{_libdir}/libkdeinit4_*.so
244%{_libdir}/kde4/kcm_*.so
245%{_libdir}/kde4/kded_*.so
246%{_libexecdir}/kde4/drkonqi
247#{_libexecdir}/kde4/installdbgsymbols.sh
248%{_libexecdir}/kde4/kcmremotewidgetshelper
249%{_libexecdir}/kde4/kdeeject
250%{_libexecdir}/kde4/kdesu
251%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
252%{_libexecdir}/kde4/kdontchangethehostname
253%{_libexecdir}/kde4/khc_docbookdig.pl
254%{_libexecdir}/kde4/khc_htdig.pl
255%{_libexecdir}/kde4/khc_htsearch.pl
256%{_libexecdir}/kde4/khc_indexbuilder
257%{_libexecdir}/kde4/khc_mansearch.pl
258%{_libexecdir}/kde4/kioexec
259%{_libexecdir}/kde4/knetattach
260%{_mandir}/man1/*
261%{_mandir}/man8/*
262%{_datadir}/icons/hicolor/*/*/*
263%{_docdir}/HTML/en/*
264%{_datadir}/applications/kde4/Help.desktop
265%{_datadir}/applications/kde4/knetattach.desktop
266%{_datadir}/applications/kde4/nepomukbackup.desktop
267%{_datadir}/applications/kde4/nepomukcontroller.desktop
268%{_datadir}/config/kshorturifilterrc
269%{_datadir}/desktop-directories/*.directory
270%{_datadir}/emoticons/kde4/
271%{_datadir}/locale/l10n/
272%{_datadir}/locale/currency/
273%{_datadir}/ontology/kde/
274%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
275%{_datadir}/services/khelpcenter.desktop
276
277%files devel
278%defattr(-,root,root,-)
279%{_includedir}/*
280%{_libdir}/libnepomuksync.so
281%{_datadir}/kde4/apps/cmake/modules/*.cmake
282
283%files libs
284%defattr(-,root,root,-)
285%{_libdir}/attica_kde.so
286%{_libdir}/libknotifyplugin.so
287%{_libdir}/libkwalletbackend.so.*
288%{_libdir}/libmolletnetwork.so.*
289%{_libdir}/libnepomukcommon.so
290%{_libdir}/libnepomukdatamanagement.so
291%{_libdir}/libnepomuksync.so.*
292%{_libdir}/kde4/*.so
293%{_libdir}/kde4/imports/
294# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
295%exclude %{_libdir}/kde4/kcm_*.so
296%exclude %{_libdir}/kde4/kded_*.so
297%{_libdir}/kde4/plugins/phonon_platform/
298
299%files flags
300%defattr(-,root,root,-)
301%{_datadir}/locale/l10n/*/flag.png
302
303
304%changelog
305* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
306- rebuild with exiv2-0.22
307
308* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
309- rebuilt without libqzeitgeist
310
311* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
312- new upstream release
313
314* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
315- new upstream release
316
317* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
318- new upstream release
319- built with exiv2-0.21.1
320
321* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
322- new upstream release
323
324* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
325- rebuilt with libsmbclient-3.5.8
326
327* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
328- new upstream release
329
330* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
331- added BR: libXpm-devel
332
333* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
334- new upstream release
335- added devel subpackage
336
337* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
338- new upstream release
339- updated summary
340- dropt Patch100
341
342* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
343- new upstream release
344- added Patch100 from Fedora
345  - backport to fix the freeze of kded on first use of the network:/kio-slave
346
347* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
348- new upstream release
349- added Conflicts: kdebase3 at Vine Linux 5
350
351* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
352- new upstream release
353
354* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
355- rebuilt with exiv2-0.19
356
357* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
358- new upstream release
359
360* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
361- new upstream release
362
363* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
364- new upstream release
365- built with new toolchain
366
367* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
368- new upstream release
369
370* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
371- new upstream release
372
373* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
374- new upstream release
375- used %%cmake macro
376
377* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
378- Initial build for Vine Linux
379
380* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
381- respin
382
383* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
384- 4.3.0
385
386* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
387- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
388
389* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
390- 4.3rc3
391
392* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
393- respin (soprano-2.3.0)
394- License: LGPLv2+
395
396* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
397- 4.3rc2
398
399* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
400- drop unneeded BR: ImageMagick (#509241)
401
402* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
403- don't start nepomuk server unconditionally (#487322)
404
405* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
406- 4.3rc1
407
408* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
409- KDE-4.3 beta2 (4.2.90)
410
411* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
412- Drop old Fedora < 8 conditionals
413
414* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
415- file conflicts with kdepim
416
417* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
418- KDE 4.3 beta 1
419
420* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
421- fix persistent systray notifications (#485796)
422
423* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
424- -flags subpkg
425- koji/noarch hacks dropped
426
427* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
428- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
429
430* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
431- KDE 4.2.2
432
433* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
434- flags subpkg (not enabled)
435- optimize scriptlets
436
437* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
438- fix PulseAudio cmake detection
439
440* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
441- 4.2.1
442
443* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
444- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
445
446* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
447- #486059 -  missing dependency on htdig
448
449* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
450- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
451
452* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
453- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
454
455* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
456- own %%_kde4_datadir/locale/l10n/
457
458* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
459- respun tarball
460
461* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
462- Files not trashed to the correct location in Dolphin/Konqueror
463  (#481598, kdebug#178479)
464- omit --with-samba crud
465
466* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
467- 4.2.0
468- +BR: pulseaudio-libs-devel xine-lib-devel
469- -BR: giflib-devel pcre-devel
470
471* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
472- tarball respin
473- drop extraneous deps (that are in kdelibs)
474
475* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
476- 4.2rc1
477
478* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
479- include %%_bindir/kdesu symlink
480
481* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
482- 4.2beta2
483
484* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
485- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
486  and should be in a -devel package if it gets shipped)
487
488* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
489- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
490
491* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
492- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
493
494* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
495- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
496
497* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
498- 4.1.80
499- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
500- BR cmake >= 2.6.2
501- Use 'make install/fast'
502- Drop subpkg phonon-backend-xine and related file entries: this has to be
503  part of phonon now that it moved there
504- Drop xine-lib-devel BR
505- Add libkwalletbackend to files list
506- Drop _default_patch_fuzz 2
507
508* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
509- apply upstream patch to fix X crash when disabling compositing
510
511* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
512- 4.1.3
513
514* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
515- apply upstream patch, kioexec processes never terminate
516
517* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
518- fix broken audio-backend-jack.svgz
519
520* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
521- add missing icons
522
523* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
524- make VERBOSE=1
525- respin against new(er) kde-filesystem
526- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
527
528* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
529- 4.1.2
530
531* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
532- fix inherit issue in iconthemes, preview icons
533  do not show
534
535* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
536- fix #460710, knetattach is kio_remote's wizard program, don't show
537  it in the menu.
538
539* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
540- 4.1.1
541
542* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
543- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
544
545* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
546- crash fix when stopping a service that is not yet initialized
547
548* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
549- don't remove autostart directory on F8- (does not conflict, fixes build
550  failure due to nepomukserver.desktop listed in filelist but not found)
551
552* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
553- 4.1.0
554
555* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
556- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
557
558* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
559- 4.0.99
560
561* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
562- respin
563
564* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
565- -phonon-backend-xine: new subpkg
566
567* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
568- 4.0.98
569
570* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
571- 4.0.85
572
573* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
574- 4.0.84
575
576* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
577- 4.0.83 (beta2)
578
579* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
580- 4.0.82
581
582* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
583- add searchproviders-shortcuts for redhat bugzilla
584
585* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
586- 4.1 beta 1
587
588* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
589- BR new minimum version of soprano-devel
590
591* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
592- update to 4.0.72 (4.1 alpha 1)
593- drop upstreamed deinterlace-crash patch
594- drop khelpcenter patch (fixed upstream)
595- update Phonon PulseAudio patch
596- drop Fedora 7 support
597- update file list
598
599* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
600- omit conflicting icons (kde3_desktop=1 case)
601
602* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
603- oxygen-icon-theme: build noarch
604
605* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
606- %%post/%%postun: hicolor icon theme scriptlets
607
608* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
609- only omit hicolor index.theme (#439374)
610
611* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
612- fix khelpcenter, search plugins/settings in correct path (#443016)
613
614* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
615- respin (at f13's request)
616
617* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
618- pulseaudio patch (use as default, if available)
619
620* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
621- don't crash if we don't have deinterlacing support in xine-lib (#440299)
622
623* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
624- rebuild for the new %%{_kde4_buildtype}
625
626* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
627- update file list for _kde4_libexecdir
628
629* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
630- 4.0.3
631
632* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
633- don't own %%_kde4_docdir/HTML/en/
634
635* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
636- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
637- include noarch build hooks (not enabled)
638
639* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
640- BR libxcb-devel everywhere (including F7)
641
642* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
643- if building for a KDE 4 desktop, include the khelpcenter.desktop service
644  description for KDE 3 here so help works in KDE 3 apps
645
646* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
647- 4.0.2
648
649* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
650- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
651
652* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
653- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
654  (kio_smb itself is already GPLv2+)
655
656* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
657- 4.0.1
658
659* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
660- respun tarball
661
662* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
663- update to 4.0.0
664- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
665
666* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
667- kde-3.97.0
668
669* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
670- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
671
672* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
673- build without libxcb in F7 as we STILL don't have it (see #373361)
674
675* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
676- no longer set kde3_desktop on F9
677- update file list for !kde3_desktop (Sebastian Vahl)
678- don't ship country flags even for full version (as in kdebase 3)
679
680* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
681- kde-3.96.2
682
683* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
684- kde-3.96.1
685
686* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
687- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
688
689* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
690- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
691
692* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
693- kde-3.96.0
694
695* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
696- kdebase-runtime-3.95.2
697
698* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
699- kdebase-runtime-3.95.0
700
701* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
702- Provides: oxygen-icon-theme ...
703
704* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
705- patch dolphin.desktop to get Dolphin to start from the menu
706
707* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
708- update to 3.94.0
709
710* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
711- don't make this the default kdebase on F9 yet
712- drop ExcludeArch: ppc64 (#300601)
713
714* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
715- ExcludeArch: ppc64 (#300601)
716- update description
717
718* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
719- add missing BR alsa-lib-devel
720
721* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
722- remove files which conflict with KDE 3
723- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
724- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
725
726* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
727- update to 3.93.0
728- drop kde4home patch (no longer applied)
729- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
730- remove kdebase-kdm Obsoletes/Provides (for the same reason)
731- remove KDM (and KDM session) setup code (for the same reason)
732- remove rss-glx conflict (Plasma is now in kdebase-workspace)
733- remove redhat-startkde patch (startkde is now in kdebase-workspace)
734- remove kde4-opt.sh (all the code in it is commented out)
735- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
736- remove bogus BRs on automake and libtool
737- remove workspace-only BRs
738- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
739- remove workspace files and directories
740- handle icons (moved from kdelibs4)
741- add mkdir %%{buildroot} in %%install
742
743* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
744- use macros.kde4
745- License: GPLv2
746
747* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
748- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
749- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
750- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
751
752* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
753- consolekit_kdm patch (#228111, kde#147790)
754- update startkde patch
755
756* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
757- kde-3.92 (kde-4-beta1)
758
759* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
760- fix startkde
761- add env/shutdown directory
762
763* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
764- kde4.desktop: fix session Name
765
766* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
767- cleanup/fix kde4.desktop
768- kdepimlibs4->kdepimlibs
769
770* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
771- fix %%_sysconfdir for %%_prefix != /usr case.
772
773* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
774- updated kde4home.diff
775- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
776
777* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
778- kde-3.91.0
779- CMAKE_BUILD_TYPE=debug
780
781* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
782- specfile cleanup (%%prefix issues mostly)
783
784* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
785- update to 3.90.1
786- bump cmake BR to 2.4.5 as required upstream now
787- don't set execute bits by hand anymore, cmake has been fixed
788- use multilibs in /opt/kde4
789- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
790- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
791  in case we want to drop the Rs on these from kdelibs4-devel
792- consistently add all BRs as -devel Rs, not just almost all, until we can
793  figure out which, if any, are really needed
794- BR libsmbclient-devel instead of samba on F>=7, EL>=6
795
796* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
797- restore minimum version requirement for cmake
798- build against libxklavier on EL5
799- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
800
801* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
802- +eXecute perms for %%{_prefix}/lib/*
803
804* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
805- rebuild for patched FindKDE4Internal.cmake
806
807* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
808- update to 3.80.3
809- update and improve parallel-installability patch
810- drop obsolete joydevice.h patch
811- remove translations of "KDE" without the "4" from kde4.desktop
812- resync BR and -devel Requires
813- don't set LD_LIBRARY_PATH
814- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
815- fix missing underscore in _datadir
816- install kde4.desktop in install, not prep
817- fix invalid syntax in kde4.desktop
818
819* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
820- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
821- compiling with QA_RPATHS=0x0003; export QA_RPATHS
822
823* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
824- parallel build support
825- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
826- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
827- spec file cleanups and added clean up in %%install
828- fixed PATH for libkdecore.so.5; cannot open shared object file;
829- added Logitech mouse support
830- added dbus-devel, hal-devel and more as BR
831- fixed broken joydevice.h - Kevin Kofler
832- added file kde4.desktop
833
834* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
835- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
836- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.