source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 2774

Revision 2774, 25.8 KB checked in by inagaki, 13 years ago (diff)

update: KDE 4.6.0
NEW: nepomukcontroller, openal-soft

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.6.0
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebase-runtime-%{version}.tar.bz2
15Source1:       khelpcenter.desktop
16
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18Patch2:        kdebase-runtime-4.2.85-knetattach.patch
19Patch3:        kdebase-runtime-4.1.1-iconthemes-inherit.patch
20Patch5:        kdebase-runtime-4.3.1-manpath.patch
21# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
22Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
23Patch7:        kdebase-runtime-4.5.3-htsearch.patch
24# Launch compiz via compiz-manager so we get window decorations and
25# other such decadent luxuries (AdamW 2011/01)
26Patch8:        kdebase-runtime-4.5.95-compiz.patch
27
28## 4.6 Upstream patches
29
30Provides:  kdebase4-runtime = %{version}-%{release}
31Obsoletes: kdebase4-runtime < %{version}-%{release}
32
33# knotify4 provides dbus service org.freedesktop.Notifications too
34Provides: desktop-notification-daemon
35
36Requires: kdepimlibs >= %{version}
37Requires: eject
38Requires: %{name}-libs = %{version}-%{release}
39Requires: %{name}-flags = %{version}-%{release}
40# KHelpcenter requires htdig for building search indices
41Requires: htdig
42
43BuildRoot:     %{_tmppath}/%{name}-%{version}-root
44BuildRequires: alsa-lib-devel
45BuildRequires: attica-devel
46BuildRequires: bzip2-devel
47BuildRequires: chrpath
48BuildRequires: clucene-core-devel
49BuildRequires: exiv2-devel
50BuildRequires: kdelibs4-devel >= %{version}
51BuildRequires: kdepimlibs-devel >= %{version}
52BuildRequires: libcanberra-devel
53BuildRequires: libsmbclient-devel
54BuildRequires: libssh-devel >= 0.4.2
55BuildRequires: libXScrnSaver-devel
56BuildRequires: OpenEXR-devel
57BuildRequires: openslp-devel
58BuildRequires: openssl-devel
59BuildRequires: pkgconfig
60BuildRequires: polkit-qt-devel
61BuildRequires: pulseaudio-libs-devel
62BuildRequires: qimageblitz-devel
63BuildRequires: shared-desktop-ontologies-devel
64BuildRequires: soprano-devel >= 2.3.0
65BuildRequires: xine-lib-devel libxcb-devel
66BuildRequires: xorg-x11-font-utils
67BuildRequires: xorg-x11-proto-devel
68BuildRequires: xz-devel
69BuildRequires: zlib-devel
70
71%if %{?_dist_release} == "vl5"
72Conflicts: kdebase3
73%endif
74# some items moved -workspace -> -runtime
75Conflicts: kdebase-workspace < 4.5.80
76
77%description
78Core runtime for KDE 4.
79
80%description -l ja
81KDE 4 の中心となるランタイム部分です.
82
83%package devel
84Summary:  Developer files for %{name}
85Summary(ja): %{name} の開発用ファイル
86Group:    Development/Libraries
87Requires: %{name}-libs = %{version}-%{release}
88
89%description devel
90%{summary}.
91
92%package libs
93Summary: Runtime libraries for %{name}
94Summary(ja): %{name} のランタイムライブラリ
95Group:   System Environment/Libraries
96Requires: kdelibs4 >= %{version}
97Requires: kdepimlibs >= %{version}
98# cagibi is runtime dep, a dbus service
99Requires: cagibi
100
101%description libs
102%{summary}.
103
104%package flags
105Summary: Geopolitical flags
106Group: User Interface/Desktops
107Requires: %{name} = %{version}-%{release}
108
109%description flags
110%{summary}.
111
112
113%prep
114%setup -q -n kdebase-runtime-%{version}
115
116%patch1 -p1 -b .searchproviders-shortcuts
117%patch2 -p1 -b .knetattach
118%patch3 -p1 -b .iconthemes-inherit
119%patch6 -p1 -b .home_onlyshowin_kde
120%patch7 -p1 -b .htsearch
121%patch8 -p1 -b .config
122
123
124%build
125mkdir -p %{_target_platform}
126pushd %{_target_platform}
127unset QTDIR || : ; . /etc/profile.d/qt4.sh
128%cmake \
129    -DCMAKE_BUILD_TYPE=release \
130    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
131    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
132    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
133    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
134    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
135    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
136    ..
137popd
138
139make %{?_smp_mflags} -C %{_target_platform}
140
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
146
147# kdesu symlink
148ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
149
150# omit hicolor index.theme, use one from hicolor-icon-theme
151rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
152
153# remove country flags because some people/countries forbid some other
154# people/countries' flags :-(
155%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
156
157# install this service for KDE 3 applications too
158mkdir $RPM_BUILD_ROOT%{_datadir}/services
159ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
160      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
161
162# FIXME: -devel type files, omit for now
163rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
164
165# rpaths
166# use chrpath hammer for now, find better patching solutions later -- Rex
167chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
168chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%post
174touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
175touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
176
177%posttrans
178gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
179gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
180update-desktop-database -q &> /dev/null ||:
181update-mime-database %{_datadir}/mime &> /dev/null
182
183%postun
184if [ $1 -eq 0 ] ; then
185    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
186    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
187    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
188    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
189    update-desktop-database -q &> /dev/null ||:
190    update-mime-database %{_datadir}/mime &> /dev/null
191fi
192
193%post libs -p /sbin/ldconfig
194%postun libs -p /sbin/ldconfig
195
196
197%files
198%defattr(-,root,root,-)
199%{_sysconfdir}/dbus-1/system.d/*
200%{_sysconfdir}/xdg/menus/kde-information.menu
201%{_bindir}/*
202# omit ksvgtopng which kdelibs3 includes
203%if %{?_dist_release} == "vl5"
204%exclude %{_bindir}/ksvgtopng
205%endif
206%{_datadir}/kde4/apps/*
207%exclude %{_datadir}/kde4/apps/cmake/
208%{_datadir}/config/*.knsrc
209%{_datadir}/autostart/nepomukserver.desktop
210%{_datadir}/config.kcfg/
211%{_datadir}/dbus-1/interfaces/*
212%{_datadir}/dbus-1/services/*
213%{_datadir}/dbus-1/system-services/*
214%{_datadir}/icons/default.kde4
215%{_datadir}/kde4/services/*
216%{_datadir}/kde4/servicetypes/*
217%{_datadir}/mime/packages/network.xml
218%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
219%{_datadir}/sounds/*
220%{_libdir}/kconf_update_bin/*
221%{_libdir}/libkdeinit4_*.so
222%{_libdir}/kde4/kcm_*.so
223%{_libdir}/kde4/kded_*.so
224%{_libexecdir}/kde4/drkonqi
225#{_libexecdir}/kde4/installdbgsymbols.sh
226%{_libexecdir}/kde4/kcmremotewidgetshelper
227%{_libexecdir}/kde4/kdeeject
228%{_libexecdir}/kde4/kdesu
229%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
230%{_libexecdir}/kde4/kdontchangethehostname
231%{_libexecdir}/kde4/khc_docbookdig.pl
232%{_libexecdir}/kde4/khc_htdig.pl
233%{_libexecdir}/kde4/khc_htsearch.pl
234%{_libexecdir}/kde4/khc_indexbuilder
235%{_libexecdir}/kde4/khc_mansearch.pl
236%{_libexecdir}/kde4/kioexec
237%{_libexecdir}/kde4/knetattach
238%{_mandir}/man1/*
239%{_mandir}/man8/*
240%{_datadir}/icons/hicolor/*/*/*
241%{_docdir}/HTML/en/*
242%{_datadir}/applications/kde4/Help.desktop
243%{_datadir}/applications/kde4/knetattach.desktop
244%{_datadir}/applications/kde4/nepomukbackup.desktop
245%{_datadir}/config/kshorturifilterrc
246%{_datadir}/desktop-directories/*.directory
247%{_datadir}/emoticons/kde4/
248%{_datadir}/locale/l10n/
249%{_datadir}/locale/currency/
250%{_datadir}/ontology/kde/
251%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
252%{_datadir}/services/khelpcenter.desktop
253
254%files devel
255%defattr(-,root,root,-)
256%{_includedir}/*
257%{_libdir}/libnepomuksync.so
258%{_datadir}/kde4/apps/cmake/modules/*.cmake
259
260%files libs
261%defattr(-,root,root,-)
262%{_libdir}/attica_kde.so
263%{_libdir}/libknotifyplugin.so
264%{_libdir}/libkwalletbackend.so.*
265%{_libdir}/libmolletnetwork.so.*
266%{_libdir}/libnepomukcommon.so
267%{_libdir}/libnepomuksync.so.*
268%{_libdir}/kde4/*.so
269%{_libdir}/kde4/imports/
270# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
271%exclude %{_libdir}/kde4/kcm_*.so
272%exclude %{_libdir}/kde4/kded_*.so
273%{_libdir}/kde4/plugins/phonon_platform/
274
275%if 0%{?flags}
276%files flags
277%defattr(-,root,root,-)
278%{_datadir}/locale/l10n/*/flag.png
279%endif
280
281
282%changelog
283* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
284- new upstream release
285- added devel subpackage
286
287* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
288- new upstream release
289- updated summary
290- dropt Patch100
291
292* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
293- new upstream release
294- added Patch100 from Fedora
295  - backport to fix the freeze of kded on first use of the network:/kio-slave
296
297* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
298- new upstream release
299- added Conflicts: kdebase3 at Vine Linux 5
300
301* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
302- new upstream release
303
304* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
305- rebuilt with exiv2-0.19
306
307* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
308- new upstream release
309
310* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
311- new upstream release
312
313* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
314- new upstream release
315- built with new toolchain
316
317* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
318- new upstream release
319
320* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
321- new upstream release
322
323* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
324- new upstream release
325- used %%cmake macro
326
327* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
328- Initial build for Vine Linux
329
330* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
331- respin
332
333* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
334- 4.3.0
335
336* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
337- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
338
339* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
340- 4.3rc3
341
342* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
343- respin (soprano-2.3.0)
344- License: LGPLv2+
345
346* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
347- 4.3rc2
348
349* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
350- drop unneeded BR: ImageMagick (#509241)
351
352* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
353- don't start nepomuk server unconditionally (#487322)
354
355* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
356- 4.3rc1
357
358* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
359- KDE-4.3 beta2 (4.2.90)
360
361* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
362- Drop old Fedora < 8 conditionals
363
364* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
365- file conflicts with kdepim
366
367* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
368- KDE 4.3 beta 1
369
370* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
371- fix persistent systray notifications (#485796)
372
373* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
374- -flags subpkg
375- koji/noarch hacks dropped
376
377* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
378- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
379
380* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
381- KDE 4.2.2
382
383* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
384- flags subpkg (not enabled)
385- optimize scriptlets
386
387* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
388- fix PulseAudio cmake detection
389
390* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
391- 4.2.1
392
393* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
394- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
395
396* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
397- #486059 -  missing dependency on htdig
398
399* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
400- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
401
402* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
403- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
404
405* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
406- own %%_kde4_datadir/locale/l10n/
407
408* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
409- respun tarball
410
411* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
412- Files not trashed to the correct location in Dolphin/Konqueror
413  (#481598, kdebug#178479)
414- omit --with-samba crud
415
416* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
417- 4.2.0
418- +BR: pulseaudio-libs-devel xine-lib-devel
419- -BR: giflib-devel pcre-devel
420
421* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
422- tarball respin
423- drop extraneous deps (that are in kdelibs)
424
425* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
426- 4.2rc1
427
428* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
429- include %%_bindir/kdesu symlink
430
431* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
432- 4.2beta2
433
434* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
435- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
436  and should be in a -devel package if it gets shipped)
437
438* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
439- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
440
441* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
442- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
443
444* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
445- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
446
447* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
448- 4.1.80
449- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
450- BR cmake >= 2.6.2
451- Use 'make install/fast'
452- Drop subpkg phonon-backend-xine and related file entries: this has to be
453  part of phonon now that it moved there
454- Drop xine-lib-devel BR
455- Add libkwalletbackend to files list
456- Drop _default_patch_fuzz 2
457
458* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
459- apply upstream patch to fix X crash when disabling compositing
460
461* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
462- 4.1.3
463
464* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
465- apply upstream patch, kioexec processes never terminate
466
467* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
468- fix broken audio-backend-jack.svgz
469
470* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
471- add missing icons
472
473* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
474- make VERBOSE=1
475- respin against new(er) kde-filesystem
476- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
477
478* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
479- 4.1.2
480
481* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
482- fix inherit issue in iconthemes, preview icons
483  do not show
484
485* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
486- fix #460710, knetattach is kio_remote's wizard program, don't show
487  it in the menu.
488
489* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
490- 4.1.1
491
492* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
493- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
494
495* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
496- crash fix when stopping a service that is not yet initialized
497
498* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
499- don't remove autostart directory on F8- (does not conflict, fixes build
500  failure due to nepomukserver.desktop listed in filelist but not found)
501
502* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
503- 4.1.0
504
505* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
506- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
507
508* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
509- 4.0.99
510
511* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
512- respin
513
514* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
515- -phonon-backend-xine: new subpkg
516
517* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
518- 4.0.98
519
520* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
521- 4.0.85
522
523* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
524- 4.0.84
525
526* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
527- 4.0.83 (beta2)
528
529* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
530- 4.0.82
531
532* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
533- add searchproviders-shortcuts for redhat bugzilla
534
535* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
536- 4.1 beta 1
537
538* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
539- BR new minimum version of soprano-devel
540
541* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
542- update to 4.0.72 (4.1 alpha 1)
543- drop upstreamed deinterlace-crash patch
544- drop khelpcenter patch (fixed upstream)
545- update Phonon PulseAudio patch
546- drop Fedora 7 support
547- update file list
548
549* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
550- omit conflicting icons (kde3_desktop=1 case)
551
552* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
553- oxygen-icon-theme: build noarch
554
555* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
556- %%post/%%postun: hicolor icon theme scriptlets
557
558* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
559- only omit hicolor index.theme (#439374)
560
561* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
562- fix khelpcenter, search plugins/settings in correct path (#443016)
563
564* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
565- respin (at f13's request)
566
567* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
568- pulseaudio patch (use as default, if available)
569
570* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
571- don't crash if we don't have deinterlacing support in xine-lib (#440299)
572
573* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
574- rebuild for the new %%{_kde4_buildtype}
575
576* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
577- update file list for _kde4_libexecdir
578
579* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
580- 4.0.3
581
582* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
583- don't own %%_kde4_docdir/HTML/en/
584
585* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
586- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
587- include noarch build hooks (not enabled)
588
589* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
590- BR libxcb-devel everywhere (including F7)
591
592* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
593- if building for a KDE 4 desktop, include the khelpcenter.desktop service
594  description for KDE 3 here so help works in KDE 3 apps
595
596* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
597- 4.0.2
598
599* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
600- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
601
602* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
603- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
604  (kio_smb itself is already GPLv2+)
605
606* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
607- 4.0.1
608
609* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
610- respun tarball
611
612* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
613- update to 4.0.0
614- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
615
616* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
617- kde-3.97.0
618
619* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
620- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
621
622* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
623- build without libxcb in F7 as we STILL don't have it (see #373361)
624
625* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
626- no longer set kde3_desktop on F9
627- update file list for !kde3_desktop (Sebastian Vahl)
628- don't ship country flags even for full version (as in kdebase 3)
629
630* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
631- kde-3.96.2
632
633* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
634- kde-3.96.1
635
636* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
637- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
638
639* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
640- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
641
642* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
643- kde-3.96.0
644
645* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
646- kdebase-runtime-3.95.2
647
648* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
649- kdebase-runtime-3.95.0
650
651* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
652- Provides: oxygen-icon-theme ...
653
654* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
655- patch dolphin.desktop to get Dolphin to start from the menu
656
657* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
658- update to 3.94.0
659
660* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
661- don't make this the default kdebase on F9 yet
662- drop ExcludeArch: ppc64 (#300601)
663
664* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
665- ExcludeArch: ppc64 (#300601)
666- update description
667
668* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
669- add missing BR alsa-lib-devel
670
671* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
672- remove files which conflict with KDE 3
673- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
674- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
675
676* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
677- update to 3.93.0
678- drop kde4home patch (no longer applied)
679- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
680- remove kdebase-kdm Obsoletes/Provides (for the same reason)
681- remove KDM (and KDM session) setup code (for the same reason)
682- remove rss-glx conflict (Plasma is now in kdebase-workspace)
683- remove redhat-startkde patch (startkde is now in kdebase-workspace)
684- remove kde4-opt.sh (all the code in it is commented out)
685- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
686- remove bogus BRs on automake and libtool
687- remove workspace-only BRs
688- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
689- remove workspace files and directories
690- handle icons (moved from kdelibs4)
691- add mkdir %%{buildroot} in %%install
692
693* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
694- use macros.kde4
695- License: GPLv2
696
697* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
698- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
699- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
700- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
701
702* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
703- consolekit_kdm patch (#228111, kde#147790)
704- update startkde patch
705
706* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
707- kde-3.92 (kde-4-beta1)
708
709* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
710- fix startkde
711- add env/shutdown directory
712
713* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
714- kde4.desktop: fix session Name
715
716* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
717- cleanup/fix kde4.desktop
718- kdepimlibs4->kdepimlibs
719
720* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
721- fix %%_sysconfdir for %%_prefix != /usr case.
722
723* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
724- updated kde4home.diff
725- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
726
727* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
728- kde-3.91.0
729- CMAKE_BUILD_TYPE=debug
730
731* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
732- specfile cleanup (%%prefix issues mostly)
733
734* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
735- update to 3.90.1
736- bump cmake BR to 2.4.5 as required upstream now
737- don't set execute bits by hand anymore, cmake has been fixed
738- use multilibs in /opt/kde4
739- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
740- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
741  in case we want to drop the Rs on these from kdelibs4-devel
742- consistently add all BRs as -devel Rs, not just almost all, until we can
743  figure out which, if any, are really needed
744- BR libsmbclient-devel instead of samba on F>=7, EL>=6
745
746* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
747- restore minimum version requirement for cmake
748- build against libxklavier on EL5
749- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
750
751* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
752- +eXecute perms for %%{_prefix}/lib/*
753
754* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
755- rebuild for patched FindKDE4Internal.cmake
756
757* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
758- update to 3.80.3
759- update and improve parallel-installability patch
760- drop obsolete joydevice.h patch
761- remove translations of "KDE" without the "4" from kde4.desktop
762- resync BR and -devel Requires
763- don't set LD_LIBRARY_PATH
764- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
765- fix missing underscore in _datadir
766- install kde4.desktop in install, not prep
767- fix invalid syntax in kde4.desktop
768
769* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
770- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
771- compiling with QA_RPATHS=0x0003; export QA_RPATHS
772
773* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
774- parallel build support
775- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
776- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
777- spec file cleanups and added clean up in %%install
778- fixed PATH for libkdecore.so.5; cannot open shared object file;
779- added Logitech mouse support
780- added dbus-devel, hal-devel and more as BR
781- fixed broken joydevice.h - Kevin Kofler
782- added file kde4.desktop
783
784* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
785- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
786- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.