source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 10050

Revision 10050, 29.1 KB checked in by iwamoto, 8 years ago (diff)

kdebase-runtime: rebuilt with libssh 0.7.3

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.14.3
7Release:       3%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.xz
15
16Patch0:        kde-runtime-4.14.3-cmakefile-glib.patch
17
18# add shortcuts for search provider
19Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
20
21# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
22Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
23
24# correct path for htsearch
25Patch7:        kdebase-runtime-4.5.3-htsearch.patch
26
27# Launch compiz via compiz-manager so we get window decorations and
28# other such decadent luxuries (AdamW 2011/01)
29Patch8:        kdebase-runtime-4.5.95-compiz.patch
30
31# add overrides in default manpath
32Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
33
34## upstreamable patches
35# make installdbgsymbols.sh use pkexec instead of su
36# increase some timeouts in an effort to see (some) errors before close
37Patch51: kde-runtime-4.9.0-installdbgsymbols.patch
38
39## upstream patches
40
41
42Provides:  kdebase4-runtime = %{version}-%{release}
43Provides:  kde-runtime = %{version}-%{release}
44Obsoletes: kdebase4-runtime < %{version}-%{release}
45
46Obsoletes: nepomukcontroller
47Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
48
49# knotify4 provides dbus service org.freedesktop.Notifications too
50Provides: desktop-notification-daemon
51
52BuildRoot:     %{_tmppath}/%{name}-%{version}-root
53BuildRequires: alsa-lib-devel
54BuildRequires: attica-devel >= 0.1.4
55BuildRequires: bzip2-devel
56BuildRequires: chrpath
57BuildRequires: clucene-core-devel
58BuildRequires: doxygen
59BuildRequires: exiv2-devel >= 0.12
60BuildRequires: glib2-devel
61BuildRequires: gpgme-devel
62BuildRequires: kdelibs-devel >= %{version}
63BuildRequires: kdepimlibs-devel >= %{version}
64BuildRequires: kactivities-devel
65BuildRequires: libXpm-devel
66BuildRequires: libXScrnSaver-devel
67BuildRequires: libcanberra-devel
68BuildRequires: libgcrypt-devel
69BuildRequires: libsmbclient-devel
70BuildRequires: libssh-devel >= 0.4.2
71BuildRequires: libwebp-devel
72BuildRequires: NetworkManager-devel
73BuildRequires: nepomuk-core
74BuildRequires: nepomuk-core-devel
75BuildRequires: OpenEXR-devel
76BuildRequires: openslp-devel
77BuildRequires: openssl-devel
78BuildRequires: pkgconfig
79BuildRequires: polkit-qt-devel
80BuildRequires: pulseaudio-libs-devel
81BuildRequires: qca2-devel
82BuildRequires: qimageblitz-devel
83BuildRequires: shared-mime-info >= 0.40
84BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
85BuildRequires: soprano-devel >= 2.6.50
86BuildRequires: xine-lib-devel libxcb-devel
87BuildRequires: xorg-x11-font-utils
88BuildRequires: xorg-x11-proto-devel
89BuildRequires: xz-devel
90BuildRequires: zlib-devel
91
92Requires: eject
93Requires: %{name}-libs = %{version}-%{release}
94Requires: %{name}-flags = %{version}-%{release}
95# KHelpcenter requires htdig for building search indices
96Requires: htdig
97# ensure default/fallback icon theme present
98# beware of bootstrapping, there be dragons
99Requires: oxygen-icon-theme >= %{version}
100
101# some items moved -workspace -> -runtime
102Conflicts: kdebase-workspace < 4.5.80
103
104Vendor: Project Vine
105Distribution: Vine Linux
106
107%description
108Core runtime for KDE 4.
109
110%description -l ja
111KDE 4 の中心となるランタイム部分です.
112
113%package devel
114Summary:  Developer files for %{name}
115Summary(ja): %{name} の開発用ファイル
116Group:    Development/Libraries
117Requires: %{name}-libs = %{version}-%{release}
118
119%description devel
120%{summary}.
121
122%description -l ja devel
123%{name} の開発用ファイルです.
124
125%package libs
126Summary: Runtime libraries for %{name}
127Summary(ja): %{name} のランタイムライブラリ
128Group:   System Environment/Libraries
129Requires: kdelibs4 >= %{version}
130Requires: kdepimlibs >= %{version}
131# cagibi is runtime dep, a dbus service
132Requires: cagibi
133
134%description libs
135%{summary}.
136
137%description -l ja libs
138%{name} のランタイムライブラリです.
139
140%package flags
141Summary: Geopolitical flags
142Group: User Interface/Desktops
143Requires: %{name}-libs = %{version}-%{release}
144BuildArch: noarch
145
146%description flags
147%{summary}.
148
149
150%prep
151%setup -q -n kde-runtime-%{version}
152
153%patch0 -p1 -b .glib
154%patch1 -p1 -b .searchproviders-shortcuts
155%patch6 -p1 -b .home_onlyshowin_kde
156%patch7 -p1 -b .htsearch
157%patch8 -p1 -b .config
158%patch9 -p1 -b .man-overrides
159%patch51 -p1 -b .installdgbsymbols
160
161
162%build
163mkdir -p %{_target_platform}
164pushd %{_target_platform}
165%cmake \
166    -DCMAKE_BUILD_TYPE=release \
167    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
168    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
169    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
170    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
171    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
172    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
173    ..
174popd
175
176make %{?_smp_mflags} -C %{_target_platform}
177
178
179%install
180rm -rf $RPM_BUILD_ROOT
181
182make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
183
184# kdesu symlink
185ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
186
187# omit hicolor index.theme, use one from hicolor-icon-theme
188rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
189
190# remove country flags because some people/countries forbid some other
191# people/countries' flags :-(
192%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
193
194# install this service for KDE 3 applications too
195mkdir $RPM_BUILD_ROOT%{_datadir}/services
196ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
197      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
198
199# FIXME: -devel type files, omit for now
200rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
201
202# rpaths
203# use chrpath hammer for now, find better patching solutions later -- Rex
204chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
205chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
206
207%clean
208rm -rf $RPM_BUILD_ROOT
209
210%post
211touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
212
213%posttrans
214gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
215update-desktop-database -q &> /dev/null ||:
216update-mime-database %{_datadir}/mime &> /dev/null
217
218%postun
219if [ $1 -eq 0 ] ; then
220    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
221    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
222    update-desktop-database -q &> /dev/null ||:
223    update-mime-database %{_datadir}/mime &> /dev/null
224fi
225
226%post libs -p /sbin/ldconfig
227%postun libs -p /sbin/ldconfig
228
229
230%files
231%defattr(-,root,root,-)
232%{_sysconfdir}/dbus-1/system.d/*
233%{_sysconfdir}/xdg/menus/kde-information.menu
234%{_bindir}/*
235# omit ksvgtopng which kdelibs3 includes
236%{_datadir}/kde4/apps/*
237%exclude %{_datadir}/kde4/apps/cmake/
238%{_datadir}/config/*.knsrc
239%{_datadir}/config.kcfg/
240%{_datadir}/dbus-1/interfaces/*
241%{_datadir}/dbus-1/services/*
242%{_datadir}/dbus-1/system-services/*
243%{_datadir}/icons/default.kde4
244%{_datadir}/kde4/services/*
245%{_datadir}/kde4/servicetypes/*
246%{_datadir}/mime/packages/network.xml
247%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
248%{_datadir}/sounds/*
249%{_libdir}/kconf_update_bin/*
250%{_libdir}/libkdeinit4_*.so
251%{_libdir}/kde4/kcm_*.so
252%{_libdir}/kde4/kded_*.so
253%{_libdir}/kde4/platformimports/touch/org/kde/plasma/*
254%{_libexecdir}/kde4/drkonqi
255#{_libexecdir}/kde4/installdbgsymbols.sh
256%{_libexecdir}/kde4/kcmremotewidgetshelper
257%{_libexecdir}/kde4/kdeeject
258%{_libexecdir}/kde4/kdesu
259%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
260%{_libexecdir}/kde4/kdontchangethehostname
261%{_libexecdir}/kde4/khc_docbookdig.pl
262%{_libexecdir}/kde4/khc_htdig.pl
263%{_libexecdir}/kde4/khc_htsearch.pl
264%{_libexecdir}/kde4/khc_indexbuilder
265%{_libexecdir}/kde4/khc_mansearch.pl
266%{_libexecdir}/kde4/kioexec
267%{_libexecdir}/kde4/knetattach
268%{_mandir}/man1/*
269%{_datadir}/icons/hicolor/*/*/*
270%{_docdir}/HTML/en/*
271%{_datadir}/applications/kde4/Help.desktop
272%{_datadir}/applications/kde4/knetattach.desktop
273%{_datadir}/config/kshorturifilterrc
274%{_datadir}/desktop-directories/*.directory
275%{_datadir}/emoticons/kde4/
276%{_datadir}/locale/l10n/
277%{_datadir}/locale/currency/
278%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
279%{_datadir}/services/khelpcenter.desktop
280%{_datadir}/mime/packages/webp.xml
281
282%files devel
283%defattr(-,root,root,-)
284%{_includedir}/*
285%{_datadir}/kde4/apps/cmake/modules/*.cmake
286
287%files libs
288%defattr(-,root,root,-)
289%{_libdir}/attica_kde.so
290%{_libdir}/libknotifyplugin.so
291%{_libdir}/libkwalletbackend.so.*
292%{_libdir}/libmolletnetwork.so.*
293%{_libdir}/kde4/*.so
294%{_libdir}/kde4/imports/
295# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
296%exclude %{_libdir}/kde4/kcm_*.so
297%exclude %{_libdir}/kde4/kded_*.so
298%{_libdir}/kde4/plugins/phonon_platform/
299%{_libdir}/kde4/plugins/imageformats/kimg_webp.so
300
301%files flags
302%defattr(-,root,root,-)
303%{_datadir}/locale/l10n/*/flag.png
304
305
306%changelog
307* Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.14.3-3
308- rebuilt with libssh 0.7.3
309
310* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
311- rebuild with exiv2-0.25
312- add Patch0 (kde-runtime-4.14.3-cmakefile-glib.patch)
313
314* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
315- new upstream release
316- add BuildRequires: libgcrypt-devel
317
318* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-2
319- rebuilt with OpenEXR 2.2.0
320- added BR: libwebp-devel
321
322* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
323- new upstream release
324
325* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
326- new upstream release
327- add BuildRequires: gpgme-devel
328
329* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-2
330- rebuild with ilmbase-2.1.0 & OpenEXR-2.1.0
331
332* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
333- new upstream release
334
335* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
336- new upstream release
337- remove Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
338
339* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
340- new upstream release
341
342* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
343- new upstream release
344- add patches from fedora
345  - Patch50 (kde-runtime-4.7.90-nepomuk_onlyshowin_kde.patch)
346  - Patch51 (kde-runtime-4.9.0-installdbgsymbols.patch)
347
348* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
349- new upstream release
350
351* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
352- new upstream release
353
354* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
355- new upstream release
356
357* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
358- rebuild with attica-0.4.1
359
360* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
361- new upstream release
362- remove Patch3 (kdebase-runtime-4.6.90-iconthemes-inherit.patch)
363- add BuildRequires: kactivities-devel, nupomuk-core-devel, qca2-devel
364
365* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-4
366- rebuild with exiv2-0.23
367
368* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-3
369- rebuild with exiv2-0.22
370
371* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
372- rebuilt without libqzeitgeist
373
374* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
375- new upstream release
376
377* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
378- new upstream release
379
380* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
381- new upstream release
382- built with exiv2-0.21.1
383
384* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
385- new upstream release
386
387* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
388- rebuilt with libsmbclient-3.5.8
389
390* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
391- new upstream release
392
393* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
394- added BR: libXpm-devel
395
396* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
397- new upstream release
398- added devel subpackage
399
400* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
401- new upstream release
402- updated summary
403- dropt Patch100
404
405* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
406- new upstream release
407- added Patch100 from Fedora
408  - backport to fix the freeze of kded on first use of the network:/kio-slave
409
410* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
411- new upstream release
412- added Conflicts: kdebase3 at Vine Linux 5
413
414* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
415- new upstream release
416
417* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
418- rebuilt with exiv2-0.19
419
420* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
421- new upstream release
422
423* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
424- new upstream release
425
426* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
427- new upstream release
428- built with new toolchain
429
430* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
431- new upstream release
432
433* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
434- new upstream release
435
436* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
437- new upstream release
438- used %%cmake macro
439
440* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
441- Initial build for Vine Linux
442
443* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
444- respin
445
446* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
447- 4.3.0
448
449* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
450- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
451
452* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
453- 4.3rc3
454
455* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
456- respin (soprano-2.3.0)
457- License: LGPLv2+
458
459* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
460- 4.3rc2
461
462* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
463- drop unneeded BR: ImageMagick (#509241)
464
465* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
466- don't start nepomuk server unconditionally (#487322)
467
468* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
469- 4.3rc1
470
471* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
472- KDE-4.3 beta2 (4.2.90)
473
474* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
475- Drop old Fedora < 8 conditionals
476
477* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
478- file conflicts with kdepim
479
480* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
481- KDE 4.3 beta 1
482
483* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
484- fix persistent systray notifications (#485796)
485
486* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
487- -flags subpkg
488- koji/noarch hacks dropped
489
490* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
491- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
492
493* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
494- KDE 4.2.2
495
496* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
497- flags subpkg (not enabled)
498- optimize scriptlets
499
500* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
501- fix PulseAudio cmake detection
502
503* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
504- 4.2.1
505
506* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
507- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
508
509* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
510- #486059 -  missing dependency on htdig
511
512* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
513- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
514
515* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
516- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
517
518* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
519- own %%_kde4_datadir/locale/l10n/
520
521* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
522- respun tarball
523
524* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
525- Files not trashed to the correct location in Dolphin/Konqueror
526  (#481598, kdebug#178479)
527- omit --with-samba crud
528
529* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
530- 4.2.0
531- +BR: pulseaudio-libs-devel xine-lib-devel
532- -BR: giflib-devel pcre-devel
533
534* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
535- tarball respin
536- drop extraneous deps (that are in kdelibs)
537
538* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
539- 4.2rc1
540
541* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
542- include %%_bindir/kdesu symlink
543
544* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
545- 4.2beta2
546
547* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
548- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
549  and should be in a -devel package if it gets shipped)
550
551* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
552- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
553
554* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
555- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
556
557* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
558- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
559
560* Wed Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
561- 4.1.80
562- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
563- BR cmake >= 2.6.2
564- Use 'make install/fast'
565- Drop subpkg phonon-backend-xine and related file entries: this has to be
566  part of phonon now that it moved there
567- Drop xine-lib-devel BR
568- Add libkwalletbackend to files list
569- Drop _default_patch_fuzz 2
570
571* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
572- apply upstream patch to fix X crash when disabling compositing
573
574* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
575- 4.1.3
576
577* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
578- apply upstream patch, kioexec processes never terminate
579
580* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
581- fix broken audio-backend-jack.svgz
582
583* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
584- add missing icons
585
586* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
587- make VERBOSE=1
588- respin against new(er) kde-filesystem
589- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
590
591* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
592- 4.1.2
593
594* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
595- fix inherit issue in iconthemes, preview icons
596  do not show
597
598* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
599- fix #460710, knetattach is kio_remote's wizard program, don't show
600  it in the menu.
601
602* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
603- 4.1.1
604
605* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
606- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
607
608* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
609- crash fix when stopping a service that is not yet initialized
610
611* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
612- don't remove autostart directory on F8- (does not conflict, fixes build
613  failure due to nepomukserver.desktop listed in filelist but not found)
614
615* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
616- 4.1.0
617
618* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
619- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
620
621* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
622- 4.0.99
623
624* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
625- respin
626
627* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
628- -phonon-backend-xine: new subpkg
629
630* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
631- 4.0.98
632
633* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
634- 4.0.85
635
636* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
637- 4.0.84
638
639* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
640- 4.0.83 (beta2)
641
642* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
643- 4.0.82
644
645* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
646- add searchproviders-shortcuts for redhat bugzilla
647
648* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
649- 4.1 beta 1
650
651* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
652- BR new minimum version of soprano-devel
653
654* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
655- update to 4.0.72 (4.1 alpha 1)
656- drop upstreamed deinterlace-crash patch
657- drop khelpcenter patch (fixed upstream)
658- update Phonon PulseAudio patch
659- drop Fedora 7 support
660- update file list
661
662* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
663- omit conflicting icons (kde3_desktop=1 case)
664
665* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
666- oxygen-icon-theme: build noarch
667
668* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
669- %%post/%%postun: hicolor icon theme scriptlets
670
671* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
672- only omit hicolor index.theme (#439374)
673
674* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
675- fix khelpcenter, search plugins/settings in correct path (#443016)
676
677* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
678- respin (at f13's request)
679
680* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
681- pulseaudio patch (use as default, if available)
682
683* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
684- don't crash if we don't have deinterlacing support in xine-lib (#440299)
685
686* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
687- rebuild for the new %%{_kde4_buildtype}
688
689* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
690- update file list for _kde4_libexecdir
691
692* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
693- 4.0.3
694
695* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
696- don't own %%_kde4_docdir/HTML/en/
697
698* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
699- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
700- include noarch build hooks (not enabled)
701
702* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
703- BR libxcb-devel everywhere (including F7)
704
705* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
706- if building for a KDE 4 desktop, include the khelpcenter.desktop service
707  description for KDE 3 here so help works in KDE 3 apps
708
709* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
710- 4.0.2
711
712* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
713- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
714
715* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
716- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
717  (kio_smb itself is already GPLv2+)
718
719* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
720- 4.0.1
721
722* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
723- respun tarball
724
725* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
726- update to 4.0.0
727- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
728
729* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
730- kde-3.97.0
731
732* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
733- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
734
735* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
736- build without libxcb in F7 as we STILL don't have it (see #373361)
737
738* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
739- no longer set kde3_desktop on F9
740- update file list for !kde3_desktop (Sebastian Vahl)
741- don't ship country flags even for full version (as in kdebase 3)
742
743* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
744- kde-3.96.2
745
746* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
747- kde-3.96.1
748
749* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
750- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
751
752* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
753- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
754
755* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
756- kde-3.96.0
757
758* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
759- kdebase-runtime-3.95.2
760
761* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
762- kdebase-runtime-3.95.0
763
764* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
765- Provides: oxygen-icon-theme ...
766
767* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
768- patch dolphin.desktop to get Dolphin to start from the menu
769
770* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
771- update to 3.94.0
772
773* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
774- don't make this the default kdebase on F9 yet
775- drop ExcludeArch: ppc64 (#300601)
776
777* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
778- ExcludeArch: ppc64 (#300601)
779- update description
780
781* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
782- add missing BR alsa-lib-devel
783
784* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
785- remove files which conflict with KDE 3
786- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
787- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
788
789* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
790- update to 3.93.0
791- drop kde4home patch (no longer applied)
792- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
793- remove kdebase-kdm Obsoletes/Provides (for the same reason)
794- remove KDM (and KDM session) setup code (for the same reason)
795- remove rss-glx conflict (Plasma is now in kdebase-workspace)
796- remove redhat-startkde patch (startkde is now in kdebase-workspace)
797- remove kde4-opt.sh (all the code in it is commented out)
798- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
799- remove bogus BRs on automake and libtool
800- remove workspace-only BRs
801- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
802- remove workspace files and directories
803- handle icons (moved from kdelibs4)
804- add mkdir %%{buildroot} in %%install
805
806* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
807- use macros.kde4
808- License: GPLv2
809
810* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
811- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
812- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
813- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
814
815* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
816- consolekit_kdm patch (#228111, kde#147790)
817- update startkde patch
818
819* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
820- kde-3.92 (kde-4-beta1)
821
822* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
823- fix startkde
824- add env/shutdown directory
825
826* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
827- kde4.desktop: fix session Name
828
829* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
830- cleanup/fix kde4.desktop
831- kdepimlibs4->kdepimlibs
832
833* Fri Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
834- fix %%_sysconfdir for %%_prefix != /usr case.
835
836* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
837- updated kde4home.diff
838- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
839
840* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
841- kde-3.91.0
842- CMAKE_BUILD_TYPE=debug
843
844* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
845- specfile cleanup (%%prefix issues mostly)
846
847* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
848- update to 3.90.1
849- bump cmake BR to 2.4.5 as required upstream now
850- don't set execute bits by hand anymore, cmake has been fixed
851- use multilibs in /opt/kde4
852- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
853- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
854  in case we want to drop the Rs on these from kdelibs4-devel
855- consistently add all BRs as -devel Rs, not just almost all, until we can
856  figure out which, if any, are really needed
857- BR libsmbclient-devel instead of samba on F>=7, EL>=6
858
859* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
860- restore minimum version requirement for cmake
861- build against libxklavier on EL5
862- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
863
864* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
865- +eXecute perms for %%{_prefix}/lib/*
866
867* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
868- rebuild for patched FindKDE4Internal.cmake
869
870* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
871- update to 3.80.3
872- update and improve parallel-installability patch
873- drop obsolete joydevice.h patch
874- remove translations of "KDE" without the "4" from kde4.desktop
875- resync BR and -devel Requires
876- don't set LD_LIBRARY_PATH
877- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
878- fix missing underscore in _datadir
879- install kde4.desktop in install, not prep
880- fix invalid syntax in kde4.desktop
881
882* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
883- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
884- compiling with QA_RPATHS=0x0003; export QA_RPATHS
885
886* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
887- parallel build support
888- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
889- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
890- spec file cleanups and added clean up in %%install
891- fixed PATH for libkdecore.so.5; cannot open shared object file;
892- added Logitech mouse support
893- added dbus-devel, hal-devel and more as BR
894- fixed broken joydevice.h - Kevin Kofler
895- added file kde4.desktop
896
897* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
898- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
899- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.