source: projects/specs/trunk/k/kdeaccessibility/kdeaccessibility-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: kdeaccessibility
2Version: 4.3.3
3Release: 1%{?_dist_release}
4Summary: tools for handicapped people to use the GUI
5Summary(ja): ハンディを持つ人の GUI 使用をサポートするツール集
6Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
7URL: http://www.kde.org/
8Group: Applications/Accessories
9License: GPLv2
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: alsa-lib-devel
13BuildRequires: desktop-file-utils
14#BuildRequires: festival
15# workaround (hopefully) temporary borkage
16BuildRequires: flite-devel
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: plasma-devel >= %{version}
19Requires: %{name}-libs = %{version}-%{release}
20
21%description
22Included with this package are:
23* kmag: a screen magnifier
24* kmousetool: a program for people whom it hurts to click the mouse
25* kmouth: program that allows people who have lost their voice
26* ktts: text to speech support
27
28# Yes, it's a bit silly to have this, esp since we don't have a -devel pkg,
29# but that's how multilib currently works. -- Rex
30%package libs
31Summary: Runtime libraries for %{name}
32Group:   System Environment/Libraries
33Requires: kdelibs4 >= %{version}
34
35%description libs
36%{summary}.
37
38
39%prep
40%setup -q
41
42%build
43mkdir -p %{_target_platform}
44pushd %{_target_platform}
45unset QTDIR || : ; . /etc/profile.d/qt4.sh
46%cmake \
47    -DCMAKE_BUILD_TYPE=release \
48    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
49    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
50    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
51    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
52    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
53    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
54    ..
55popd
56
57make %{?_smp_mflags} -C %{_target_platform}
58
59
60%install
61rm -rf $RPM_BUILD_ROOT
62make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
63
64# hack around HTML doc multilib conflicts
65for doxy_hack in kmousetool kmouth kttsd ; do
66pushd $RPM_BUILD_ROOT%{_docdir}/HTML/en/${doxy_hack}
67bunzip2 index.cache.bz2
68sed -i -e 's!<a name="id[0-9]*"></a>!!g' index.cache
69bzip2 -9 index.cache
70done
71popd
72
73# unpackaged files
74rm -vf $RPM_BUILD_ROOT%{_libdir}/libkttsd.so
75
76
77%check
78for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
79  desktop-file-validate $f
80done
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
87touch --no-create %{_datadir}/icons/mono &> /dev/null || :
88
89%postun
90if [ $1 -eq 0 ] ; then
91  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
92  touch --no-create %{_datadir}/icons/mono &> /dev/null
93  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null
94  gtk-update-icon-cache %{_datadir}/icons/mono &> /dev/null || :
95fi
96
97%posttrans
98gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
99gtk-update-icon-cache %{_datadir}/icons/mono &> /dev/null || :
100
101%post libs -p /sbin/ldconfig
102
103%postun libs -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root)
107%doc COPYING
108%{_bindir}/*
109%{_datadir}/kde4/apps/kmag/
110%{_datadir}/kde4/apps/kmousetool/
111%{_datadir}/kde4/apps/kmouth/
112%{_datadir}/kde4/apps/kttsd/
113%{_datadir}/kde4/apps/color-schemes/*.colors
114%config %{_datadir}/config/*
115%{_datadir}/applications/kde4/*.desktop
116%{_datadir}/kde4/services/*
117%{_datadir}/kde4/servicetypes/*
118%doc %{_docdir}/HTML/en/kmag/
119%doc %{_docdir}/HTML/en/kmousetool/
120%doc %{_docdir}/HTML/en/kmouth/
121%doc %{_docdir}/HTML/en/kttsd/
122%{_datadir}/icons/mono
123%{_datadir}/icons/hicolor/*/*/*
124%{_libdir}/kde4/*
125%{_mandir}/man1/*.1*
126
127%files libs
128%defattr(-,root,root,-)
129%{_libdir}/libkttsd.so.4*
130
131%changelog
132* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
133- new upstream release
134
135* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
136- new upstream release
137
138* Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
139- new upstream release
140- used %%cmake macro
141
142* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
143- new upstream release
144
145* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
146- applied new versioning policy, spec in UTF-8
147- changed Group to Group: Applications/Accessories
148
149* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
150- rebuild for VineSeed
151
152* Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
153- new upstream release
154
155* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
156- rebuild for VineSeed
157
158* Thu May 24 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
159- new upstream release
160
161* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
162- new upstream release
163
164* Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
165- added --with-qt-libraries and --enable-libsuffix option
166
167* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
168- rebuild for VineSeed
169
170* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
171- new upstream release
172
173* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
174- rebuild for VineSeed
175
176* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
177- new upstream release
178
179* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
180- rebuild for VineSeed
181
182* Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
183- new upstream release
184
185* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
186- rebuild for VineSeed
187
188* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
189- new upstream release
190
191* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
192- rebuild for VineSeed
193
194* Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
195- new upstream release
196
197* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
198- rebuild for VineSeed
199
200* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
201- new upstream release
202
203* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
204- new upstream release
205
206* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
207- new upstream release
208
209* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
210- new upstream release
211
212* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
213- rebuild for VineSeed
214
215* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
216- new upstream release
217
218* Thu Jun 30 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
219- build for VineSeed
220- add --disable-rpath to configure option
221
222* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
223- new upstream release
224- use %%{?_smp_mflags} for make option
225
226* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
227- rebuild for VineSeed
228
229* Tue Mar 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
230- new upstream release
231
232* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
233- new upstream release (3.4.0-rc1)
234- update %%files
235
236* Mon Feb  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
237- new upstream release
238- update %%files
239
240* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
241- rebuild for VineSeed
242
243* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
244- source upgrade
245- build for Vine Linux 3.1
246
247* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
248- source upgrade
249
250* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
251- rebuild with qt32
252
253* Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
254- source upgrade
255- remove lines about vine26
256
257* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
258- source upgrade
259- add URL: http://www.kde.org/
260
261* Thu Mar 25 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
262- first release
Note: See TracBrowser for help on using the repository browser.