source: projects/specs/trunk/k/kdbg/kdbg-vl.spec @ 9275

Revision 9275, 4.6 KB checked in by inagaki, 9 years ago (diff)

2015-01-17 Ryoichi INAGAKI <ryo1@…>

  • kcoloredit, kgrab, kiconedit, kuickshow: rebuilt
  • kdbg, knemo: updated


Line 
1Summary: KDbg - a graphical user interface to gdb
2Summary(ja): GDB のグラフィカルユーザインターフェイス
3Name: kdbg
4Version: 2.5.4
5Release: 1%{?_dist_release}
6
7License: GPL+
8Group: Applications/Development
9URL: http://www.kdbg.org/
10
11Source: http://download.sourceforge.net/kdbg/%{name}-%{version}.tar.gz
12Patch0: kdbg-2.5.1-icons.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: cmake
16BuildRequires: desktop-file-utils
17BuildRequires: gettext
18BuildRequires: kdelibs4-devel
19Requires(post): desktop-file-utils
20Requires(postun): desktop-file-utils
21Requires: gdb
22Requires: xterm
23
24%description
25KDbg is a K Desktop Environment (KDE) GUI for gdb, the GNU debugger.
26KDbg provides the programmer with an intuitive interface for setting
27breakpoints, inspecting variables, and stepping through code. KDbg
28requires X and KDE to be installed in order to run.
29
30%prep
31%setup -q
32%patch0 -p1 -b .icons
33
34%build
35# don't install icons, which are included in oxygen-icon-theme
36rm -f kdbg/pics/*action-debug-run*
37
38mkdir -p %{_target_platform}
39pushd %{_target_platform}
40%{cmake} \
41    -DCMAKE_BUILD_TYPE=release \
42    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
43    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
44    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
45    -DKDE_DISTRIBUTION_TEXT="%{version}-%{release} Vine Linux" \
46    ..
47popd
48
49make %{?_smp_mflags} -C %{_target_platform}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make DESTDIR=$RPM_BUILD_ROOT install/fast -C %{_target_platform}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%post
59touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
60touch --no-create %{_datadir}/icons/oxygen  &> /dev/null || :
61
62%postun
63if [ $1 -eq 0 ] ; then
64  update-desktop-database -q &> /dev/null
65  touch --no-create %{_datadir}/icons/hicolor &> /dev/null
66  touch --no-create %{_datadir}/icons/oxygen  &> /dev/null || :
67  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
68  gtk-update-icon-cache %{_datadir}/icons/oxygen  &> /dev/null || :
69fi
70
71%posttrans
72update-desktop-database -q &> /dev/null
73gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
74gtk-update-icon-cache %{_datadir}/icons/oxygen  &> /dev/null || :
75
76
77%files
78%defattr(-,root,root)
79%doc BUGS ChangeLog* COPYING README TODO ReleaseNotes-*
80%{_bindir}/kdbg
81%{_datadir}/applications/kde4/*
82%{_datadir}/kde4/apps/%{name}
83%{_datadir}/icons/*/*/*/*
84%{_datadir}/locale/*
85%config (noreplace) %{_datadir}/config/kdbgrc
86%doc %{_docdir}/HTML/*
87
88%changelog
89* Sat Jan 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.5.4-1
90- updated to 2.5.4
91- built on current VineSeed
92
93* Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 2.1.1-3
94- rebuilt without smp option
95- added BR: arts-devel
96
97* Wed Mar 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.1-2
98- rebuilt with new toolchain
99- added %%post, %%postun and %%posttrans section
100- added Patch0 from Fedora
101  * Fri Feb 27 2009 Than Ngo <than@redhat.com> - 2.1.1-1
102  - fix build issue against gcc-4.4
103
104* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.1-1
105- applied new versioning policy, spec in UTF-8
106- new upstream release
107
108* Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> 2.0.4-0vl3
109- changed configure to %%configure
110
111* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.4-0vl2
112- rebuild for VineSeed
113
114* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.4-0vl1
115- new upstream release
116- update URL
117
118* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.0-0vl1
119- new upstream release
120
121* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl3
122- rebuild with kde-3.4.0 (VineSeed)
123
124* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl2
125- rebuild with kde-3.4.0 (Vine3.1)
126
127* Fri Oct 22 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.10-0vl1
128- source upgrade
129
130* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.9-0vl2
131- use License tag
132- rebuild with qt-3.3.2 and kde-3.2.2
133
134* Sun Sep 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.9-0vl1
135- source upgrade
136- change spec to build with gcc-3.2.3
137
138* Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.8-0vl1
139- source upgrade
140- change spec to build with gcc295
141- change make option for SMP and add script
142
143* Sun Jun 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.7-0vl2
144- rebuild with qt-3.1.2 and kde-3.1.2
145
146* Tue Mar  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.7-0vl1
147- source upgrade
148- build with qt-3.1.1 and kde-3.1
149
150* Mon Oct 14 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.6-0vl1
151- source upgrade
152- build with qt-3.0.5 and kde-3.0.4
153
154* Tue Aug  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.5-0vl1
155- first release
Note: See TracBrowser for help on using the repository browser.