source: projects/specs/trunk/k/kcoloredit/kcoloredit-vl.spec @ 10763

Revision 10763, 4.7 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define iversion 2.0.0
2
3Name:           kcoloredit
4Version:        4.4.0
5Release:        3%{?_dist_release}
6Summary:        A color palette Editor
7Summary(ja):    カラーパレットエディタ
8
9Group:          Applications/Graphics
10License:        GPLv2+
11URL:            https://www.kde.org/applications/graphics/kcoloredit/
12Source0:        ftp://ftp.kde.org/pub/kde/stable/%{version}/src/extragear/kcoloredit-%{iversion}-kde%{version}.tar.bz2
13
14## upstream patches
15# fix FTBFS with the new stricter ld in F13 (#564815): explicitly link libX11
16Patch100: kcoloredit-2.0.0-kde4.4.0-ftbfs.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19#BuildRequires:  kde-filesystem >= 4
20BuildRequires:  kdelibs4-devel >= 4
21BuildRequires:  desktop-file-utils
22BuildRequires:  gettext
23BuildRequires:  cmake
24
25Requires: kdelibs4 >= %{version}
26Requires(post): xdg-utils
27Requires(postun): xdg-utils
28
29%description
30KColorEdit is a palette files editor. It can be used for editing
31color palettes and for color choosing and naming.
32
33%prep
34%setup -qn kcoloredit-%{iversion}-kde%{version}
35%patch100 -p1 -b .ftbfs
36
37%build
38mkdir -p %{_target_platform}
39pushd %{_target_platform}
40%{cmake} \
41    -DCMAKE_BUILD_TYPE=release \
42    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
43    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
44    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
45    ..
46popd
47
48
49make %{?_smp_mflags} -C %{_target_platform}
50
51
52%install
53rm -rf $RPM_BUILD_ROOT
54make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
55
56# validate desktop file
57desktop-file-install --vendor "" \
58    --dir $RPM_BUILD_ROOT%{_datadir}/applications/kde4 \
59    $RPM_BUILD_ROOT%{_datadir}/applications/kde4/%{name}.desktop
60
61
62%find_lang %{name}
63HTML_DIR=$(kde4-config --expandvars --install html)
64if [ -d $RPM_BUILD_ROOT${HTML_DIR} ]; then
65for lang_dir in $RPM_BUILD_ROOT${HTML_DIR}/* ; do
66  if [ -d ${lang_dir} ]; then
67    lang=$(basename ${lang_dir})
68    echo "%lang(${lang}) ${HTML_DIR}/${lang}/%{name}/" >> %{name}.lang
69  fi
70done
71fi
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
78
79%postun
80xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
81
82
83%files -f %{name}.lang
84%defattr(-,root,root,-)
85%doc AUTHORS COPYING README
86%{_bindir}/kcoloredit
87%{_datadir}/kde4/apps/kcoloredit/
88%{_datadir}/applications/kde4/kcoloredit.desktop
89%{_datadir}/icons//hicolor/*/*/kcoloredit.png
90
91%changelog
92* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 4.4.0-3
93- rebuild with gcc-5.4.0
94
95* Fri Jan 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.4.0-2
96- rebuilt on current VineSeed
97- added Patch100 from Fedora
98  * Sat Feb 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.4.0-2
99  - fix FTBFS with the new stricter ld in F13 (#564815): explicitly link libX11
100
101* Mon Mar 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
102- new upstream release
103- built with new toolchain
104
105* Fri Nov 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
106- new upstream release
107
108* Sat Sep 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-2
109- initial build for Vine Linux
110
111* Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 4.3.1-1
112- 4.3.1
113
114* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-1
115- 4.3.0
116
117* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.4-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
119
120* Tue Jun 10 2009 Sebastian Vahl <fedora@deadbabylon.de> - 4.2.4-1
121- 4.2.4
122
123* Tue May 12 2009 Sebastian Vahl <fedora@deadbabylon.de> - 4.2.3-1
124- 4.2.3
125
126* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-2
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
128
129* Fri Jan 23 2009 Than Ngo <than@redhat.com> - 4.2.0-1
130- 4.2.0
131
132* Mon Nov 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.3-2
133- dependency fixes, cosmetics
134
135* Fri Nov 14 2008 Than Ngo <than@redhat.com> 4.1.3-1
136- 4.1.3
137
138* Sat Oct 04 2008 Than Ngo <than@redhat.com> 4.1.2-1
139- 4.1.2
140
141* Fri Aug 29 2008 Than Ngo <than@redhat.com> 4.1.1-1
142- 4.1.1
143
144* Thu Aug 28 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1-1
145- 4.1 (final)
146
147* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
148- 4.1 beta1
149
150* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
151- rebuild (again) for the fixed %%{_kde4_buildtype}
152
153* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-1
154- update to 4.0.3
155- rebuild for NDEBUG and _kde4_libexecdir
156
157* Tue Mar 04 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.0.2-1
158- new upstream version: 4.0.2
159
160* Thu Feb 14 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.0.1-2
161- remove reference to KDE 4 in summary
162
163* Fri Feb 08 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.0.1-1
164- new upstream version: 4.0.1
165
166* Fri Jan 25 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.0.0-1
167- Initial version of kde-4.0.0 version
Note: See TracBrowser for help on using the repository browser.