source: projects/specs/trunk/k/kate/kate-vl.spec @ 7801

Revision 7801, 6.7 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.11.1

Line 
1Name:    kate
2Summary: Advanced Text Editor
3Summary(ja): 高機能なテキストエディタ
4Version: 4.11.1
5Release: 1%{?_dist_release}
6
7# kwrite LGPLv2+
8# kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
9# ktexteditor: LGPLv2
10# katepart: LGPLv2
11License: LGPLv2 and LGPLv2+ and GPLv2+
12Group:   Applications/Editors
13URL:     https://projects.kde.org/projects/kde/kdebase/kate
14
15Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}
18BuildRequires: desktop-file-utils
19BuildRequires: kdelibs4-devel >= %{version}
20BuildRequires: kactivities-devel >= %{version}
21BuildRequires: soprano-devel
22BuildRequires: sip-devel
23BuildRequires: python-devel
24BuildRequires: PyQt4-devel
25BuildRequires: PyKDE4-devel
26BuildRequires: qjson-devel
27
28Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
29Requires: %{name}-part = %{version}-%{release}
30Requires: %{name}-libs = %{version}-%{release}
31
32%description
33%{summary}.
34
35%package devel
36Summary:  Development files for %{name}
37Summary(ja): %{name} の開発用ファイル
38Group:    Development/Libraries
39Requires: %{name}-libs = %{version}-%{release}
40Requires: kdelibs4-devel
41
42%description devel
43%{summary}.
44
45%package libs
46Summary:  Runtime files for %{name}
47Summary(ja): %{name} のランタイムライブラリ
48Group:    System Environment/Libraries
49# when split occurred
50Conflicts: kdesdk4-libs < 4.6.95-10
51#Requires: %{name} = %{version}-%{release}
52
53%description libs
54%{summary}.
55
56%package part
57Summary: Kate kpart plugin
58Summary(ja): Kate kpart プラグイン
59License: LGPLv2
60Group:   Applications/Editors
61# when split occurred
62Conflicts: kdelibs4 < 4.6.95-10
63
64%description part
65%{summary}.
66
67%package -n kwrite
68Summary: Text Editor
69Summary(ja): テキストエディタ
70License: LGPLv2+
71Group:   Applications/Editors
72# when split occurred
73Conflicts: kdebase4 < 4.6.95-10
74Requires: %{name}-part = %{version}-%{release}
75Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
76
77%description -n kwrite
78%{summary}.
79
80%package pate
81Summary: Kate python plugin
82Summary(ja): Kate python プラグイン
83License: LGPLv2
84Group:   System Environment/Libraries
85
86%description pate
87%{summary}.
88
89%prep
90%setup -q
91
92
93%build
94mkdir -p %{_target_platform}
95pushd %{_target_platform}
96%cmake \
97    -DCMAKE_BUILD_TYPE=release \
98    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
99    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
100    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
101    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
102    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
103    ..
104popd
105
106make %{?_smp_mflags} -C %{_target_platform}
107
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
113
114# move devel symlinks (that would otherwise conflict with kdelibs3-devel)
115mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
116pushd $RPM_BUILD_ROOT%{_libdir}
117for i in lib*.so
118do
119    case "$i" in
120        libkate*interfaces.so)
121            linktarget=`readlink "$i"`
122            rm -f "$i"
123            ln -sf "../../$linktarget" "kde4/devel/$i"
124            ;;
125    esac
126done
127popd
128
129## unpackaged files
130# playground artsticomment -devel bits
131rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
132rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
133
134
135%check
136for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
137  desktop-file-validate $f
138done
139
140
141%post
142touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
143
144%posttrans
145gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
146update-mime-database %{_datadir}/mime >& /dev/null
147
148%postun
149if [ $1 -eq 0 ] ; then
150    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
151    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
152    update-mime-database %{_datadir}/mime >& /dev/null
153fi
154
155%post part -p /sbin/ldconfig
156%postun part -p /sbin/ldconfig
157
158
159%files
160%doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/README kate/TODO
161%{_bindir}/kate
162%{_libdir}/libkdeinit4_kate.so
163%{_datadir}/applications/kde4/kate.desktop
164%{_datadir}/kde4/apps/kate/
165%{_datadir}/kde4/apps/katexmltools/
166%{_datadir}/kde4/apps/kconf_update/kate*.upd
167%{_datadir}/icons/hicolor/*/*/*
168%{_mandir}/man1/kate.1.gz
169%{_datadir}/config/katerc
170%{_datadir}/kde4/services/kate*.desktop
171%{_libdir}/kde4/kate*plugin.so
172%{_libdir}/kde4/katefiletemplates.so
173%{_datadir}/kde4/apps/katepart/
174%{_datadir}/kde4/apps/ktexteditor_*/
175%{_datadir}/kde4/services/ktexteditor_*.desktop
176%{_libdir}/kde4/ktexteditor_*.so
177%{_datadir}/kde4/services/plasma-applet-katesession.desktop
178%{_datadir}/kde4/servicetypes/kateplugin.desktop
179%{_libdir}/kde4/plasma_applet_katesession.so
180%{_libdir}/kde4/kate_kttsd.so
181%{_datadir}/config/ktexteditor_codesnippets_core.knsrc
182# these should *probably* be moved to hicolor -- rex
183%{_datadir}/doc/HTML/en/kate/
184
185%files libs
186%{_libdir}/libkateinterfaces.so.4*
187%{_libdir}/libkatepartinterfaces.so.4*
188
189%files devel
190%{_libdir}/kde4/devel/libkateinterfaces.so
191%{_libdir}/kde4/devel/libkatepartinterfaces.so
192%{_includedir}/kde4/kate_export.h
193%{_includedir}/kde4/kate/
194
195%files part
196%doc part/AUTHORS part/ChangeLog part/COPYING.LIB
197%doc part/INDENTATION part/NEWS part/README* part/TODO*
198%{_libdir}/kde4/katepart.so
199%{_libdir}/libkatepartinterfaces.so.4*
200%{_datadir}/config/katemoderc
201%{_datadir}/kde4/services/katepart.desktop
202
203%files -n kwrite
204%{_bindir}/kwrite
205%{_datadir}/kde4/apps/kwrite
206%{_libdir}/libkdeinit4_kwrite.so
207%{_datadir}/applications/kde4/kwrite.desktop
208%{_datadir}/doc/HTML/en/kwrite/
209
210%files pate
211%{python_sitearch}/PyKate4
212%{_datadir}/config/kateschemarc
213%{_datadir}/config/katesyntaxhighlightingrc
214%{_datadir}/kde4/services/pate.desktop
215
216
217%changelog
218* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
219- new upstream release
220
221* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
222- new upstream release
223- add BuildRequires: kactivities-devel, sip-devel, python-devel, PyQt4-devel, PyKDE4-devel, qjson-devel
224- create %%{name}-pate subpackage
225
226* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
227- new upstream release
228
229* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
230- new upstream release
231
232* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
233- new upstream release
234
235* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
236- new upstream release
237
238* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
239- new upstream release
240
241* Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
242- new upstream release
243
244* Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
245- new upstream release
246
247* Mon Aug  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
248- Initial build for Vine Linux
249
250* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
251- 4.7.0
252
253* Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
254- first try
255
Note: See TracBrowser for help on using the repository browser.