source: projects/specs/trunk/k/kate/kate-vl.spec @ 6725

Revision 6725, 5.9 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name:    kate
2Summary: Advanced Text Editor
3Summary(ja): 高機能なテキストエディタ
4Version: 4.9.0
5Release: 1%{?_dist_release}
6
7# kwrite LGPLv2+
8# kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
9# ktexteditor: LGPLv2
10# katepart: LGPLv2
11License: LGPLv2 and LGPLv2+ and GPLv2+
12Group:   Applications/Editors
13URL:     https://projects.kde.org/projects/kde/kdebase/kate
14
15Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}
18BuildRequires: desktop-file-utils
19BuildRequires: kdelibs4-devel >= %{version}
20BuildRequires: soprano-devel
21
22Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
23Requires: %{name}-part = %{version}-%{release}
24Requires: %{name}-libs = %{version}-%{release}
25
26%description
27%{summary}.
28
29%package devel
30Summary:  Development files for %{name}
31Summary(ja): %{name} の開発用ファイル
32Group:    Development/Libraries
33Requires: %{name}-libs = %{version}-%{release}
34Requires: kdelibs4-devel
35
36%description devel
37%{summary}.
38
39%package libs
40Summary:  Runtime files for %{name}
41Summary(ja): %{name} のランタイムライブラリ
42Group:    System Environment/Libraries
43# when split occurred
44Conflicts: kdesdk4-libs < 4.6.95-10
45#Requires: %{name} = %{version}-%{release}
46
47%description libs
48%{summary}.
49
50%package part
51Summary: Kate kpart plugin
52Summary(ja): Kate kpart プラグイン
53License: LGPLv2
54Group:   Applications/Editors
55# when split occurred
56Conflicts: kdelibs4 < 4.6.95-10
57
58%description part
59%{summary}.
60
61%package -n kwrite
62Summary: Text Editor
63Summary(ja): テキストエディタ
64License: LGPLv2+
65Group:   Applications/Editors
66# when split occurred
67Conflicts: kdebase4 < 4.6.95-10
68Requires: %{name}-part = %{version}-%{release}
69Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
70
71%description -n kwrite
72%{summary}.
73
74
75%prep
76%setup -q
77
78
79%build
80mkdir -p %{_target_platform}
81pushd %{_target_platform}
82%cmake \
83    -DCMAKE_BUILD_TYPE=release \
84    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
85    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
86    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
87    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
88    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
89    ..
90popd
91
92make %{?_smp_mflags} -C %{_target_platform}
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
99
100# move devel symlinks (that would otherwise conflict with kdelibs3-devel)
101mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
102pushd $RPM_BUILD_ROOT%{_libdir}
103for i in lib*.so
104do
105    case "$i" in
106        libkate*interfaces.so)
107            linktarget=`readlink "$i"`
108            rm -f "$i"
109            ln -sf "../../$linktarget" "kde4/devel/$i"
110            ;;
111    esac
112done
113popd
114
115## unpackaged files
116# playground artsticomment -devel bits
117rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
118rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
119
120
121%check
122for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
123  desktop-file-validate $f
124done
125
126
127%post
128touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
129
130%posttrans
131gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
132update-mime-database %{_datadir}/mime >& /dev/null
133
134%postun
135if [ $1 -eq 0 ] ; then
136    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
137    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
138    update-mime-database %{_datadir}/mime >& /dev/null
139fi
140
141%post part -p /sbin/ldconfig
142%postun part -p /sbin/ldconfig
143
144
145%files
146%doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/NEWS kate/README kate/TODO
147%{_bindir}/kate
148%{_libdir}/libkdeinit4_kate.so
149%{_datadir}/applications/kde4/kate.desktop
150%{_datadir}/kde4/apps/kate/
151%{_datadir}/kde4/apps/katexmltools/
152%{_datadir}/kde4/apps/kconf_update/kate*.upd
153%{_datadir}/icons/hicolor/*/*/*
154%{_mandir}/man1/kate.1.gz
155%{_datadir}/config/katerc
156%{_datadir}/config/katefiletemplates.knsrc
157%{_datadir}/kde4/services/kate*.desktop
158%{_libdir}/kde4/kate*plugin.so
159%{_libdir}/kde4/katefiletemplates.so
160%{_datadir}/kde4/apps/katepart/
161%{_datadir}/kde4/apps/ktexteditor_*/
162%{_datadir}/kde4/services/ktexteditor_*.desktop
163%{_libdir}/kde4/ktexteditor_*.so
164%{_datadir}/kde4/services/plasma-applet-katesession.desktop
165%{_datadir}/kde4/servicetypes/kateplugin.desktop
166%{_libdir}/kde4/plasma_applet_katesession.so
167%{_libdir}/kde4/kate_kttsd.so
168# snippets plugin
169%{_bindir}/ktesnippets_editor
170%{_datadir}/applications/kde4/ktesnippets_editor.desktop
171%{_datadir}/config/ktexteditor_codesnippets_core.knsrc
172# these should *probably* be moved to hicolor -- rex
173%{_datadir}/icons/oxygen/*/actions/*
174%{_datadir}/mime/packages/ktesnippets.xml
175%{_datadir}/doc/HTML/en/kate/
176
177%files libs
178%{_libdir}/libkateinterfaces.so.4*
179%{_libdir}/libktexteditor_codesnippets_core.so.0*
180
181%files devel
182%{_libdir}/kde4/devel/libkateinterfaces.so
183%{_libdir}/kde4/devel/libkatepartinterfaces.so
184%{_libdir}/libktexteditor_codesnippets_core.so
185%{_includedir}/kde4/kate_export.h
186%{_includedir}/kde4/kate/
187%{_includedir}/kde4/ktexteditor_codesnippets_core/
188
189%files part
190%doc part/AUTHORS part/ChangeLog part/COPYING.LIB
191%doc part/INDENTATION part/NEWS part/README* part/TODO*
192%{_libdir}/kde4/katepart.so
193%{_libdir}/libkatepartinterfaces.so.4*
194%{_datadir}/config/katemoderc
195%{_datadir}/config/katepartpluginsrc
196%{_datadir}/kde4/services/katepart.desktop
197
198%files -n kwrite
199%{_bindir}/kwrite
200%{_datadir}/kde4/apps/kwrite
201%{_libdir}/libkdeinit4_kwrite.so
202%{_datadir}/applications/kde4/kwrite.desktop
203%{_datadir}/doc/HTML/en/kwrite/
204
205%changelog
206* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
207- new upstream release
208
209* Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
210- new upstream release
211
212* Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
213- new upstream release
214
215* Mon Aug  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
216- Initial build for Vine Linux
217
218* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
219- 4.7.0
220
221* Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
222- first try
223
Note: See TracBrowser for help on using the repository browser.