source: projects/specs/trunk/k/kate/kate-vl.spec @ 5323

Revision 5323, 5.8 KB checked in by inagaki, 12 years ago (diff)

update: PyKDE4, kate, kdebase-workspace, shared-desktop-ontologies

Line 
1Name:    kate
2Summary: Advanced Text Editor
3Summary(ja): 高機能なテキストエディタ
4Version: 4.7.4
5Release: 1%{?_dist_release}
6
7# kwrite LGPLv2+
8# kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
9# ktexteditor: LGPLv2
10# katepart: LGPLv2
11License: LGPLv2 and LGPLv2+ and GPLv2+
12Group:   Applications/Editors
13URL:     https://projects.kde.org/projects/kde/kdebase/kate
14
15Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}
18BuildRequires: desktop-file-utils
19BuildRequires: kdelibs4-devel >= %{version}
20BuildRequires: soprano-devel
21
22Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
23Requires: %{name}-part = %{version}-%{release}
24Requires: %{name}-libs = %{version}-%{release}
25
26%description
27%{summary}.
28
29%package devel
30Summary:  Development files for %{name}
31Summary(ja): %{name} の開発用ファイル
32Group:    Development/Libraries
33Requires: %{name}-libs = %{version}-%{release}
34Requires: kdelibs4-devel
35
36%description devel
37%{summary}.
38
39%package libs
40Summary:  Runtime files for %{name}
41Summary(ja): %{name} のランタイムライブラリ
42Group:    System Environment/Libraries
43# when split occurred
44Conflicts: kdesdk4-libs < 4.6.95-10
45#Requires: %{name} = %{version}-%{release}
46
47%description libs
48%{summary}.
49
50%package part
51Summary: Kate kpart plugin
52Summary(ja): Kate kpart プラグイン
53License: LGPLv2
54Group:   Applications/Editors
55# when split occurred
56Conflicts: kdelibs4 < 4.6.95-10
57
58%description part
59%{summary}.
60
61%package -n kwrite
62Summary: Text Editor
63Summary(ja): テキストエディタ
64License: LGPLv2+
65Group:   Applications/Editors
66# when split occurred
67Conflicts: kdebase4 < 4.6.95-10
68Requires: %{name}-part = %{version}-%{release}
69Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
70
71%description -n kwrite
72%{summary}.
73
74
75%prep
76%setup -q
77
78
79%build
80mkdir -p %{_target_platform}
81pushd %{_target_platform}
82unset QTDIR || : ; . /etc/profile.d/qt4.sh
83%cmake \
84    -DCMAKE_BUILD_TYPE=release \
85    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
86    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
87    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
88    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
89    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
90    ..
91popd
92
93make %{?_smp_mflags} -C %{_target_platform}
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
100
101# move devel symlinks (that would otherwise conflict with kdelibs3-devel)
102mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
103pushd $RPM_BUILD_ROOT%{_libdir}
104for i in lib*.so
105do
106    case "$i" in
107        libkate*interfaces.so)
108            linktarget=`readlink "$i"`
109            rm -f "$i"
110            ln -sf "../../$linktarget" "kde4/devel/$i"
111            ;;
112    esac
113done
114popd
115
116## unpackaged files
117# playground artsticomment -devel bits
118rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
119rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
120
121
122%check
123for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
124  desktop-file-validate $f
125done
126
127
128%post
129touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
130
131%posttrans
132gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
133update-mime-database %{_datadir}/mime >& /dev/null
134
135%postun
136if [ $1 -eq 0 ] ; then
137    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
138    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
139    update-mime-database %{_datadir}/mime >& /dev/null
140fi
141
142%post part -p /sbin/ldconfig
143%postun part -p /sbin/ldconfig
144
145
146%files
147%doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/NEWS kate/README kate/TODO
148%{_bindir}/kate
149%{_libdir}/libkdeinit4_kate.so
150%{_datadir}/applications/kde4/kate.desktop
151%{_datadir}/kde4/apps/kate/
152%{_datadir}/kde4/apps/katexmltools/
153%{_datadir}/kde4/apps/kconf_update/kate*.upd
154%{_datadir}/icons/hicolor/*/*/*
155%{_mandir}/man1/kate.1.gz
156%{_datadir}/config/katerc
157%{_datadir}/config/katefiletemplates.knsrc
158%{_datadir}/kde4/services/kate*.desktop
159%{_libdir}/kde4/kate*plugin.so
160%{_libdir}/kde4/katefiletemplates.so
161%{_datadir}/kde4/apps/katepart/
162%{_datadir}/kde4/apps/ktexteditor_*/
163%{_datadir}/kde4/services/ktexteditor_*.desktop
164%{_libdir}/kde4/ktexteditor_*.so
165%{_datadir}/kde4/services/plasma-applet-katesession.desktop
166%{_datadir}/kde4/servicetypes/kateplugin.desktop
167%{_libdir}/kde4/plasma_applet_katesession.so
168%{_libdir}/kde4/kate_kttsd.so
169# snippets plugin
170%{_bindir}/ktesnippets_editor
171%{_datadir}/applications/kde4/ktesnippets_editor.desktop
172%{_datadir}/config/ktexteditor_codesnippets_core.knsrc
173# these should *probably* be moved to hicolor -- rex
174%{_datadir}/icons/oxygen/*/actions/*
175%{_datadir}/mime/packages/ktesnippets.xml
176%{_datadir}/doc/HTML/en/kate/
177
178%files libs
179%{_libdir}/libkateinterfaces.so.4*
180%{_libdir}/libktexteditor_codesnippets_core.so.0*
181
182%files devel
183%{_libdir}/kde4/devel/libkateinterfaces.so
184%{_libdir}/kde4/devel/libkatepartinterfaces.so
185%{_libdir}/libktexteditor_codesnippets_core.so
186%{_includedir}/kde4/kate_export.h
187%{_includedir}/kde4/kate/
188%{_includedir}/kde4/ktexteditor_codesnippets_core/
189
190%files part
191%doc part/AUTHORS part/ChangeLog part/COPYING.LIB
192%doc part/INDENTATION part/NEWS part/README* part/TODO*
193%{_libdir}/kde4/katepart.so
194%{_libdir}/libkatepartinterfaces.so.4*
195%{_datadir}/config/katemoderc
196%{_datadir}/config/katepartpluginsrc
197%{_datadir}/kde4/services/katepart.desktop
198
199%files -n kwrite
200%{_bindir}/kwrite
201%{_datadir}/kde4/apps/kwrite
202%{_libdir}/libkdeinit4_kwrite.so
203%{_datadir}/applications/kde4/kwrite.desktop
204%{_datadir}/doc/HTML/en/kwrite/
205
206%changelog
207* Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
208- new upstream release
209
210* Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
211- new upstream release
212
213* Mon Aug  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
214- Initial build for Vine Linux
215
216* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
217- 4.7.0
218
219* Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
220- first try
221
Note: See TracBrowser for help on using the repository browser.