source: projects/specs/trunk/k/kate/kate-vl.spec @ 10570

Revision 10570, 7.2 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:    kate
2Summary: Advanced Text Editor
3Summary(ja): 高機能なテキストエディタ
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7# kwrite LGPLv2+
8# kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
9# ktexteditor: LGPLv2
10# katepart: LGPLv2
11License: LGPLv2 and LGPLv2+ and GPLv2+
12Group:   Applications/Editors
13URL:     https://projects.kde.org/projects/kde/kdebase/kate
14
15Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}
18BuildRequires: desktop-file-utils
19BuildRequires: kdelibs-devel >= %{version}
20BuildRequires: kactivities-devel
21BuildRequires: soprano-devel
22BuildRequires: sip-devel
23BuildRequires: python-devel
24BuildRequires: PyQt4-devel
25BuildRequires: PyKDE4-devel
26BuildRequires: qjson-devel
27
28Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
29Requires: %{name}-part = %{version}-%{release}
30Requires: %{name}-libs = %{version}-%{release}
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36%{summary}.
37
38%package devel
39Summary:  Development files for %{name}
40Summary(ja): %{name} の開発用ファイル
41Group:    Development/Libraries
42Requires: %{name}-libs = %{version}-%{release}
43Requires: kdelibs-devel
44
45%description devel
46%{summary}.
47
48%package libs
49Summary:  Runtime files for %{name}
50Summary(ja): %{name} のランタイムライブラリ
51Group:    System Environment/Libraries
52# when split occurred
53Conflicts: kdesdk4-libs < 4.6.95-10
54#Requires: %{name} = %{version}-%{release}
55
56%description libs
57%{summary}.
58
59%package part
60Summary: Kate kpart plugin
61Summary(ja): Kate kpart プラグイン
62License: LGPLv2
63Group:   Applications/Editors
64# when split occurred
65Conflicts: kdelibs4 < 4.6.95-10
66
67%description part
68%{summary}.
69
70%package -n kwrite
71Summary: Text Editor
72Summary(ja): テキストエディタ
73License: LGPLv2+
74Group:   Applications/Editors
75# when split occurred
76Conflicts: kdebase4 < 4.6.95-10
77Requires: %{name}-part = %{version}-%{release}
78Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
79
80%description -n kwrite
81%{summary}.
82
83%package pate
84Summary: Kate python plugin
85Summary(ja): Kate python プラグイン
86License: LGPLv2
87Group:   System Environment/Libraries
88
89%description pate
90%{summary}.
91
92%prep
93%setup -q
94
95
96%build
97mkdir -p %{_target_platform}
98pushd %{_target_platform}
99%cmake \
100    -DCMAKE_BUILD_TYPE=release \
101    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
102    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
103    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
104    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
105    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
106    ..
107popd
108
109make %{?_smp_mflags} -C %{_target_platform}
110
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
116
117# move devel symlinks (that would otherwise conflict with kdelibs3-devel)
118mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
119pushd $RPM_BUILD_ROOT%{_libdir}
120for i in lib*.so
121do
122    case "$i" in
123        libkate*interfaces.so)
124            linktarget=`readlink "$i"`
125            rm -f "$i"
126            ln -sf "../../$linktarget" "kde4/devel/$i"
127            ;;
128    esac
129done
130popd
131
132## unpackaged files
133# playground artsticomment -devel bits
134rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
135rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
136
137
138%check
139for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
140  desktop-file-validate $f
141done
142
143
144%post
145touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
146
147%posttrans
148gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
149update-mime-database %{_datadir}/mime >& /dev/null
150
151%postun
152if [ $1 -eq 0 ] ; then
153    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
154    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
155    update-mime-database %{_datadir}/mime >& /dev/null
156fi
157
158%post part -p /sbin/ldconfig
159%postun part -p /sbin/ldconfig
160
161
162%files
163%doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/README kate/TODO
164%{_bindir}/kate
165%{_libdir}/libkdeinit4_kate.so
166%{_datadir}/applications/kde4/kate.desktop
167%{_datadir}/kde4/apps/kate/
168%{_datadir}/kde4/apps/katexmltools/
169%{_datadir}/kde4/apps/kconf_update/kate*.upd
170%{_datadir}/icons/hicolor/*/*/*
171%{_mandir}/man1/kate.1.gz
172%{_datadir}/config/katerc
173%{_datadir}/kde4/services/kate*.desktop
174%{_libdir}/kde4/kate*plugin.so
175%{_libdir}/kde4/katefiletemplates.so
176%{_datadir}/kde4/apps/katepart/
177%{_datadir}/kde4/apps/ktexteditor_*/
178%{_datadir}/kde4/services/ktexteditor_*.desktop
179%{_libdir}/kde4/ktexteditor_*.so
180%{_datadir}/kde4/services/plasma-applet-katesession.desktop
181%{_datadir}/kde4/servicetypes/kateplugin.desktop
182%{_libdir}/kde4/plasma_applet_katesession.so
183%{_libdir}/kde4/kate_kttsd.so
184%{_datadir}/config/ktexteditor_codesnippets_core.knsrc
185# these should *probably* be moved to hicolor -- rex
186%{_datadir}/doc/HTML/en/kate/
187
188%files libs
189%{_libdir}/libkateinterfaces.so.4*
190%{_libdir}/libkatepartinterfaces.so.4*
191
192%files devel
193%{_libdir}/kde4/devel/libkateinterfaces.so
194%{_libdir}/kde4/devel/libkatepartinterfaces.so
195%{_includedir}/kde4/kate_export.h
196%{_includedir}/kde4/kate/
197
198%files part
199%doc part/AUTHORS part/ChangeLog part/COPYING.LIB
200%doc part/INDENTATION part/NEWS part/README* part/TODO*
201%{_libdir}/kde4/katepart.so
202%{_libdir}/libkatepartinterfaces.so.4*
203%{_datadir}/config/katemoderc
204%{_datadir}/kde4/services/katepart.desktop
205
206%files -n kwrite
207%{_bindir}/kwrite
208%{_datadir}/kde4/apps/kwrite
209%{_libdir}/libkdeinit4_kwrite.so
210%{_datadir}/applications/kde4/kwrite.desktop
211%{_datadir}/kde4/servicetypes/katepythonplugin.desktop
212%{_datadir}/doc/HTML/en/kwrite/
213
214%files pate
215%{python_sitearch}/PyKate4
216%{_datadir}/config/kateschemarc
217%{_datadir}/config/katesyntaxhighlightingrc
218%{_datadir}/kde4/services/pate.desktop
219
220
221%changelog
222* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
223- rebuild with gcc-5.4.0
224
225* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
226- new upstream release
227
228* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
229- new upstream release
230
231* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
232- new upstream release
233
234* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
235- new upstream release
236
237* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
238- new upstream release
239
240* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
241- new upstream release
242- add BuildRequires: kactivities-devel, sip-devel, python-devel, PyQt4-devel, PyKDE4-devel, qjson-devel
243- create %%{name}-pate subpackage
244
245* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
246- new upstream release
247
248* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
249- new upstream release
250
251* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
252- new upstream release
253
254* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
255- new upstream release
256
257* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
258- new upstream release
259
260* Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
261- new upstream release
262
263* Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
264- new upstream release
265
266* Mon Aug  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
267- Initial build for Vine Linux
268
269* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
270- 4.7.0
271
272* Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
273- first try
274
Note: See TracBrowser for help on using the repository browser.