source: projects/specs/trunk/k/kalzium/kalzium-vl.spec @ 10568

Revision 10568, 4.8 KB checked in by Takemikaduchi, 8 years ago (diff)

grantlee: update to 0.5.1
others: rebuils with gcc-5.4.0

Line 
1Name: kalzium
2Summary: Periodic table and chemistry tools for KDE
3Version: 4.14.3
4Release: 2%{?_dist_release}
5
6License: GPLv2+
7Group: Applications/Edutainment
8URL: http://edu.kde.org/kalzium/
9
10Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
11
12Patch0: kalzium-4.14.3-cmake.patch
13
14## upstream patches
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: avogadro-devel
18BuildRequires: desktop-file-utils
19BuildRequires: eigen2-devel
20BuildRequires: kdelibs4-devel >= %{version}
21BuildRequires: ocaml
22BuildRequires: openbabel-devel >= 2.2.0
23BuildRequires: soprano-devel
24BuildRequires: python-devel
25
26Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
27
28Conflicts: kdeedu4 < 4.6.50
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34Kalzium is a full-featured chemistry application for KDE, including
35a Periodic Table of Elements, chemical reference, chemical equation
36solver, and 3D molecule viewer.
37
38This package is part of the KDE education module.
39
40%package libs
41Summary: Runtime libraries for %{name}
42Summary(ja): %{name} のランタイムライブラリ
43Group:   System Environment/Libraries
44Conflicts: kdeedu4-libs < 4.6.50
45
46%description libs
47%{summary}.
48
49%package devel
50Summary: Development files for %{name}
51Summary(ja): %{name} の開発用ファイル
52Group: Development/Libraries
53Requires: %{name}-libs = %{version}-%{release}
54Conflicts: kdeedu4-devel < 4.6.50
55
56%description devel
57Header files for developing applications using %{name}.
58
59
60%prep
61%setup -q
62%patch0 -p1 -b .cmake
63
64%build
65mkdir -p %{_target_platform}
66pushd %{_target_platform}
67%cmake \
68    -DCMAKE_BUILD_TYPE=release \
69    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
70    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
71    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
72    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
73    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
74    ..
75popd
76
77make %{?_smp_mflags} -C %{_target_platform}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%check
87for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
88    desktop-file-validate $f
89done
90
91
92%post
93touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
94
95%posttrans
96update-desktop-database -q &> /dev/null ||:
97gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
98
99%postun
100if [ $1 -eq 0 ] ; then
101    update-desktop-database -q &> /dev/null ||:
102    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
103    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
104fi
105
106%post libs -p /sbin/ldconfig
107
108%postun libs -p /sbin/ldconfig
109
110
111%files
112%defattr(-,root,root)
113%doc COPYING COPYING.DOC
114%{_bindir}/kalzium
115%{_libdir}/kde4/*.so
116%{_datadir}/appdata/kalzium.appdata.xml
117%{_datadir}/applications/kde4/kalzium_cml.desktop
118%{_datadir}/applications/kde4/kalzium.desktop
119%{_datadir}/config/kalzium.knsrc
120%{_datadir}/config.kcfg/kalzium.kcfg
121%{_datadir}/icons/hicolor/*/*/*
122%{_datadir}/kde4/apps/desktoptheme/*
123%{_datadir}/kde4/apps/kalzium
124%{_datadir}/kde4/apps/libkdeedu/*
125%{_datadir}/kde4/services/*.desktop
126%{_mandir}/man1/kalzium*
127%doc %{_docdir}/HTML/en/kalzium/
128
129%files libs
130%defattr(-,root,root)
131%{_libdir}/libscience.so.*
132
133%files devel
134%defattr(-,root,root)
135%{_includedir}/kde4/libkdeedu/*.h
136%{_libdir}/libscience.so
137
138
139%changelog
140* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
141- rebuild with gcc-5.4.0
142- add Patch0 (kalzium-4.14.3-cmake.patch)
143
144* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
145- new upstream release
146
147* Wed May 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
148- new upstream release
149
150* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
151- new upstream release
152
153* Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
154- new upstream release
155
156* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-2
157- rebuild with libboost-1.54.0
158
159* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
160- new upstream release
161
162* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
163- new upstream release
164
165* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
166- new upstream release
167
168* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
169- new upstream release
170
171* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
172- new upstream release
173
174* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
175- new upstream release
176
177* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
178- new upstream release
179
180* Sun Feb 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-3
181- rebuild with python-2.7.2
182- add BuildRequires: python-devel
183
184* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-2
185- rebuild with glew-1.7.0
186
187* Thu Sep  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
188- split from kdeedu
189
Note: See TracBrowser for help on using the repository browser.