source: projects/specs/trunk/k/kakasi/kakasi-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tkver 2.04
2%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
3
4Summary: Filter to convert Kanji to Hiragana, Katakana or Romaji
5Summary(ja): 漢字かなまじり文をひらがな文やローマ字文に変換するフィルタ
6Name: kakasi
7Version: 2.3.4
8Release: 2%{?_dist_release}
9Group: Applications/Text
10License: GPLv2+
11URL: http://kakasi.namazu.org/
12Source: ftp://kakasi.namazu.org/pub/kakasi/kakasi-%{version}.tar.gz
13Source1: http://search.cpan.org/CPAN/authors/id/D/DA/DANKOGAI/Text-Kakasi-%{tkver}.tar.gz
14Patch0: kakasi-2.3.4-strdup.patch
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: perl >= 1:5.10.0
18
19Provides: perl-Text-Kakasi = %{tkver}
20
21
22%description
23KAKASI is the language processing filter to convert Kanji characters
24to Hiragana, Katakana or Romaji(1) and may be helpful to read Japanese
25documents. perl module for kakasi is also involved.
26
27%description -l ja
28KAKASI は漢字かなまじり文をひらがな文やローマ字文に変換することを
29目的として作成したプログラムと辞書の総称です。
30このパッケージには、kakasi を perlで用いるモジュール Text-Kakasi-%{tkver}
31も含んでいます。
32
33
34%package devel
35Summary: Libraries and include files of KAKASI
36Group: Development/Libraries
37Summary(ja): KAKASIのライブラリとヘッダファイル
38
39%description devel
40Libraries and include files of KAKASI
41
42%description devel -l ja
43KAKASI のライブラリとヘッダファイルです
44
45%prep
46%setup -q -a 1
47find . -type d -name CVS | xargs -r rm -frv
48
49%patch0 -p1 -b .strdup
50
51%build
52%configure --disable-static
53make
54
55# build Text-Kakasi
56cd Text-Kakasi-%{tkver}
57
58CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
59make INC=-I../lib/ LDFLAGS=-L../lib/
60make test
61cd -
62
63%install
64rm -rf %{buildroot}
65%makeinstall
66
67# install manual page
68mkdir -p %{buildroot}%{_mandir}/ja/man1
69install -p -m 644 doc/kakasi.1 %{buildroot}%{_mandir}/ja/man1
70
71# install Text-Kakasi
72cd Text-Kakasi-%{tkver}
73make DESTDIR=$RPM_BUILD_ROOT install
74find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
75  -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
76
77rm -rf ../Text-Kakasi
78mkdir -p ../Text-Kakasi
79cp -a README* COPYING* MANIFEST ../Text-Kakasi
80cd -
81
82# removed unpackaed files
83rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
84
85%clean
86rm -rf %{buildroot}
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%files
93%defattr(-,root,root)
94%doc doc Text-Kakasi
95%doc README* AUTHORS COPYING ChangeLog TODO NEWS
96%{_bindir}/*
97%{_libdir}/libkakasi.so.*
98%dir %{_datadir}/kakasi
99%{_datadir}/kakasi/*
100%{perl_vendorarch}/Text/Kakasi.pm
101%{perl_vendorarch}/Text/Kakasi/JP.pod
102%{perl_vendorarch}/auto/Text/Kakasi
103%{_mandir}/man3/*
104%{_mandir}/ja/man1/kakasi.1*
105
106%files devel
107%defattr(-,root,root)
108%{_includedir}/*
109%{_libdir}/libkakasi.so
110
111
112%changelog
113* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.4-2
114- spec in utf-8
115- remove static library
116
117* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.4-1vl5
118- rebuilt with perl 5.10.0
119- applied new versioning policy
120- removed lib*.la from devel package
121- fixed %%doc section
122- fixed %%changelog typo
123
124* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.4-0vl7
125- add strdup.patch (patch0) to avoid segmentation fault
126
127* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.4-0vl6
128- rebuilt with new toolchains and perl-5.8.6
129- updated Text-Kakasi source and its URL
130- added Provides: perl-Text-Kakasi
131
132* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 2.3.4-0vl5
133- rebuilt on perl-5.8.2
134
135* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 2.3.4-0vl4
136- rebuilt on perl-5.8.1
137
138* Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 2.3.4-0vl3
139- rebuild with perl-5.8.0
140
141* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 2.3.4-0vl2
142- make sure thet libkakasi.{a,la,so} are splitted into devel subpackage
143
144* Fri Sep  7 2001 Jun Nishii <jun@vinelinux.org> - 2.3.4-0vl1
145- ver.up
146- ver.up Text-Kakasi
147
148* Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
149- 2.3.3-0vl4
150- rebuilt with perl-5.6.1
151
152* Wed Jun 13 2001 Jun Nishii <jun@vinelinux.org> 2.3.3-0vl3
153- modify perl version dependency
154
155* Fri May 11 2001 Hiroaki Irokawa <irorin@terra.dti.ne.jp>
156- 2.3.3-0vl2
157- TextKakasi VersionDown(1.05 -> 1.04)
158
159* Mon May  7 2001 Hiroaki Irokawa <irorin@terra.dti.ne.jp>
160- 2.3.3-0vl1
161- update to 2.3.3(TextKakasi 1.04 -> 1.05)
162
163* Sat Jan 13 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
164- 2.3.2-0vl3
165- use better macros, _mandir
166- dont pack CVS directory
167
168* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
169- 2.3.2-0vl2
170- modified %files section to handle compressed man page(s)
171
172* Sat May 27 2000 Jun Nishii <jun@vinelinux.org>
173- 2.3.2-0vl1
174- merge Text Kakasi
175
176* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
177- change group
178- strip bins
179
180* Fri Oct 29 1999 Jun Nishii <jun@flatout.org>
181- updated to 2.3.1
182
183* Thu Oct 28 1999 Jun Nishii <jun@flatout.org>
184- updated to 2.3.0
185- separate devel
186
187* Mon Sep 20 1999 Jun Nishii <jun@flatout.org>
188- added %defattr
189
190* Wed Jul 28 1999 Jun Nishii <jun@flatout.org>
191- rebuild for Vine-1.9
Note: See TracBrowser for help on using the repository browser.