source: projects/specs/trunk/k/k3b/k3b-vl.spec @ 1801

Revision 1801, 7.8 KB checked in by inagaki, 14 years ago (diff)

update: k3b, self-build-k3b-extra

Line 
1Name: k3b
2Summary: CD/DVD/Blu-ray burning application for KDE
3Summary(ja): KDE 向け CD/DVD/Blu-ray 作成アプリケーション
4Version: 2.0.1
5Release: 2%{?_dist_release}
6
7Group: Applications/Archiving
8License: GPLv2+
9URL: http://www.k3b.org/
10
11Source0: http://downloads.sourceforge.net/sourceforge/k3b/k3b-%{version}%{?pre}.tar.bz2
12# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
13Source1: ox32-k3b.png
14Source2: k3brc
15
16ExcludeArch: s390 s390x
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: desktop-file-utils
20BuildRequires: flac-devel
21BuildRequires: gettext
22BuildRequires: kdelibs4-devel
23BuildRequires: kdemultimedia4-devel
24BuildRequires: libdvdread-devel
25BuildRequires: libmpcdec-devel
26BuildRequires: libmusicbrainz-devel
27BuildRequires: libsamplerate-devel
28BuildRequires: libsndfile-devel
29BuildRequires: libvorbis-devel
30BuildRequires: taglib-devel
31# needed by k3bsetup
32BuildRequires: polkit-qt-devel
33
34Requires: cdrecord mkisofs
35Requires: cdrdao
36Requires: dvd+rw-tools
37
38Obsoletes: k3b-i18n
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44K3b is a CD and DVD burning application for Linux systems optimized for KDE.
45It provides a comfortable user interface to perform most
46CD/DVD burning tasks like creating an Audio CD from a set of audio files or copying a CD.
47
48[Notice]
49Please install self-build-k3b-extra package if you want to handle MP3 and WMA files.
50
51%description -l ja
52K3b は、KDE の為に最適化された Linux システム用の CD/DVD 作成アプリケーションです.
53多様なCD/DVDの作成に快適なユーザーインターフェースを提供します.
54また、音楽データや CD の複製等、音楽 CD を簡単に作成できます.
55
56K3b にて MP3/WMA ファイルを扱いたい場合は、self-build-k3b-extra パッケージを
57追加でインストールしてください.
58
59%package libs
60Summary: Runtime libraries for %{name}
61Summary(ja): %{name} のランタイムライブラリ
62Group:   System Environment/Libraries
63Requires: kdelibs4 >= 4.4.0
64
65%description libs
66%{summary}.
67
68%description -l ja libs
69%{summary}.
70
71%package devel
72Summary: Files for the development of applications which will use %{name}
73Summary(ja): %{name} 使用するアプリケーションを開発するためのファイル
74Group: Development/Libraries
75Requires: %{name}-libs = %{version}-%{release}
76Requires: kdelibs4-devel >= 4.4.0
77
78%description devel
79%{summary}.
80
81%description -l ja devel
82%{summary}.
83
84%prep
85%setup -q
86
87%build
88mkdir -p %{_target_platform}
89pushd %{_target_platform}
90unset QTDIR || : ; . /etc/profile.d/qt4.sh
91%{cmake} \
92    -DCMAKE_BUILD_TYPE=release \
93    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
94    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
95    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
96    -DK3B_BUILD_FFMPEG_DECODER_PLUGIN:BOOL=OFF \
97    -DK3B_BUILD_MAD_DECODER_PLUGIN::BOOL=OFF \
98    -DK3B_BUILD_LAME_ENCODER_PLUGIN:BOOL=OFF \
99    ..
100#   -DK3B_BUILD_K3BSETUP:BOOL=OFF \
101popd
102
103make %{?_smp_mflags} -C %{_target_platform}
104
105
106%install
107rm -rf $RPM_BUILD_ROOT
108make install/fast -C %{_target_platform} DESTDIR=$RPM_BUILD_ROOT
109
110%find_lang k3b --with-kde
111%find_lang k3bsetup
112%find_lang kio_videodvd
113%find_lang libk3b
114%find_lang libk3bdevice
115cat k3bsetup.lang >> k3b.lang
116cat kio_videodvd.lang >> libk3b.lang
117cat libk3bdevice.lang >> libk3b.lang
118
119# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
120if [ ! -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png ]; then
121  echo "NOTICE: %{_datadir}/icons/hicolor/32x32/apps/k3b.png missing, borrowing oxygen version"
122  install -pD -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png
123fi
124
125
126%check
127desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/k3b.desktop
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%post
133touch --no-create %{_datadir}/icons/hicolor ||:
134
135%postun
136if [ $1 -eq 0 ] ; then
137    gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
138    update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
139    update-mime-database %{_datadir}/mime &> /dev/null
140fi
141
142%posttrans
143gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
144update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
145update-mime-database %{_datadir}/mime &> /dev/null
146
147%post libs -p /sbin/ldconfig
148
149%postun libs -p /sbin/ldconfig
150
151
152%files -f k3b.lang
153%defattr(-,root,root,755)
154%doc README COPYING COPYING.DOC ChangeLog
155%{_sysconfdir}/dbus-1/system.d/*.conf
156%{_bindir}/k3b
157%{_bindir}/k3bsetup
158%{_libdir}/kde4/*.so
159%{_libexecdir}/kde4/k3bsetuphelper
160%{_datadir}/applications/kde4/k3b.desktop
161%{_datadir}/dbus-1/system-services/*.service
162%{_datadir}/icons/hicolor/*/*/*
163%{_datadir}/kde4/apps/k3b/
164%{_datadir}/kde4/apps/konqsidebartng/virtual_folders/services/*.desktop
165%{_datadir}/kde4/apps/solid/actions/k3b*.desktop
166%{_datadir}/kde4/services/*.desktop
167%{_datadir}/kde4/services/*.protocol
168%{_datadir}/kde4/services/ServiceMenus/k3b*.desktop
169%{_datadir}/kde4/servicetypes/k3b*.desktop
170%{_datadir}/mime/packages/x-k3b.xml
171%{_datadir}/polkit-1/actions/*.policy
172%{_datadir}/sounds/k3b_*
173
174%files libs -f libk3b.lang
175%defattr(-,root,root,-)
176%{_libdir}/libk3bdevice.so.6*
177%{_libdir}/libk3blib.so.6*
178
179%files devel
180%defattr(-,root,root,-)
181%{_includedir}/kde4/k3b*.h
182%{_libdir}/libk3bdevice.so
183%{_libdir}/libk3blib.so
184
185%changelog
186* Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
187- fixed %%build section to remove qt-devel dependency
188
189* Wed Sep  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
190- new upstream release
191
192* Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
193- new upstream release
194- updated build dependencies
195
196* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.0.5-6
197- drop required packages to resolve unmet dependency <BTS:VineLinux:797>
198  - Requires: libstdc++2_10, libstdc++2_10-compat, dvdrecord, libzvt
199  - BuildRequires: libzvt-devel
200
201* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-5
202- changed to Requires: self-build-libmad from libmad
203- changed to BuildRequires: self-build-libmad from libmad-devel
204- added Requires: %{name} = %{version}-%{release} in k3b-i18n subpackage
205
206* Sun Jan 18 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-4
207- removed Release: tag of k3b-i18n subpackage
208
209* Sat Jan 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-3
210- rebuild with libdvdread.so.4 for vl4 <BTS:651>
211- spec in utf-8
212- merged the spec of 1.0.5-1vl4 release:
213  - added --with-lame --with-libdvdread in %%configure options
214  - set --vendor="vine" in desktop-file-install
215
216* Mon Jan 12 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1
217- new upstream release
218- change %{_includedir}/k3b
219- drop {_localedir}/*  (i18n)
220- add devel Package
221
222* Fri Jan 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-2vl5
223- It returned it: %{_libdir}/kde3/*.la
224
225* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1vl5
226- new upstream release.
227- spec in utf-8, and applied vine versioning policy.
228- Remove *.la.
229- specfile updates.
230
231*Tue Dec 26 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.17-0vl1
232-new upstream release
233
234*Sun Jun 18 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl3
235-with-k3bsetup=no option is deleted.
236
237*Sat Apr 15 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl1
238-new upstream release
239-Requires -> sox and libsndfile added
240-BuildPreReq -> sox-devel and libsndfile-devel added
241-with-k3bsetup=no option added
242
243*Sun Apr 9 2006 TOSHI <toshi-52@sa.il24.net> 0.12.14-0vl1
244-new upstream release
245
246*Tue Feb 14 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
247-new upstream release
248-Requires -> Libstdc++2_10 and libstdc++2_10-compat added
249
250*Sat Feb 9 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
251-new upstream release
252-added i18n to spec
253
254*Thu Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.3-0vl1
255-new upstream release
256
257* Thu Jul 12 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.2-0vl1
258-new upstream release
259
260* Thu May 30 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12beta2-0vl1
261-1st Release.
Note: See TracBrowser for help on using the repository browser.