source: projects/specs/trunk/k/k3b/k3b-vl.spec @ 1427

Revision 1427, 7.4 KB checked in by inagaki, 14 years ago (diff)

updated: k3b
NEW: self-build-k3b-extra

Line 
1Name: k3b
2Summary: CD/DVD/Blu-ray burning application for KDE
3Summary(ja): KDE 用の CD/DVD/Blu-ray 作成アプリケーション
4Version: 2.0.0
5Release: 1%{?_dist_release}
6
7Group: Applications/Archiving
8License: GPLv2+
9URL: http://www.k3b.org/
10
11Source0: http://downloads.sourceforge.net/sourceforge/k3b/k3b-%{version}%{?pre}.tar.bz2
12# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
13Source1: ox32-k3b.png
14Source2: k3brc
15
16ExcludeArch: s390 s390x
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: desktop-file-utils
20BuildRequires: flac-devel
21BuildRequires: gettext
22BuildRequires: kdelibs4-devel
23BuildRequires: kdemultimedia4-devel
24BuildRequires: libdvdread-devel
25BuildRequires: libmpcdec-devel
26BuildRequires: libmusicbrainz-devel
27BuildRequires: libsamplerate-devel
28BuildRequires: libsndfile-devel
29BuildRequires: libvorbis-devel
30BuildRequires: taglib-devel
31# needed by k3bsetup
32BuildRequires: polkit-qt-devel
33
34Requires: cdrecord mkisofs
35Requires: cdrdao
36Requires: dvd+rw-tools
37
38Obsoletes: k3b-i18n
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44K3b is a CD and DVD burning application for Linux systems optimized for KDE.
45It provides a comfortable user interface to perform most
46CD/DVD burning tasks like creating an Audio CD from a set of audio files or copying a CD.
47
48[Notice]
49Please install self-build-k3b-extra package if you want to handle MP3 and WMA files.
50
51%description -l ja
52K3b は、KDE の為に最適化された Linux システム用の CD/DVD 作成アプリケーションです.
53多様なCD/DVDの作成に快適なユーザーインターフェースを提供します.
54また、音楽データや CD の複製等、音楽 CD を簡単に作成できます.
55
56K3b にて MP3/WMA ファイルを扱いたい場合は、self-build-k3b-extra パッケージを
57追加でインストールしてください.
58
59%package libs
60Summary: Runtime libraries for %{name}
61Group:   System Environment/Libraries
62Requires: kdelibs4 >= 4.4.0
63
64%description libs
65%{summary}.
66
67%package devel
68Summary: Files for the development of applications which will use %{name}
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71Requires: kdelibs4-devel >= 4.4.0
72
73%description devel
74%{summary}.
75
76
77%prep
78%setup -q
79
80%build
81unset QTDIR || : ; . /etc/profile.d/qt.sh
82
83mkdir -p %{_target_platform}
84pushd %{_target_platform}
85unset QTDIR || : ; . /etc/profile.d/qt4.sh
86%{cmake} \
87    -DCMAKE_BUILD_TYPE=release \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
91    -DK3B_BUILD_FFMPEG_DECODER_PLUGIN:BOOL=OFF \
92    -DK3B_BUILD_MAD_DECODER_PLUGIN::BOOL=OFF \
93    -DK3B_BUILD_LAME_ENCODER_PLUGIN:BOOL=OFF \
94    ..
95popd
96#   -DK3B_BUILD_K3BSETUP:BOOL=OFF \
97
98make %{?_smp_mflags} -C %{_target_platform}
99
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install/fast -C %{_target_platform} DESTDIR=$RPM_BUILD_ROOT
104
105%find_lang k3b --with-kde
106%find_lang k3bsetup
107%find_lang libk3b
108%find_lang libk3bdevice
109cat k3bsetup.lang >> k3b.lang
110cat libk3bdevice.lang >> libk3b.lang
111
112# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
113if [ ! -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png ]; then
114  echo "NOTICE: %{_datadir}/icons/hicolor/32x32/apps/k3b.png missing, borrowing oxygen version"
115  install -pD -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png
116fi
117
118
119%check
120desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/k3b.desktop
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post
126touch --no-create %{_datadir}/icons/hicolor ||:
127
128%postun
129if [ $1 -eq 0 ] ; then
130    gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
131    update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
132    update-mime-database %{_datadir}/mime &> /dev/null
133fi
134
135%posttrans
136gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
137update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
138update-mime-database %{_datadir}/mime &> /dev/null
139
140%post libs -p /sbin/ldconfig
141
142%postun libs -p /sbin/ldconfig
143
144
145%files -f k3b.lang
146%defattr(-,root,root,755)
147%doc README COPYING COPYING.DOC ChangeLog
148%{_sysconfdir}/dbus-1/system.d/*.conf
149%{_bindir}/k3b
150%{_bindir}/k3bsetup
151%{_libdir}/kde4/*.so
152%{_libexecdir}/kde4/k3bsetuphelper
153%{_datadir}/applications/kde4/k3b.desktop
154%{_datadir}/dbus-1/system-services/*.service
155%{_datadir}/icons/hicolor/*/*/*
156%{_datadir}/kde4/apps/k3b/
157%{_datadir}/kde4/apps/konqsidebartng/virtual_folders/services/*.desktop
158%{_datadir}/kde4/apps/solid/actions/k3b*.desktop
159%{_datadir}/kde4/services/*.desktop
160%{_datadir}/kde4/services/*.protocol
161%{_datadir}/kde4/services/ServiceMenus/k3b*.desktop
162%{_datadir}/kde4/servicetypes/k3b*.desktop
163%{_datadir}/mime/packages/x-k3b.xml
164%{_datadir}/polkit-1/actions/*.policy
165%{_datadir}/sounds/k3b_*
166
167%files libs -f libk3b.lang
168%defattr(-,root,root,-)
169%{_libdir}/libk3bdevice.so.6*
170%{_libdir}/libk3blib.so.6*
171
172%files devel
173%defattr(-,root,root,-)
174%{_includedir}/kde4/k3b*.h
175%{_libdir}/libk3bdevice.so
176%{_libdir}/libk3blib.so
177
178%changelog
179* Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
180- new upstream release
181- updated build dependencies
182
183* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.0.5-6
184- drop required packages to resolve unmet dependency <BTS:VineLinux:797>
185  - Requires: libstdc++2_10, libstdc++2_10-compat, dvdrecord, libzvt
186  - BuildRequires: libzvt-devel
187
188* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-5
189- changed to Requires: self-build-libmad from libmad
190- changed to BuildRequires: self-build-libmad from libmad-devel
191- added Requires: %{name} = %{version}-%{release} in k3b-i18n subpackage
192
193* Sun Jan 18 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-4
194- removed Release: tag of k3b-i18n subpackage
195
196* Sat Jan 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-3
197- rebuild with libdvdread.so.4 for vl4 <BTS:651>
198- spec in utf-8
199- merged the spec of 1.0.5-1vl4 release:
200  - added --with-lame --with-libdvdread in %%configure options
201  - set --vendor="vine" in desktop-file-install
202
203* Mon Jan 12 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1
204- new upstream release
205- change %{_includedir}/k3b
206- drop {_localedir}/*  (i18n)
207- add devel Package
208
209* Fri Jan 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-2vl5
210- It returned it: %{_libdir}/kde3/*.la
211
212* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1vl5
213- new upstream release.
214- spec in utf-8, and applied vine versioning policy.
215- Remove *.la.
216- specfile updates.
217
218*Tue Dec 26 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.17-0vl1
219-new upstream release
220
221*Sun Jun 18 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl3
222-with-k3bsetup=no option is deleted.
223
224*Sat Apr 15 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl1
225-new upstream release
226-Requires -> sox and libsndfile added
227-BuildPreReq -> sox-devel and libsndfile-devel added
228-with-k3bsetup=no option added
229
230*Sun Apr 9 2006 TOSHI <toshi-52@sa.il24.net> 0.12.14-0vl1
231-new upstream release
232
233*Tue Feb 14 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
234-new upstream release
235-Requires -> Libstdc++2_10 and libstdc++2_10-compat added
236
237*Sat Feb 9 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
238-new upstream release
239-added i18n to spec
240
241*Thu Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.3-0vl1
242-new upstream release
243
244* Thu Jul 12 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.2-0vl1
245-new upstream release
246
247* Thu May 30 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12beta2-0vl1
248-1st Release.
Note: See TracBrowser for help on using the repository browser.