source: projects/specs/trunk/k/k3b/k3b-vl.spec @ 1795

Revision 1795, 7.7 KB checked in by inagaki, 14 years ago (diff)

update: k3b, self-build-k3b-extra

Line 
1Name: k3b
2Summary: CD/DVD/Blu-ray burning application for KDE
3Summary(ja): KDE 用の CD/DVD/Blu-ray 作成アプリケーション
4Version: 2.0.1
5Release: 1%{?_dist_release}
6
7Group: Applications/Archiving
8License: GPLv2+
9URL: http://www.k3b.org/
10
11Source0: http://downloads.sourceforge.net/sourceforge/k3b/k3b-%{version}%{?pre}.tar.bz2
12# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
13Source1: ox32-k3b.png
14Source2: k3brc
15
16ExcludeArch: s390 s390x
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: desktop-file-utils
20BuildRequires: flac-devel
21BuildRequires: gettext
22BuildRequires: kdelibs4-devel
23BuildRequires: kdemultimedia4-devel
24BuildRequires: libdvdread-devel
25BuildRequires: libmpcdec-devel
26BuildRequires: libmusicbrainz-devel
27BuildRequires: libsamplerate-devel
28BuildRequires: libsndfile-devel
29BuildRequires: libvorbis-devel
30BuildRequires: taglib-devel
31# needed by k3bsetup
32BuildRequires: polkit-qt-devel
33
34Requires: cdrecord mkisofs
35Requires: cdrdao
36Requires: dvd+rw-tools
37
38Obsoletes: k3b-i18n
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44K3b is a CD and DVD burning application for Linux systems optimized for KDE.
45It provides a comfortable user interface to perform most
46CD/DVD burning tasks like creating an Audio CD from a set of audio files or copying a CD.
47
48[Notice]
49Please install self-build-k3b-extra package if you want to handle MP3 and WMA files.
50
51%description -l ja
52K3b は、KDE の為に最適化された Linux システム用の CD/DVD 作成アプリケーションです.
53多様なCD/DVDの作成に快適なユーザーインターフェースを提供します.
54また、音楽データや CD の複製等、音楽 CD を簡単に作成できます.
55
56K3b にて MP3/WMA ファイルを扱いたい場合は、self-build-k3b-extra パッケージを
57追加でインストールしてください.
58
59%package libs
60Summary: Runtime libraries for %{name}
61Summary(ja): %{name} のランタイムライブラリ
62Group:   System Environment/Libraries
63Requires: kdelibs4 >= 4.4.0
64
65%description libs
66%{summary}.
67
68%package devel
69Summary: Files for the development of applications which will use %{name}
70Summary(ja): %{name} 使用するアプリケーションを開発するためのファイル
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73Requires: kdelibs4-devel >= 4.4.0
74
75%description devel
76%{summary}.
77
78
79%prep
80%setup -q
81
82%build
83unset QTDIR || : ; . /etc/profile.d/qt.sh
84
85mkdir -p %{_target_platform}
86pushd %{_target_platform}
87unset QTDIR || : ; . /etc/profile.d/qt4.sh
88%{cmake} \
89    -DCMAKE_BUILD_TYPE=release \
90    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
91    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
92    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
93    -DK3B_BUILD_FFMPEG_DECODER_PLUGIN:BOOL=OFF \
94    -DK3B_BUILD_MAD_DECODER_PLUGIN::BOOL=OFF \
95    -DK3B_BUILD_LAME_ENCODER_PLUGIN:BOOL=OFF \
96    ..
97popd
98#   -DK3B_BUILD_K3BSETUP:BOOL=OFF \
99
100make %{?_smp_mflags} -C %{_target_platform}
101
102
103%install
104rm -rf $RPM_BUILD_ROOT
105make install/fast -C %{_target_platform} DESTDIR=$RPM_BUILD_ROOT
106
107%find_lang k3b --with-kde
108%find_lang k3bsetup
109%find_lang kio_videodvd
110%find_lang libk3b
111%find_lang libk3bdevice
112cat k3bsetup.lang >> k3b.lang
113cat kio_videodvd.lang >> libk3b.lang
114cat libk3bdevice.lang >> libk3b.lang
115
116# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
117if [ ! -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png ]; then
118  echo "NOTICE: %{_datadir}/icons/hicolor/32x32/apps/k3b.png missing, borrowing oxygen version"
119  install -pD -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png
120fi
121
122
123%check
124desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/k3b.desktop
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130touch --no-create %{_datadir}/icons/hicolor ||:
131
132%postun
133if [ $1 -eq 0 ] ; then
134    gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
135    update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
136    update-mime-database %{_datadir}/mime &> /dev/null
137fi
138
139%posttrans
140gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
141update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
142update-mime-database %{_datadir}/mime &> /dev/null
143
144%post libs -p /sbin/ldconfig
145
146%postun libs -p /sbin/ldconfig
147
148
149%files -f k3b.lang
150%defattr(-,root,root,755)
151%doc README COPYING COPYING.DOC ChangeLog
152%{_sysconfdir}/dbus-1/system.d/*.conf
153%{_bindir}/k3b
154%{_bindir}/k3bsetup
155%{_libdir}/kde4/*.so
156%{_libexecdir}/kde4/k3bsetuphelper
157%{_datadir}/applications/kde4/k3b.desktop
158%{_datadir}/dbus-1/system-services/*.service
159%{_datadir}/icons/hicolor/*/*/*
160%{_datadir}/kde4/apps/k3b/
161%{_datadir}/kde4/apps/konqsidebartng/virtual_folders/services/*.desktop
162%{_datadir}/kde4/apps/solid/actions/k3b*.desktop
163%{_datadir}/kde4/services/*.desktop
164%{_datadir}/kde4/services/*.protocol
165%{_datadir}/kde4/services/ServiceMenus/k3b*.desktop
166%{_datadir}/kde4/servicetypes/k3b*.desktop
167%{_datadir}/mime/packages/x-k3b.xml
168%{_datadir}/polkit-1/actions/*.policy
169%{_datadir}/sounds/k3b_*
170
171%files libs -f libk3b.lang
172%defattr(-,root,root,-)
173%{_libdir}/libk3bdevice.so.6*
174%{_libdir}/libk3blib.so.6*
175
176%files devel
177%defattr(-,root,root,-)
178%{_includedir}/kde4/k3b*.h
179%{_libdir}/libk3bdevice.so
180%{_libdir}/libk3blib.so
181
182%changelog
183* Wed Sep  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
184- new upstream release
185
186* Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
187- new upstream release
188- updated build dependencies
189
190* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.0.5-6
191- drop required packages to resolve unmet dependency <BTS:VineLinux:797>
192  - Requires: libstdc++2_10, libstdc++2_10-compat, dvdrecord, libzvt
193  - BuildRequires: libzvt-devel
194
195* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-5
196- changed to Requires: self-build-libmad from libmad
197- changed to BuildRequires: self-build-libmad from libmad-devel
198- added Requires: %{name} = %{version}-%{release} in k3b-i18n subpackage
199
200* Sun Jan 18 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-4
201- removed Release: tag of k3b-i18n subpackage
202
203* Sat Jan 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-3
204- rebuild with libdvdread.so.4 for vl4 <BTS:651>
205- spec in utf-8
206- merged the spec of 1.0.5-1vl4 release:
207  - added --with-lame --with-libdvdread in %%configure options
208  - set --vendor="vine" in desktop-file-install
209
210* Mon Jan 12 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1
211- new upstream release
212- change %{_includedir}/k3b
213- drop {_localedir}/*  (i18n)
214- add devel Package
215
216* Fri Jan 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-2vl5
217- It returned it: %{_libdir}/kde3/*.la
218
219* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1vl5
220- new upstream release.
221- spec in utf-8, and applied vine versioning policy.
222- Remove *.la.
223- specfile updates.
224
225*Tue Dec 26 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.17-0vl1
226-new upstream release
227
228*Sun Jun 18 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl3
229-with-k3bsetup=no option is deleted.
230
231*Sat Apr 15 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl1
232-new upstream release
233-Requires -> sox and libsndfile added
234-BuildPreReq -> sox-devel and libsndfile-devel added
235-with-k3bsetup=no option added
236
237*Sun Apr 9 2006 TOSHI <toshi-52@sa.il24.net> 0.12.14-0vl1
238-new upstream release
239
240*Tue Feb 14 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
241-new upstream release
242-Requires -> Libstdc++2_10 and libstdc++2_10-compat added
243
244*Sat Feb 9 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
245-new upstream release
246-added i18n to spec
247
248*Thu Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.3-0vl1
249-new upstream release
250
251* Thu Jul 12 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.2-0vl1
252-new upstream release
253
254* Thu May 30 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12beta2-0vl1
255-1st Release.
Note: See TracBrowser for help on using the repository browser.