source: projects/specs/trunk/j/julia/julia-vl.spec @ 12031

Revision 12031, 7.2 KB checked in by ara_t, 5 years ago (diff)

julia: rebuild with gfortran-8.2.0

Line 
1%define pkg_name    julia
2%define pkg_version 1.0.3
3%define pkg_release 2%{?_dist_release}
4
5Summary: High-level, high-performance dynamic programming language for numerical computing
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: MIT, BSD and GPLv3
11# julia, utf8proc, libwhich: MIT
12# libunwind, libuv, openblas, llvm: BSD
13# patchelf, mpfr: GPLv3
14Group:   Applications/Edutainment
15URL:     https://julialang.org/
16
17Source0: https://github.com/JuliaLang/julia/releases/download/v%{version}/%{name}-%{version}.tar.gz
18
19Source11: libunwind-1.1-julia2.tar.gz
20Source12: libuv-ed3700c849289ed01fe04273a7bf865340b2bd7e.tar.gz
21Source13: patchelf-0.9.tar.gz
22Source14: utf8proc-97ef668b312b96382714dbb8eaac4affce0816e6.tar.gz
23Source15: llvm-6.0.0.src.tar.xz
24Source16: openblas-e8a68ef261a33568b0f0cf53e0e2287e9f12e69e.tar.gz
25Source17: libwhich-81e9723c0273d78493dc8c8ed570f68d9ce7e89e.tar.gz
26Source18: mpfr-4.0.1.tar.bz2
27
28
29# # Patches from Fedora srpm
30# Patch0: julia_unwind_version.patch
31
32# # https://github.com/JuliaLang/julia/pull/22603
33# # Remove ieee754_rem_pio2 in favor of a rem_pio2_kernel written in Julia.
34# Patch1: julia-0.6.3-issue22603.patch
35
36# # # not make debug
37Patch11: julia-Makefile_release.patch
38
39# ## Patches for make test
40# # Avoid test error
41# Patch21: julia-0.6.3-skip_libgit2_test.patch
42Patch21: julia-skip-LibGit2-libgit2.patch
43
44# # https://github.com/JuliaLang/julia/pull/23124
45# # Bump tolerance a bit in stressful test of eigs on matrix
46# # with many repeated eigenvalues.
47# Patch22: julia-0.6.3-issue23124.patch
48
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50
51BuildRequires: cmake
52BuildRequires: gcc-gfortran
53BuildRequires: gmp-devel
54BuildRequires: openspecfun-devel
55BuildRequires: openlibm-devel
56BuildRequires: blas lapack suitesparse-devel
57BuildRequires: dSFMT-devel
58BuildRequires: pcre2-devel
59BuildRequires: curl-devel
60BuildRequires: libssh2-devel
61BuildRequires: libgit2-devel
62BuildRequires: mbedtls-devel
63BuildRequires: libatomic
64BuildRequires: desktop-file-utils
65
66Requires: openlibm
67Requires: blas lapack suitesparse
68Requires: dSFMT
69Requires: pcre2
70Requires: libssh2 mbedtls
71Requires: libgit2
72Requires: libatomic
73
74
75Vendor: Project Vine
76Distribution: Vine Linux
77Packager: ara_t
78
79
80%description
81Julia is a high-level, high-performance dynamic programming language
82for numerical computing. It provides a sophisticated compiler,
83distributed parallel execution, numerical accuracy, and an extensive
84mathematical function library. Julia’s Base library, largely written
85in Julia itself, also integrates mature, best-of-breed open source C
86and Fortran libraries for linear algebra, random number generation,
87signal processing, and string processing. In addition, the Julia developer
88community is contributing a number of external packages through Julia's
89built-in package manager at a rapid pace.
90IJulia, a collaboration between the Jupyter and Julia communities,
91provides a powerful browser-based graphical notebook interface to Julia.
92
93Julia programs are organized around multiple dispatch; by defining functions
94and overloading them for different combinations of argument types,
95which can also be user-defined. For a more in-depth discussion of the
96rationale and advantages of Julia over other systems, see the following
97highlights or read the introduction in the online manual.
98#'
99
100
101%prep
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%setup -q
104
105# %patch0 -p1 -b .unwind
106# %patch1 -p1 -b.ieee754_rem_pio2
107
108%patch11 -b .release
109%patch21 -b .skip_test
110# %patch22 -p1 -b .tolerance
111
112cat > Make.user <<EOF
113# Link to the LLVM shared library
114USE_LLVM_SHLIB=0
115
116# Link to the LLVM shared library
117USE_SYSTEM_LLVM=0
118USE_SYSTEM_LIBUNWIND=0
119USE_SYSTEM_LIBUV=0
120USE_SYSTEM_LIBM=0
121USE_SYSTEM_OPENLIBM=1
122UNTRUSTED_SYSTEM_LIBM=0
123USE_SYSTEM_OPENSPECFUN=1
124
125USE_SYSTEM_PCRE=1
126USE_SYSTEM_DSFMT=1
127USE_SYSTEM_GMP=1
128USE_SYSTEM_MPFR=0
129USE_SYSTEM_SUITESPARSE=1
130
131USE_SYSTEM_BLAS=0
132USE_SYSTEM_LAPACK=0
133
134USE_SYSTEM_LIBSSH2=1
135USE_SYSTEM_CURL=1
136USE_SYSTEM_LIBGIT2=1
137USE_SYSTEM_MBEDTLS=1
138EOF
139
140%{__mkdir_p} deps/srccache
141%{__cp} \
142 %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} \
143 %{SOURCE16} %{SOURCE17} %{SOURCE18} \
144 deps/srccache
145
146# About build, build_libdir and build_bindir
147# see https://github.com/JuliaLang/julia/issues/5063#issuecomment-32628111
148%global julia_builddir %{_builddir}/%{name}-%{version}/build
149%global installopts prefix=%{_prefix} bindir=%{_bindir} libdir=%{_libdir} libexecdir=%{_libexecdir} datarootdir=%{_datarootdir} includedir=%{_includedir} sysconfdir=%{_sysconfdir} build_prefix=%{julia_builddir} build_bindir=%{julia_builddir}%{_bindir} build_libdir=%{julia_builddir}%{_libdir} build_private_libdir=%{julia_builddir}%{_libdir}/julia build_libexecdir=%{julia_builddir}%{_libexecdir} build_datarootdir=%{julia_builddir}%{_datarootdir} build_includedir=%{julia_builddir}%{_includedir} build_sysconfdir=%{julia_builddir}%{_sysconfdir}
150
151# Required so that the image is not optimized for the build CPU
152# # (i386 does not work yet: https://github.com/JuliaLang/julia/issues/7185)
153# # Without specifying MARCH, the Julia system image would only work on native CPU
154# using openblas
155%ifarch %{ix86}
156%global march pentium4
157%endif
158%ifarch x86_64
159%global march x86-64
160%endif
161
162%global commonopts MARCH=%{march} %{installopts}
163
164%build
165%{__make} %{?_smp_mflags} %{commonopts}
166
167# to avoid making documents
168%{__mkdir_p} doc/_build/html/en
169touch doc/_build/html/en/index.html
170
171%install
172%{__make} %{commonopts} install DESTDIR=${RPM_BUILD_ROOT}
173
174# remove unnecessary sofiles
175pushd ${RPM_BUILD_ROOT}%{_libdir}/julia
176%{__rm} libgcc_s.so.* libgfortran.so.* libquadmath.so.*
177popd
178
179# move html files
180pushd ${RPM_BUILD_ROOT}%{_docdir}
181%{__mv} julia %{name}-%{version}
182%{__rm} -rf %{name}-%{version}/html
183popd
184
185
186%{__cp} \
187 CONTRIBUTING.md DISTRIBUTING.md HISTORY.md \
188 LICENSE.md NEWS.md README.md \
189 ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
190
191%check
192%{__make} %{?_smp_mflags} %{commonopts} test
193
194%clean
195%{__rm} -rf ${RPM_BUILD_ROOT}
196
197%post
198%{_syssbindir}/ldconfig
199if [ -x %{_bindir}/update-desktop-database ] ; then
200    %{_bindir}/update-desktop-database %{_datadir}/applications
201fi
202
203%postun
204%{_syssbindir}/ldconfig
205if [ $1 -eq 0 ] ; then
206    if [ -x %{_bindir}/update-desktop-database ] ; then
207        %{_bindir}/update-desktop-database %{_datadir}/applications
208    fi
209fi
210
211
212%files
213%defattr(-, root, root)
214%{_bindir}/julia*
215%{_sysconfdir}/%{name}
216%{_includedir}/%{name}
217%{_libdir}/%{name}/
218%{_libdir}/libjulia*
219%{_datadir}/appdata/
220%{_datadir}/applications/
221%{_datadir}/icons/
222%{_datadir}/julia/
223%{_docdir}/%{name}-%{version}
224%{_mandir}/man1/
225
226
227%changelog
228* Sat Jan 26 2019 Toshiaki Ara <ara_t@384.jp> 1.0.3-2
229- remove unnecessary sofiles
230- rebuild with gfortran-8.2.0
231
232* Sat Jan 05 2019 Toshiaki Ara <ara_t@384.jp> 1.0.3-1
233- update to 1.0.3
234
235* Fri Nov 16 2018 Toshiaki Ara <ara_t@384.jp> 1.0.2-1
236- update to 1.0.2
237
238* Thu Oct 04 2018 Toshiaki Ara <ara_t@384.jp> 1.0.1-1
239- update to 1.0.1
240
241* Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0-2
242- rebuild with suitesparse-4.4.6
243
244* Fri Aug 17 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0-1
245- update to 1.0.0
246- add/update sources
247- drop some Patches
248- add BuildRequires: and Requires: libatomic
249
250* Sat Jul 14 2018 Toshiaki Ara <ara_t@384.jp> 0.6.4-1
251- new upstream release
252- update SOURCE17 (openblas)
253
254* Sun Jun 17 2018 Toshiaki Ara <ara_t@384.jp> 0.6.3-1
255- new package
256
Note: See TracBrowser for help on using the repository browser.