source: projects/specs/trunk/j/json-glib/json-glib-vl.spec @ 12005

Revision 12005, 5.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define glib_ver 2.48.0
4
5Name:           json-glib
6Version:        1.4.4
7Release:        1%{?_dist_release}
8Summary:        Library for JavaScript Object Notation format
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://live.gnome.org/JsonGlib
13#VCS:           git:git://git.gnome.org/json-glib
14Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.xz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  meson
18BuildRequires:  glib2-devel >= %{glib_ver}
19BuildRequires:  gobject-introspection-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25%{name} is a library providing serialization and deserialization support
26for the JavaScript Object Notation (JSON) format.
27
28
29%package        devel
30Summary:        Development files for %{name}
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       glib2-devel >= %{glib_ver}
34Requires:       gtk-doc
35Requires:       pkgconfig
36
37
38%description devel
39The %{name}-devel package contains libraries and header files for
40developing applications that use %{name}.
41
42# compat32
43%package -n compat32-%{name}
44Summary:        Library for JavaScript Object Notation format
45Group:          System Environment/Libraries
46
47%description -n compat32-%{name}
48%{name} is a library providing serialization and deserialization support
49for the JavaScript Object Notation (JSON) format.
50
51
52%prep
53%setup -q
54
55
56%build
57%meson
58%meson_build
59
60
61%install
62rm -rf %{buildroot}
63%meson_install
64
65rm -rf %{buildroot}%{_libexecdir}/installed-tests
66rm -rf %{buildroot}%{_datadir}/installed-tests
67
68%find_lang %{name}-1.0
69
70%check
71# make check
72
73
74%clean
75rm -rf %{buildroot}
76
77
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82%post -n compat32-%{name} -p /sbin/ldconfig
83
84%postun -n compat32-%{name} -p /sbin/ldconfig
85
86%files -f %{name}-1.0.lang
87%defattr(-,root,root,-)
88%license COPYING
89%doc NEWS
90%{_bindir}/json-glib-format
91%{_bindir}/json-glib-validate
92%{_libdir}/lib%{name}*.so.*
93%{_libdir}/girepository-1.0/Json-1.0.typelib
94
95%files devel
96%defattr(-,root,root,-)
97%{_libdir}/lib%{name}*.so
98%{_libdir}/pkgconfig/%{name}-1.0.pc
99%{_includedir}/%{name}-1.0/
100#%{_datadir}/gtk-doc/html/%{name}/
101%{_datadir}/gir-1.0/Json-1.0.gir
102
103%if %{build_compat32}
104%files -n compat32-%{name}
105%defattr(-,root,root,-)
106%{_libdir}/lib%{name}*.so.*
107%endif
108
109
110%changelog
111* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4.4-1
112- new upstream release.
113
114* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-1
115- new upstream release
116
117* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.4-2
118- create compat32-json-glib subpackage
119
120* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.4-1
121- new upstream release
122
123* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.2-1
124- new upstream release
125
126* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
127- new upstream release
128
129* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.2-2
130- rebuild with VineSeed environment
131
132* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.2-1
133- new upstream release
134
135* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.0-1
136- new upstream release
137
138* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.2-1
139- new upstream release
140
141* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.14.2-1
142- update to 0.14.2
143
144* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.14.0-1
145- new upstream release
146
147* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.4-1
148- new upstream release
149
150* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.4-1
151- new upstream release
152
153* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
154- new upstream release
155
156* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.0-1
157- initial build for Vine Linux
158
159
160* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.10.4-3
161- Rebuild with new gobject-introspection
162
163* Thu Jul  1 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.10.4-2
164- Rebuild for "Incompatible version 1.0 (supported: 1.1)"
165  for introspection file
166
167* Fri Mar 19 2010 Brian Pepple <bpepple@fedoraproject.org> - 0.10.4-1
168- Update to 0.10.4.
169
170* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> - 0.10.0-3
171- Require the gobject-introspection-devel package, not the library
172
173* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> - 0.10.0-2
174- Enable gobject-introspection support
175
176* Tue Dec 29 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.10.0-1
177- Update to 0.10.0.
178
179* Mon Nov 16 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.8.2-1
180- Update to 0.8.2.
181
182* Tue Sep 29 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.8.0-1
183- Update to 0.8.0.
184- Update source url.
185
186* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-4
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
188
189* Thu Feb 26 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.6.2-3
190- Disable tests for now.
191
192* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-2
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
194
195* Sat May 31 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.6.2-1
196- Update to 0.6.2.
197- Enable tests.
198
199* Mon May 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.6.0-1
200- Update 0.6.0.
201- Disable tests for now.
202- Add requires on gtk-doc.
203
204* Sun Apr 20 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.4.0-1
205- Initial Fedora spec.
206
Note: See TracBrowser for help on using the repository browser.