source: projects/specs/trunk/j/json-glib/json-glib-vl.spec @ 10716

Revision 10716, 5.5 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define glib_ver 2.48.0
4
5Name:           json-glib
6Version:        1.2.0
7Release:        1%{?_dist_release}
8Summary:        Library for JavaScript Object Notation format
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://live.gnome.org/JsonGlib
13#VCS:           git:git://git.gnome.org/json-glib
14Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.2/%{name}-%{version}.tar.xz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  glib2-devel >= %{glib_ver}
18BuildRequires:  gobject-introspection-devel
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: Takemikaduchi
23
24%description
25%{name} is a library providing serialization and deserialization support
26for the JavaScript Object Notation (JSON) format.
27
28
29%package        devel
30Summary:        Development files for %{name}
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       glib2-devel >= %{glib_ver}
34Requires:       gtk-doc
35Requires:       pkgconfig
36
37
38%description devel
39The %{name}-devel package contains libraries and header files for
40developing applications that use %{name}.
41
42# compat32
43%package -n compat32-%{name}
44Summary:        Library for JavaScript Object Notation format
45Group:          System Environment/Libraries
46
47%description -n compat32-%{name}
48%{name} is a library providing serialization and deserialization support
49for the JavaScript Object Notation (JSON) format.
50
51
52%prep
53%setup -q
54
55
56%build
57%configure --enable-static=no
58make %{?_smp_mflags} V=1
59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT
64find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
65
66# Copy the files from the tarball to avoid the IDs generated by gtk-doc being
67# different on different builds
68mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
69cp -a doc/reference/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/%{name}/
70
71%find_lang %{name}-1.0
72
73%check
74# make check
75
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80
81%post -p /sbin/ldconfig
82
83%postun -p /sbin/ldconfig
84
85%post -n compat32-%{name} -p /sbin/ldconfig
86
87%postun -n compat32-%{name} -p /sbin/ldconfig
88
89%files -f %{name}-1.0.lang
90%defattr(-,root,root,-)
91%doc COPYING NEWS
92%{_bindir}/json-glib-format
93%{_bindir}/json-glib-validate
94%{_libdir}/lib%{name}*.so.*
95%{_libdir}/girepository-1.0/Json-1.0.typelib
96
97%files devel
98%defattr(-,root,root,-)
99%{_libdir}/lib%{name}*.so
100%{_libdir}/pkgconfig/%{name}-1.0.pc
101%{_includedir}/%{name}-1.0/
102%{_datadir}/gtk-doc/html/%{name}/
103%{_datadir}/gir-1.0/Json-1.0.gir
104
105%if %{build_compat32}
106%files -n compat32-%{name}
107%defattr(-,root,root,-)
108%{_libdir}/lib%{name}*.so.*
109%endif
110
111
112%changelog
113* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-1
114- new upstream release
115
116* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.4-2
117- create compat32-json-glib subpackage
118
119* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.4-1
120- new upstream release
121
122* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.2-1
123- new upstream release
124
125* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
126- new upstream release
127
128* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.2-2
129- rebuild with VineSeed environment
130
131* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.2-1
132- new upstream release
133
134* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.16.0-1
135- new upstream release
136
137* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.2-1
138- new upstream release
139
140* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.14.2-1
141- update to 0.14.2
142
143* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.14.0-1
144- new upstream release
145
146* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.4-1
147- new upstream release
148
149* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.4-1
150- new upstream release
151
152* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
153- new upstream release
154
155* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.0-1
156- initial build for Vine Linux
157
158
159* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 0.10.4-3
160- Rebuild with new gobject-introspection
161
162* Thu Jul  1 2010 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.10.4-2
163- Rebuild for "Incompatible version 1.0 (supported: 1.1)"
164  for introspection file
165
166* Fri Mar 19 2010 Brian Pepple <bpepple@fedoraproject.org> - 0.10.4-1
167- Update to 0.10.4.
168
169* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> - 0.10.0-3
170- Require the gobject-introspection-devel package, not the library
171
172* Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> - 0.10.0-2
173- Enable gobject-introspection support
174
175* Tue Dec 29 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.10.0-1
176- Update to 0.10.0.
177
178* Mon Nov 16 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.8.2-1
179- Update to 0.8.2.
180
181* Tue Sep 29 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.8.0-1
182- Update to 0.8.0.
183- Update source url.
184
185* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-4
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
187
188* Thu Feb 26 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.6.2-3
189- Disable tests for now.
190
191* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-2
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
193
194* Sat May 31 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.6.2-1
195- Update to 0.6.2.
196- Enable tests.
197
198* Mon May 19 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.6.0-1
199- Update 0.6.0.
200- Disable tests for now.
201- Add requires on gtk-doc.
202
203* Sun Apr 20 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.4.0-1
204- Initial Fedora spec.
205
Note: See TracBrowser for help on using the repository browser.