source: projects/specs/trunk/j/js/js-vl.spec @ 10460

Revision 10460, 10.8 KB checked in by Takemikaduchi, 8 years ago (diff)

firefox: new upstrream release
others: rebuild with gcc-5.4.0

Line 
1#% global hgdate 51702867d932
2
3Summary:        JavaScript interpreter and libraries
4Summary(ja):    JavaScript インタプリタ及びライブラリ
5Name:           js
6Epoch:          1
7Version:        1.8.5
8Release:        5%{?hgdate:.hg%{hgdate}}%{?_dist_release}
9License:        GPLv2+ or LGPLv2+ or MPLv1.1
10Group:          Development/Languages
11URL:            http://www.mozilla.org/js/
12
13Source0:        http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
14Patch0:         js-1.8.5-64bit-big-endian.patch
15Patch1:         js-1.8.5-secondary-jit.patch
16Patch2:         js185-destdir.patch
17#Patch3:        js-1.8.5-configure.patch
18Patch3:         js-1.8.5-537701.patch
19Patch4:         js185-arm-nosoftfp.patch
20Patch5:         js185-libedit.patch
21Patch6:         0001-Make-js-config.h-multiarch-compatible.patch
22
23Provides:       libjs = %{version}-%{release}
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25BuildRequires:  nspr-devel >= 4.7
26BuildRequires:, python
27BuildRequires:  zip
28BuildRequires:  libedit-devel
29BuildRequires:  ncurses-devel
30BuildRequires:  autoconf213
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34
35%description
36JavaScript is the Netscape-developed object scripting language used in millions
37of web pages and server applications worldwide. Netscape's JavaScript is a
38superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
39with only mild differences from the published standard.
40
41
42%package devel
43Summary: Header files, libraries and development documentation for %{name}
44Summary(ja): %{name} のヘッダファイル、ライブラリ及び開発用ドキュメント
45Group: Development/Libraries
46Requires: %{name} = %{epoch}:%{version}-%{release}
47Requires: pkgconfig
48Requires: ncurses-devel
49Provides: libjs-devel = %{version}-%{release}
50
51%description devel
52This package contains the header files, static libraries and development
53documentation for %{name}. If you like to develop programs using %{name},
54you will need to install %{name}-devel.
55
56
57%prep
58# All patches come from old version and maintainer. I think it is Fedora related only
59%setup -q -n %{name}-%{version}
60%patch0 -p2 -b .64bit-big-endian
61%patch1 -p2 -b .secondary-jit
62%patch2 -p0 -b .destdir
63%patch3 -p1 -b .537701
64%patch4 -p1 -b .armhfp
65%patch5 -p1 -b .libedit
66%patch6 -p1 -b .multiarch
67
68cd js
69
70# Rm parts with spurios licenses, binaries
71# Some parts under BSD (but different suppliers): src/assembler
72#rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
73rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
74
75pushd src
76autoconf-2.13
77popd
78
79# Create pkgconfig file
80%{__cat} > libjs.pc << 'EOF'
81prefix=%{_prefix}
82exec_prefix=%{_prefix}
83libdir=%{_libdir}
84includedir=%{_includedir}
85
86Name: libjs
87Description: JS library
88Requires: nspr >= 4.7
89Version: %{version}
90Libs: -L${libdir} -ljs
91Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
92EOF
93
94
95%build
96cd js/src
97CPPFLAGS="$(pkg-config --cflags libedit)" \
98%configure \
99    --with-system-nspr \
100    --enable-threadsafe \
101    --enable-readline
102
103%{__make} %{?_smp_mflags}
104
105%install
106%{__rm} -rf %{buildroot}
107cd js
108%{__make} -C src install DESTDIR=%{buildroot}
109# We don't want this
110%{__rm} -f %{buildroot}%{_bindir}/js-config
111%{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
112%{__rm} -rf %{buildroot}%{_libdir}/*.a
113%{__rm} -rf %{buildroot}%{_libdir}/*.la
114
115%{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
116
117# For compatibility
118# XXX do we really need libjs?!?!?!
119pushd %{buildroot}%{_libdir}
120%{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
121%{__ln_s} libmozjs185.so.1.0 libjs.so.1
122%{__ln_s} libmozjs185.so libmozjs.so
123%{__ln_s} libmozjs185.so libjs.so
124popd
125
126%{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
127
128%clean
129%{__rm} -rf %{buildroot}
130
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136
137%files
138%defattr(-,root,root,-)
139%doc js/src/README.html
140%{_bindir}/js
141%{_libdir}/*.so.*
142
143%files devel
144%defattr(-,root,root,-)
145%{_bindir}/jscpucfg
146%{_libdir}/pkgconfig/*.pc
147%{_libdir}/*.so
148%{_includedir}/js
149%{_includedir}/js*.h
150%{_includedir}/*.tbl
151%{_includedir}/js.msg
152%{_includedir}/prmjtime.h
153
154%changelog
155* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-5
156- rebuild with gcc-5.4.0
157
158* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1:1.8.5-4
159- added Patch5 to build with libedit instead of readline
160
161* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-3
162- rebuild with VineSeed environment
163
164* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-2
165- add Patch4 (js-1.8.5-537701.patch) from fedora
166- add Patch5 (js185-arm-nosoftfp.patch) from fedora
167
168* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-1
169- add Patch3 (js-1.8.5-configure.patch)
170- merge spec file with fedora package
171
172  * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
173  - new upstream release
174  - applied new versioning policy
175  - removed no longer provided perlconnect parts.
176
177  * Mon Jun  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
178  - initial build for Vine Linux
179
180
181* Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
182- Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
183- Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
184- Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
185
186* Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
187- Include mozjs185.pc, clean up build
188- Based on work from Christopher Aillon <caillon@redhat.com>
189- Switch to using make install DESTDIR=, instead of hardcoding build rules.
190- Add DESTDIR= patch from GNOME 3.2 jhbuild
191- Make mozjs185 the canonical target for both libmozjs and libmozjs185.
192
193* Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
194- add secondary arch patches from xulrunner
195
196* Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
197- devel subpackage needs to ask for the newly added epoch
198
199* Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
200- Add Epoch: 1 to allow update of 1.70-13 version.
201
202* Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
203- Correct symlink to provide backward capabiliies libjs.so.1
204
205* Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
206- Update to release.
207- Remove unneeded anymore patches.
208- Add backward capability symlink.
209
210* Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
211- Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
212- Gone -DJS_C_STRINGS_ARE_UTF8
213- Add BR autoconf213, change build system to use configure.
214- Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
215- Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
216- Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
217- Add BR python, zip.
218
219* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
220- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
221
222* Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
223- Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
224
225* Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
226- updated the va_copy patch for s390
227
228* Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
229- Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
230
231* Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
232- Reformat spec with tabs.
233- By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
234
235* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
237
238* Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
239- update the va_copy patch for s390x
240
241* Thu Apr  9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
242- Update description (#487903).
243
244* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
245- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
246
247* Wed Jun  4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
248- Add two missing files (#449715)
249
250* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
251- Rebuild for perl 5.10 (again)
252
253* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
254- Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
255- Remove no longer provided perlconnect parts.
256
257* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
258- BR: perl(ExtUtils::Embed)
259
260* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
261- rebuild for new perl
262
263* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
264- Rebuild for new BuildID feature.
265
266* Mon Aug  6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
267- Update License field.
268- Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
269
270* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
271- Include jsopcode.tbl and js.msg in devel (#235481).
272- Install static lib mode 644 instead of 755.
273
274* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
275- Update to 1.60.
276- Rebuild in order to link against ncurses instead of termcap (#226773).
277- Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
278- Change mode of perl library from 555 to 755 (#224603).
279
280* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
281- Fix pkgconfig file (#204232 & dupe #204236).
282
283* Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
284- FC6 rebuild.
285- Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
286
287* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
288- FC5 rebuild.
289
290* Thu Feb  9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
291- Rebuild for new gcc/glibc.
292
293* Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
294- Fix .pc file.
295
296* Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
297- Update to 1.5.0 final.
298- Spec file cleanups.
299- Move docs from devel to main, since we need the license there.
300- Remove no longer needed js-perlconnect.patch.
301- Update js-1.5-va_copy.patch.
302- Include a pkgconfig file (#178993).
303
304* Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
305- Link shared lib with libperl.
306
307* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
308- rebuilt
309
310* Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
311- Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
312
313* Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
314- Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
315
316* Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
317- Include perlconnect.
318- Include readline support, rebuild using "--without readline" to disable.
319- Add libjs* provides for upstream compatibility.
320- Install header files in %%{_includedir} instead of %%{_includedir}/js.
321
322* Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
323- Update to 1.5rc6a.
324
325* Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
326- Initial package. (using DAR)
327
Note: See TracBrowser for help on using the repository browser.