source: projects/specs/trunk/j/jq/jq-vl.spec @ 9212

Revision 9212, 1.3 KB checked in by iwaim, 9 years ago (diff)

jq 1.4-1

Line 
1%define ver 1.4
2%define rel 1
3
4Summary: a command-line JSON processor
5Name: jq
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: BSD
9Group: Applications/Text
10URL: http://stedolan.github.io/jq/
11Source0: http://stedolan.github.io/jq/download/source/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13
14Vendor: Project Vine
15Distribution: Vine Linux
16Packager: iwaim
17
18%description
19jq is like sed for JSON data – you can use it to slice and filter and
20map and transform structured data with the same ease that sed, awk,
21grep and friends let you play with text.
22
23%package devel
24Summary: Development files for %{name}
25Group: Development/Libraries
26Requires: %{name} = %{version}-%{release}
27
28%description devel
29The %{name}-devel package contains libraries and header files for
30developing applications that use %{name}.
31
32%prep
33%setup -q
34%configure --enable-shared --enable-static=no
35
36%build
37%__make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%makeinstall
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%check
47make check
48
49%post -p /sbin/ldconfig
50
51%postun -p /sbin/ldconfig
52
53%files
54%defattr(-,root,root,-)
55%doc AUTHORS COPYING README*
56%{_bindir}/jq
57%{_libdir}/libjq.so.*
58%{_mandir}/man1/jq.1*
59
60%files devel
61%defattr(-,root,root,-)
62%{_includedir}/*.h
63%{_libdir}/libjq.so
64
65%changelog
66* Fri Jan  2 2015 IWAI, Masaharu <iwaim.sub@gmail.com>
67- initial release Vine Linux
Note: See TracBrowser for help on using the repository browser.