source: projects/specs/trunk/j/jpilot/jpilot-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name jpilot
2%define version 0.99.9
3%define pilot_link_version 0.11.7
4Name:           %{name}
5Summary:        Palm pilot desktop for Linux
6Summary(ja):    Palm Desktop の Linux版
7Version:        %{version}
8Release:        1%{?_dist_release}
9License:        GPL
10Group:          Applications/Communications
11URL:            http://www.jpilot.org/
12Source:         http://wwww.jpilot.org/%{name}-%{version}.tar.gz
13Patch:          jpilot.jp.patch
14Patch1:         jpilot-0.99.4-usbinfo.patch.bz2
15Patch2:         jpilot-0.99.1u-plugins-improvement.patch.bz2
16BuildPreReq:    gettext, gtk2-devel >= 2.0.3
17BuildPreReq:    pilot-link-devel >= %{pilot_link_version}
18BuildPreReq:    openssl-devel, ImageMagick
19Requires:       pilot-link >= %{pilot_link_version}, gtk2 >= 2.0.3
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25J-Pilot is a desktop organizer application for the palm pilot that runs
26under Linux and UNIX.  It is similar in functionality to the one that 3com
27distributes for a well known rampant legacy operating system.
28
29%description -l ja
30J-Pilot は Linux と UNIX で使用できる Palm handheld device 用の連携ソフト
31です。このソフトは Palm 社が Windows 向けに提供しているものと同様の機能を
32備えています。
33
34%prep
35%setup -q
36#%patch -p0
37#%patch1 -p1
38%patch2 -p1
39
40%build
41%configure --enable-stock-buttons FORCE_PILOT_LIBS=%{_libdir}
42%{__make}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46%makeinstall
47
48# copy icon pixmap.
49%__install -d -m 755 ${RPM_BUILD_ROOT}/%{_datadir}/pixmaps
50%__install -m644 %{_builddir}/%{name}-%{version}/icons/jpilot-icon4.xpm ${RPM_BUILD_ROOT}/%{_datadir}/pixmaps/jpilot.xpm
51
52%find_lang %{name}
53
54# clean documentation done by makefile itself.
55#rm -rf %{buildroot}/usr/doc
56
57perl -p -i -e 's|%{buildroot}||' %{buildroot}/%{_libdir}/*la
58
59mkdir -p %{buildroot}/%{_includedir}
60install -m 644 {libplugin,prefs}.h %{buildroot}%{_includedir}/
61
62## remove unuse files
63rm -rf %{buildroot}%{_libdir}/*.la
64
65
66#%post -p /sbin/ldconfig
67
68#%postun -p /sbin/ldconfig
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files -f %{name}.lang
75%defattr(-,root,root)
76%doc AUTHORS BUGS ChangeLog COPYING NEWS README TODO
77%doc docs/manual.html docs/jpilot-*.png docs/jpilot-*.jpg
78%doc docs/plugin.html
79%{_bindir}/*
80%{_datadir}/jpilot/jpilotrc.*
81%{_datadir}/jpilot/*.pdb
82%{_datadir}/applications/jpilot.desktop
83%{_datadir}/pixmaps/jpilot.xpm
84%{_mandir}/man1/*
85%{_libdir}/*.so.*
86%{_libdir}/*.so
87#%{_libdir}/*.la
88%{_includedir}/*.h
89
90%changelog
91* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.99.9-1vl5
92- applied new versioning policy, spec in utf-8
93- added FORCE_PILOT_LIBS to %%configure
94- removed *.la
95
96* Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.99.9-0vl1
97- source update
98- unset --enable-gtk2 option (now gtk2 build is default).
99
100* Wed Nov 26 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.99.8-0vl1
101- source update
102- add japanese translation.
103- update Source URI.
104- change configure option.
105  (build with gtk2 and use gtk stock icons on buttons.)
106- change Requires and BuildPreReq. (gtk1 to gtk2)
107- comment out unnecessary step in %%install section.
108- use %%find_lang macro in %%install section.(also %%files section)
109- add %%{_datadir}/applications/jpilot.desktop in %%file section.
110- build for VineSeed Plus.
111- add icon pixmap.
112
113* Mon Mar 25 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.99.5-0vl1
114- source update
115
116* Tue Feb 18 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.99.4-0vl1
117- source update and synced with 0.99.4-1mdk
118
119  * Thu Jan 16 2003 Fran輟is Pons <fpons@mandrakesoft.com> 0.99.4-1mdk
120  - patch and documentations files updated.
121  - removed ldconfig from %%post and %%postun.
122  - use provided icons by project and convert them to png on the fly.
123  - fixed headers in a true include directory.
124  - 0.99.4 and pilot-link-0.11.6.
125
126  * Tue Oct 15 2002 Fran輟is Pons <fpons@mandrakesoft.com> 0.99.3-1mdk
127  - 0.99.3 and pilot-link-0.11.5.
128
129  * Thu Aug 08 2002 Fran輟is Pons <fpons@mandrakesoft.com> 0.99.2-5mdk
130  - rebuild with pilot-link-0.11.3.
131
132  * Sat Aug  3 2002 Stefan van der Eijk <stefan@eijk.nu> 0.99.2-4mdk
133  - BuildRequires
134
135  * Wed Jul 17 2002 Fran輟is Pons <fpons@mandrakesoft.com> 0.99.2-3mdk
136  - rebuild with pilot-link-0.11.0.
137  - more strict requires from jpilot-plugin-devel to jpilot.
138
139  * Thu Jun 13 2002 Fran輟is Pons <fpons@mandrakesoft.com> 0.99.2-2mdk
140  - rebuild with pilot-link-0.10.99.
141  - added missing requires for devel package.
142  - moved some files in devel package.
143
144  * Tue May 28 2002 Fran輟is Pons <fpons@mandrakesoft.com> 0.99.2-1mdk
145  - add patch to fix directory creation right.
146  - 0.99.2.
147
148  * Mon Jan 28 2002 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.9mdk
149  - Upgrade to latest snapshot.
150
151  * Tue Jan 15 2002 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.8mdk
152  - Add Jason Day contributed code from pre to get jpilot-syncmal works.
153
154  * Thu Jan 10 2002 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.7mdk
155  - Upgrade to latest snapshot.
156
157  * Fri Dec  7 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.6mdk
158  - Last dated snapshot.
159  - Fix rpmlint's.
160
161  * Mon Nov 19 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.5mdk
162  - Fix DESTDIR with makeinstall.
163
164  * Sat Sep 29 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.4mdk
165  - rpmlint fixes.
166
167  * Sat Jun 23 2001 Stefan van der Eijk <stefan@eijk.nu> 0.99.1-0.3mdk
168  - BuildRequires:        gtk+-devel
169
170  * Wed Jun 20 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.2mdk
171  - Fix plugins loading.
172
173  * Wed Jun 20 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.1-0.1mdk
174  - Sanitize spec file.
175  - 0.99.1 pre.
176
177  * Sun Jun 10 2001 Stefan van der Eijk <stefan@eijk.nu> 0.99-3mdk
178  - BuildRequires: pilot-link-devel
179
180  * Sun Apr 22 2001 Stew Benedict <sbenedict@mandrakesoft.com> 0.99-2mdk
181  - need prefs.h in plugins for jpilot-syncmal
182
183  * Thu Feb 08 2001 Geoffrey lee <snailtalk@mandrakesoft.com> 0.99-1mdk
184  - new and shiny source.
185  - change the URL.
186  - change the URL on the source tag.
187  - Don't apply patch1 anymore. (security mode 0700 fix.)
188  - remove libplugin.a (can't find it anymore.)
189  - when using tar use -j to pass through the bzip2 filter, not -I.
190
191* Mon Oct 22 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.98.1-0vl3
192- changed URL and Source (upstream moved)
193- use RPM macros
194- added Requires: pilot-link, gtk+ >= 1.2.0
195- added BuildPreReq: gtk+-devel >= 1.2.0
196
197* Wed Sep 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.98.1-0vl2
198- added BuildPreReq: pilot-link-devel
199
200* Sat Oct  7 2000 Jun Nishii <jun@vinelinux.org>
201- 0.98.1-0vl1 based on 0.98.1-2 on the jpilot page
202- build for Vine Linux 2.1
Note: See TracBrowser for help on using the repository browser.