source: projects/specs/trunk/j/jpackage-utils/jpackage-utils-vl.spec @ 1563

Revision 1563, 23.5 KB checked in by inagaki, 14 years ago (diff)

updated: gcc, jpackage-utils
NEW: ecj, fastjar, java-1.5.0-gcj

Line 
1# Copyright (c) 2000-2008, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30%define gcj_support 1
31
32%define distver 1.7
33%define section free
34
35Name:           jpackage-utils
36Summary:        JPackage utilities
37Summary(ja):    JPackage ユーティリティ集
38Version:        1.7.5
39Release:        1%{?_dist_release}
40
41License:        BSD
42URL:            http://www.jpackage.org/
43Group:          System Environment/Base
44
45Source0:        %{name}-%{version}.tar.bz2
46Source1:        %{name}-README
47Source2:        abs2rel.sh
48Source3:        abs2rel.lua
49Patch0:         %{name}-enable-gcj-support.patch
50Patch1:         %{name}-own-mavendirs.patch
51Patch2:         %{name}-prefer-jre.patch
52Patch3:         %{name}-set-classpath.patch
53
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55BuildArch:      noarch
56Requires:       coreutils
57
58%description
59Utilities for the JPackage Project <http://www.jpackage.org/>:
60
61It contains also the License, man pages, documentation, XSL files of general
62use with maven2, a header file for spec files, etc. Please See
63the %{_docdir}/%{name}-%{version}/%{name}-README file for more
64information.
65
66%prep
67%setup -q
68%patch0 -p0
69%patch1 -p1
70%patch2 -p1
71%patch3 -p1
72
73cp -p %{SOURCE1} %{SOURCE2} %{SOURCE3} .
74
75%build
76echo "JPackage release %{distver} (%{distribution}) for %{buildarch}" \
77 > etc/jpackage-release
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82# Pull macros out of macros.jpackage and emulate them during install for
83# smooth bootstrapping experience.
84for dir in \
85    jvmdir jvmjardir jvmprivdir \
86    jvmlibdir jvmdatadir jvmsysconfdir \
87    jvmcommonlibdir jvmcommondatadir jvmcommonsysconfdir \
88    javadir jnidir javadocdir mavenpomdir \
89    mavendepmapdir mavendepmapfragdir; do
90  export _${dir}=$(rpm --eval $(%{__grep} -E "^%_${dir}\b" \
91    misc/macros.jpackage | %{__awk} '{ print $2 }'))
92done
93
94install -dm 755 ${RPM_BUILD_ROOT}%{_bindir}
95install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/{java,rpm}
96%if %{gcj_support}
97install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/java/security
98install -dm 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/java/security/security.d
99%endif
100install -dm 755 ${RPM_BUILD_ROOT}${_jvmdir}
101install -dm 755 ${RPM_BUILD_ROOT}${_jvmjardir}
102install -dm 755 ${RPM_BUILD_ROOT}${_jvmprivdir}
103install -dm 755 ${RPM_BUILD_ROOT}${_jvmlibdir}
104install -dm 755 ${RPM_BUILD_ROOT}${_jvmdatadir}
105install -dm 755 ${RPM_BUILD_ROOT}${_jvmsysconfdir}
106install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonlibdir}
107install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommondatadir}
108install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonsysconfdir}
109install -dm 755 ${RPM_BUILD_ROOT}${_javadir}
110install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-utils
111install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-ext
112install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.3.1,1.4.0,1.4.1,1.4.2}
113install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0}
114install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}
115install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-ext
116install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.3.1,1.4.0,1.4.1,1.4.2}
117install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0}
118install -dm 755 ${RPM_BUILD_ROOT}${_javadocdir}
119install -dm 755 ${RPM_BUILD_ROOT}${_mavenpomdir}
120install -dm 755 ${RPM_BUILD_ROOT}${_mavendepmapfragdir}
121
122install -pm 755 bin/* ${RPM_BUILD_ROOT}%{_bindir}
123install -pm 644 etc/font.properties ${RPM_BUILD_ROOT}%{_sysconfdir}/java
124
125# Install abs2rel scripts
126install -pm 755 abs2rel.sh  ${RPM_BUILD_ROOT}%{_javadir}-utils
127install -pm 644 abs2rel.lua ${RPM_BUILD_ROOT}%{_javadir}-utils
128
129# Create an initial (empty) depmap
130echo -e "<dependencies>\\n" \
131  > ${RPM_BUILD_ROOT}${_mavendepmapdir}/maven2-depmap.xml
132echo -e "</dependencies>\\n" \
133  >> ${RPM_BUILD_ROOT}${_mavendepmapdir}/maven2-depmap.xml
134
135cat > etc/java.conf << EOF
136# System-wide Java configuration file                                -*- sh -*-
137#
138# JPackage Project <http://www.jpackage.org/>
139
140# Location of jar files on the system
141JAVA_LIBDIR=${_javadir}
142
143# Location of arch-specific jar files on the system
144JNI_LIBDIR=${_jnidir}
145
146# Root of all JVM installations
147JVM_ROOT=${_jvmdir}
148
149# You can define a system-wide JVM root here if you're not using the
150# default one.
151#
152# If you have the a base JRE package installed
153# (e.g. java-1.6.0-openjdk):
154#JAVA_HOME=\$JVM_ROOT/jre
155#
156# If you have the a devel JDK package installed
157# (e.g. java-1.6.0-openjdk-devel):
158#JAVA_HOME=\$JVM_ROOT/java
159
160# Options to pass to the java interpreter
161JAVACMD_OPTS=
162EOF
163
164install -pm 644 etc/java.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/java
165install -pm 644 etc/jpackage-release ${RPM_BUILD_ROOT}%{_sysconfdir}/java
166install -pm 644 java-utils/* ${RPM_BUILD_ROOT}${_javadir}-utils
167install -pm 644 misc/macros.jpackage ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm
168%{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
169install -pm 644 man/* ${RPM_BUILD_ROOT}%{_mandir}/man1
170%{__mkdir_p} ${RPM_BUILD_ROOT}${_javadir}-utils/xml
171install -pm 644 xml/* ${RPM_BUILD_ROOT}${_javadir}-utils/xml
172
173cat <<EOF > %{name}-%{version}.files
174%{_bindir}/*
175%{_mandir}/man1/*
176%dir %{_sysconfdir}/java
177%if %{gcj_support}
178%{_sysconfdir}/java/security
179%endif
180%dir ${_jvmdir}
181%dir ${_jvmjardir}
182%dir ${_jvmprivdir}
183# %dir ${_jvmlibdir}
184%dir ${_jvmdatadir}
185%dir ${_jvmsysconfdir}
186%dir ${_jvmcommonlibdir}
187%dir ${_jvmcommondatadir}
188%dir ${_jvmcommonsysconfdir}
189%dir ${_javadir}
190%dir ${_javadir}-*
191%dir ${_jnidir}
192%dir ${_jnidir}-*
193%dir ${_javadocdir}
194%dir %{_datadir}/maven2
195%dir ${_mavenpomdir}
196%dir ${_mavendepmapdir}
197%dir ${_mavendepmapfragdir}
198${_javadir}-utils/*
199%config %{_sysconfdir}/java/jpackage-release
200%config(noreplace) %{_sysconfdir}/java/java.conf
201%config(noreplace) %{_sysconfdir}/java/font.properties
202%config(noreplace) %{_sysconfdir}/rpm/macros.jpackage
203%config(noreplace) ${_mavendepmapdir}/maven2-depmap.xml
204EOF
205
206
207%clean
208rm -rf $RPM_BUILD_ROOT
209
210%files -f %{name}-%{version}.files
211%defattr(-,root,root,-)
212%doc %{name}-README LICENSE.txt HEADER.JPP doc/* etc/httpd-javadoc.conf
213
214%changelog
215* Fri Aug 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.5-1
216- updated to 1.7.5
217- added abs2rel script
218
219* Wed Apr 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.4-2jpp2
220- changed Group to System Environment/Base
221
222* Wed Apr 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-2jpp1
223- use new versioning policy
224
225* Thu Mar 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-2jpp0vl1
226- initial build for Vine Linux
227
228* Tue Jan 22 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.4-2jpp.2
229- Replace GCJ security directory.
230
231* Tue Jan 22 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.4-2jpp.1
232- Import jpackage-utils 1.7.4-2jpp.
233
234* Mon Jan 21 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.4
235- Remove AutoReqProv.
236- Remove Requires and BuildRequires.
237- Wrap export, install and maven lines at 80 columns.
238- Add jre option to java.conf comment.
239- Related: rhbz#428520
240- Remove commented jpackage.org sections.
241- Remove duplicate files from files list.
242- Remove trailing whitespace.
243- Remove rebuild-security-providers.
244- Resolves: rhbz#260161
245
246* Fri Jan 04 2008 Ralph Apel <r.apel at r-apel.de> - 0:1.7.4-2jpp
247- Fix Bug 293
248
249* Wed Dec 19 2007 Ville Skyttä <scop at jpackage.org> - 0:1.7.4-1jpp
250- Terminate functions with %%{nil} in macros.jpackage.
251- Make %%jpackage_script install the script with 0755 permissions.
252- Use exec in java-functions' run().
253
254* Wed Jun 20 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.3
255- Add 1.7.0 directories.
256
257* Fri May 25 2007 Jason Corley <jason.corley@gmail.com> - 0:1.7.3-2jpp
258- change distribution and vendor to macros
259- rebuild in mock
260
261* Thu Jan 11 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.2
262- Add 1.6.0 directories missed in merge.
263- Resolves: rhbz#221262
264
265* Mon Dec 11 2006 Thomas Fitzsimmons <fitzsim@redhat.com> - 0:1.7.3-1jpp.1
266- Import version 0:1.7.3-1jpp from jpackage.org.
267- Change release numbering format to Xjpp.Y.fc7.
268- Resolves: rhbz#218936
269
270* Sat Nov 11 2006 Ville Skyttä <scop at jpackage.org> - 0:1.7.3-1jpp
271- Add Java 1.6.0 dirs.
272
273* Mon Oct 23 2006 Deepak Bhole <dbhole@redhat.com> 1.7.2-1jpp
274- Added maven2 depmap related macros.
275
276* Tue Sep 19 2006 Fernando Nasser <fnasser@jpackage.org> 0:1.7.1-1jpp
277- Add new scripts from Deepak Bhole
278- Add documentation from Jason Corley
279- Add XLT file shared by maven2 packages
280
281* Fri Nov 04 2005 Fernando Nasser <fnasser@jpackage.org> 0:1.7.0-1jpp
282- Initial 1.7 release (eq. to 1.6.6)
283- Add Copyright notice and license as header
284
285* Sun Sep 18 2005 David Walluck <david@jpackage.org> 0:1.6.6-1jpp
286- always define macros
287
288* Sat Sep 17 2005 David Walluck <david@jpackage.org> 0:1.6.5-2jpp
289- clean tarball
290
291* Sat Sep 17 2005 David Walluck <david@jpackage.org> 0:1.6.5-1jpp
292- fix conditional macros
293- merge nim's and robert's changes
294
295* Mon Aug 22 2005 David Walluck <david@jpackage.org> 0:1.6.4-1jpp
296- long needed s/All/Some in error messages
297
298* Fri Jan 28 2005 Nicolas Mailhot <nim at jpackage.org> - 0:1.6.3-1jpp
299- prefer full JVM to JRE when not specified (my bad, sorry)
300- remove LICENSE.txt as it does not seem to exist in the jpp16 branch anymore
301
302* Sat Jan 15 2005 Nicolas Mailhot <nim at jpackage.org> - 0:1.6.2-1jpp
303- Happy new year jpackagers!
304- No longer define JAVA_HOME in default shipped java.conf (me)
305- Search if $JVM_ROOT/jre or $JVM_ROOT/java exist in functions if JAVA_HOME is
306  not defined in java.conf (me)
307- Source ~/.java/java.conf in addition to /etc/java/java.conf in functions
308  (me)
309- Make find-jar use the same error code as build-classpath (Joe Wortmann)
310  (note however find-jar was never intended to use directly in scripts, it's
311   a low-level way to test the search engine)
312- Change macros slightly so they no longer wreak havoc on x86_64 systems
313  (Thomas Fitzsimmons for Red Hat)
314  This is probably only a short-term fix since we've yet to decide how to
315  handle real x86_64 JVMs cleanly.
316
317* Thu Dec 16 2004 Robert Ottenhag <support@bea.com> -  0:1.6.3-1jpp
318- Move the systemPrefs stuff into a separate new package java-systemprefs
319
320* Wed Dec 15 2004 Robert Ottenhag <support@bea.com> -  0:1.6.2-1jpp
321- Reapply all updates from 1.5.40-1jpp o 1.5.42-1jpp
322  + Add support for splitting the installation of Java VMs/SDK/JREs
323    according to FHS 2.3 in its architecture dependent, architecture
324    independent, and configuration parts. Added new macros and dirs
325    - %%{_jvmlibdir}, defined as %%{_libdir}/jvm, equal to %%{_jvmdir},
326    - %%{_jvmdatadir}, defined as %%{_datadir}/jvm
327    - %%{_jvmsysconfdir}, defined as %%{_sysconfdir}/jvm
328  + Add support for splitting the installation of Java VMs/SDK/JREs
329    in its common architecture dependent, architecture
330    independent, and configuration parts. Added new macros and dirs
331    - %%{_jvmcommonlibdir}, defined as %%{_libdir}/jvm-commmon
332    - %%{_jvmcommondatadir}, defined as %%{_datadir}/jvm-commmon
333    - %%{_jvmcommonsysconfdir}, defined as %%{_sysconfdir}/jvm-commmon
334  + Ensure that a global systemPrefs database used by
335    java.util.prefs.FileSystemPreferences exists at
336    /etc/.java/.systemPrefs, or create an empty one if not, and
337    symlink to it from %%{_jvmcommonsysconfdir}/java/jre/systemprefs.
338
339* Sat Dec  4 2004 Ville Skyttä <scop at jpackage.org> - 0:1.6.1-1jpp
340- java-functions (set_jvm_dirs): try "java -fullversion" before
341  "java -version" for performance, improve regexps, use sed from $PATH.
342- Include correct specfile in tarball.
343
344* Tue Nov 2 2004 Nicolas Mailhot <nim@jpackage.org> - 0:1.6.0-2jpp
345- fix missing %%{_jnidir} in file list
346
347* Tue Oct 12 2004 Ville Skyttä <scop at jpackage.org> - 0:1.6.0-1jpp
348- Start preparing for JPackage 1.6:
349  - License change: jpackage-utils >= 1.6.0 is available under the (BSD-like)
350    JPackage License.  See included LICENSE.txt.
351  - Remove support for Java < 1.4 (dirs only for now).
352  - Remove java_home.list and support for it.
353- Add support for installing macros.jpackage into Asianux's rpm config,
354  thanks to Robert Ottenhag for the info.
355
356* Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:1.5.38-2jpp
357- Rebuild with ant-1.6.2
358
359* Mon Jun  7 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.38-1jpp
360- Update java_home.list with Sun's default 1.5.0beta2 location.
361- Nuke extra copy of java.conf from tarball.
362
363* Wed May 26 2004 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> - 0:1.5.37-1jpp
364- add the --preserve-naming switch to build-jar-repository, and document it
365  (following a discussion with Chip Turner)
366
367* Thu May  6 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.36-1jpp
368- Fix bootstrap problem by ensuring that build time macro expansion for
369  %%{_sysconfdir}/java.conf uses macros defined in this package and does not
370  rely on the macros being already defined.
371- Include correct spec file in tarball.
372
373* Tue May 04 2004 David Walluck <david@jpackage.org> 0:1.5.35-1jpp
374- expand macros in %%{_sysconfdir}/java.conf
375
376* Fri Mar 26 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.34-1jpp
377- Update java_home.list with Sun's default 1.4.2_04, 1.4.1_07, 1.3.1_10
378  and 1.3.1_11 locations.
379
380* Tue Feb 09 2004 David Walluck <david@anti-microsoft.org> 0:1.5.33-1jpp
381- update for J2SE 1.5.0 Beta 1
382
383* Tue Jan 13 2004 Ville Skyttä <scop at jpackage.org> - 0:1.5.32-1jpp
384- Fix java-functions location in diff-jars.
385- Add (X)Emacs mode cookies to java.conf and java-functions.
386- Micro-performance improvement to set_javacmd.
387- Insert macros.jpackage before anything starting with "~/" in rpmrc's.
388- Include example httpd.conf snippet for javadocs.
389
390* Mon Dec 29 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.31-1jpp
391- Update java_home.list with Sun's default 1.4.2_03, 1.4.1_06 and 1.4.0_04
392  locations.
393
394* Thu Nov 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> - 0:1.5.30-1jpp
395- Add a minimalist xfonset entry to the default font.properties
396
397* Tue Oct 21 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.29-1jpp
398- Update java_home.list with Sun's default 1.4.2_02 and 1.4.1_05 locations.
399
400* Fri Oct 17 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.28-1jpp
401- Make package bootstrappable, thanks to Markus Pilzecker for ideas.
402
403* Sun Aug 31 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.27-1jpp
404- Update jpackage-1.5-policy wrt. jvm-private and speling fixxes.
405
406* Sat Aug 30 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.26-1jpp
407- Add %%{_jvmprivdir} (== %%{_libdir}/jvm-private), a directory for
408  JVM-private stuff (eg. JCE policy jars).
409- Update java_home.list with Sun's default 1.4.2_01 location.
410
411* Thu Aug 14 2003 Ville Skyttä <scop at jpackage.org> - 0:1.5.25-1jpp
412- Update java_home.list.
413- Save .spec in UTF-8.
414
415* Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.24-1jpp
416- fix more symlinks/copy corner cases
417
418* Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.23-1jpp
419- debug 1.5.22
420
421* Tue Jun 10 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.22-1jpp
422- more correct java version detection regexp, courtesy of Scott Brickner
423- allow creation of harlink/copy jar repositories since tomcat4 seems to need
424  this (reported by Greg Barton)
425
426* Sun May 18 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.21-1jpp
427- fix a bug in jar repository handling
428- remove unused APPDIR in jar resolution
429- add doc for jpackage 1.5 policy
430
431* Tue May 16 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.20-1jpp
432- remove unneeded and brittle complexity
433
434* Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.19-1jpp
435- fix new jar repository scripts (more corner cases)
436- create symlinks for not-found extensions to allow a later repository rebuild
437- create symlinks as [extension].jar, for example [jsse][jcert].jar
438- allow both extension split and collapsing
439  (one jar -> one directory of jars or the other way round)
440
441* Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.18-1jpp
442- fix new scripts
443
444* Tue May 13 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.17-1jpp
445- add initial java repository support
446
447* Sat May 10 2003 David Walluck <david@anti-microsoft.org> 0:1.5.16-1jpp
448- %%jpackage_script macro fix
449- add %%doc to file list
450- add %%config(noreplace) to jpackage-release in file list to shut up rpmlint
451
452* Wed May 7 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.15-1jpp
453- fix error message in java dir computation
454
455* Sun Apr 26 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.14-3jpp
456- use java fonts if available first
457
458* Sat Apr 26 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.14-1jpp
459- add java font config
460
461* Wed Apr 23 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-5jpp
462- use quotes in 'test -f'
463
464* Mon Apr 21 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-4jpp
465- use hardcoded file list for %%postun and %%triggerin
466
467* Thu Apr 17 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-3jpp
468- don't use quotes around the 'find' command in %%postun and %%triggerin
469- don't add a 'macrofiles:' line in %%triggerin to rpmrc if one isn't
470  already there
471
472* Tue Apr 15 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-2jpp
473- try to support macros.jpackage on RedHat 9
474
475* Mon Apr 14 2003 David Walluck <david@anti-microsoft.org> 0:1.5.13-1jpp
476- change CLASSPATH to _CLASSPATH and JARS to _JARS
477- clean up trailing ':' in _CLASSPATH
478
479* Mon Apr 14 2003 Nicolas Mailhot <Nicolas.Mailhot at laPoste.net> 0:1.5.12-1jpp
480- remove build-classpath dependency on David's stuff since it fails horribly
481  when people actually use it
482- try to actually fix triggers
483
484* Sat Apr 12 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-3jpp
485- don't remove macros.jpackage from rpmrc on jpackage-utils upgrade
486
487* Sat Apr 12 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-2jpp
488- remove argouml.log from tarball
489
490* Fri Apr 11 2003 David Walluck <david@anti-microsoft.org> 0:1.5.11-1jpp
491- add build-classpath-directory
492- add epoch
493
494* Thu Apr 10 2003 David Walluck <david@anti-microsoft.org> 1.5.10-1jpp
495- back to using %%{_libdir}/rpm/rpmrc for macros.jpackage
496- add %%{_javadir}--1.4.2 and %%{_jnidir}-1.4.2 directories
497- update package description
498- add JAVACMD_OPTS to java.conf
499- use new external java.conf
500- update build-classpath and java-functions to support directories in
501  CLASSPATH
502
503* Mon Mar 24 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.9-1jpp
504- more symlinks handling
505
506* Wed Mar 19 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.7-1jpp
507- register new jvm alternatives
508- allow use of build-classpath for incomplete paths
509
510* Tue Mar 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.6-1jpp
511- resurect borked icon/menu handling
512- hopefuly support jni jars (arch-dependant jars)
513
514* Thu Feb 13 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.4-3jpp
515- extract jar resolving logic from classpath builder
516- hopefully integrate classpath builder in set_classpath macro
517
518* Wed Feb 12 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.3-1jpp
519- add classpath builder
520
521* Wed Feb 12 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.2-1jpp
522- New reorg
523
524* Tue Feb 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.1-1jpp
525- add some extension handling
526- fix some macros broken in 1.5.0
527
528* Tue Feb 11 2003 Nicolas Mailhot <Nicolas.Mailhot@jpackage.org> 1.5.0-1jpp
529- use a tar source file
530- use lsb locations
531- prepare for multi-jvm extensions support
532
533* Mon Feb 10 2003 David Walluck <david@anti-microsoft.org> 1.4.8-1jpp
534- better installation of macros
535- update %%description to list all files currently included in this package
536- jpackage-release in %%{_sysconfdir}, not /etc (I hope this is more
537  correct)
538
539* Sun Feb 09 2003 David Walluck <david@anti-microsoft.org> 1.4.7-1jpp
540- fix sed in %%jpackage_script when paths to jars contain '/'
541- fix typo in macros documentation
542- add jpackage-policy
543- add jpackage-release
544
545* Wed Feb 05 2003 David Walluck <david@anti-microsoft.org> 1.4.6-1jpp
546- macro bugfixes
547- instead of tarball we now use %%{SOURCEn} format
548
549* Fri Jan 31 2003 David Walluck <david@anti-microsoft.org> 1.4.5-1jpp
550- add macros.jpackage (DO NOT attempt to use this until we figure something
551  out, but I would still like to get some feedback about how it looks so far)
552
553* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.4-1jpp
554- fix exiting on failed `which` (Ville Skyttä <scop at jpackage.org>)
555
556* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.3-2jpp
557- fix release tag in %%changelog
558
559* Sun Jan 26 2003 David Walluck <david@anti-microsoft.org> 1.4.3-1jpp
560- java-functions changes:
561  + set_jvm: look for javac first to avoid erroneously setting
562    JAVA_HOME to the location of the jre unless we have to
563  + set_jvm: follow symlinks to avoid erroneously setting JAVA_HOME to
564    /usr/bin
565  + set_jvm: export JAVA_HOME
566- changed to use install instead of mkdir and cp
567- remove %%attr and rely on install to set the permissions instead
568
569* Sat Jan 25 2003 Ville Skyttä <scop at jpackage.org> - 1.4.2-1jpp
570- java-functions changes:
571  + Prevent non-success exit code from "which" in set_jvm, it can now
572    be used when building RPMs.
573  + Use set_jvm in set_javacmd.
574  + Use set_javacmd and $JAVACMD in run.
575- Fix Group tag.
576
577* Sat Dec 28 2002 Ville Skyttä <scop at jpackage.org> - 1.4.1-1jpp
578- Add Sun's 1.4.0_03 and BEA JRockit 7.0SP1 default RPM locations.
579
580* Thu Nov 21 2002 Ville Skyttä <scop at jpackage.org> - 1.4-1jpp
581- Fix diff-jars when diffing 2 jars with same basename (#635202).
582- Add IBM's 1.4 default RPM location to jvm.list.
583
584* Fri Nov  8 2002 Ville Skyttä <scop at jpackage.org> - 1.3-6jpp
585- Add Sun's 1.3.1_06 default RPM location.
586
587* Sat Oct 19 2002 Ville Skyttä <scop at jpackage.org> 1.3-5jpp
588- Add Sun's 1.4.1_01 and 1.3.1_05 default RPM locations.
589
590* Tue Sep 17 2002 Ville Skyttä <scop at jpackage.org> 1.3-4jpp
591- Add Sun's 1.4.1 default rpm location.
592
593* Thu Sep 12 2002 Ville Skyttä <scop at jpackage.org> 1.3-3jpp
594- Add Sun's 1.4.0_02 and new BEA JRockit locations.
595
596* Sat Jun 29 2002 Ville Skyttä <scop at jpackage.org> 1.3-2jpp
597- Add section macro.
598
599* Sat Jun 29 2002 Ville Skyttä <scop at jpackage.org> 1.3-1jpp
600- Add some variants of Sun J2SE java homes as well as JRockit.
601- Add Distribution tag.
602
603* Fri May 3 2002 Nicolas Mailhot <nmailhot@users.sourceforge.net> 1.2-1jpp
604Add some stuff to please jakarta ant developpers :
605- OSX java home
606- new function set_javacmd with AIX hack included
607
608* Wed Dec 19 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.1-1jpp
609- java-functions: centralized configuration
610- java-functions: jvm list lookup
611- diff-jars: fixed typo
612- diff-jars: used /tmp for files
613- corrected changelog
614
615* Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.0-1jpp
616- first JPackage release
Note: See TracBrowser for help on using the repository browser.