source: projects/specs/trunk/j/jman_pages/jman_pages-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define jman 0.5
2%define rel 20090715
3
4Summary: Japanese manual pages
5Summary(ja): 日本語マニュアル・ページ集
6Name: jman_pages
7Version: %{jman}
8Release: %{rel}%{?_dist_release}
9Source0: http://www.linux.or.jp/JM/man-pages-ja-%{rel}.tar.gz
10Source1: installman.sh.vine
11License: distributable
12Group: Applications/Documentation
13URL: http://www.linux.or.jp/JM/
14Obsoletes: xjman_pages
15Requires: man
16BuildArch: noarch
17BuildRequires: man gzip perl
18Buildroot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: daisuke, inagaki
23
24%description
25Japanese Manual Pages by JM-Project (Japanese Manual Project)
26See http://www.linux.or.jp/JM/ for detail.
27
28  Section 1 = User Commands
29  Section 2 = System Calls and error numbers
30  Section 3 = Functions in the C libraries
31  Section 4 = Device drivers (special Files) (ex. hd, sd)
32  Section 5 = File Formats
33  Section 6 = Games and other diversions
34  Section 7 = Miscellaneous topics (ex. nroff, ascii)
35  Section 8 = System maintenance and operation commands
36
37Sometimes the content can differ from Texinfo manual or roff manual
38in English. So if unsure reading Japanese manual, please see
39%{_defaultdocdir}/%{name}-%{version}/translation_list/ and try other formats.
40
41
42%description -l ja
43JM-Project (Japanese Manual Project) による, 日本語マニュアル・ページです.
44JM-Projectについては, http://www.linux.or.jp/JM/ を御覧ください.
45
46各章の構成は英語版と同じく以下のようになっています。
47
48  第 1 章 = ユーザーコマンド
49  第 2 章 = システムコール
50  第 3 章 = C 言語ライブラリ
51  第 4 章 = スペシャルファイル (例: hd, sd)
52  第 5 章 = ファイルフォーマットとプロトコル (例: wtmp, /etc/passwd, nfs)
53  第 6 章 = ゲーム
54  第 7 章 = 約束事, マクロパッケージなど (例: nroff, ascii)
55  第 8 章 = システム管理
56
57なお、日本語版マニュアルが、英語版マニュアルや Texinfo 形式のマニュアルに
58追従できていない場合があります。
59
60%{_defaultdocdir}/%{name}-%{version}/translation_list/ 以下にインストールされる翻訳
61進行状況リストを見て、適宜他の形式のマニュアルの原文に当たってください。
62
63
64%prep
65%setup -q -n man-pages-ja-%{rel}
66cp %{SOURCE1} installman.sh
67
68%build
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73### install jman pages ###
74make DESTDIR=$RPM_BUILD_ROOT install
75
76### copy translation_lists for installation ###
77(mkdir translation_list
78cd manual
79for i in */translation_list ; do
80    j=`echo $i | cut -d/ -f1`
81    cp -p $i ../translation_list/$j
82done
83)
84
85# move to %%{_mandir}/ja
86mkdir -p $RPM_BUILD_ROOT%{_mandir}
87mv $RPM_BUILD_ROOT%{_datadir}/jman $RPM_BUILD_ROOT%{_mandir}/ja
88
89# remove conflict files
90# shadow-utils, cdparanoia, man
91for i in \
92   man1/chage.1 man1/gpasswd.1 man1/newgrp.1 \
93   man1/sg.1 man5/faillog.5 man5/login.defs.5 \
94   man5/shadow.5 man8/adduser.8 man8/chpasswd.8 \
95   man8/faillog.8 man8/groupadd.8 man8/groupdel.8 \
96   man8/groupmod.8 man8/grpck.8 man8/grpconv.8 \
97   man8/grpunconv.8 man8/lastlog.8 man8/newusers.8 \
98   man8/pwck.8 man8/pwconv.8 man8/pwunconv.8 \
99   man8/useradd.8 man8/userdel.8 man8/usermod.8 \
100   man1/cdparanoia.1 \
101   man1/apropos.1 man1/man.1 man1/whatis.1
102do
103  rm $RPM_BUILD_ROOT%{_mandir}/ja/$i*
104done
105
106### make database ###
107# copy makewhatis to exec by a non-root user
108sed 's@/var/cache/man/whatis@%{buildroot}/usr/share/man/ja/whatis@g' \
109        < /usr/sbin/makewhatis > makewhatis
110sh ./makewhatis $RPM_BUILD_ROOT/usr/share/man/ja/
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(-,root,root)
117%doc ChangeLog INSTALL README translation_list
118%{_mandir}/ja
119
120%changelog
121* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-20090715vl5
122- source as of 20090715
123- move jman to %%{_mandir}/ja
124- remove conflict files
125
126* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20081015vl5
127- source as of 20081015
128
129* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.5-20080315vl5
130- applied new versioning policy, spec in utf-8
131
132* Sun Mar 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20080315vl1
133- source as of 20080315
134
135* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20070815vl1
136- source as of 20070815
137
138* Thu Oct 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20061015vl1
139- source as of 20061015
140
141* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5-20060715vl2
142- change Group to Applications/Documentation. <BTS:VineLinux:163>
143
144* Wed Jul 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20060715vl1
145- source as of 20060715
146
147* Mon Jan 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20060115vl1
148- source as of 20060115
149
150* Mon Sep 19 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20050915vl1
151- source as of 20050915
152
153* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20050615vl1
154- source as of 20050615
155
156* Wed Feb 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20050215vl1
157- source as of 20050215
158
159* Fri Sep 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20040915vl1
160- source as of 20040915
161- add BuildRequires: gzip, perl
162
163* Wed Jun 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20040615vl1
164- source as of 20040615
165
166* Wed May 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20040415vl1
167- source as of 20040415
168
169* Sun Dec 21 2003 IWAI, Masaharu <iwai@alib.jp> 0.5-20031215vl1
170- source as of 20031215
171- add crontab-0days.patch (Patch0)
172
173* Wed Oct 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20031015vl1
174- source as of 20031015
175
176* Wed Apr 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20030415vl1
177- source as of 20030415
178
179* Tue Feb 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20030217vl1
180- source as of 20030217
181
182* Thu Sep 22 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20020915vl1
183- source as of 20020915
184- add translation_list to %doc
185- updated description
186
187* Thu Sep 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20020828vl1
188- source as of 20020828
189
190* Fri May 31 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-20020515vl1
191- source as of 20020515
192
193* Tue Jan 15 2002 Toru Sagami <sagami@vinelinux.org> 0.5-20020115vl1
194- source as of 20020115
195
196* Sat Nov 17 2001 Toru Sagami <sagami@vinelinux.org>
197- 0.5-20011215
198
199* Sat Nov 17 2001 Toru Sagami <sagami@vinelinux.org>
200- 0.5-20011115: a bit modified to fit with current makewhatis
201
202* Fri Aug 17 2001 <sagami@vinelinux.org>
203- 0.5-20010815
204
205* Sun Jul 15 2001 <sagami@vinelinux.org>
206- 0.5-20010715
207
208* Tue Apr 17 2001 sagami@vinelinux.org
209- 0.5-20010415
210
211* Tue Sep  5 2000 Jun Nishii <jun@vinelinux.org>
212- 0.5-20000815
213
214* Thu Jul 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
215- added makewhatis patch.
216
217* Wed Jul 13 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
218- updated to 20000615.
219- added configure patch to create install script easily.
220- move man directory from /usr/share/man  to /usr/share/jman.
221
222* Tue Apr 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
223- updated to 20000415.
224- move man directory from ja_JP.ujis to ja.
225
226* Wed Mar 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
227- renew the installman.sh
228
229* Wed Mar 15 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
230- build man-20000315
231
232* Mon Dec 20 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
233- build man-19991215
234- Modified installman.sh, and %install to enable you to rebuild.
235
236* Wed Nov 11 1999 Jun Nishii <jun@flatout.org>
237- build man-991015
238- remove xjman (merged to XFree86)
239
240* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
241- build with good-whatis
242
243* Fri Apr 23 1999 Jun Nishii <jun@flatout.org>
244- added bug fixed man pages
245- move to /usr/share/man
246
247* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
248- added a message in summary, take a little time for installation
249
250* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
251- merged some bug fixed manuals
252- added rpm.8 rpm2cpio.8 (thanks Mr.Kanda)
253
254* Sat Jan 2 1999 Jun Nishii <jun@flatout.org>
255- updated to 0.4
256
257* Wed Nov 11 1998 Jun Nishii <jun@flatout.org>
258- use -p for makewhatis
259
260* Tue Oct 06 1998 Jun Nishii <jun@flatout.org>
261- first release
262
Note: See TracBrowser for help on using the repository browser.