source: projects/specs/trunk/j/jemalloc/jemalloc-vl.spec @ 12131

Revision 12131, 9.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           jemalloc
4Version:        5.2.1
5
6Release:        1%{?_dist_release}
7Summary:        General-purpose scalable concurrent malloc implementation
8Summary(ja):    汎用・スケーラブル・並行な malloc 実装
9
10Group:          System Environment/Libraries
11License:        BSD
12URL:            http://www.canonware.com/jemalloc/
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildRequires:  /usr/bin/xsltproc
21%ifnarch s390
22BuildRequires:  valgrind-devel
23%endif
24
25%description
26General-purpose scalable concurrent malloc(3) implementation.
27This distribution is the stand-alone "portable" implementation of %{name}.
28
29%package devel
30Summary:        Development files for %{name}
31Requires:       %{name} = %{version}-%{release}
32Group:          Development/Libraries
33
34%description devel
35The %{name}-devel package contains libraries and header files for
36developing applications that use %{name}.
37
38%package -n compat32-jemalloc
39Summary:        General-purpose scalable concurrent malloc implementation
40Summary(ja):    汎用・スケーラブル・並行な malloc 実装
41Group:          System Environment/Libraries
42
43%description -n compat32-jemalloc
44General-purpose scalable concurrent malloc(3) implementation.
45This distribution is the stand-alone "portable" implementation of %{name}.
46
47%prep
48%setup -q
49
50%build
51%ifarch i686
52%if 0%{?fedora} >= 21
53CFLAGS="%{optflags} -msse2"
54%endif
55%endif
56
57%if 0%{?rhel} && 0%{?rhel} < 7
58export LDFLAGS="%{?__global_ldflags} -lrt"
59%endif
60
61# disable Transparent HugePages on Vine Linux.
62perl -pi -e 's/je_cv_thp=yes/je_cv_thp=no/' configure
63
64%configure
65make %{?_smp_mflags}
66%check
67make check
68
69
70%install
71rm -rf %{buildroot}
72make install DESTDIR=%{buildroot}
73# Install this with doc macro instead
74rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
75
76# None of these in fedora
77find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
78
79
80%clean
81rm -rf %{buildroot}
82
83
84%files
85%defattr(-,root,root,-)
86%license COPYING
87%doc README VERSION
88%doc doc/jemalloc.html
89%{_libdir}/libjemalloc.so.*
90%{_bindir}/jemalloc.sh
91%{_bindir}/jemalloc-config
92%{_bindir}/jeprof
93%{_libdir}/pkgconfig/jemalloc.pc
94
95%files devel
96%defattr(-,root,root,-)
97%{_includedir}/jemalloc
98%{_libdir}/libjemalloc.so
99%{_mandir}/man3/jemalloc.3*
100
101%if %{build_compat32}
102%files -n compat32-jemalloc
103%{_libdir}/libjemalloc.so.*
104%endif
105
106%post
107/sbin/ldconfig
108
109%postun
110/sbin/ldconfig
111
112%changelog
113* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.2.1-1
114- new upstream release.
115
116* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.1.0-1
117- new upstream release.
118- added a sub-package 'compat32-jemalloc'.
119
120* Sat Dec 02 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.0.1-1
121- new upstream release.
122
123* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.5.0-1
124- new upstream release.
125
126* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.0-1
127- new upstream release.
128
129* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
130- new upstream release.
131
132* Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
133- new upstream release.
134
135* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
136- initial build for Vine Linux.
137
138* Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
139- New upstream release
140
141* Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
142- New upstream release
143- Removed oom test patch, it has been fixed upstream
144
145* Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
146- oom test also fails on 32bit ppc, so patch it out there as well
147
148* Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
149- New upstream release
150- Added a patch removing a non-critical test that fails on i386
151- Removed now included negative bitshift patch.
152
153* Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
154- New upstream release
155- Removed the no-pprof patch, as jemalloc now comes with its own prof variant
156- Removed atomic.h patch for armv5tel. jemalloc now provides a specific
157  variant for armv5tel
158- Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
159- Added -lrt to LDFLAGS for rhel<7
160
161* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
163
164* Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
165- valgrind-devel is not available on s390, closes #1131014
166
167* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
169
170* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
171- bz #1106933 fix only for fedora 21 and above
172
173* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
174- Added valgrind-devel to BuildRequires, fixing bz #974270
175
176* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
177- Added an i686 build fixing bz #1106933
178
179* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
181
182* Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
183- Patch that removes explicit altivec on el5/ppc
184
185* Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
186- New upstream release. This release fixes a critical regression
187
188* Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
189- New upstream release
190- Updated nopprof patch to match new release
191- Fixed a few bogus changelog entries
192
193* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
194- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
195
196* Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
197- New upstream release
198
199* Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
200- New upstream release
201- Dropped s390 patch, it's in upstream now.
202
203* Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
204- New upstream release
205 
206* Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
207- New upstream release
208 
209* Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
210- New upstream release
211- Removed ptmalloc_lock_all patch, it is merged upstream
212
213* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
215
216* Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
217- Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
218  closing #824646
219
220* Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
221- New upstream release
222- Updated no_pprof patch to match new release
223- Updated s390 patch to match new relase
224- Added make check
225- Added new script jemalloc.sh
226- Added a patch for atomic operations on epel5/ppc
227
228* Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
229- Improve ARM patch
230
231* Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
232- no attomics on armv5tel
233
234* Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
235- substitute version information in the header (#788517)
236
237* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
239
240* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
241- New upstream release, closes #75618
242
243* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
244- New upstream release
245
246* Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
247- New upstream release, closes #735057
248
249* Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
250- New upstream release, closes #727103
251- Updated no_pprof patch for 2.2.2
252
253* Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
254- New upstream release
255
256* Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
257- New upstream release
258- Updated no_pprof patch for 2.2.0
259
260* Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
261- New upstream release
262
263* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
265
266* Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
267- New upstream release
268
269* Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
270- New upstream release
271- Updated patch to remove pprof
272- Added html doc and xsltproc as a requirement to build it
273
274* Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
275- fix build on s390
276
277* Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
278- Added a patch that removes pprof, as it already exists in the
279  google-perftools package
280- Cosmetic fixes as requested in the package review (rhbz#653682)
281
282* Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
283- First cut of an rpm distribution of jemalloc
Note: See TracBrowser for help on using the repository browser.