source: projects/specs/trunk/j/jed/jed-vl.spec @ 8813

Revision 8813, 6.2 KB checked in by daisuke, 10 years ago (diff)

jed: small fix spec file

Line 
1%define mainver 0.99
2%define subver 19
3
4Summary: Fast, compact editor based on the S-Lang screen library
5Summary(ja): Slang 画面ライブラリを用いた高速でコンパクトなエディタ
6Name: jed
7Version: %{mainver}.%{subver}
8Release: 3%{?_dist_release}
9License: GPL+
10Group: Applications/Editors
11Source0: ftp://space.mit.edu/pub/davis/jed/v%{mainver}/jed-%{mainver}-%{subver}.tar.bz2
12Patch1: jed-0.99.12-xkeys.patch
13URL: http://www.jedsoft.org/jed/
14Patch2: jed-etc.patch
15Patch3: jed-multilib-newauto.patch
16Obsoletes: jed-common jed-xjed
17Requires: slang-slsh
18BuildRequires: slang-devel >= 2.0
19BuildRequires: autoconf
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22Vendor:       Project Vine
23Distribution: Vine Linux
24Packager:     Daisuke SUZUKI <daisuke@linux.or.jp>
25
26%description
27Jed is a fast, compact editor based on the S-lang screen library.  Jed
28features include emulation of the Emacs, EDT, WordStar and Brief
29editors; support for extensive customization with slang macros,
30colors, keybindings; and a variety of programming modes with syntax
31highlighting.
32
33You should install jed if you've used it before and you like it, or if
34you haven't used any text editors before and you're still deciding
35what you'd like to use.
36
37%description -l ja
38Jed は slang 画面ライブラリを使った高速でコンパクトなエディタです.
39Jed の機能には,Emacs/EDT/WordStar/Brief エディタのエミュレーション,
40カラー,キーバインド等の slang マクロを使った豊富なカスタマイズ機能
41等があります.他にも幾多のプログラミングモードを備えており,シンタックス
42ハイライト機能を備えています.
43
44%prep
45%setup -q -n jed-%{mainver}-%{subver}
46%patch1 -p1 -b .xkeys
47%patch2 -p1
48%if "%{_lib}" == "lib64"
49%patch3 -p1
50%endif
51
52find doc -type f -exec chmod a-x {} \;
53
54cd autoconf
55autoconf
56mv configure ..
57cd ..
58
59%build
60export JED_ROOT="%{_datadir}/jed"
61%configure
62make
63
64%install
65rm -rf $RPM_BUILD_ROOT
66make install DESTDIR=$RPM_BUILD_ROOT
67
68pushd $RPM_BUILD_ROOT%{_datadir}/jed
69  export JED_ROOT=.
70  ../../bin/jed -batch -n -l ./lib/preparse.sl < /dev/null
71popd
72
73rm -f $RPM_BUILD_ROOT%{_mandir}/man*/rgrep*
74
75rm -rf $RPM_BUILD_ROOT%{_datadir}/jed/doc/{txt,manual,README}
76rm -rf $RPM_BUILD_ROOT%{_datadir}/jed/bin $RPM_BUILD_ROOT%{_datadir}/jed/info
77
78sed -i "s|JED_ROOT|%{_datadir}/jed|g" $RPM_BUILD_ROOT/%{_mandir}/man1/jed.1
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(-,root,root)
85%doc COPYING COPYRIGHT doc INSTALL INSTALL.unx README changes.txt
86%{_bindir}/*
87%{_mandir}/man1/jed.*
88%{_datadir}/jed
89
90%changelog
91* Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.99.19-3
92- rebuilt
93
94* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.99.19-2
95- added Requires: slang-slsh
96
97* Sun Apr 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.19-1
98- new upstream release
99
100* Fri Jun 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.18-1
101- new upstream release
102- use slang-2.0
103- drop canna/slang-j patch
104- drop xjed, rgrep
105  - add Obsoletes: jed-xjed, jed-common
106
107* Sun Jan 13 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.99.14-0vl8
108- moved JED_ROOT to %%{_datadir}/jed
109- updated Source14: jed.sh and Source15: jed.csh
110
111* Tue Mar 27 2007 Shu KONNO <owa@bg.wakwak.com> 0.99.14-0vl7
112- added '--libdir=%%{_libdir}' to configure options
113- added Patch20: configure-slang.x86_64.patch
114- added Patch21: configure-canna.x86_64.patch
115
116* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.14-0vl6
117- disable canna by default
118
119* Fri Jul 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.14-0vl5
120- rebuild with new toolchains
121- s/Copyright/License/
122
123* Mon Feb 11 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.99.14-0vl4
124- added /etc/profile.d/jed.sh & jed.csh
125- added patch jed-initcolor.patch
126- fixed README.vine dot.jedrc.vine and jed.rc
127
128* Sat Feb  9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.99.14-0vl3
129- fixed input canna for xjed
130- delete jed-menu.patch
131- added BuildPrereq and info patch
132- added Help Browse Docs
133- modified README.vine
134
135* Wed Jan 23 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.99.14-0vl2
136- fixed menu mode (added jed-menu.patch and fixed jedrc patch)
137- fixed jed on kon console
138- add xjed.desktop and delete wmconfig/xjed
139
140* Wed Oct  3 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.99.14-0vl1
141- update to jed-B0.99-14
142- fixed ruby mode
143
144* Sat Sep  8 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.99.13-0vl4
145- delete xjed & gpm patches and clean spec file
146  added dot.skkrc.vine and fixed README.vine
147  skktcp moved jed-common from jed
148
149* Sat Jul 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 0.99.13-0vl3
150- delete rgrep package
151- add ruby mode
152- byte compiled japanese.sl kinsoku.sl canna.sl skk.sl
153- fixed vi.sl and jp version
154
155* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.13-0vl2
156- fixed typo in jed-B0.99-13jp0-make.patch
157  ( ../info/jes.* -> ../info/jed.* )
158
159* Wed Jun 27 2001 Matubara <matubara@mb.asmnet.ne.jp>
160- 0.99.13-0vl1
161- updatei to jed-B0.99-13
162- use jed-B0.99-13jp1 patch
163- use better macros
164- add skktcp
165- use Release No for Vine Linux
166
167* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
168- 0.98.7_jp-3
169- /usr/man -> %%{_mandir}
170- added Japanese summary and description
171
172* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
173- 0.98.7_jp-2
174- modified %files section to handle compressed man page(s)
175
176* Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
177- added japanese patch j055
178
179* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
180- auto rebuild in the new build environment (release 2)
181
182* Thu Oct 29 1998 Bill Nottingham <notting@redhat.com>
183- update to 0.98.7 for Raw Hide
184- split off lib stuff into jed-common
185
186* Mon Oct  5 1998 Jeff Johnson <jbj@redhat.com>
187- change rgep group tag, same as grep.
188
189* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
190- build root
191
192* Thu May 07 1998 Prospector System <bugs@redhat.com>
193- translations modified for de, fr, tr
194
195* Wed Apr 15 1998 Erik Troan <ewt@redhat.com>
196- built against new ncurses
197
198* Mon Nov  3 1997 Michael Fulbright <msf@redhat.com>
199- added wmconfig entry for xjed
200
201* Tue Oct 21 1997 Michael Fulbright <msf@redhat.com>
202- updated to 0.98.4
203- included man pages in file lists
204
205* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
206- built against glibc
Note: See TracBrowser for help on using the repository browser.