source: projects/specs/trunk/j/jd/jd-vl.spec @ 898

Revision 898, 6.1 KB checked in by inagaki, 14 years ago (diff)

updated: jd, squid

Line 
1###  for Vine Linux 4.x / 5.x  ###
2
3%define  pkg_version  2.6.0
4%define  strtag       100208
5%define  repoid       40140
6%define  vendor_rel   2
7
8%define  pre_release  0
9%if %{pre_release}
10%define  pkg_release  %{vendor_rel}.%{strtag}%{?_dist_release}
11%else
12%define  pkg_release  %{vendor_rel}%{?_dist_release}
13%endif
14
15## icon install dist dir
16%define  icondir  %{_datadir}/icons/hicolor
17
18## enable/disable sound (0:disable 1:enable)
19%define  sound  1
20
21Summary:      A 2ch browser
22Summary(ja):  2ちゃんねる用ブラウザ
23Name:         jd
24Version:      %{pkg_version}
25Release:      %{pkg_release}
26
27Source0:  http://prdownloads.sourceforge.jp/jd4linux/%{repoid}/%{name}-%{version}-%{strtag}.tgz
28Source1:  jd-vl.desktop
29
30# upstream svn patches
31# Patch100: jd-2.5.0_http_201.patch
32# Patch100: jd-2.4.0_close_err_image.patch
33# Patch110: jd-2.4.0_tag_drawing_fix.patch
34Patch100: jd-2.6.0_gtkmm28.patch
35
36License:  GPL
37Group:    Applications/Internet
38URL:      http://jd4linux.sourceforge.jp/
39
40Requires:  gtkmm2 >= 2.8
41Requires:  glibmm
42Requires:  zlib >= 1.2
43Requires:  pango
44Requires:  gnutls >= 1.2
45Prereq:    desktop-file-utils
46
47BuildRequires:  libtool, automake, autoconf
48BuildRequires:  gtkmm2-devel >= 2.8
49BuildRequires:  glibmm-devel
50BuildRequires:  zlib-devel >= 1.2
51BuildRequires:  XOrg-devel
52BuildRequires:  pango-devel
53BuildRequires:  gnutls-devel >= 1.2
54%if %{sound}
55BuildRequires:  alsa-lib-devel
56%endif
57BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root
58
59Packager: tomcat, iwamoto
60Vendor: Project Vine
61Distribution: Vine Linux
62
63%description
64JD is a 2ch browser based on gtkmm2.
65
66%description -l ja
67JD は gtkmm2 ベースの2ちゃんねる用ブラウザです。
68
69%prep
70%setup -q -n %{name}-%{version}-%{strtag}
71# find . -name .svn | sort -r | xargs %{__rm} -rf
72
73# Patch 100 - 200 are upstream patches
74# %patch100 -p2 -b .close_err_image
75%patch100 -p2 -b .gtkmm28
76
77%build
78autoreconf -i
79
80## set TZ for __TIME__
81export TZ='Asia/Tokyo'
82
83%if %{sound}
84%configure  --with-alsa
85%else
86%configure
87%endif
88
89%{__make} %{?_smp_mflags}
90
91%install
92%{__rm} -rf ${RPM_BUILD_ROOT}
93%{__make} install DESTDIR=${RPM_BUILD_ROOT}
94
95%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
96%{__install} -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/jd.desktop
97
98for i in 16 32 48 96;do \
99  %{__mkdir_p} ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps; \
100  %{__install} -p -m644 src/icons/%{name}$i.png ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps/%{name}.png; \
101done
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%post
107update-desktop-database %{_datadir}/applications
108
109%postun
110update-desktop-database %{_datadir}/applications
111
112
113%files
114%defattr(-,root,root)
115%doc COPYING ChangeLog README
116%{_bindir}/%{name}
117%{_datadir}/applications/%{name}.desktop
118%{_datadir}/pixmaps/%{name}.png
119%{icondir}/*/apps/%{name}.png
120
121%changelog
122* Mon Mar 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-2
123- add Patch100 to build fix with <= gtkmm28 (Vine 4.x env)
124
125* Mon Feb  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-1
126- new upstream release   
127
128* Sat Feb  6 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-0.100130
129- 2.6.0 rc1 (not for release)
130
131* Tue Dec 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
132- new upstream release 
133
134* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091225
135- 2.5.5 rc1 (not for release)
136
137* Wed Dec 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091220
138- 2.5.5 beta (not for release)
139- drop patch100 (included in new release)
140
141* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.0-1
142- new upstream release
143
144* Mon Sep 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.2-1
145- new upstream release
146
147* Tue Sep 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
148- 2.4.2-rc090921-0
149- for test
150
151* Mon Jul 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.1-1
152- new upstream release
153
154* Sat Jul 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
155- 2.4.1-rc090705-1
156- new upstream rc release for testing
157- drop patch100, 110 (included in new release)
158
159* Sat May 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.0-2
160- Merge spec file for vl4 and for vl5
161- add patch100, 110 from upstream svn
162
163* Sat May 23 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.4.0-1vl4
164- new upstream release
165
166* Fri Mar 06 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.3.0-1vl4
167- new upstream release
168
169* Fri Jan 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.0-2vl4
170- fix icon file install method
171
172* Sun Dec 28 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.1.0-1vl4
173- new upstream release
174
175* Mon Nov 24 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.3-1vl4
176- new upstream release
177
178* Wed Oct 01 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1vl4
179- rebuild for official
180
181* Sun Sep 21 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1tomvl4
182- update to 2.0.2
183
184* Sun Feb 03 2008 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom3
185- build with gnutls-1.4.1(official package)
186
187* Sun Dec 30 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom2
188- build with gnutls-1.6.3(unofficial package)
189
190* Sat Dec 29 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom1
191- new upstream release
192- drop Patch0 (jd-1.9.5-desktop-vi.patch)
193- add Source1 (jd-vi.desktop)
194
195* Fri Nov 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.7-1tom1
196- new upstream release
197
198* Sat Oct 06 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.6-1tom1
199- new upstream release
200
201* Wed Jul 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1tom2
202- modified jd-vi.spec
203- add patch0
204
205* Sun Jul 01 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1
206- new upstream release
207
208* Wed May 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-2
209- fix the Help file is not installed
210
211* Wed Apr 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-1
212- new upstream release
213
214* Sat Feb 03 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.5-1
215- new upstream release
216
217* Mon Dec 18 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.1-1
218- new upstream release
219
220* Thu Nov 30 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.0-1
221- initial build for Vine Linux
222
223* Sun Mar  9 2006 Houritsuchu <houritsuchu@hotmail.com>
224- Version up.
225- add icon
226
227* Sat Feb 25 2006 Houritsuchu <houritsuchu@hotmail.com>
228- first
Note: See TracBrowser for help on using the repository browser.