source: projects/specs/trunk/j/jd/jd-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1###  for Vine Linux 4.x / 5.x  ###
2
3%define  pkg_version  2.6.0
4%define  strtag       100208
5%define  repoid       40140
6%define  vendor_rel   1
7
8%define  pre_release  0
9%if %{pre_release}
10%define  pkg_release  %{vendor_rel}.%{strtag}%{?_dist_release}
11%else
12%define  pkg_release  %{vendor_rel}%{?_dist_release}
13%endif
14
15## icon install dist dir
16%define  icondir  %{_datadir}/icons/hicolor
17
18## enable/disable sound (0:disable 1:enable)
19%define  sound  1
20
21Summary:      A 2ch browser
22Summary(ja):  2ちゃんねる用ブラウザ
23Name:         jd
24Version:      %{pkg_version}
25Release:      %{pkg_release}
26
27Source0:  http://prdownloads.sourceforge.jp/jd4linux/%{repoid}/%{name}-%{version}-%{strtag}.tgz
28Source1:  jd-vl.desktop
29
30# upstream svn patches
31# Patch100: jd-2.5.0_http_201.patch
32# Patch100: jd-2.4.0_close_err_image.patch
33# Patch110: jd-2.4.0_tag_drawing_fix.patch
34
35License:  GPL
36Group:    Applications/Internet
37URL:      http://jd4linux.sourceforge.jp/
38
39Requires:  gtkmm2 >= 2.8
40Requires:  glibmm
41Requires:  zlib >= 1.2
42Requires:  pango
43Requires:  gnutls >= 1.2
44Prereq:    desktop-file-utils
45
46BuildRequires:  libtool, automake, autoconf
47BuildRequires:  gtkmm2-devel >= 2.8
48BuildRequires:  glibmm-devel
49BuildRequires:  zlib-devel >= 1.2
50BuildRequires:  XOrg-devel
51BuildRequires:  pango-devel
52BuildRequires:  gnutls-devel >= 1.2
53%if %{sound}
54BuildRequires:  alsa-lib-devel
55%endif
56BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root
57
58Packager: tomcat, iwamoto
59Vendor: Project Vine
60Distribution: Vine Linux
61
62%description
63JD is a 2ch browser based on gtkmm2.
64
65%description -l ja
66JD は gtkmm2 ベースの2ちゃんねる用ブラウザです。
67
68%prep
69%setup -q -n %{name}-%{version}-%{strtag}
70# find . -name .svn | sort -r | xargs %{__rm} -rf
71
72# Patch 100 - 200 are upstream patches
73# %patch100 -p2 -b .close_err_image
74
75%build
76autoreconf -i
77
78## set TZ for __TIME__
79export TZ='Asia/Tokyo'
80
81%if %{sound}
82%configure  --with-alsa
83%else
84%configure
85%endif
86
87%{__make} %{?_smp_mflags}
88
89%install
90%{__rm} -rf ${RPM_BUILD_ROOT}
91%{__make} install DESTDIR=${RPM_BUILD_ROOT}
92
93%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
94%{__install} -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/jd.desktop
95
96for i in 16 32 48 96;do \
97  %{__mkdir_p} ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps; \
98  %{__install} -p -m644 src/icons/%{name}$i.png ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps/%{name}.png; \
99done
100
101%clean
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104%post
105update-desktop-database %{_datadir}/applications
106
107%postun
108update-desktop-database %{_datadir}/applications
109
110
111%files
112%defattr(-,root,root)
113%doc COPYING ChangeLog README
114%{_bindir}/%{name}
115%{_datadir}/applications/%{name}.desktop
116%{_datadir}/pixmaps/%{name}.png
117%{icondir}/*/apps/%{name}.png
118
119%changelog
120* Mon Feb  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-1
121- new upstream release   
122
123* Sat Feb  6 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-0.100130
124- 2.6.0 rc1 (not for release)
125
126* Tue Dec 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
127- new upstream release 
128
129* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091225
130- 2.5.5 rc1 (not for release)
131
132* Wed Dec 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091220
133- 2.5.5 beta (not for release)
134- drop patch100 (included in new release)
135
136* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.0-1
137- new upstream release
138
139* Mon Sep 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.2-1
140- new upstream release
141
142* Tue Sep 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
143- 2.4.2-rc090921-0
144- for test
145
146* Mon Jul 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.1-1
147- new upstream release
148
149* Sat Jul 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
150- 2.4.1-rc090705-1
151- new upstream rc release for testing
152- drop patch100, 110 (included in new release)
153
154* Sat May 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.0-2
155- Merge spec file for vl4 and for vl5
156- add patch100, 110 from upstream svn
157
158* Sat May 23 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.4.0-1vl4
159- new upstream release
160
161* Fri Mar 06 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.3.0-1vl4
162- new upstream release
163
164* Fri Jan 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.0-2vl4
165- fix icon file install method
166
167* Sun Dec 28 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.1.0-1vl4
168- new upstream release
169
170* Mon Nov 24 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.3-1vl4
171- new upstream release
172
173* Wed Oct 01 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1vl4
174- rebuild for official
175
176* Sun Sep 21 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1tomvl4
177- update to 2.0.2
178
179* Sun Feb 03 2008 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom3
180- build with gnutls-1.4.1(official package)
181
182* Sun Dec 30 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom2
183- build with gnutls-1.6.3(unofficial package)
184
185* Sat Dec 29 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom1
186- new upstream release
187- drop Patch0 (jd-1.9.5-desktop-vi.patch)
188- add Source1 (jd-vi.desktop)
189
190* Fri Nov 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.7-1tom1
191- new upstream release
192
193* Sat Oct 06 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.6-1tom1
194- new upstream release
195
196* Wed Jul 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1tom2
197- modified jd-vi.spec
198- add patch0
199
200* Sun Jul 01 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1
201- new upstream release
202
203* Wed May 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-2
204- fix the Help file is not installed
205
206* Wed Apr 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-1
207- new upstream release
208
209* Sat Feb 03 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.5-1
210- new upstream release
211
212* Mon Dec 18 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.1-1
213- new upstream release
214
215* Thu Nov 30 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.0-1
216- initial build for Vine Linux
217
218* Sun Mar  9 2006 Houritsuchu <houritsuchu@hotmail.com>
219- Version up.
220- add icon
221
222* Sat Feb 25 2006 Houritsuchu <houritsuchu@hotmail.com>
223- first
Note: See TracBrowser for help on using the repository browser.