source: projects/specs/trunk/j/jd/jd-vl.spec @ 971

Revision 971, 6.6 KB checked in by iwamoto, 14 years ago (diff)

new upstream release

Line 
1###  for Vine Linux 4.x / 5.x  ###
2
3%define  pkg_version  2.6.5
4%define  strtag       100425
5%define  repoid       40140
6%define  vendor_rel   3
7
8%define  pre_release  0
9%if %{pre_release}
10%define  pkg_release  %{vendor_rel}.%{strtag}%{?_dist_release}
11%else
12%define  pkg_release  %{vendor_rel}%{?_dist_release}
13%endif
14
15## icon install dist dir
16%define  icondir  %{_datadir}/icons/hicolor
17
18## enable/disable sound (0:disable 1:enable)
19%define  sound  1
20
21Summary:      A 2ch browser
22Summary(ja):  2ちゃんねる用ブラウザ
23Name:         jd
24Version:      %{pkg_version}
25Release:      %{pkg_release}
26
27Source0:  http://prdownloads.sourceforge.jp/jd4linux/%{repoid}/%{name}-%{version}-%{strtag}.tgz
28Source1:  jd-vl.desktop
29
30# upstream svn patches
31# Patch100: jd-2.5.0_http_201.patch
32# Patch100: jd-2.4.0_close_err_image.patch
33# Patch110: jd-2.4.0_tag_drawing_fix.patch
34# Patch100: jd-2.6.0_gtkmm28.patch
35Patch110: jd-2.6.5_vine4.patch
36
37License:  GPL
38Group:    Applications/Internet
39URL:      http://jd4linux.sourceforge.jp/
40
41Requires:  gtkmm2 >= 2.8
42Requires:  glibmm
43Requires:  zlib >= 1.2
44Requires:  pango
45Requires:  gnutls >= 1.2
46Requires(pre): desktop-file-utils
47# Prereq:    desktop-file-utils
48
49BuildRequires:  libtool, automake, autoconf
50BuildRequires:  gtkmm2-devel >= 2.8
51BuildRequires:  glibmm-devel
52BuildRequires:  zlib-devel >= 1.2
53BuildRequires:  XOrg-devel
54BuildRequires:  pango-devel
55BuildRequires:  gnutls-devel >= 1.2
56BuildRequires:  libgpg-error-devel
57%if %{sound}
58BuildRequires:  alsa-lib-devel
59%endif
60BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root
61
62Packager: tomcat, iwamoto
63Vendor: Project Vine
64Distribution: Vine Linux
65
66%description
67JD is a 2ch browser based on gtkmm2.
68
69%description -l ja
70JD は gtkmm2 ベースの2ちゃんねる用ブラウザです。
71
72%prep
73%setup -q -n %{name}-%{version}-%{strtag}
74# find . -name .svn | sort -r | xargs %{__rm} -rf
75
76# Patch 100 - 200 are upstream patches
77# %patch100 -p2 -b .close_err_image
78# %patch100 -p2 -b .gtkmm28
79%if %{?_dist_release} == "vl4"
80%patch110 -p1 -b .vine4
81%endif
82
83%build
84autoreconf -i
85
86## set TZ for __TIME__
87export TZ='Asia/Tokyo'
88
89%if %{sound}
90%configure  --with-alsa
91%else
92%configure
93%endif
94
95%{__make} %{?_smp_mflags}
96
97%install
98%{__rm} -rf ${RPM_BUILD_ROOT}
99%{__make} install DESTDIR=${RPM_BUILD_ROOT}
100
101%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
102%{__install} -p -m644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/jd.desktop
103
104for i in 16 32 48 96;do \
105  %{__mkdir_p} ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps; \
106  %{__install} -p -m644 src/icons/%{name}$i.png ${RPM_BUILD_ROOT}%{icondir}/$i"x"$i/apps/%{name}.png; \
107done
108
109%clean
110%{__rm} -rf ${RPM_BUILD_ROOT}
111
112%post
113update-desktop-database %{_datadir}/applications
114
115%postun
116update-desktop-database %{_datadir}/applications
117
118
119%files
120%defattr(-,root,root)
121%doc COPYING ChangeLog README
122%{_bindir}/%{name}
123%{_datadir}/applications/%{name}.desktop
124%{_datadir}/pixmaps/%{name}.png
125%{icondir}/*/apps/%{name}.png
126
127%changelog
128* Sun May  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-3
129- chaneg tag Prereq: -> Requires(pre):
130
131* Thu Apr 29 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-2
132- add patch110 to fix build error on Vine4
133- add BR: libgpg-error-devel
134
135* Wed Apr 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.5-1
136- new upstream release   
137- drop Patch100 (is included in new release)
138
139* Mon Mar 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-2
140- add Patch100 to build fix with <= gtkmm28 (Vine 4.x env)
141
142* Mon Feb  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-1
143- new upstream release   
144
145* Sat Feb  6 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.0-0.100130
146- 2.6.0 rc1 (not for release)
147
148* Tue Dec 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
149- new upstream release 
150
151* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091225
152- 2.5.5 rc1 (not for release)
153
154* Wed Dec 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-0.091220
155- 2.5.5 beta (not for release)
156- drop patch100 (included in new release)
157
158* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.0-1
159- new upstream release
160
161* Mon Sep 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.2-1
162- new upstream release
163
164* Tue Sep 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
165- 2.4.2-rc090921-0
166- for test
167
168* Mon Jul 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.1-1
169- new upstream release
170
171* Sat Jul 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
172- 2.4.1-rc090705-1
173- new upstream rc release for testing
174- drop patch100, 110 (included in new release)
175
176* Sat May 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.0-2
177- Merge spec file for vl4 and for vl5
178- add patch100, 110 from upstream svn
179
180* Sat May 23 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.4.0-1vl4
181- new upstream release
182
183* Fri Mar 06 2009 tomcat <webmaster2@tomcat.nyanta.jp> 2.3.0-1vl4
184- new upstream release
185
186* Fri Jan 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.0-2vl4
187- fix icon file install method
188
189* Sun Dec 28 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.1.0-1vl4
190- new upstream release
191
192* Mon Nov 24 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.3-1vl4
193- new upstream release
194
195* Wed Oct 01 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1vl4
196- rebuild for official
197
198* Sun Sep 21 2008 tomcat <webmaster2@tomcat.nyanta.jp> 2.0.2-1tomvl4
199- update to 2.0.2
200
201* Sun Feb 03 2008 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom3
202- build with gnutls-1.4.1(official package)
203
204* Sun Dec 30 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom2
205- build with gnutls-1.6.3(unofficial package)
206
207* Sat Dec 29 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.8-1tom1
208- new upstream release
209- drop Patch0 (jd-1.9.5-desktop-vi.patch)
210- add Source1 (jd-vi.desktop)
211
212* Fri Nov 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.7-1tom1
213- new upstream release
214
215* Sat Oct 06 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.6-1tom1
216- new upstream release
217
218* Wed Jul 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1tom2
219- modified jd-vi.spec
220- add patch0
221
222* Sun Jul 01 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.9.5-1
223- new upstream release
224
225* Wed May 23 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-2
226- fix the Help file is not installed
227
228* Wed Apr 04 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.8-1
229- new upstream release
230
231* Sat Feb 03 2007 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.5-1
232- new upstream release
233
234* Mon Dec 18 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.1-1
235- new upstream release
236
237* Thu Nov 30 2006 tomcat <webmaster2@tomcat.nyanta.jp> 1.8.0-1
238- initial build for Vine Linux
239
240* Sun Mar  9 2006 Houritsuchu <houritsuchu@hotmail.com>
241- Version up.
242- add icon
243
244* Sat Feb 25 2006 Houritsuchu <houritsuchu@hotmail.com>
245- first
Note: See TracBrowser for help on using the repository browser.