source: projects/specs/trunk/j/java_cup/java_cup-vl.spec @ 9288

Revision 9288, 8.3 KB checked in by inagaki, 9 years ago (diff)

2015-01-24 Ryoichi INAGAKI <ryo1@…>

  • java_cup: added Patch
  • rhino, xerces-c, xml-common-apis, xmlcopyeditor: updated


Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define pkg_version     11a
32%define section         free
33##define with_bootstrap  0
34%define with_bootstrap  1
35
36Name:           java_cup
37Version:        0.11a
38Release:        7%{?_dist_release}
39Summary:        Java source interpreter
40
41Group:          Development/Libraries
42License:        MIT
43URL:            http://www.cs.princeton.edu/%7Eappel/modern/java/CUP/
44
45#svn export -r 21 https://www2.in.tum.de/repos/cup/develop/ java_cup-0.11a
46#tar cjf java_cup-0.11a.tar.bz2 java_cup-0.11a/
47Source0:        java_cup-0.11a.tar.bz2
48Source1:        java_cup-pom.xml
49# Add OSGi manifests
50Source2:        %{name}-MANIFEST.MF
51Source4:        %{name}-runtime-MANIFEST.MF
52# Taken from http://www2.cs.tum.edu/projects/cup/
53Source3:        LICENSE.txt
54
55Patch0:         %{name}-build.patch
56Patch1:         java_cup-0.11a-manifest.patch
57# Patch from eclipe-pdt to get around generated actions methods exceeding the 65535 bytes limit:
58# http://git.eclipse.org/c/pdt/org.eclipse.pdt.git/tree/plugins/org.eclipse.php.core.parser/javacup10k_split_do_action_method.diff
59Patch2:         javacup10k_split_do_action_method.diff
60
61BuildArch:      noarch
62BuildRoot:      %{_tmppath}/%{name}-%{version}-root
63BuildRequires:  ant
64BuildRequires:  java-devel
65BuildRequires:  jpackage-utils >= 1.5
66#BuildRequires: jflex
67%if !%{with_bootstrap}
68BuildRequires:  java_cup >= 0.11a
69%endif
70BuildRequires:  zip
71Requires:       java-headless
72
73%description
74java_cup is a LALR Parser Generator for Java
75
76%package javadoc
77Summary: Javadoc for java_cup
78Summary(ja): java_cup の Javadoc
79Group: Documentation
80
81%description javadoc
82Javadoc for java_cup
83
84%package manual
85Summary: Documentation for java_cup
86Summary(ja): java_cup のドキュメント
87Group: Documentation
88
89%description manual
90Documentation for java_cup.
91
92%prep
93%setup -q
94%patch0 -b .build
95%patch1 -p1 -b .manifest
96pushd src
97%patch2 -p1 -b .orig
98popd
99cp %{SOURCE1} pom.xml
100cp %{SOURCE3} .
101
102# remove all binary files
103find -name "*.class" -delete
104
105%if ! %{with_bootstrap}
106# remove prebuilt JFlex
107rm -rf java_cup-0.11a/bin/JFlex.jar
108
109# remove prebuilt java_cup, if not bootstrapping
110rm -rf java_cup-0.11a/bin/java-cup-11.jar
111%endif
112
113%build
114%if !%{with_bootstrap}
115export CLASSPATH=$(build-classpath java_cup java_cup-runtime jflex)
116%endif
117
118ant
119find . -name parser.cup -exec rm {} \;
120ant javadoc
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125# inject OSGi manifests
126mkdir -p META-INF
127cp -p %{SOURCE2} META-INF/MANIFEST.MF
128touch META-INF/MANIFEST.MF
129zip -u dist/java-cup-%{pkg_version}.jar META-INF/MANIFEST.MF
130cp -p %{SOURCE4} META-INF/MANIFEST.MF
131touch META-INF/MANIFEST.MF
132zip -u dist/java-cup-%{pkg_version}-runtime.jar META-INF/MANIFEST.MF
133
134# jar
135install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
136install -m 644 dist/java-cup-%{pkg_version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
137install -m 644 dist/java-cup-%{pkg_version}-runtime.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-runtime-%{version}.jar
138
139# poms
140#install -d -m 755 %{buildroot}%{_mavenpomdir}
141#install -pm 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
142#add_maven_depmap
143
144# javadoc
145install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
146cp -pr dist/javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
147
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152#post
153#update_maven_depmap
154
155#postun
156#update_maven_depmap
157
158%files
159%defattr(0644,root,root,0755)
160%doc changelog.txt LICENSE.txt
161%{_javadir}/*
162
163%files manual
164%defattr(0644,root,root,0755)
165%doc manual.html LICENSE.txt
166
167%files javadoc
168%defattr(0644,root,root,0755)
169%doc LICENSE.txt
170%{_javadocdir}/%{name}
171
172%changelog
173* Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.11a-7
174- rebuilt on current VineSeed
175- added Patch1 and Patch2
176
177* Sat Jun  2 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11a-6
178- rebuilt with rpm-4.8.1-3
179- updated URL
180
181* Sat Sep  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11a-5
182- Initial build for Vine Linux
183
184* Mon Feb 15 2010 Alexander Kurtakov <akurtako@redhat.com> 1:0.11a-4
185- Add maven pom and depmap.
186
187* Wed Jan 20 2010 Alexander Kurtakov <akurtako@redhat.com> 1:0.11a-3
188- Fix bootstrap.
189
190* Sun Jan 17 2010 Miloš Jakubíček <xjakub@fi.muni.cz> - 1:0.11a-2
191- Rebuilt in non-bootstrap mode (removed all prebuilt jars).
192- Added BR: jflex and java_cup >= 1:0.11a for non-bootstrap mode
193- Remove unnecessary R(post,postun): coreutils
194
195* Fri Jan 8 2010 Alexander Kurtakov <akurtako@redhat.com> 1:0.11a-1
196- Update to 0.11a.
197- Drop gcj_support.
198
199* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.10k-3
200- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
201
202* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.10k-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
204
205* Tue Jul 15 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:0.10k-1
206- Fix the version to match upstream, so that FEver can be used
207
208* Wed Jul  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:0.10-0.k.6.3
209- drop repotag
210
211* Sun Feb 17 2008 Lubomir Kundrak <lkundrak@redhat.com> - 1:0.10-0.k.6jpp.2
212- Ant task
213- Clean up to satisfy QA script and rpmlint
214
215* Fri Aug 04 2006 Vivek Lakshmanan <vivekl@redhat.com> - 1:0.10-0.k.6jpp.1
216- Re-sync with latest version from JPP.
217- Partially adopt new naming convention.
218
219* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 1:0.10-0.k.5jpp_2fc
220- Rebuilt
221
222* Thu Jul 20 2006 Vivek Lakshmanan <vivekl@redhat.com> - 1:0.10-0.k.5jpp_1fc
223- Re-sync with latest version from JPP.
224
225* Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 1:0.10-0.k.4jpp_1fc
226- Conditional native compilation for GCJ.
227
228* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:0.10-0.k.1jpp_10fc
229- rebuild
230
231* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1:0.10-0.k.1jpp_9fc
232- stop scriptlet spew
233
234* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:0.10-0.k.1jpp_8fc
235- bump again for double-long bug on ppc(64)
236
237* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:0.10-0.k.1jpp_7fc
238- rebuilt for new gcc4.1 snapshot and glibc changes
239
240* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1:0.10-0.k.1jpp_6fc
241- rebuilt again
242
243* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
244- rebuilt
245
246* Tue Jul 19 2005 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_5fc
247- Build on ia64, ppc64, s390 and s390x.
248- Switch to aot-compile-rpm.
249
250* Tue Jun 28 2005 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_4fc
251- BC-compile.
252
253* Tue Jun 21 2005 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_3fc
254- Remove classes from the tarball.
255
256* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 1:0.10-0.k.1jpp_2fc
257- Build into Fedora.
258
259* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> 1:0.10-0.k.1jpp_1rh
260- RH vacuuming
261
262* Thu Jan 22 2004 David Walluck <david@anti-microsoft.org> 1:0.10-0.k.1jpp
263- fix version/release (bump epoch)
264- change License tag from Free to BSD-style
265- add Distribution tag
266- really update for JPackage 1.5
267
268* Wed Mar 26 2003 Paul Nasrat <pauln@truemesh.com> 0.10k-1jpp
269- for jpackage-utils 1.5
270- New spec reverse engineered from binary rpms
Note: See TracBrowser for help on using the repository browser.