source: projects/specs/trunk/j/jasper1/jasper1-vl.spec @ 10956

Revision 10956, 6.6 KB checked in by tomop, 7 years ago (diff)

gd, jasper, jasper1, libtiff, openjpeg2, sqlite3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:        jasper1
4Summary:     implementation of the JPEG-2000 standard, Part 1
5Version:     1.900.1
6Release:     12%{?_dist_release}
7
8Group:       Applications/Graphics
9License:     Modified BSD (see LICENSE)
10URL:         http://www.ece.uvic.ca/~mdadams/jasper/
11
12Source:      jasper-%{version}.zip
13
14Patch1: jasper-1.701.0-GL.patch
15# autoconf/automake bits of patch1
16Patch2: jasper-1.701.0-GL-ac.patch
17# CVE-2007-2721 (bug #240397)
18# borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=413041;msg=88
19Patch3: patch-libjasper-stepsizes-overflow.diff
20# borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469786
21Patch4: jpc_dec.c.patch
22# OpenBSD hardening patches addressing couple of possible integer overflows
23# during the memory allocations
24# https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3520
25Patch5: jasper-1.900.1-CVE-2008-3520.patch
26# https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-3522
27Patch6: jasper-1.900.1-CVE-2008-3522.patch
28# add pkg-config support
29Patch7: jasper-pkgconfig.patch
30
31Patch8: jasper-1.900.1-CVE-2011-4516-CVE-2011-4517-CERT-VU-887409.patch
32
33Patch9: jasper-CVE-2014-9029.patch
34Patch10: jasper-CVE-2014-8137.patch
35Patch11: jasper-CVE-2014-8138.patch
36
37# Issues found by static analysis of code
38Patch110: jasper-1.900.1-Coverity-BAD_SIZEOF.patch
39Patch111: jasper-1.900.1-Coverity-CHECKED_RETURN.patch
40Patch112: jasper-1.900.1-Coverity-FORWARD_NULL.patch
41Patch113: jasper-1.900.1-Coverity-NULL_RETURNS.patch
42Patch114: jasper-1.900.1-Coverity-RESOURCE_LEAK.patch
43Patch115: jasper-1.900.1-Coverity-UNREACHABLE.patch
44Patch116: jasper-1.900.1-Coverity-UNUSED_VALUE.patch
45
46# from debian
47Patch1000: 09-CVE-2016-1577.patch
48Patch1001: 10-CVE-2016-2089.patch
49Patch1002: 11-CVE-2016-2116.patch
50
51BuildRoot:   %{_tmppath}/jasper-%{version}-root
52BuildRequires: autoconf automake libtool
53BuildRequires: freeglut-devel
54BuildRequires: libGLU-devel
55BuildRequires: libjpeg-devel
56BuildRequires: pkgconfig
57
58Requires:    jasper-libs = %{version}-%{release}
59
60Vendor:       Project Vine
61Distribution: Vine Linux
62
63%description
64JasPer is a collection of software (i.e., a library and application
65programs) for the coding and manipulation of images.  This software
66can handle image data in a variety of formats.  One such format
67supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
68
69%package libs
70Summary: Runtime libraries for jasper
71Group:   System Environment/Libraries
72
73%description libs
74This package contains runtime libraries for JasPer.
75
76# compat32
77%package -n compat32-jasper1-libs
78Summary: Runtime libraries for jasper
79Group:   System Environment/Libraries
80
81%description -n compat32-jasper1-libs
82This package contains runtime libraries for JasPer.
83
84
85%prep
86%setup -q -n jasper-%{version}
87
88%patch1 -p1 -b .GL
89%patch2 -p1 -b .GL-ac
90%patch3 -p1 -b .CVE-2007-2721
91%patch4 -p1 -b .jpc_dec_assertion
92%patch5 -p1 -b .CVE-2008-3520
93%patch6 -p1 -b .CVE-2008-3522
94%patch7 -p1 -b .pkgconfig
95%patch8 -p1 -b .CVE-2011-4516-4517
96%patch9 -p1 -b .CVE-2014-9029
97%patch10 -p1 -b .CVE-2014-8137-variant2
98%patch11 -p1 -b .CVE-2014-8138
99
100%patch110 -p1 -b .BAD_SIZEOF
101%patch111 -p1 -b .CHECKED_RETURN
102%patch112 -p1 -b .FORWARD_NULL
103%patch113 -p1 -b .NULL_RETURNS
104%patch114 -p1 -b .RESOURCE_LEAK
105%patch115 -p1 -b .UNREACHABLE
106%patch116 -p1 -b .UNUSED_VALUE
107
108%patch1000 -p1 -b .CVE-2016-1577
109%patch1001 -p1 -b .CVE-2016-2089
110%patch1002 -p1 -b .CVE-2016-2116
111
112autoreconf --verbose --force --install
113
114%build
115CFLAGS="%{optflags} -fno-strict-overflow" \
116%configure --enable-shared --disable-static
117
118make %{?_smp_mflags}
119
120%install
121[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
122make install DESTDIR=$RPM_BUILD_ROOT
123
124# remove .la
125rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
126
127%clean
128[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
129
130%post libs -p /sbin/ldconfig
131
132%postun libs -p /sbin/ldconfig
133
134%post -n compat32-jasper1-libs -p /sbin/ldconfig
135
136%postun -n compat32-jasper1-libs -p /sbin/ldconfig
137
138%files libs
139%defattr(-,root,root)
140%{_libdir}/libjasper*.so.*
141
142# compat32
143%if %{build_compat32}
144%files -n compat32-jasper1-libs
145%defattr(-,root,root)
146%{_libdir}/libjasper*.so.*
147%endif
148
149%changelog
150* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-12
151- created a new package for compatibility only.
152
153* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
154- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
155
156* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
157- imported all patches from RawHide.
158
159* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
160- rebuild with libpng-1.6.12
161
162* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
163- rebuilt with current VineSeed
164
165* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
166- added compat32 subpackage for x86_64 arch support.
167
168* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
169- splited out runtime library to sub package
170- enable opengl again, add BuildRequires: freeglut-devel
171
172* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
173- remove .la
174- add --disable-static to configure option
175
176* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
177- added Patch0 from VinePlus/4.0
178  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
179  - add patch100 for fix CVE-2007-2721
180  - add Vendor/Distributin Tag
181
182* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
183- remove BuildPrereq: freeglut-devel and Requires freeglut
184- add --disable-opengl to configure option
185
186* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
187- add BuildPreReq: unzip (used in the %%pre section)
188
189* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
190- new upstream release
191
192* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
193- new upstream release
194- changed Group to System Environment/Libraries
195- added --mandir=%{_mandir}
196- added %post and %postun section
197
198* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
199- added --libdir=%{_libdir} configure option
200
201* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
202- build with freeglut
203- change BuildPrereq and Requires
204
205* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
206- new upstream version (jasper-1.701.0)
207
208* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
209- rebuild for VineSeedPlus
210
211* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
212- source upgrade
213- change spec to build for VineLinux
214
215* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
216- spec file created
Note: See TracBrowser for help on using the repository browser.