source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 12484

Revision 12484, 6.1 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

LibRaw?-0.20.0-1

OpenImageIO-2.2.6.1-1

babl-0.1.78-1

gegl04-0.4.26-1

gthumb-3.10.0-1

jasper-2.0.19-1

pugixml-1.10-1

pybind11-2.5.0-7

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           jasper
4Summary:        implementation of the JPEG-2000 standard, Part 1
5Version:        2.0.19
6Release:        1%{?_dist_release}
7Group:          graphics
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        Modified BSD (see LICENSE)
12URL:            https://www.ece.uvic.ca/~frodo/jasper/
13Source:         https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
14
15# skip hard-coded prefix/lib rpath
16Patch1:         jasper-2.0.14-rpath.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  autoconf automake libtool
20BuildRequires:  freeglut-devel
21BuildRequires:  libGLU-devel
22BuildRequires:  libjpeg-devel
23BuildRequires:  pkgconfig
24BuildRequires:  cmake
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28%description
29JasPer is a collection of software (i.e., a library and application
30programs) for the coding and manipulation of images.  This software
31can handle image data in a variety of formats.  One such format
32supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
33
34
35%package devel
36Summary:     Include Files and Documentation for jasper
37Group:       programming
38Requires:    %{name}-libs = %{version}-%{release}
39Requires:    libjpeg-devel
40
41%description devel
42This package contains libjasper, a library implementing the JPEG-2000
43image compression standard Part 1.
44
45
46%package libs
47Summary: Runtime libraries for %{name}
48Group:   system
49
50%description libs
51This package contains runtime libraries for JasPer.
52
53
54# compat32
55%package -n compat32-%{name}-devel
56Summary:     Include Files and Documentation for jasper
57Group:       programming
58Requires:    %{name}-libs = %{version}-%{release}
59Requires:    compat32-libjpeg-devel
60
61%description -n compat32-%{name}-devel
62This package contains libjasper, a library implementing the JPEG-2000
63image compression standard Part 1.
64
65
66%package -n compat32-%{name}-libs
67Summary: Runtime libraries for %{name}
68Group:   system
69
70%description -n compat32-%{name}-libs
71This package contains runtime libraries for JasPer.
72
73
74%prep
75%setup -q -n %{name}-version-%{version}
76
77%patch1 -p1 -b .rpath
78
79
80%build
81mkdir -p builder
82pushd builder
83%cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
84popd
85%make_build -C builder
86
87
88%install
89[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
90make install/fast DESTDIR=%{buildroot} -C builder
91
92# Unpackaged files
93rm -f doc/README
94rm -f %{buildroot}%{_libdir}/lib*.la
95rm -rf %{buildroot}%{_docdir}/JasPer
96
97
98%check
99make test -C builder
100
101
102%clean
103[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
104
105
106%post libs -p /sbin/ldconfig
107%postun libs -p /sbin/ldconfig
108
109%post -n compat32-%{name}-libs -p /sbin/ldconfig
110%postun -n compat32-%{name}-libs -p /sbin/ldconfig
111
112
113%files
114%defattr(-,root,root)
115%{!?_licensedir:%global license %%doc}
116%{_bindir}/*
117%{_mandir}/man1/*
118
119%files libs
120%license COPYRIGHT LICENSE
121%doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
122%defattr(-,root,root)
123%{_libdir}/libjasper*.so.*
124
125%files devel
126%defattr(-,root,root)
127%{_includedir}/jasper
128%{_libdir}/libjasper*.so
129%{_libdir}/pkgconfig/jasper.pc
130
131# compat32
132%if %{build_compat32}
133%files -n compat32-%{name}-libs
134%defattr(-,root,root)
135%{_libdir}/libjasper*.so.*
136
137%files -n compat32-%{name}-devel
138%defattr(-,root,root)
139%{_libdir}/libjasper*.so
140%{_libdir}/pkgconfig/jasper.pc
141%endif
142
143%changelog
144* Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
145- new upstream release.
146
147* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
148- new upstream release.
149- dropped Patch1: fixed in upstream.
150- imported Patch1 from rawhide.
151
152* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
153- new upstream release.
154- dropped all patches.
155- imported patch1 from rawhide.
156
157* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
158- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
159
160* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
161- imported all patches from RawHide.
162
163* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
164- rebuild with libpng-1.6.12
165
166* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
167- rebuilt with current VineSeed
168
169* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
170- added compat32 subpackage for x86_64 arch support.
171
172* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
173- splited out runtime library to sub package
174- enable opengl again, add BuildRequires: freeglut-devel
175
176* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
177- remove .la
178- add --disable-static to configure option
179
180* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
181- added Patch0 from VinePlus/4.0
182  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
183  - add patch100 for fix CVE-2007-2721
184  - add Vendor/Distributin Tag
185
186* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
187- remove BuildPrereq: freeglut-devel and Requires freeglut
188- add --disable-opengl to configure option
189
190* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
191- add BuildPreReq: unzip (used in the %%pre section)
192
193* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
194- new upstream release
195
196* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
197- new upstream release
198- changed Group to System Environment/Libraries
199- added --mandir=%{_mandir}
200- added %post and %postun section
201
202* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
203- added --libdir=%{_libdir} configure option
204
205* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
206- build with freeglut
207- change BuildPrereq and Requires
208
209* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
210- new upstream version (jasper-1.701.0)
211
212* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
213- rebuild for VineSeedPlus
214
215* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
216- source upgrade
217- change spec to build for VineLinux
218
219* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
220- spec file created
Note: See TracBrowser for help on using the repository browser.