source: projects/specs/trunk/i/iverilog/iverilog-vl.spec @ 5620

Revision 5620, 5.7 KB checked in by kenta, 12 years ago (diff)

iverilog: new upstream release

Line 
1# TODO for 1.0 release - redefine
2#Version:     0.9.%{snapshot}
3#Release:     6%{?dist}
4# to
5#Version:     1.0
6#Release:     1.snap%{snapshot}%{?dist}
7
8#
9# Test suite for iverilog is detailed on
10# https://fedorahosted.org/fedora-electronic-lab/wiki/Testing/iverilog
11# Please execute the testsuite as explained before pushed a new release to stable repos
12#
13
14%define      snapshot 20091230
15
16Name:        iverilog
17Version:     0.9.5
18Release:     1%{?_dist_release}
19Summary:     Icarus Verilog is a verilog compiler and simulator
20
21Group:       Applications/Engineering
22License:     GPLv2
23URL:         http://www.icarus.com/eda/verilog/index.html
24
25# Development Snapshot Download :
26# git clone git://icarus.com/~steve-icarus/verilog
27# cd verilog
28# git checkout --track -b v0_9-branch origin/v0_9-branch
29
30# This is the latest stable snapshot
31Source0:       ftp://ftp.icarus.com/pub/eda/verilog/v0.9/verilog-%{version}.tar.gz
32
33BuildRoot:   %{_tmppath}/%{name}-%{version}-root
34
35BuildRequires: zlib-devel
36BuildRequires: bzip2-devel
37BuildRequires: bison
38BuildRequires: flex
39BuildRequires: gperf
40BuildRequires: autoconf
41
42
43%description
44Icarus Verilog is a Verilog compiler that generates a variety of
45engineering formats, including simulation. It strives to be true
46to the IEEE-1364 standard.
47
48%package devel
49Summary:     Icarus Verilog devel files
50Group:       Development/Libraries
51Requires:    %{name} = %{version}-%{release}
52
53%description devel
54Icarus Verilog devel files.
55
56%prep
57%setup -q -n verilog-%{version}
58
59#sh autoconf.sh
60
61# clean junks from tarball
62find . -type f -name ".git" -exec rm '{}' \;
63rm -rf `find . -type d -name "autom4te.cache" -exec echo '{}' \;`
64
65
66%build
67
68CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" \
69%configure
70
71make %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75
76make         prefix=%{buildroot}%{_prefix} \
77             bindir=%{buildroot}%{_bindir} \
78             libdir=%{buildroot}%{_libdir} \
79             libdir64=%{buildroot}%{_libdir} \
80             includedir=%{buildroot}%{_includedir} \
81             mandir=%{buildroot}%{_mandir}  \
82             vpidir=%{buildroot}%{_libdir}/ivl/ \
83             INSTALL="install -p" \
84install
85
86
87
88%check
89make check
90
91%clean
92rm -rf %{buildroot}
93
94%files
95%defattr(-,root,root,-)
96# contents of QUICK_START.txt can be found also on README.txt, hence omitted
97%doc attributes.txt BUGS.txt COPYING extensions.txt glossary.txt ieee1364-notes.txt
98%doc README.txt swift.txt netlist.txt t-dll.txt vpi.txt tgt-fpga/fpga.txt
99%doc va_math.txt cadpli/cadpli.txt xilinx-hint.txt examples/
100%{_bindir}/*
101%{_libdir}/ivl
102%{_mandir}/man1/*
103
104%files devel
105%defattr(-,root,root,-)
106# headers for PLI: This is intended to be used by the user.
107%{_includedir}/*.h
108# RHBZ 480531
109%{_libdir}/*.a
110
111
112%changelog
113* Mon Feb 06 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9.5-1
114- new upstream release
115
116* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-1
117- Initial build for Vine Linux
118
119* Wed Dec 30 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091230-1
120- New stable snapshot - 0.9.2
121
122* Sat Dec 12 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091212-1
123- New development snapshot - 0.9.2 final prerelease snapshot
124
125* Sat Dec 05 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091205-1
126- New development snapshot - 0.9.2 prerelease snapshot
127
128* Fri Dec 04 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091204-1
129- New development snapshot - 0.9.2 prerelease snapshot
130
131* Sat Nov 28 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091130-1
132- New development snapshot
133
134* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20090423-6
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
136
137* Mon Jun 13 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20090423-5
138- Improved VPI support
139
140* Mon Mar 23 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20081118-4
141- new development release
142
143* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20081118-2
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
145
146* Sun Dec 07 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20081118-1
147- new snapshot release upstream.
148
149* Fri Sep 12 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080905-1
150- new snapshot release upstream.
151
152* Mon May 26 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080429-1
153- new snapshot release upstream.
154
155* Fri Mar 28 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080314-1
156- new snapshot release upstream.
157- add check section for some tests
158
159* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.20070608-2
160- Autorebuild for GCC 4.3
161
162* Sun Jun 10 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070608-1
163- new snapshot release upstream.
164
165* Mon Apr 23 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070421-1
166- new snapshot release upstream.
167
168* Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070227-1
169- new snapshot release.
170
171* Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070123-5
172- clean junks from tarball
173- exlude static library
174- smp build seems fine
175- use snapshot instead of cvsver macro
176- follow package n-v-r from fedora standard
177
178* Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-4
179- use cvsver macro
180- move examples in main.
181- more spec cleanup
182
183* Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-3
184- buildroot coherency in spec
185
186* Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-2
187- first build for fedora-extras
188- request gnu/stubs-32.h to force working gcc in 32 bit enviroment
189- fix PAGE_SIZE wich is missing on some arch
190- dont use libdir macro, all library always will be 32 bit
191
192* Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-1
193- initial release
Note: See TracBrowser for help on using the repository browser.