source: projects/specs/trunk/i/iverilog/iverilog-vl.spec @ 9492

Revision 9492, 5.9 KB checked in by inagaki, 9 years ago (diff)

2015-04-05 Ryoichi INAGAKI <ryo1@…>

  • cadaver, freetds, iverlog: rebuilt
  • tgif: updated


Line 
1# TODO for 1.0 release - redefine
2#Version:     0.9.%{snapshot}
3#Release:     6%{?dist}
4# to
5#Version:     1.0
6#Release:     1.snap%{snapshot}%{?dist}
7
8#
9# Test suite for iverilog is detailed on
10# https://fedorahosted.org/fedora-electronic-lab/wiki/Testing/iverilog
11# Please execute the testsuite as explained before pushed a new release to stable repos
12#
13
14%define      snapshot 20091230
15
16Name:        iverilog
17Version:     0.9.7
18Release:     2%{?_dist_release}
19Summary:     A Verilog simulation and synthesis tool
20
21Group:       Applications/Engineering
22License:     GPLv2
23URL:         http://iverilog.icarus.com/
24
25# Development Snapshot Download :
26# git clone git://icarus.com/~steve-icarus/verilog
27# cd verilog
28# git checkout --track -b v0_9-branch origin/v0_9-branch
29
30# This is the latest stable snapshot
31Source0:       ftp://ftp.icarus.com/pub/eda/verilog/v0.9/verilog-%{version}.tar.gz
32
33BuildRoot:   %{_tmppath}/%{name}-%{version}-root
34BuildRequires: autoconf
35BuildRequires: bison
36BuildRequires: bzip2-devel
37BuildRequires: flex
38BuildRequires: gperf
39BuildRequires: ncurses-devel
40BuildRequires: readline-devel
41BuildRequires: zlib-devel
42
43%description
44Icarus Verilog is a Verilog compiler that generates a variety of
45engineering formats, including simulation. It strives to be true
46to the IEEE-1364 standard.
47
48%package devel
49Summary:     Icarus Verilog devel files
50Group:       Development/Libraries
51Requires:    %{name} = %{version}-%{release}
52
53%description devel
54Icarus Verilog devel files.
55
56%prep
57%setup -q -n verilog-%{version}
58
59#sh autoconf.sh
60
61# clean junks from tarball
62find . -type f -name ".git" -exec rm '{}' \;
63rm -rf `find . -type d -name "autom4te.cache" -exec echo '{}' \;`
64
65
66%build
67
68CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" \
69%configure
70
71make %{?_smp_mflags}
72
73%install
74rm -rf %{buildroot}
75
76make         prefix=%{buildroot}%{_prefix} \
77             bindir=%{buildroot}%{_bindir} \
78             libdir=%{buildroot}%{_libdir} \
79             libdir64=%{buildroot}%{_libdir} \
80             includedir=%{buildroot}%{_includedir} \
81             mandir=%{buildroot}%{_mandir}  \
82             vpidir=%{buildroot}%{_libdir}/ivl/ \
83             INSTALL="install -p" \
84             install
85
86%check
87make check
88
89%clean
90rm -rf %{buildroot}
91
92%files
93%defattr(-,root,root,-)
94# contents of QUICK_START.txt can be found also on README.txt, hence omitted
95%doc attributes.txt BUGS.txt COPYING extensions.txt glossary.txt ieee1364-notes.txt
96%doc README.txt swift.txt netlist.txt t-dll.txt vpi.txt tgt-fpga/fpga.txt
97%doc va_math.txt cadpli/cadpli.txt xilinx-hint.txt examples/
98%{_bindir}/*
99%{_libdir}/ivl
100%{_mandir}/man1/*
101
102%files devel
103%defattr(-,root,root,-)
104# headers for PLI: This is intended to be used by the user.
105%{_includedir}/*.h
106# RHBZ 480531
107%{_libdir}/*.a
108
109
110%changelog
111* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.9.7-2
112- rebuilt with readline 6.3
113
114* Sun Feb  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.9.7-1
115- updated to 0.9.7
116- built on current VineSeed
117- added BR: ncurses-devel, readline-devel
118
119* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-1
120- Initial build for Vine Linux
121
122* Wed Dec 30 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091230-1
123- New stable snapshot - 0.9.2
124
125* Sat Dec 12 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091212-1
126- New development snapshot - 0.9.2 final prerelease snapshot
127
128* Sat Dec 05 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091205-1
129- New development snapshot - 0.9.2 prerelease snapshot
130
131* Fri Dec 04 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091204-1
132- New development snapshot - 0.9.2 prerelease snapshot
133
134* Sat Nov 28 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20091130-1
135- New development snapshot
136
137* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20090423-6
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
139
140* Mon Jun 13 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20090423-5
141- Improved VPI support
142
143* Mon Mar 23 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> - 0.9.20081118-4
144- new development release
145
146* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.20081118-2
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
148
149* Sun Dec 07 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20081118-1
150- new snapshot release upstream.
151
152* Fri Sep 12 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080905-1
153- new snapshot release upstream.
154
155* Mon May 26 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080429-1
156- new snapshot release upstream.
157
158* Fri Mar 28 2008 Balint Cristian <rezso@rdsor.ro> 0.9.20080314-1
159- new snapshot release upstream.
160- add check section for some tests
161
162* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.20070608-2
163- Autorebuild for GCC 4.3
164
165* Sun Jun 10 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070608-1
166- new snapshot release upstream.
167
168* Mon Apr 23 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070421-1
169- new snapshot release upstream.
170
171* Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070227-1
172- new snapshot release.
173
174* Thu Feb 27 2007 Balint Cristian <cbalint@redhat.com> 0.9.20070123-5
175- clean junks from tarball
176- exlude static library
177- smp build seems fine
178- use snapshot instead of cvsver macro
179- follow package n-v-r from fedora standard
180
181* Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-4
182- use cvsver macro
183- move examples in main.
184- more spec cleanup
185
186* Thu Feb 23 2007 Balint Cristian <cbalint@redhat.com> 20070123-3
187- buildroot coherency in spec
188
189* Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-2
190- first build for fedora-extras
191- request gnu/stubs-32.h to force working gcc in 32 bit enviroment
192- fix PAGE_SIZE wich is missing on some arch
193- dont use libdir macro, all library always will be 32 bit
194
195* Thu Feb 22 2007 Balint Cristian <cbalint@redhat.com> 20070123-1
196- initial release
Note: See TracBrowser for help on using the repository browser.