source: projects/specs/trunk/i/itcl/itcl-vl.spec @ 9233

Revision 9233, 8.5 KB checked in by inagaki, 9 years ago (diff)

2015-01-07 Ryoichi INAGAKI <ryo1@…>

  • accerciser: changed Group
  • asciidoc: updated and changed Group
  • bashdb: updated and changed Group
  • itcl: updated


RevLine 
[9233]1%define tcl_major       8.5
2%define tk_major        8.5
3%define thread_major    2.7
4%define itcl_major      3.4
[521]5%define itclvers        %{itcl_major}.1
6
7Summary: [Incr Tcl] OOP Extension for TCL
8Summary(ja): [Incr Tcl] TCL のオブジェクト指向拡張
9Name: itcl
10Version: %{itclvers}
[9233]11Release: 1%{?_dist_release}
[521]12Group: Development/Languages
13License: BSD
[9233]14Source0: http://prdownloads.sourceforge.net/incrtcl/itcl%{itclvers}.tar.gz
[521]15Patch31: itcl-3.2.1-makecfg.patch
16
[9233]17Buildroot: %{_tmppath}/%{name}-%{version}-root
[521]18BuildRequires: tcl >= %{tcl_major}
19BuildRequires: tk >= %{tk_major}
20BuildRequires: thread >= %{thread_major}
21Requires: tcl >= %{tcl_major}
22Requires: tk >= %{tk_major}
23Requires: thread >= %{thread_major}
[9233]24
[521]25Distribution: Vine Linux
26Vendor: Project Vine
27
28%description
29[incr Tcl] is an object-oriented extension of the Tcl language.  It
30was created to support more structured programming in Tcl.  Tcl scripts
31that grow beyond a few thousand lines become extremely difficult to
32maintain.  This is because the building blocks of vanilla Tcl are
33procedures and global variables, and all of these building blocks
34must reside in a single global namespace.  There is no support for
35protection or encapsulation.
36
37[incr Tcl] introduces the notion of objects.  Each object is a bag
38of data with a set of procedures or "methods" that are used to
39manipulate it.  Objects are organized into "classes" with identical
40characteristics, and classes can inherit functionality from one
41another.  This object-oriented paradigm adds another level of
42organization on top of the basic variable/procedure elements, and
43the resulting code is easier to understand and maintain.
44
45%description -l ja
46[incr Tcl] は Tcl 言語のオブジェクト指向な拡張キットで、Tcl で
47より構造的なプログラムをサポートするために作成されました。
482, 3000 行を超えるくらい増えた Tcl スクリプトは、メンテナンスが極めて
49困難です。これは vanilla Tcl を構成するブロックが手続きやグローバル変数
50であり、それらすべてのブロック一つのグローバルな名前空間に属さなければ
51ならないためです。保護やカプセル化はサポートされておりません。
52
53[incr Tcl]はオブジェクトの概念を導入します。各オブジェクトは、それを操作
54するために使用する手続きや「方法」のセットを含んだデータのひと包みになり
55ます。オブジェクトはその識別特性により「クラス」化され、クラスはお互いに
56機能を継承することができます。このオブジェクト指向のパラダイムにより、基
57本的な変数/手続きの要素の上に、別のレベルの組織化を行うことができます。
58その結果、コードの理解やメンテナンスが容易になります。
59
60%prep
61%setup -q -n %{name}%{itclvers}
[9233]62#patch31 -p1 -b .makecfg
[521]63
64
65#==========================================
66%build
67
68# make the libraries reentrant
69RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
70
71#------------------------------------------
72# Itcl
73#
74%configure \
[9233]75    --enable-shared \
76    --enable-threads \
77    --with-tcl=%{_libdir}
[521]78
79make
80
81#==========================================
82%install
83rm -rf ${RPM_BUILD_ROOT}
84
85#------------------------------------------
86# Itcl
87#
[9233]88make install DESTDIR=$RPM_BUILD_ROOT \
89        ITCL_LIBRARY=%{_datadir}/itcl%{itcl_major} \
90        ITK_LIBRARY=%{_datadir}/itk%{itcl_major}
[521]91
92# fixed *Config variables
93ln -sf ../itclConfig.sh $RPM_BUILD_ROOT%{_libdir}/itcl%{itcl_major}/itclConfig.sh
[9233]94#ln -sf ../itkConfig.sh $RPM_BUILD_ROOT%{_libdir}/itk%{itcl_major}/itkConfig.sh
[521]95
[9233]96#echo "ITCL_SRC_DIR='%{_includedir}/tcl%{tcl_major}/'" >> $RPM_BUILD_ROOT%{_libdir}/itcl%{itcl_major}/itclConfig.sh
97#echo "ITCL_BUILD_LIB_SPEC='-L%{_libdir} -litcl%{itcl_major}'" >> $RPM_BUILD_ROOT%{_libdir}/itcl%{itcl_major}/itclConfig.sh
[521]98
99# install include files
[9233]100#mkdir -p $RPM_BUILD_ROOT%{_includedir}/tcl%{tcl_major}/generic
101#mkdir -p $RPM_BUILD_ROOT%{_includedir}/tk%{tk_major}/generic
[521]102
[9233]103#cp itcl/generic/*.h $RPM_BUILD_ROOT%{_includedir}/tcl%{tcl_major}/generic
104#cp itk/generic/*.h $RPM_BUILD_ROOT%{_includedir}/tk%{tk_major}/generic
[521]105
106#==========================================
107%clean
108rm -rf $RPM_BUILD_ROOT
109
[9233]110#-f itcl.files -n itcl
111%files
[521]112%defattr(-,root,root,-)
[9233]113%doc doc/license.terms
114%{_includedir}/*.h
115%{_libdir}/%{name}%{itcl_major}/*
116%{_libdir}/itclConfig.sh
117%{_mandir}/mann/*.gz
[521]118
119
120%changelog
[9233]121* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.1-1
122- updated to 3.4.1
123- built with tcl/tk 8.5.15 and thread 2.7.1
124
[1262]125* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.2.1-2
126- rebuilt with tcl/tk-8.4.19-2
127
[521]128* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.1-1vl5
129- applied new versioning policy and spec in utf-8
130
131* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.1-0vl4
132- rebuild with tcl/tk-8.4.18
133
134* Tue Jan 01 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.1-0vl3
135- moved itcl script path to /usr/share/{itcl3.2,itk3.2} like tcl/tk
136
137* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 3.2.1-0vl2
138- rebuild with tcl/tk-8.4.16
139- changed macro %%thread_major to 2.6
140- added {ITCL,ITK}_LIBRARY to %%makeinstall for lib64 support
141
142* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.1-0vl1
143- update based on BitWalk's tcltk-8.4.2-83bw
144
145* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
146- split itcl
147
148* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
149- expand some macros.. (FIXME)
150
151* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
152- use %configure macros
153- add Patch 47,50
154
155* Thu May 31 2001 <sagami@vinelinux.org>
156- 8.0.5_jp-10
157- unexpand old %%{configure}, new one causes build failure
158- fixed missing libtkx.so libtclx.so symlink in /usr/lib
159- install manpages into %%{_mandir} and mode 644
160
161* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
162- 8.0.5_jp-9
163- modified %install section to handle compressed man pages
164- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
165
166* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
167- changed default fonts
168
169* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
170- added defattr
171
172* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
173- added some symlinks, such as libtcl8.0.so.
174- obsoletes version number using _jp, now 8.0.5-31vl1
175
176* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
177- Apply Tcl/Tk 8.0 Japanese Patch 1.7
178
179* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
180- fix tclX symlinks.
181- compile on systems where SIGPWR == SIGLOST.
182
183* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
184- update tcl/tk to 8.0.5.
185- avoid "containing" in Tix (#2332).
186
187* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
188- use /usr/bin/write in kibitz (#1320).
189- use cirrus.sprl.umich.edu in weather (#1926).
190
191* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
192- auto rebuild in the new build environment (release 28)
193
194* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
195- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
196
197* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
198- expect does unaligned access on alpha (#989)
199- upgrade tcl/tk/tclX to 8.0.4
200- upgrade expect to 5.28.
201- add itcl 3.0.1
202
203* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
204- call libtoolize to allow building on the arm
205- build for glibc 2.1
206- strip binaries
207
208* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
209- update tcl/tk/tclX to 8.0.3, expect is updated also.
210
211* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
212- expect: mkpasswd needs delay before sending password (problem #576)
213
214* Thu May 07 1998 Prospector System <bugs@redhat.com>
215- translations modified for de, fr, tr
216
217* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
218- fixed expect binaries exec permissions
219
220* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
221- updated to Tix 4.1.0.006
222- updated version numbers of tcl/tk to relflect includsion of p2
223
224* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
225- updated tcl/tk to patch level 2
226- updated tclX to 8.0.2
227
228* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
229- fixed filelist for tix... replacing path to the expect binary in scripts
230  was leaving junk files around.
231
232* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
233- added patch to remove libieee test in configure.in for tcl and tk.
234  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
235  solution for all systems
236- fixed src urls
237
238* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
239- removed version numbers from descriptions
240
241* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
242- updated to tcl/tk 8.0 and related versions of packages
243
244* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
245- built against glibc
246- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.