source: projects/specs/trunk/i/isl/isl-vl.spec @ 10405

Revision 10405, 2.9 KB checked in by Takemikaduchi, 8 years ago (diff)

gcc-5.4.0 & python3-3.5.2

Line 
1Summary: Integer point manipulation library
2Name: isl
3Version: 0.14.1
4License: MIT
5Group: System Environment/Libraries
6URL: http://isl.gforge.inria.fr/
7
8%global libmajor 13
9%global libversion %{libmajor}.1.1
10
11# Please set buildid below when building a private version of this rpm to
12# differentiate it from the stock rpm.
13#
14# % global buildid .local
15
16Release: 1%{?_dist_release}
17
18BuildRequires: gmp-devel
19BuildRequires: pkgconfig
20
21Source0: http://isl.gforge.inria.fr/isl-%{version}.tar.xz
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: Takemikaduchi
28
29%description
30isl is a library for manipulating sets and relations of integer points
31bounded by linear constraints.  Supported operations on sets include
32intersection, union, set difference, emptiness check, convex hull,
33(integer) affine hull, integer projection, computing the lexicographic
34minimum using parametric integer programming, coalescing and parametric
35vertex enumeration.  It also includes an ILP solver based on generalized
36basis reduction, transitive closures on maps (which may encode infinite
37graphs), dependence analysis and bounds on piecewise step-polynomials.
38
39%package devel
40Summary: Development for building integer point manipulation library
41Requires: isl == %{version}-%{release}
42Requires: gmp-devel
43Group: Development/Libraries
44
45%description devel
46isl is a library for manipulating sets and relations of integer points
47bounded by linear constraints.  Supported operations on sets include
48intersection, union, set difference, emptiness check, convex hull,
49(integer) affine hull, integer projection, computing the lexicographic
50minimum using parametric integer programming, coalescing and parametric
51vertex enumeration.  It also includes an ILP solver based on generalized
52basis reduction, transitive closures on maps (which may encode infinite
53graphs), dependence analysis and bounds on piecewise step-polynomials.
54
55%prep
56%setup -q
57
58%build
59%configure
60make %{?_smp_mflags} V=1
61
62%install
63%make_install INSTALL="install -p"
64rm -f %{buildroot}/%{_libdir}/libisl.a
65rm -f %{buildroot}/%{_libdir}/libisl.la
66mkdir -p %{buildroot}/%{_datadir}
67%global gdbprettydir %{_datadir}/gdb/auto-load/%{_libdir}
68mkdir -p %{buildroot}/%{gdbprettydir}
69mv %{buildroot}/%{_libdir}/*-gdb.py* %{buildroot}/%{gdbprettydir}
70
71%check
72make check
73
74%post -p /sbin/ldconfig
75%postun -p /sbin/ldconfig
76
77%files
78%{_libdir}/libisl.so.%{libmajor}
79%{_libdir}/libisl.so.%{libversion}
80%{gdbprettydir}/*
81%doc AUTHORS ChangeLog LICENSE README
82
83%files devel
84%{_includedir}/*
85%{_libdir}/libisl.so
86%{_libdir}/pkgconfig/isl.pc
87%doc doc/manual.pdf
88
89
90%changelog
91* Sat Jun 25 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
92- initial build for Vine Linux
93
94
95* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14-4
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
97
98* Mon Jan 5 2015 David Howells <dhowells@redhat.com> - 0.14-3
99- Initial packaging.
Note: See TracBrowser for help on using the repository browser.