source: projects/specs/trunk/i/iscan/iscan-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Macro definitions
2%define ver     1.10.0
3%define rel     3
4%define epsane_ver 1.0.6
5%define epsane_maj 1
6
7Summary:        Image Scan! for Linux is the frontend for epson scanners
8Summary(ja):    Image Scan! for Linux - EPSON À½¥¹¥­¥ã¥ÊÍѤΥեí¥ó¥È¥¨¥ó¥É
9Name:           iscan
10Version:        %{ver} 
11Release:        %{rel}vl1
12License:        GPL (with exception clause)/EKPL
13URL:            http://www.epkowa.co.jp/
14Source:         iscan-%{ver}-%{rel}.tar.gz
15Group:          Applications/Multimedia
16Requires:       sane >= 1.0.3
17BuildRoot:      /var/tmp/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
22
23%description
24Image Scan! for Linux is the frontend for epson scanners
25
26%description -l ja
27iscan (Image Scan! for Linux) ¤Ï EPSON À½¥¹¥­¥ã¥ÊÍѤΥեí¥ó¥È¥¨¥ó¥É
28¤Ç¤¹¡£
29
30%prep
31%setup -q
32
33%build
34%configure
35make %{?_smp_mflags}
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39%makeinstall
40
41%clean
42rm -rf ${RPM_BUILD_ROOT}
43
44%post
45config=%{_sysconfdir}/sane.d/dll.conf
46if test -z "$(grep epkowa $config)"; then
47    echo Adding the SANE epkowa backend for EPSON scanners to $config
48    echo Your old configuration is saved in $config.orig
49    cp $config $config.orig
50    echo epkowa >> $config
51fi
52if test -n "$(grep '#[[:space:]]*epkowa' $config)"; then
53    echo Enabling SANE epkowa backend for EPSON scanners in $config
54    echo Your old configuration is saved in $config.orig
55    mv $config $config.orig
56    sed 's,#[[:space:]]*\(epkowa\),\1,' $config.orig > $config
57fi
58if test -z "$(grep 6566/tcp %{_sysconfdir}/services)"; then
59    echo Adding the sane service to %{_sysconfdir}/services
60    echo The original file is saved in %{_sysconfdir}/services.orig
61    cp %{_sysconfdir}/services %{_sysconfdir}/services.orig
62    echo "sane 6566/tcp saned # SANE network scanner daemon" >> %{_sysconfdir}/services
63fi
64
65%preun
66if [ $1 = 0 ]
67then
68        rm -f %{_libdir}/sane/libsane-epson.so
69        rm -f %{_libdir}/sane/libsane-epson.so.%{epsane_maj}
70fi
71
72%files
73%defattr(-,root,root)
74%doc README README.ja
75%doc COPYING COPYING.LIB COPYING.KOWA COPYING.KOWA.ja
76%doc doc/xinetd.sane
77%{_sysconfdir}/sane.d/epkowa.conf
78%{_bindir}/iscan
79%{_libdir}/libesmod.so*
80%{_libdir}/libesint*.so*
81%{_libdir}/sane/libsane-epkowa.so*
82%{_datadir}/iscan/esf*.bin
83%{_datadir}/locale/*/LC_MESSAGES/iscan.mo
84%{_mandir}/man1/*
85
86
87%changelog
88* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3vl1
89- new upstream release
90
91* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-0vl1
92- initial build for Vine Linux based on epkowa package.
93- use rpmmacros
94
Note: See TracBrowser for help on using the repository browser.