source: projects/specs/trunk/i/iputils/iputils-vl.spec @ 521

Revision 521, 10.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Network monitoring tools including ping.
2Summary(ja): ping 等のネットワークモニタツール集
3Name: iputils
4Version: 20071127
5Release: 2%{?_dist_release}
6License: BSD
7Group: System Environment/Daemons
8URL: http://www.skbuff.net/iputils
9Source0: http://www.skbuff.net/iputils//%{name}-s%{version}.tar.bz2
10Source1: ifenslave.tar.gz
11Source3: rdisc.initd
12
13Patch0: iputils-20020927-rh.patch
14Patch1: iputils-20020124-countermeasures.patch
15Patch2: iputils-20020927-addrcache.patch
16Patch3: iputils-20020927-ping-subint.patch
17Patch4: iputils-ping_cleanup.patch
18Patch5: iputils-ifenslave.patch
19Patch6: iputils-20020927-arping-infiniband.patch
20Patch7: iputils-20070202-idn.patch
21Patch8: iputils-20070202-open-max.patch
22Patch9: iputils-20070202-traffic_class.patch
23Patch10: iputils-20070202-arping_timeout.patch
24Patch11: iputils-20071127-output.patch
25Patch12: iputils-20070202-ia64_align.patch
26Patch13: iputils-20071127-warnings.patch
27Patch14: iputils-20071127-typing_bug.patch
28Patch15: iputils-20071127-corr_type.patch
29
30# Vine Source(s)/Patch(es)
31Source10: iputils-20020927-ja.po
32Patch100: iputils-s20071127-gettext.patch
33
34Prefix: %{_prefix}
35BuildRoot: %{_tmppath}/%{name}-root
36BuildPreReq: docbook-utils perl-SGMLSpm
37BuildPreReq: glibc-kernheaders >= 2.4-8.19
38PreReq: chkconfig
39
40%description
41The iputils package contains basic utilities for monitoring a network,
42including ping. The ping command sends a series of ICMP protocol
43ECHO_REQUEST packets to a specified network host to discover whether
44the target machine is alive and receiving network traffic.
45
46%prep
47%setup -q -a 1 -n %{name}-s%{version}
48
49%patch0 -p1 -b .rh
50%patch1 -p1 -b .countermeasures
51%patch2 -p1 -b .addrcache
52%patch3 -p1 -b .ping-subint
53%patch4 -p1 -b .cleanup
54%patch5 -p1 -b .addr
55%patch6 -p1 -b .infiniband
56%patch7 -p1 -b .idn
57%patch8 -p1 -b .open-max
58%patch9 -p1 -b .traffic_class
59%patch10 -p1 -b .arping_timeout
60%patch11 -p1 -b .output
61%patch12 -p1 -b .ia64_align
62%patch13 -p1 -b .warnings
63%patch14 -p1 -b .typing_bug
64%patch15 -p1 -b .corr_type
65
66#
67%patch100 -p1 -b .gettext
68
69# add ja.po
70cp %{SOURCE10} po/ja.po
71
72%build
73%ifarch s390 s390x
74export CFLAGS="$RPM_OPT_FLAGS -fPIE"
75%else
76export CFLAGS="$RPM_OPT_FLAGS -fpie"
77%endif
78export LDFLAGS="-pie"
79make %{?_smp_mflags} arping clockdiff ping ping6 rdisc tracepath tracepath6 po
80gcc -Wall $RPM_OPT_FLAGS ifenslave.c -o ifenslave
81make -C doc man
82
83%install
84rm -rf ${RPM_BUILD_ROOT}
85
86mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
87mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
88install -c clockdiff            ${RPM_BUILD_ROOT}%{_sbindir}/
89install -cp arping              ${RPM_BUILD_ROOT}/sbin/
90ln -s /sbin/arping              ${RPM_BUILD_ROOT}%{_sbindir}/arping
91install -cp ping                ${RPM_BUILD_ROOT}/bin/
92install -cp ifenslave           ${RPM_BUILD_ROOT}/sbin/
93install -cp rdisc               ${RPM_BUILD_ROOT}/sbin/
94install -cp ping6               ${RPM_BUILD_ROOT}/bin/
95install -cp tracepath           ${RPM_BUILD_ROOT}/bin/
96install -cp tracepath6          ${RPM_BUILD_ROOT}/bin/
97
98mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
99ln -sf /bin/ping6 ${RPM_BUILD_ROOT}%{_sbindir}
100ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
101ln -sf /bin/tracepath6 ${RPM_BUILD_ROOT}%{_sbindir}
102
103mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
104install -cp doc/clockdiff.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
105install -cp doc/arping.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
106install -cp doc/ping.8          ${RPM_BUILD_ROOT}%{_mandir}/man8/
107install -cp doc/rdisc.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
108install -cp doc/tracepath.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
109install -cp ifenslave.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
110ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
111ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
112
113install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
114install -m 755 -p %SOURCE3 ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
115
116%post
117/sbin/chkconfig --add rdisc
118
119%preun
120if [ $1 = 0 ]; then
121   service rdisc stop >/dev/null 2>&1
122   /sbin/chkconfig --del rdisc
123fi
124
125%postun
126if [ "$1" -ge "1" ]; then
127    service rdisc restart >/dev/null 2>&1 || :
128fi
129
130
131%clean
132rm -rf ${RPM_BUILD_ROOT}
133
134%files
135%defattr(-,root,root)
136%doc RELNOTES README.bonding
137%{_sbindir}/clockdiff
138%ifos linux
139/sbin/arping
140%{_sbindir}/arping
141%attr(4755,root,root)   /bin/ping
142/sbin/ifenslave
143%else
144%attr(4755,root,root)   %{_sbindir}/ping
145%{_sbindir}/arping
146%{_sbindir}/ifenslave
147%endif
148/sbin/rdisc
149%attr(4755,root,root) /bin/ping6
150/bin/tracepath
151/bin/tracepath6
152#%attr(4755,root,root)/bin/traceroute6
153%{_sbindir}/ping6
154%{_sbindir}/tracepath
155%{_sbindir}/tracepath6
156#%{_sbindir}/traceroute6
157%attr(0644,root,root) %{_mandir}/man8/*
158%config(noreplace) %{_sysconfdir}/rc.d/init.d/rdisc
159
160%changelog
161* Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
162- rebuild to add sign..
163
164* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
165- new upstream release
166- spec in utf-8
167
168* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
169- remove traceroute6 that is now provided by traceroute package.
170- merge changes from FC
171
172* Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
173- ppc patch (Patch110) removed (it's no necessary now)
174
175* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
176- update to 20020927 merged with 20020927-13
177- update i18n patch, ja.po
178  * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
179  - Fixed unaligned access problem on ia64 (#101417)
180  * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
181  - Dont use own headers, use glibc and kernheaders.
182  * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
183  - fix build with new glibc-kernheaders
184  * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
185  - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
186  * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
187  - One more update to ifenslave.c
188  * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
189  - Updated ifenslave.c and README.bonding to latest version.
190  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
191  - Bumped release and rebuilt
192  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
193  - Fixed DNS lookup problems (#68212).
194  - Added warning if binding problem failed on subinterface (#81640).
195  * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
196  - Removed bonding tarball and replaced it with ifenslave.c and README
197  - FHS compliance for all tools, now to be found in /bin with compat symlinks to
198    old places.
199  * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
200  - Updated to latest upstream version.
201  * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
202  - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
203  - Fixed ipv6 error printing problem (#66659).
204  * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
205  - Added a patch to activate the rdisc server (#64270).
206  - Display the countermeasures warning only in verbose (#55236)
207  * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
208  - quit trying to build HTML versions of the man pages
209  * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
210  - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
211  * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
212  - Update to iputils-ss020124.
213
214* Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
215- changed Patch110 to have clear_bit() within the ipv6 source for ppc
216
217* Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
218- based on 20001110-7 from Rawhide
219- merged Vine changes from 20001010-1vl4
220  --- Mon Jul 16 2001 <sagami@vinelinux.org>
221    - 20001010-1vl4
222    - use %%{find_lang} to fix so as not to own locale dir
223
224  --- Thu Jun 07 2001 <sagami@vinelinux.org>
225    - 20001010-1vl3: rebuilt for %%{_mandir}
226
227  --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
228    - 20001010-1vl2
229    - remove ping6 for ppc
230    - added Japanese summary and description
231
232  --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
233    - added ja.po and nls patch
234
235* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
236- automated rebuild
237
238* Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
239- Fixed buffer overflow problem in traceroute6.c (#51135)
240
241* Mon Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
242- Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
243
244* Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
245- Fixed ping statistics overflow bug (#43801)
246
247* Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
248- Fixed a bunch of compiler warnings (#37131)
249- Fixed wrong exit code for no packets and deadline (#40323)
250- Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
251  /usr/sbin/ provided for backwards compatibility.
252
253* Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
254- install in.rdisc.8c as rdisc.8
255
256* Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
257- update to ss001110
258- doco fixes (#23844).
259
260* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
261- update to ss001007.
262
263* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
264- fix spelling mistake (#15714).
265
266* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
267- turn on -U on machines without TSC (#15223).
268
269* Tue Aug  1 2000 Jeff Johnson <jbj@redhat.com>
270- better doco patch (#15050).
271
272* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
273- fix include-glibc/ to work with new glibc 2.2 resolver headers
274
275* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
276- automatic rebuild
277
278* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
279- FHS packaging.
280- update to ss000418.
281- perform reverse DNS lookup only once for same input.
282
283* Sun Mar  5 2000 Jeff Johnson <jbj@redhat.com>
284- include README.ifenslave doco.
285- "ping -i N" was broke for N >= 3 (#9929).
286- update to ss000121:
287-- clockdiff: preserve raw socket errno.
288-- ping: change error exit code to 1 (used to be 92,93, ...)
289-- ping,ping6: if -w specified, transmit until -c limit is reached.
290-- ping,ping6: exit code non-zero if some packets not received within deadline.
291
292* Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
293- man page corrections (#9690).
294
295* Wed Feb  9 2000 Jeff Johnson <jbj@jbj.org>
296- add ifenslave.
297
298* Thu Feb  3 2000 Elliot Lee <sopwith@redhat.com>
299- List /usr/sbin/rdisc in %files list.
300
301* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
302- add remaining binaries.
303- casts to remove compilation warnings.
304- terminate if -w deadline is reached exactly (#8724).
305
306* Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
307- create (only ping for now, traceroute et al soon).
Note: See TracBrowser for help on using the repository browser.