source: projects/specs/trunk/i/iputils/iputils-vl.spec @ 12316

Revision 12316, 11.6 KB checked in by tomop, 4 years ago (diff)

updated 22 packages

actdiag-0.5.4-1

blockdiag-1.5.4-1

clamav-0.102.1-1

ghostscript-9.27-3

git-2.24.1-1

incron-0.5.12-4

iputils-20190709-2

libsass-3.6.3-1

libxslt-1.1.34-1

nginx-1.16.1-4

nsd-4.2.4-1

nwdiag-1.0.4-1

oniguruma-6.9.4-1

php73-7.3.12-1

python-funcparserlib-0.3.6-1

python-webcolors-1.10-1

samba-4.10.10-1

seqdiag-0.9.6-1

strongswan-5.8.1-1

trousers-0.3.14-1

unbound-1.9.6-1

unrar-free-0.0.1.20140707-1

Line 
1Summary: Network monitoring tools including ping.
2Summary(ja): ping 等のネットワークモニタツール集
3Name: iputils
4Version: 20190709
5Release: 2%{?_dist_release}
6# some parts are under the original BSD (ping.c)
7# some are under GPLv2+ (tracepath.c)
8License: BSD and GPLv2+
9Group: System Environment/Daemons
10URL: https://github.com/iputils/iputils
11Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
12Source1: ifenslave.tar.gz
13Source3: rdisc.initd
14Source5: rdisc.sysconfig
15Source6: ninfod.initd
16Source7: ninfod.sysconfig
17
18Source10: bsd.txt
19Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
20
21Patch1: iputils-ifenslave.patch
22Patch2: iputils-fix-arping.patch
23
24# Vine Source(s)/Patch(es)
25
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: docbook-utils perl-SGMLSpm
29BuildRequires: glibc-kernheaders >= 2.4-8.19
30BuildRequires: libidn2-devel
31BuildRequires: openssl-devel
32BuildRequires: libcap-devel
33BuildRequires: libxslt
34BuildRequires: docbook5-style-xsl
35BuildRequires: meson
36Requires(post): chkconfig
37Requires(preun): chkconfig
38Requires(preun): initscripts
39Requires(postun): initscripts
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45The iputils package contains basic utilities for monitoring a network,
46including ping. The ping command sends a series of ICMP protocol
47ECHO_REQUEST packets to a specified network host to discover whether
48the target machine is alive and receiving network traffic.
49
50%prep
51%setup -q -a 1 -n %{name}-s%{version}
52
53cp %{SOURCE10} %{SOURCE11} .
54
55%patch1 -p1
56%patch2 -p1
57
58%build
59%ifarch s390 s390x
60export CFLAGS="$RPM_OPT_FLAGS -fPIE"
61%else
62export CFLAGS="$RPM_OPT_FLAGS -fpie"
63%endif
64export LDFLAGS="-pie -Wl,-z,relro,-z,now"
65
66%meson
67%meson_build
68%ninja_build -C %{_target_platform} iputils-gmo
69
70gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
71
72
73%install
74rm -rf ${RPM_BUILD_ROOT}
75
76mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
77mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
78mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
79mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
80
81pushd %{_target_platform}
82install -c clockdiff            ${RPM_BUILD_ROOT}%{_sbindir}/
83install -cp arping              ${RPM_BUILD_ROOT}/sbin/
84ln -s /sbin/arping              ${RPM_BUILD_ROOT}%{_sbindir}/arping
85install -cp ping                ${RPM_BUILD_ROOT}/bin/
86install -cp ../ifenslave                ${RPM_BUILD_ROOT}/sbin/
87install -cp rdisc               ${RPM_BUILD_ROOT}/sbin/
88install -cp tracepath           ${RPM_BUILD_ROOT}/bin/
89install -cp ninfod/ninfod       ${RPM_BUILD_ROOT}/sbin/
90
91ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
92ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
93ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
94ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
95
96mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
97install -cp doc/clockdiff.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
98install -cp doc/arping.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
99install -cp doc/ping.8          ${RPM_BUILD_ROOT}%{_mandir}/man8/
100install -cp doc/rdisc.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
101install -cp doc/tracepath.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
102install -cp doc/ninfod.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
103install -cp ../ifenslave.8              ${RPM_BUILD_ROOT}%{_mandir}/man8/
104ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
105ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
106
107install -dp ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES
108install -m 644 po/ja.gmo $RPM_BUILD_ROOT%{_datadir}/locale/ja/LC_MESSAGES/iputils.mo
109popd
110
111find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
112
113install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
114install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
115install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
116install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
117install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
118
119%find_lang %{name}
120
121
122%post
123/sbin/chkconfig --add rdisc
124/sbin/chkconfig --add ninfod
125
126%preun
127if [ $1 = 0 ]; then
128   service rdisc stop >/dev/null 2>&1
129   service ninfod stop >/dev/null 2>&1
130   /sbin/chkconfig --del rdisc
131   /sbin/chkconfig --del ninfod
132fi
133
134%postun
135if [ "$1" -ge "1" ]; then
136    service rdisc condrestart >/dev/null 2>&1 || :
137    service ninfod condrestart >/dev/null 2>&1 || :
138fi
139
140
141%clean
142rm -rf ${RPM_BUILD_ROOT}
143
144%files -f %{name}.lang
145%defattr(-,root,root)
146%license LICENSE*
147%doc README.*
148%{_sbindir}/clockdiff
149/sbin/arping
150%{_sbindir}/arping
151%attr(4755,root,root)   /bin/ping
152/sbin/ifenslave
153/sbin/rdisc
154/bin/tracepath
155/sbin/ninfod
156%{_sbindir}/ping
157%{_sbindir}/ping6
158%{_sbindir}/tracepath
159%{_sbindir}/tracepath6
160%{_mandir}/man8/*
161%{_sysconfdir}/rc.d/init.d/rdisc
162%{_sysconfdir}/rc.d/init.d/ninfod
163%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
164%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
165
166%changelog
167* Wed Nov 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20190709-2
168- imported Patch2 from upstream to fix arping.
169
170* Tue Oct 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20190709-1
171- updated to 20190709.
172- dropped Source1000 and Patch1000: merged into upstream.
173- switched buildsystem to meson.
174- dropped Patch0: Makefile is deprecated.
175
176* Sat Nov 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180629-1
177- updated to 20180629.
178- dropped Patch2-5 (fixed in upstream).
179- updated gettext patch and translation.
180- added BR:libxslt.
181- added BR:docbook-style-xsl.
182
183* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
184- fixed initscripts.
185
186* Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
187- updated to 20161105.
188- updated gettext patch and translation.
189- updated license.
190
191* Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
192- update to 20140519
193- update URL to new upstream
194- update gettext patch and translation
195
196* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
197- new upstream release
198- merget with fedora/20101006-8
199- update gettext patch and ja.po
200
201* Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
202- rebuild to add sign..
203
204* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
205- new upstream release
206- spec in utf-8
207
208* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
209- remove traceroute6 that is now provided by traceroute package.
210- merge changes from FC
211
212* Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
213- ppc patch (Patch110) removed (it's no necessary now)
214
215* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
216- update to 20020927 merged with 20020927-13
217- update i18n patch, ja.po
218  * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
219  - Fixed unaligned access problem on ia64 (#101417)
220  * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
221  - Dont use own headers, use glibc and kernheaders.
222  * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
223  - fix build with new glibc-kernheaders
224  * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
225  - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
226  * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
227  - One more update to ifenslave.c
228  * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
229  - Updated ifenslave.c and README.bonding to latest version.
230  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
231  - Bumped release and rebuilt
232  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
233  - Fixed DNS lookup problems (#68212).
234  - Added warning if binding problem failed on subinterface (#81640).
235  * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
236  - Removed bonding tarball and replaced it with ifenslave.c and README
237  - FHS compliance for all tools, now to be found in /bin with compat symlinks to
238    old places.
239  * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
240  - Updated to latest upstream version.
241  * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
242  - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
243  - Fixed ipv6 error printing problem (#66659).
244  * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
245  - Added a patch to activate the rdisc server (#64270).
246  - Display the countermeasures warning only in verbose (#55236)
247  * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
248  - quit trying to build HTML versions of the man pages
249  * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
250  - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
251  * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
252  - Update to iputils-ss020124.
253
254* Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
255- changed Patch110 to have clear_bit() within the ipv6 source for ppc
256
257* Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
258- based on 20001110-7 from Rawhide
259- merged Vine changes from 20001010-1vl4
260  --- Mon Jul 16 2001 <sagami@vinelinux.org>
261    - 20001010-1vl4
262    - use %%{find_lang} to fix so as not to own locale dir
263
264  --- Thu Jun 07 2001 <sagami@vinelinux.org>
265    - 20001010-1vl3: rebuilt for %%{_mandir}
266
267  --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
268    - 20001010-1vl2
269    - remove ping6 for ppc
270    - added Japanese summary and description
271
272  --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
273    - added ja.po and nls patch
274
275* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
276- automated rebuild
277
278* Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
279- Fixed buffer overflow problem in traceroute6.c (#51135)
280
281* Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
282- Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
283
284* Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
285- Fixed ping statistics overflow bug (#43801)
286
287* Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
288- Fixed a bunch of compiler warnings (#37131)
289- Fixed wrong exit code for no packets and deadline (#40323)
290- Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
291  /usr/sbin/ provided for backwards compatibility.
292
293* Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
294- install in.rdisc.8c as rdisc.8
295
296* Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
297- update to ss001110
298- doco fixes (#23844).
299
300* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
301- update to ss001007.
302
303* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
304- fix spelling mistake (#15714).
305
306* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
307- turn on -U on machines without TSC (#15223).
308
309* Tue Aug  1 2000 Jeff Johnson <jbj@redhat.com>
310- better doco patch (#15050).
311
312* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
313- fix include-glibc/ to work with new glibc 2.2 resolver headers
314
315* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
316- automatic rebuild
317
318* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
319- FHS packaging.
320- update to ss000418.
321- perform reverse DNS lookup only once for same input.
322
323* Sun Mar  5 2000 Jeff Johnson <jbj@redhat.com>
324- include README.ifenslave doco.
325- "ping -i N" was broke for N >= 3 (#9929).
326- update to ss000121:
327-- clockdiff: preserve raw socket errno.
328-- ping: change error exit code to 1 (used to be 92,93, ...)
329-- ping,ping6: if -w specified, transmit until -c limit is reached.
330-- ping,ping6: exit code non-zero if some packets not received within deadline.
331
332* Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
333- man page corrections (#9690).
334
335* Wed Feb  9 2000 Jeff Johnson <jbj@jbj.org>
336- add ifenslave.
337
338* Thu Feb  3 2000 Elliot Lee <sopwith@redhat.com>
339- List /usr/sbin/rdisc in %files list.
340
341* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
342- add remaining binaries.
343- casts to remove compilation warnings.
344- terminate if -w deadline is reached exactly (#8724).
345
346* Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
347- create (only ping for now, traceroute et al soon).
Note: See TracBrowser for help on using the repository browser.