source: projects/specs/trunk/i/ipsec-tools/ipsec-tools-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: ipsec-tools
2Version: 0.6.7
3Release: 1%{?_dist_release}
4Summary: Tools for configuring and using IPsec
5Summary(ja): IPsecツール
6License: BSD
7Group: System Environment/Base
8URL: http://ipsec-tools.sourceforge.net/
9Source: http://prdownload.sourceforge.net/ipsec-tools/ipsec-tools-%{version}.tar.bz2
10#Source1: ipsec.h
11#Source2: pfkeyv2.h
12Source3: racoon.conf
13Source4: psk.txt
14#Source5: xfrm.h
15#Source6: udp.h
16Source7: racoon.init
17Source8: ipsec.conf
18
19Patch: ipsec-tools-0.5-libs.patch
20Patch2: isakmp.c.diff
21Patch5: ipsec-tools-0.5-64bit.patch
22Patch7: ipsec-tools-0.6.5-mls.patch
23Patch9: racoon-lspp-ipsec.patch
24
25#BuildRequires: openssl-devel, krb5-devel, bison, flex, automake, libtool
26BuildRequires: openssl-devel, bison, flex, automake, libtool, glibc-kernheaders
27#BuildRequires: libselinux-devel >= 1.30.28-2
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29#Requires: initscripts >= 7.31.11.EL-1
30Requires: initscripts
31
32Vendor: Project Vine
33Distribution: Vine Linux
34       
35%description
36This is the IPsec-Tools package.  You need this package in order to
37really use the IPsec functionality in the linux-2.5+ kernels.  This
38package builds:
39 
40        - setkey, a program to directly manipulate policies and SAs
41        - racoon, an IKEv1 keying daemon
42
43%description -l ja
44これは IPsecツールのパッケージです。Linux Kernel 2.5 以上の IPsec
45機能を使うにはこのパッケージが必要です。パッケージには以下の物が
46含まれています。
47
48        - setkey, SA と SP を操作/設定する為のプログラム
49        - racoon, IKEv1 自動鍵交換デーモン
50
51%prep
52%setup -q
53%patch -p1
54%patch2 -p1
55%patch5 -p1 -b .64bit
56#%patch7 -p1 -b .mls
57#%patch9 -p1 -b .sctx
58
59#mkdir -p kernel-headers/linux
60#cp %{SOURCE1} %{SOURCE2} %{SOURCE5} %{SOURCE6} kernel-headers/linux
61#./bootstrap
62
63%build
64sed -i 's|-Werror||g' configure
65CFLAGS="$RPM_OPT_FLAGS" %configure \
66 --sysconfdir=%{_sysconfdir}/racoon \
67 --with-kernel-headers=/usr/include \
68 --without-readline \
69 --enable-adminport \
70 --enable-hybrid \
71 --enable-frag \
72 --enable-dpd \
73 --enable-natt
74# --enable-gssapi \
75# --enable-security-context
76make
77
78%install
79rm -rf $RPM_BUILD_ROOT
80mkdir -p $RPM_BUILD_ROOT/sbin
81mkdir -p $RPM_BUILD_ROOT%{_sbindir}
82mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/racoon
83mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
84make install DESTDIR=$RPM_BUILD_ROOT
85# no devel stuff for now
86rm -rf $RPM_BUILD_ROOT%{_libdir}/libipsec.{a,la} \
87      $RPM_BUILD_ROOT%{_libdir}/libracoon.{a,la} \
88      $RPM_BUILD_ROOT%{_includedir} \
89      $RPM_BUILD_ROOT%{_mandir}/man3
90
91install -m 600 %{SOURCE3} \
92  $RPM_BUILD_ROOT%{_sysconfdir}/racoon/racoon.conf
93install -m 600 %{SOURCE4} \
94  $RPM_BUILD_ROOT%{_sysconfdir}/racoon/psk.txt
95install -m 755 %{SOURCE7} \
96  $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/racoon
97install -m 600 %{SOURCE8} \
98  $RPM_BUILD_ROOT%{_sysconfdir}/ipsec.conf
99
100mv $RPM_BUILD_ROOT%{_sbindir}/setkey $RPM_BUILD_ROOT/sbin
101
102mkdir -m 0700 -p $RPM_BUILD_ROOT%{_sysconfdir}/racoon/certs
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%files
108%defattr(-,root,root)
109%doc src/racoon/samples/racoon.conf src/racoon/samples/psk.txt
110%doc src/racoon/doc/FAQ
111%doc ChangeLog NEWS README
112/sbin/*
113%{_sbindir}/*
114%{_mandir}/man*/*
115%dir /etc/racoon
116%dir /etc/racoon/certs
117%dir /var/racoon
118%config(noreplace) %{_sysconfdir}/racoon/psk.txt
119%config(noreplace) %{_sysconfdir}/racoon/racoon.conf
120%config %{_sysconfdir}/rc.d/init.d/racoon
121%config(noreplace) %{_sysconfdir}/ipsec.conf
122
123%changelog
124* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.7-1vl5
125- applied new versioning policy, spec in utf-8
126
127* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.7-0vl1
128- new upstream release (including security fix CVE-2007-1841)
129- rebuilt with new toolchain
130
131* Wed Feb 28 2007 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 0.6.6-1vl1
132- initial build for Vine Linux
133
134* Wed Jan 17 2007 Harald Hoyer <harald@redhat.com> - 0.6.6-1
135- version 0.6.6
136
137* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 0.6.5-6
138- rebuilt for unwind info generation, broken in gcc-4.1.1-21
139
140* Mon Sep 25 2006 Harald Hoyer <harald@redhat.com> - 0.6.5-5
141- added patch for selinux integration (bug #207159)
142
143* Fri Aug  4 2006 Harald Hoyer <harald@redhat.com> - 0.6.5-4
144- backport of important 0.6.6 fixes:
145  - sets NAT-T ports to 0 if no NAT encapsulation
146  - fixed memory leak
147
148* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6.5-3.1
149- rebuild
150
151* Wed Jun 21 2006 Harald Hoyer <harald@redhat.com> - 0.6.5-3
152- more build requirements
153
154* Tue Apr 18 2006 Dan Walsh <dwalsh@redhat.com> - 0.6.5-2
155- Fix patch to build MLS Stuff correctly
156
157* Tue Apr 18 2006 Dan Walsh <dwalsh@redhat.com> - 0.6.5-1
158- Update to latest upstream version
159- Add MLS Patch to allow use of labeled networks
160- Patch provided by Joy Latten <latten@austin.ibm.com>
161
162* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.4-1.1
163- bump again for double-long bug on ppc(64)
164
165* Tue Feb 07 2006 Harald Hoyer <harald@redhat.com> 0.6.4-1
166- version 0.6.4
167
168* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.3-1.2
169- rebuilt for new gcc4.1 snapshot and glibc changes
170
171* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
172- rebuilt
173
174* Mon Dec 05 2005 Harald Hoyer <harald@redhat.com> 0.6.3-1
175- version 0.6.3, which contains fixes for various DoS problems
176
177* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> 0.6.1-2
178- rebuilt against new openssl
179
180* Wed Oct 12 2005 Harald Hoyer <harald@redhat.com> 0.6.1-1
181- version 0.6.1
182
183* Mon Mar 28 2005 Bill Nottingham <notting@redhat.com> 0.5-4
184- fix 64-bit issue in setph1attr() (<aviro@redhat.com>)
185
186* Mon Mar 14 2005 Bill Nottingham <notting@redhat.com> 0.5-3
187- add patch for DoS (CAN-2005-0398, #145532)
188
189* Sat Mar  5 2005 Uwe Beck <ubeck@c3pdm.com> 0.5-2
190- now racoon use /etc/racoon/racoon.conf as default
191- add the /var/racoon directory for racoon.sock
192
193* Wed Feb 23 2005 Bill Nottingham <notting@redhat.com> 0.5-1
194- update to 0.5
195
196* Thu Nov  4 2004 Bill Nottingham <notting@redhat.com> 0.3.3-2
197- don't use new 0.3.3 handling of stdin in setkey; it breaks the
198  format (#138105)
199
200* Mon Sep 27 2004 Bill Nottingham <notting@redhat.com> 0.3.3-1
201- update to 0.3.3 (#122211)
202
203* Sun Aug 08 2004 Alan Cox <alan@redhat.com> 0.2.5-6
204- fix buildreqs (Steve Grubb)
205
206* Mon Jun 28 2004 Nalin Dahyabhai <nalin@redhat.com> 0.2.5-5
207- rebuild
208
209* Fri Jun 25 2004 Nalin Dahyabhai <nalin@redhat.com> 0.2.5-4
210- backport certificate validation fixes from 0.3.3 (#126568)
211
212* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
213- rebuilt
214
215* Wed Apr 14 2004 Bill Nottingham <notting@redhat.com> - 0.2.5-2
216- add patch for potential remote DoS (CAN-2004-0403)
217
218* Tue Apr  6 2004 Bill Nottingham <notting@redhat.com>
219- update to 0.2.5
220
221* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
222- rebuilt
223
224* Mon Feb 23 2004 Bill Nottingham <notting@redhat.com>
225- update to 0.2.4, fix racoon install location (#116374, <kajtzu@fi.basen.net>)
226
227* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
228- rebuilt
229
230* Mon Dec  8 2003 Bill Nottingham <notting@redhat.com> 0.2.2-8
231- rebuild
232
233* Fri Aug 29 2003 Bill Nottingham <notting@redhat.com> 0.2.2-7
234- add fix for #103238
235
236* Tue Aug  5 2003 Bill Nottingham <notting@redhat.com> 0.2.2-6
237- update kernel interface bits, rebuild against them
238
239* Tue Jul 29 2003 Bill Nottingham <notting@redhat.com> 0.2.2-5
240- rebuild
241
242* Wed Jul  2 2003 Bill Notitngham <notting@redhat.com> 0.2.2-4
243- ship a much more pared-down racoon.conf and psk.txt
244
245* Thu Jun  5 2003 Bill Notitngham <notting@redhat.com> 0.2.2-3
246- update pfkey header for current kernels
247
248* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
249- rebuilt
250
251* Fri May  2 2003 Bill Nottingham <notting@redhat.com> 0.2.2-1
252- update to 0.2.2
253
254* Fri Mar  7 2003 Bill Nottingham <notting@redhat.com>
255- initial build
Note: See TracBrowser for help on using the repository browser.