source: projects/specs/trunk/i/iproute/iproute-vl.spec @ 3546

Revision 3546, 15.7 KB checked in by daisuke, 13 years ago (diff)

iproute:

  • drop tex documents (almost same as man pages...)
  • remove BR: texlive, linuxdoc-tools
  • fix %%files
Line 
1##%define date_version 070710
2%define cbq_version v0.7.3
3
4Summary: Advanced IP routing and network device configuration tools
5Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
6Name: iproute
7Version: 2.6.31
8Release: 5%{?_dist_release}
9Group: Applications/System
10Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
11URL:    http://linux-net.osdl.org/index.php/Iproute2
12Patch0: man-pages.patch
13Patch1: iproute2-2.6.29-kernel.patch
14Patch2: iproute2-ss050901-opt_flags.patch
15Patch3: iproute2-2.6.25-segfault.patch
16Patch4: iproute2-sharepath.patch
17Patch5: iproute2-2.6.31-tc_modules.patch
18Patch6: iproute2-2.6.29-IPPROTO_IP_for_SA.patch
19Patch7: iproute2-example-cbq-service.patch
20Patch8: iproute2-2.6.32-macvlan.patch
21Patch9: iproute2-2.6.33-kernel-headers.patch
22
23# VINE
24Patch100: iproute2-2.6.15-platex.patch
25
26License: GPLv2+
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28BuildRequires: flex psutils db4-devel bison
29
30
31%description
32The iproute package contains networking utilities (ip and rtmon, for
33example) which are designed to use the advanced networking
34capabilities of the Linux 2.4.x and 2.6.x kernel.
35
36%description -l ja
37このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
38ネットワーク技術を使うように設計された、ネットワーキングユーティリ
39ティが収録されています(例えばipやrtmonなどが収録されています)。
40
41
42%package devel
43Summary: Libraries, includes, etc. to develop iptables
44Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
45Group: Development/Libraries
46Requires: %{name} = %{version}
47
48%description devel
49Libraries, include files, etc you can use to develop iproute2.
50
51
52%prep
53%setup -q -n iproute2-%{version}
54%patch0 -p1
55%patch1 -p1 -b .kernel
56%patch2 -p1 -b .opt_flags
57%patch3 -p1 -b .seg
58%patch4 -p1 -b .share
59%patch5 -p1 -b .ipt
60%patch6 -p1 -b .ipproto
61%patch7 -p1 -b .fix_cbq
62%patch8 -p1 -b .macvlan
63%patch9 -p1 -b .headers
64
65%patch100 -p1 -b .platex
66
67
68%build
69export LIBDIR=%{_libdir}
70
71make %{?_smp_mflags}
72
73%install
74[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
75
76mkdir -p $RPM_BUILD_ROOT/sbin \
77        $RPM_BUILD_ROOT%{_sbindir} \
78        $RPM_BUILD_ROOT%{_mandir}/man8 \
79        $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2 \
80        $RPM_BUILD_ROOT%{_datadir}/tc \
81        $RPM_BUILD_ROOT%{_libdir}/tc \
82        $RPM_BUILD_ROOT%{_libdir}/iproute2 \
83        $RPM_BUILD_ROOT%{_includedir}/iproute2
84
85install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
86install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
87#netem is static
88#install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
89#install -m 755 tc/q_atm.so $RPM_BUILD_ROOT%{_libdir}/tc
90install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
91install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
92rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
93iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
94install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
95install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
96
97install -m 644 lib/lib*.a $RPM_BUILD_ROOT%{_libdir}/iproute2
98install -m 644 include/*.h $RPM_BUILD_ROOT%{_includedir}/iproute2
99
100install -m 644 etc/iproute2/* $RPM_BUILD_ROOT%{_sysconfdir}/iproute2
101
102cp -f etc/iproute2/* $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2
103rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
104
105#create example avpkt file
106cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/cbq-0000.example
107DEVICE=eth0,10Mbit,1Mbit
108RATE=128Kbit
109WEIGHT=10Kbit
110PRIO=5
111RULE=192.168.1.0/24
112EOF
113
114cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/avpkt
115AVPKT=3000
116EOF
117
118
119%clean
120[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
121
122
123%files
124%defattr(-,root,root,-)
125%dir %{_sysconfdir}/iproute2
126%doc README.decnet README.iproute2+tc RELNOTES
127%doc examples
128%doc iproute2-%{version}/examples
129/sbin/*
130%{_mandir}/man8/*
131%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
132%{_sbindir}/*
133%dir %{_datadir}/tc
134%{_datadir}/tc/*
135%dir %{_libdir}/tc/
136#%{_libdir}/tc/*
137%dir %{_sysconfdir}/sysconfig/cbq
138%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
139
140
141%files devel
142%defattr(-,root,root)
143%{_libdir}/iproute2/lib*.a
144%dir %{_includedir}/iproute2
145%{_includedir}/iproute2/*.h
146
147
148%changelog
149* Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
150- don't build/include documents. (almost same as man pages...)
151- remove BR: texlive ,linuxdoc-tools
152
153* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
154- rebuilt with rpm-4.8.1-3
155
156* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
157- rebuilt with gcc-4.4.3-3 on ppc
158
159* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
160- rebuilt with rpm-4.8.0-3 (on ppc)
161
162* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
163- new upstream release
164  - import patches from fedora package
165- build with db4-4.8
166
167* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
168- updated to 2.6.25 based on 2.6.25-1 from Fedora
169- build with db4-4.6.21
170- keep Patch100 from 2.6.16-1vl5
171-changelogs for previous Vine package as follows:
172  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
173  - apply new versioning policy.
174
175  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
176  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
177    (Patch10 not applied until VineSeed kernel goes higher versions)
178  - rebuilt with new toolchain and db4-4.3.x
179
180  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
181  - added Patch5 to make documents without errors
182
183  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
184  - update to 2.6.15-060110
185
186  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
187  - added BuildRequires: linuxdoc-tools
188
189  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
190  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
191
192  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
193  - new upstream release
194  - changed Group: of devel package
195  - applyed patches from Fedora development
196    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
197    - Took tons of manpages from debian, much more complete (#123952).
198  - added Japanese translation from spec translation project :-)
199
200  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
201  - 2.2.4-14vl2
202  - rename package name iproute to iproute2
203  - rebuild development version
204
205* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
206- update
207- remove patch for backward compatibility
208- add patch for AEAD compatibility
209
210* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
211- add creating ps file again. Fix was done in texlive
212
213* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
214- rebuild without tetex files. It isn't working in rawhide yet. Added
215        new source for ps files.
216- #431179 backward compatibility for previous iproute versions
217
218* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
219- rebuild with fix tetex and linuxdoc-tools -> manual pdf
220- clean unnecessary patches
221- add into spec *.so objects, new BR linux-atm-libs-devel
222
223* Tue Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
224- new version from upstrem 2.3.23
225
226* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
227- move files from /usr/lib/tc to /usr/share/tc
228- remove listing files twice
229
230* Fri Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
231- package review #225903
232
233* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
234- rebuild for new db4
235
236* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
237- upgrade to 2.6.22
238
239* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
240- fix broken tc-pfifo man page (#232891)
241
242* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
243- upgrade to 2.6.20
244
245* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
246- upgrade to 2.6.19
247
248* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
249- fix snapshot version
250
251* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
252- spec file cleanup
253- one more rebuilt against db4
254
255* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
256- fix defective manpage for tc-pfifo (#215399)
257
258* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
259- rebuilt against new db4
260
261* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
262- upgrade to upstream 2.6.18
263- initcwnd patch merged
264- bug fix for xfrm monitor
265- alignment fixes for cris
266- documentation corrections
267       
268* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
269- fix ip.8 man page, add initcwnd option
270
271* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
272- rebuilt for unwind info generation, broken in gcc-4.1.1-21
273
274* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
275- fix crash when resolving ip address
276
277* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
278- add LOWER_UP and DORMANT flags (#202199)
279- use dist tag
280
281* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
282- rebuild
283
284* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
285- improve handling of initcwnd value (#179719)
286
287* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
288- fix BuildRequires: flex (#193403)
289
290* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
291- upgrade to 2.6.16-060323
292- don't hardcode /usr/lib in tc (#186607)
293
294* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
295- own /usr/lib/tc (#181953)
296- obsoletes shapecfg (#182284)
297
298* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
299- bump again for double-long bug on ppc(64)
300
301* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
302- rebuilt for new gcc4.1 snapshot and glibc changes
303
304* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
305- upgrade to 2.6.15-060110
306
307* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
308- rebuilt
309
310* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
311- remove backup of config files (#175302)
312
313* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
314- use tc manpages and cbq.init from source tarball (#172851)
315
316* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
317- new upstream source
318
319* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
320- add warning to ip tunnel add command (#128107)
321
322* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
323- update from upstream (appears to fix #170111)
324
325* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
326- update from upstream
327- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
328
329* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
330- add RPM_OPT_FLAGS
331
332* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
333- forget to apply the patch :(
334
335* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
336- make ip help work again (#168449)
337
338* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
339- upgrade to ss050901 for 2.6.14 kernel headers
340
341* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
342- added /sbin/cbq script and sample configuration files (#166301)
343
344* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
345- upgrade to iproute2-050816
346
347* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
348- update to snapshot for 2.6.13+ kernel
349
350* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
351- removed useless initvar patch (#150798)
352- new upstream source
353
354* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
355- update to iproute-2.6.11
356
357* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
358- gcc4 rebuilt
359
360* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
361- update to iproute-2.6.10
362
363* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
364- added arpd into sbin
365
366* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
367- debug info removed from makefile and from spec (#140891)
368
369* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
370- source file updated from snapshot version
371- endian patch adding <endian.h>
372
373* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
374- added installation of netem module for tc
375
376* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
377- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
378
379* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
380- updated to iproute-2.6.9, spec file change, patches cleared
381
382* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
383- rebuilt
384
385* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
386- Took tons of manpages from debian, much more complete (#123952).
387
388* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
389- rebuilt
390
391* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
392- Built security errata version for FC1.
393
394* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
395- Fixed -f option for ss (#118355).
396- Small description fix (#110997).
397- Added initialization of some vars (#74961).
398- Added patch to initialize "default" rule as well (#60693).
399
400* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
401- rebuilt
402
403* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
404- Security errata for netlink (CAN-2003-0856).
405
406* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
407- Updated to latest version. Used by other distros, so seems stable. ;-)
408- Quite a few patches needed updating in that turn.
409- Added ss (#107363) and several other new nifty tools.
410
411* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
412- rebuilt
413
414* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
415- rebuilt
416
417* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
418- rebuilt
419
420* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
421- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
422
423* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
424- remove flags patch at author's request
425
426* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
427- automated rebuild
428
429* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
430- Don't forcibly strip binaries
431
432* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
433- Fixed missing diffserv and atm support in config (#57278).
434- Fixed inconsistent numeric base problem for command line (#65473).
435
436* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
437- Added patch to fix crosscompiling by Adrian Linkins.
438
439* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
440- Update to latest stable release 2.4.7-now-ss010824.
441- Added simple man page for ip.
442
443* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
444- allow setting of allmulti & promisc flags (#48669)
445
446* Mon Jul 02 2001 Than Ngo <than@redhat.com>
447- fix build problem in beehive if kernel-sources is not installed
448
449* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
450- updated to iproute2-2.2.4-now-ss001007.tar.gz
451- bzip2 source tar file
452- "License" replaces "Copyright"
453- added "BuildPrereq: tetex-latex tetex-dvips psutils"
454- rebuilt for 7.2
455
456* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
457- use the system headers - the included ones are broken
458- ETH_P_ECHO went away
459
460* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
461- test for specific KERNEL_INCLUDE directories.
462
463* Thu Oct 12 2000 Than Ngo <than@redhat.com>
464- rebuild for 7.1
465
466* Thu Oct 12 2000 Than Ngo <than@redhat.com>
467- add default configuration files for iproute (Bug #10549, #18887)
468
469* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
470- fix include-glibc/ to cope with glibc 2.2 new resolver headers
471
472* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
473- automatic rebuild
474
475* Sun Jun 18 2000 Than Ngo <than@redhat.de>
476- rebuilt in the new build environment
477- use RPM macros
478- handle RPM_OPT_FLAGS
479
480* Sat Jun 03 2000 Than Ngo <than@redhat.de>
481- fix iproute to build with new glibc
482
483* Fri May 26 2000 Ngo Than <than@redhat.de>
484- update to 2.2.4-now-ss000305
485- add configuration files
486
487* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
488- strip binaries
489
490* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
491- first build
Note: See TracBrowser for help on using the repository browser.