source: projects/specs/trunk/i/iproute/iproute-vl.spec @ 521

Revision 521, 15.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1##%define date_version 070710
2%define cbq_version v0.7.3
3
4Summary: Advanced IP routing and network device configuration tools
5Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
6Name: iproute
7Version: 2.6.31
8Release: 3%{?_dist_release}
9Group: Applications/System
10Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
11#Source1: iproute-doc-2.6.22.tar.gz
12URL:    http://linux-net.osdl.org/index.php/Iproute2
13Patch0: man-pages.patch
14Patch1: iproute2-2.6.29-kernel.patch
15Patch2: iproute2-ss050901-opt_flags.patch
16Patch3: iproute2-2.6.25-segfault.patch
17Patch4: iproute2-sharepath.patch
18Patch5: iproute2-2.6.31-tc_modules.patch
19Patch6: iproute2-2.6.29-IPPROTO_IP_for_SA.patch
20Patch7: iproute2-example-cbq-service.patch
21Patch8: iproute2-2.6.32-macvlan.patch
22Patch9: iproute2-2.6.33-kernel-headers.patch
23
24# VINE
25Patch100: iproute2-2.6.15-platex.patch
26
27License: GPLv2+
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
29BuildRequires: tetex linuxdoc-tools
30BuildRequires: flex psutils db4-devel bison
31
32
33%description
34The iproute package contains networking utilities (ip and rtmon, for
35example) which are designed to use the advanced networking
36capabilities of the Linux 2.4.x and 2.6.x kernel.
37
38%description -l ja
39このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
40ネットワーク技術を使うように設計された、ネットワーキングユーティリ
41ティが収録されています(例えばipやrtmonなどが収録されています)。
42
43
44%package devel
45Summary: Libraries, includes, etc. to develop iptables
46Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
47Group: Development/Libraries
48Requires: %{name} = %{version}
49
50%description devel
51Libraries, include files, etc you can use to develop iproute2.
52
53
54%prep
55%setup -q -n iproute2-%{version}
56%patch0 -p1
57%patch1 -p1 -b .kernel
58%patch2 -p1 -b .opt_flags
59%patch3 -p1 -b .seg
60%patch4 -p1 -b .share
61%patch5 -p1 -b .ipt
62%patch6 -p1 -b .ipproto
63%patch7 -p1 -b .fix_cbq
64%patch8 -p1 -b .macvlan
65%patch9 -p1 -b .headers
66
67%patch100 -p1 -b .platex
68
69
70%build
71export LIBDIR=%{_libdir}
72
73make %{?_smp_mflags}
74make -C doc
75
76
77%install
78[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
79
80mkdir -p $RPM_BUILD_ROOT/sbin \
81        $RPM_BUILD_ROOT%{_sbindir} \
82        $RPM_BUILD_ROOT%{_mandir}/man8 \
83        $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2 \
84        $RPM_BUILD_ROOT%{_datadir}/tc \
85        $RPM_BUILD_ROOT%{_libdir}/tc \
86        $RPM_BUILD_ROOT%{_libdir}/iproute2 \
87        $RPM_BUILD_ROOT%{_includedir}/iproute2
88
89install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
90install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
91#netem is static
92#install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
93#install -m 755 tc/q_atm.so $RPM_BUILD_ROOT%{_libdir}/tc
94install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
95install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
96rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
97iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
98install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
99install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
100
101install -m 644 lib/lib*.a $RPM_BUILD_ROOT%{_libdir}/iproute2
102install -m 644 include/*.h $RPM_BUILD_ROOT%{_includedir}/iproute2
103
104install -m 644 etc/iproute2/* $RPM_BUILD_ROOT%{_sysconfdir}/iproute2
105
106cp -f etc/iproute2/* $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2
107rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
108
109#copy the tex file from source for time when tex was broken
110#source1 was created from last functional version
111#tar -xvzf %{SOURCE1}
112#mkdir -p $RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}-%{version}
113#cd %{name}-doc-2.6.22
114#cp -pR *.ps ../doc
115
116#create example avpkt file
117cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/cbq-0000.example
118DEVICE=eth0,10Mbit,1Mbit
119RATE=128Kbit
120WEIGHT=10Kbit
121PRIO=5
122RULE=192.168.1.0/24
123EOF
124
125cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/avpkt
126AVPKT=3000
127EOF
128
129
130%clean
131[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
132
133
134%files
135%defattr(-,root,root,-)
136%dir %{_sysconfdir}/iproute2
137%doc iproute2-%{version}/README.decnet iproute2-%{version}/README.iproute2+tc iproute2-%{version}/RELNOTES iproute2-%{version}/examples/README.cbq
138%doc iproute2-%{version}/doc/*.ps
139%doc iproute2-%{version}/examples
140/sbin/*
141%{_mandir}/man8/*
142%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
143%{_sbindir}/*
144%dir %{_datadir}/tc
145%{_datadir}/tc/*
146%dir %{_libdir}/tc/
147#%{_libdir}/tc/*
148%dir %{_sysconfdir}/sysconfig/cbq
149%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
150
151
152%files devel
153%defattr(-,root,root)
154%{_libdir}/iproute2/lib*.a
155%dir %{_includedir}/iproute2
156%{_includedir}/iproute2/*.h
157
158
159%changelog
160* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
161- rebuilt with gcc-4.4.3-3 on ppc
162
163* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
164- rebuilt with rpm-4.8.0-3 (on ppc)
165
166* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
167- new upstream release
168  - import patches from fedora package
169- build with db4-4.8
170
171* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
172- updated to 2.6.25 based on 2.6.25-1 from Fedora
173- build with db4-4.6.21
174- keep Patch100 from 2.6.16-1vl5
175-changelogs for previous Vine package as follows:
176  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
177  - apply new versioning policy.
178
179  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
180  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
181    (Patch10 not applied until VineSeed kernel goes higher versions)
182  - rebuilt with new toolchain and db4-4.3.x
183
184  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
185  - added Patch5 to make documents without errors
186
187  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
188  - update to 2.6.15-060110
189
190  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
191  - added BuildRequires: linuxdoc-tools
192
193  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
194  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
195
196  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
197  - new upstream release
198  - changed Group: of devel package
199  - applyed patches from Fedora development
200    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
201    - Took tons of manpages from debian, much more complete (#123952).
202  - added Japanese translation from spec translation project :-)
203
204  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
205  - 2.2.4-14vl2
206  - rename package name iproute to iproute2
207  - rebuild development version
208
209* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
210- update
211- remove patch for backward compatibility
212- add patch for AEAD compatibility
213
214* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
215- add creating ps file again. Fix was done in texlive
216
217* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
218- rebuild without tetex files. It isn't working in rawhide yet. Added
219        new source for ps files.
220- #431179 backward compatibility for previous iproute versions
221
222* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
223- rebuild with fix tetex and linuxdoc-tools -> manual pdf
224- clean unnecessary patches
225- add into spec *.so objects, new BR linux-atm-libs-devel
226
227* Tue Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
228- new version from upstrem 2.3.23
229
230* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
231- move files from /usr/lib/tc to /usr/share/tc
232- remove listing files twice
233
234* Fri Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
235- package review #225903
236
237* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
238- rebuild for new db4
239
240* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
241- upgrade to 2.6.22
242
243* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
244- fix broken tc-pfifo man page (#232891)
245
246* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
247- upgrade to 2.6.20
248
249* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
250- upgrade to 2.6.19
251
252* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
253- fix snapshot version
254
255* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
256- spec file cleanup
257- one more rebuilt against db4
258
259* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
260- fix defective manpage for tc-pfifo (#215399)
261
262* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
263- rebuilt against new db4
264
265* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
266- upgrade to upstream 2.6.18
267- initcwnd patch merged
268- bug fix for xfrm monitor
269- alignment fixes for cris
270- documentation corrections
271       
272* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
273- fix ip.8 man page, add initcwnd option
274
275* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
276- rebuilt for unwind info generation, broken in gcc-4.1.1-21
277
278* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
279- fix crash when resolving ip address
280
281* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
282- add LOWER_UP and DORMANT flags (#202199)
283- use dist tag
284
285* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
286- rebuild
287
288* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
289- improve handling of initcwnd value (#179719)
290
291* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
292- fix BuildRequires: flex (#193403)
293
294* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
295- upgrade to 2.6.16-060323
296- don't hardcode /usr/lib in tc (#186607)
297
298* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
299- own /usr/lib/tc (#181953)
300- obsoletes shapecfg (#182284)
301
302* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
303- bump again for double-long bug on ppc(64)
304
305* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
306- rebuilt for new gcc4.1 snapshot and glibc changes
307
308* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
309- upgrade to 2.6.15-060110
310
311* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
312- rebuilt
313
314* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
315- remove backup of config files (#175302)
316
317* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
318- use tc manpages and cbq.init from source tarball (#172851)
319
320* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
321- new upstream source
322
323* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
324- add warning to ip tunnel add command (#128107)
325
326* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
327- update from upstream (appears to fix #170111)
328
329* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
330- update from upstream
331- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
332
333* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
334- add RPM_OPT_FLAGS
335
336* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
337- forget to apply the patch :(
338
339* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
340- make ip help work again (#168449)
341
342* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
343- upgrade to ss050901 for 2.6.14 kernel headers
344
345* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
346- added /sbin/cbq script and sample configuration files (#166301)
347
348* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
349- upgrade to iproute2-050816
350
351* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
352- update to snapshot for 2.6.13+ kernel
353
354* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
355- removed useless initvar patch (#150798)
356- new upstream source
357
358* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
359- update to iproute-2.6.11
360
361* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
362- gcc4 rebuilt
363
364* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
365- update to iproute-2.6.10
366
367* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
368- added arpd into sbin
369
370* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
371- debug info removed from makefile and from spec (#140891)
372
373* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
374- source file updated from snapshot version
375- endian patch adding <endian.h>
376
377* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
378- added installation of netem module for tc
379
380* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
381- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
382
383* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
384- updated to iproute-2.6.9, spec file change, patches cleared
385
386* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
387- rebuilt
388
389* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
390- Took tons of manpages from debian, much more complete (#123952).
391
392* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
393- rebuilt
394
395* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
396- Built security errata version for FC1.
397
398* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
399- Fixed -f option for ss (#118355).
400- Small description fix (#110997).
401- Added initialization of some vars (#74961).
402- Added patch to initialize "default" rule as well (#60693).
403
404* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
405- rebuilt
406
407* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
408- Security errata for netlink (CAN-2003-0856).
409
410* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
411- Updated to latest version. Used by other distros, so seems stable. ;-)
412- Quite a few patches needed updating in that turn.
413- Added ss (#107363) and several other new nifty tools.
414
415* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
416- rebuilt
417
418* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
419- rebuilt
420
421* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
422- rebuilt
423
424* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
425- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
426
427* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
428- remove flags patch at author's request
429
430* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
431- automated rebuild
432
433* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
434- Don't forcibly strip binaries
435
436* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
437- Fixed missing diffserv and atm support in config (#57278).
438- Fixed inconsistent numeric base problem for command line (#65473).
439
440* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
441- Added patch to fix crosscompiling by Adrian Linkins.
442
443* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
444- Update to latest stable release 2.4.7-now-ss010824.
445- Added simple man page for ip.
446
447* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
448- allow setting of allmulti & promisc flags (#48669)
449
450* Mon Jul 02 2001 Than Ngo <than@redhat.com>
451- fix build problem in beehive if kernel-sources is not installed
452
453* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
454- updated to iproute2-2.2.4-now-ss001007.tar.gz
455- bzip2 source tar file
456- "License" replaces "Copyright"
457- added "BuildPrereq: tetex-latex tetex-dvips psutils"
458- rebuilt for 7.2
459
460* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
461- use the system headers - the included ones are broken
462- ETH_P_ECHO went away
463
464* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
465- test for specific KERNEL_INCLUDE directories.
466
467* Thu Oct 12 2000 Than Ngo <than@redhat.com>
468- rebuild for 7.1
469
470* Thu Oct 12 2000 Than Ngo <than@redhat.com>
471- add default configuration files for iproute (Bug #10549, #18887)
472
473* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
474- fix include-glibc/ to cope with glibc 2.2 new resolver headers
475
476* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
477- automatic rebuild
478
479* Sun Jun 18 2000 Than Ngo <than@redhat.de>
480- rebuilt in the new build environment
481- use RPM macros
482- handle RPM_OPT_FLAGS
483
484* Sat Jun 03 2000 Than Ngo <than@redhat.de>
485- fix iproute to build with new glibc
486
487* Fri May 26 2000 Ngo Than <than@redhat.de>
488- update to 2.2.4-now-ss000305
489- add configuration files
490
491* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
492- strip binaries
493
494* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
495- first build
Note: See TracBrowser for help on using the repository browser.