source: projects/specs/trunk/i/iproute/iproute-vl.spec @ 11533

Revision 11533, 18.4 KB checked in by tomop, 6 years ago (diff)

iproute-4.14.1-2

Line 
1%bcond_without tipc
2%bcond_with texdoc
3%define cbq_version v0.7.3
4
5Summary: Advanced IP routing and network device configuration tools
6Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
7Name: iproute
8Version: 4.14.1
9Release: 2%{?_dist_release}
10Group: Applications/System
11Source: https://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
12URL: http://kernel.org/pub/linux/utils/net/%{name}2/
13Source1: cbq-0000.example
14Source2: avpkt
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19# http://www.spinics.net/lists/netdev/msg325114.html
20Patch1:             iproute2-3.19.0-docs.patch
21
22# VINE
23Patch100: iproute2-3.14.0-platex.patch
24
25License: GPLv2+ and Public Domain
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27BuildRequires: bison flex
28BuildRequires: iptables-devel >= 1.4.10, libdb-devel
29BuildRequires: pkgconfig
30%if %{with texdoc}
31BuildRequires: texlive-collection-fontsrecommended
32BuildRequires: texlive-collection-latexrecommended
33BuildRequires: texlive-collection-langafrican
34BuildRequires: texlive-collection-langarabic
35BuildRequires: texlive-collection-langchinese
36BuildRequires: texlive-collection-langczechslovak
37BuildRequires: texlive-collection-langenglish
38BuildRequires: texlive-collection-langeuropean
39BuildRequires: texlive-collection-langfrench
40BuildRequires: texlive-collection-langindic
41BuildRequires: texlive-collection-langitalian
42BuildRequires: texlive-collection-langkorean
43BuildRequires: texlive-collection-langpolish
44BuildRequires: texlive-collection-langportuguese
45BuildRequires: texlive-collection-langspanish
46BuildRequires: texlive-collection-langother
47BuildRequires: linuxdoc-tools psutils
48%endif
49%if %{with tipc}
50BuildRequires: libmnl-devel
51%endif
52
53Requires: iptables >= 1.4.10
54
55%description
56The iproute package contains networking utilities (ip and rtmon, for
57example) which are designed to use the advanced networking
58capabilities of the Linux 2.4.x and 2.6.x kernel.
59
60%description -l ja
61このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
62ネットワーク技術を使うように設計された、ネットワーキングユーティリ
63ティ(ip, rtmon等々)が収録されています。
64
65%package doc
66Summary: ip and tc documentation with examples
67Summary(ja): ip, tcのドキュメントとサンプル
68Group: Applications/System
69License: GPLv2+
70
71%description doc
72The iproute documentation contains howtos and examples of settings.
73
74%package devel
75Summary: Libraries, includes, etc. to develop iptables
76Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
77Group: Development/Libraries
78Requires: %{name} = %{version}
79
80%description devel
81Libraries, include files, etc you can use to develop iproute2.
82
83
84%prep
85%setup -q -n iproute2-%{version}
86%if %{with texdoc}
87%patch1 -p1 -b .doc
88%patch100 -p1 -b .platex
89%endif
90
91%build
92export CFLAGS="%{optflags}"
93export LIBDIR=/%{_libdir}
94export IPT_LIB_DIR=/%{_lib}/xtables
95./configure
96make %{?_smp_mflags}
97%if %{with texdoc}
98#make -C doc
99%endif
100
101%install
102[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
103
104mkdir -p \
105    %{buildroot}%{_includedir} \
106    %{buildroot}/sbin \
107    %{buildroot}%{_sbindir} \
108    %{buildroot}%{_mandir}/man3 \
109    %{buildroot}%{_mandir}/man7 \
110    %{buildroot}%{_mandir}/man8 \
111    %{buildroot}%{_libdir}/tc \
112    %{buildroot}%{_sysconfdir}/iproute2/{rt_protos.d,rt_tables.d} \
113    %{buildroot}%{_sysconfdir}/sysconfig/cbq
114
115for binary in \
116    ip/ifcfg \
117    ip/ip \
118    ip/rtmon \
119    tc/tc
120    do install -m755 ${binary} %{buildroot}/sbin/
121done
122
123install -m755 examples/cbq.init-%{cbq_version} %{buildroot}/sbin/cbq
124
125for binary in \
126    bridge/bridge \
127    genl/genl \
128    ip/routef \
129    ip/routel \
130    ip/rtpr \
131%if %{with tipc}
132    tipc/tipc \
133%endif
134    misc/arpd \
135    misc/ifstat \
136    misc/lnstat \
137    misc/nstat \
138    misc/rtacct \
139    misc/ss
140    do install -m755 ${binary} %{buildroot}%{_sbindir}
141done
142
143cd %{buildroot}%{_sbindir}
144    ln -s lnstat ctstat
145    ln -s lnstat rtstat
146cd -
147
148# Libs
149install -m644 netem/*.dist %{buildroot}%{_libdir}/tc
150install -m755 tc/m_xt.so %{buildroot}%{_libdir}/tc
151cd %{buildroot}%{_libdir}/tc
152    ln -s m_xt.so m_ipt.so
153cd -
154
155# libnetlink
156install -m644 include/libnetlink.h %{buildroot}%{_includedir}
157install -m644 lib/libnetlink.a %{buildroot}%{_libdir}
158
159# Manpages
160iconv -f latin1 -t utf8 man/man8/ss.8 > man/man8/ss.8.utf8 &&
161    mv man/man8/ss.8.utf8 man/man8/ss.8
162install -m644 man/man3/*.3 %{buildroot}%{_mandir}/man3
163install -m644 man/man7/*.7 %{buildroot}%{_mandir}/man7
164install -m644 man/man8/*.8 %{buildroot}%{_mandir}/man8
165
166# Config files
167for f in `find etc/iproute2/ -maxdepth 1 -type f`;
168    do install -m644 $f %{buildroot}%{_sysconfdir}/iproute2
169done
170
171install -m644 etc/iproute2/rt_protos.d/* %{buildroot}%{_sysconfdir}/iproute2/rt_protos.d/
172
173install -m644 etc/iproute2/rt_tables.d/* %{buildroot}%{_sysconfdir}/iproute2/rt_tables.d/
174
175for config in \
176    %{SOURCE1} \
177    %{SOURCE2}
178    do install -m644 ${config} %{buildroot}%{_sysconfdir}/sysconfig/cbq
179done
180
181
182%clean
183[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
184
185
186%files
187%dir %{_sysconfdir}/iproute2
188%dir %{_sysconfdir}/iproute2/rt_protos.d
189%dir %{_sysconfdir}/iproute2/rt_tables.d
190%doc COPYING
191%doc README README.decnet README.iproute2+tc README.distribution README.lnstat
192%{_mandir}/man7/*
193%{_mandir}/man8/*
194%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/bpf_pinning
195%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/ematch_map
196%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/group
197%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/nl_protos
198%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_dsfield
199%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_protos
200%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_realms
201%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_scopes
202%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_tables
203%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_protos.d/*
204%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_tables.d/*
205/sbin/*
206%{_sbindir}/*
207%dir %{_libdir}/tc/
208%{_libdir}/tc/*
209%dir %{_sysconfdir}/sysconfig/cbq
210%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
211
212%files doc
213%doc COPYING
214%doc doc/*
215%doc examples
216
217%files devel
218%doc COPYING
219%{_mandir}/man3/*
220%{_libdir}/libnetlink.a
221%{_includedir}/libnetlink.h
222
223
224%changelog
225* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.14.1-2
226- rebuilt with iptables-1.6.
227
228* Fri Dec 01 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.14.1-1
229- new upstream release.
230- dropped TeX docs.
231
232* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.1-1
233- new upstream release.
234- dropped all patches and imported from fc23.
235
236* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.14.0-1
237- new upstream release.
238- replaced Patch100.
239
240* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.38-1
241- update to 2.6.38.1
242- build with iptables-1.4.10
243- add BR: iptables-devel
244
245* Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
246- don't build/include documents. (almost same as man pages...)
247- remove BR: texlive ,linuxdoc-tools
248
249* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
250- rebuilt with rpm-4.8.1-3
251
252* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
253- rebuilt with gcc-4.4.3-3 on ppc
254
255* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
256- rebuilt with rpm-4.8.0-3 (on ppc)
257
258* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
259- new upstream release
260  - import patches from fedora package
261- build with db4-4.8
262
263* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
264- updated to 2.6.25 based on 2.6.25-1 from Fedora
265- build with db4-4.6.21
266- keep Patch100 from 2.6.16-1vl5
267-changelogs for previous Vine package as follows:
268  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
269  - apply new versioning policy.
270
271  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
272  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
273    (Patch10 not applied until VineSeed kernel goes higher versions)
274  - rebuilt with new toolchain and db4-4.3.x
275
276  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
277  - added Patch5 to make documents without errors
278
279  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
280  - update to 2.6.15-060110
281
282  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
283  - added BuildRequires: linuxdoc-tools
284
285  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
286  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
287
288  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
289  - new upstream release
290  - changed Group: of devel package
291  - applyed patches from Fedora development
292    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
293    - Took tons of manpages from debian, much more complete (#123952).
294  - added Japanese translation from spec translation project :-)
295
296  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
297  - 2.2.4-14vl2
298  - rename package name iproute to iproute2
299  - rebuild development version
300
301* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
302- update
303- remove patch for backward compatibility
304- add patch for AEAD compatibility
305
306* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
307- add creating ps file again. Fix was done in texlive
308
309* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
310- rebuild without tetex files. It isn't working in rawhide yet. Added
311        new source for ps files.
312- #431179 backward compatibility for previous iproute versions
313
314* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
315- rebuild with fix tetex and linuxdoc-tools -> manual pdf
316- clean unnecessary patches
317- add into spec *.so objects, new BR linux-atm-libs-devel
318
319* Wed Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
320- new version from upstrem 2.3.23
321
322* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
323- move files from /usr/lib/tc to /usr/share/tc
324- remove listing files twice
325
326* Thu Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
327- package review #225903
328
329* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
330- rebuild for new db4
331
332* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
333- upgrade to 2.6.22
334
335* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
336- fix broken tc-pfifo man page (#232891)
337
338* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
339- upgrade to 2.6.20
340
341* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
342- upgrade to 2.6.19
343
344* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
345- fix snapshot version
346
347* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
348- spec file cleanup
349- one more rebuilt against db4
350
351* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
352- fix defective manpage for tc-pfifo (#215399)
353
354* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
355- rebuilt against new db4
356
357* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
358- upgrade to upstream 2.6.18
359- initcwnd patch merged
360- bug fix for xfrm monitor
361- alignment fixes for cris
362- documentation corrections
363       
364* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
365- fix ip.8 man page, add initcwnd option
366
367* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
368- rebuilt for unwind info generation, broken in gcc-4.1.1-21
369
370* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
371- fix crash when resolving ip address
372
373* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
374- add LOWER_UP and DORMANT flags (#202199)
375- use dist tag
376
377* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
378- rebuild
379
380* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
381- improve handling of initcwnd value (#179719)
382
383* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
384- fix BuildRequires: flex (#193403)
385
386* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
387- upgrade to 2.6.16-060323
388- don't hardcode /usr/lib in tc (#186607)
389
390* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
391- own /usr/lib/tc (#181953)
392- obsoletes shapecfg (#182284)
393
394* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
395- bump again for double-long bug on ppc(64)
396
397* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
398- rebuilt for new gcc4.1 snapshot and glibc changes
399
400* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
401- upgrade to 2.6.15-060110
402
403* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
404- rebuilt
405
406* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
407- remove backup of config files (#175302)
408
409* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
410- use tc manpages and cbq.init from source tarball (#172851)
411
412* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
413- new upstream source
414
415* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
416- add warning to ip tunnel add command (#128107)
417
418* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
419- update from upstream (appears to fix #170111)
420
421* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
422- update from upstream
423- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
424
425* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
426- add RPM_OPT_FLAGS
427
428* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
429- forget to apply the patch :(
430
431* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
432- make ip help work again (#168449)
433
434* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
435- upgrade to ss050901 for 2.6.14 kernel headers
436
437* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
438- added /sbin/cbq script and sample configuration files (#166301)
439
440* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
441- upgrade to iproute2-050816
442
443* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
444- update to snapshot for 2.6.13+ kernel
445
446* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
447- removed useless initvar patch (#150798)
448- new upstream source
449
450* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
451- update to iproute-2.6.11
452
453* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
454- gcc4 rebuilt
455
456* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
457- update to iproute-2.6.10
458
459* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
460- added arpd into sbin
461
462* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
463- debug info removed from makefile and from spec (#140891)
464
465* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
466- source file updated from snapshot version
467- endian patch adding <endian.h>
468
469* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
470- added installation of netem module for tc
471
472* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
473- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
474
475* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
476- updated to iproute-2.6.9, spec file change, patches cleared
477
478* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
479- rebuilt
480
481* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
482- Took tons of manpages from debian, much more complete (#123952).
483
484* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
485- rebuilt
486
487* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
488- Built security errata version for FC1.
489
490* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
491- Fixed -f option for ss (#118355).
492- Small description fix (#110997).
493- Added initialization of some vars (#74961).
494- Added patch to initialize "default" rule as well (#60693).
495
496* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
497- rebuilt
498
499* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
500- Security errata for netlink (CAN-2003-0856).
501
502* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
503- Updated to latest version. Used by other distros, so seems stable. ;-)
504- Quite a few patches needed updating in that turn.
505- Added ss (#107363) and several other new nifty tools.
506
507* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
508- rebuilt
509
510* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
511- rebuilt
512
513* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
514- rebuilt
515
516* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
517- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
518
519* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
520- remove flags patch at author's request
521
522* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
523- automated rebuild
524
525* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
526- Don't forcibly strip binaries
527
528* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
529- Fixed missing diffserv and atm support in config (#57278).
530- Fixed inconsistent numeric base problem for command line (#65473).
531
532* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
533- Added patch to fix crosscompiling by Adrian Linkins.
534
535* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
536- Update to latest stable release 2.4.7-now-ss010824.
537- Added simple man page for ip.
538
539* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
540- allow setting of allmulti & promisc flags (#48669)
541
542* Mon Jul 02 2001 Than Ngo <than@redhat.com>
543- fix build problem in beehive if kernel-sources is not installed
544
545* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
546- updated to iproute2-2.2.4-now-ss001007.tar.gz
547- bzip2 source tar file
548- "License" replaces "Copyright"
549- added "BuildPrereq: tetex-latex tetex-dvips psutils"
550- rebuilt for 7.2
551
552* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
553- use the system headers - the included ones are broken
554- ETH_P_ECHO went away
555
556* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
557- test for specific KERNEL_INCLUDE directories.
558
559* Thu Oct 12 2000 Than Ngo <than@redhat.com>
560- rebuild for 7.1
561
562* Thu Oct 12 2000 Than Ngo <than@redhat.com>
563- add default configuration files for iproute (Bug #10549, #18887)
564
565* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
566- fix include-glibc/ to cope with glibc 2.2 new resolver headers
567
568* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
569- automatic rebuild
570
571* Sun Jun 18 2000 Than Ngo <than@redhat.de>
572- rebuilt in the new build environment
573- use RPM macros
574- handle RPM_OPT_FLAGS
575
576* Sat Jun 03 2000 Than Ngo <than@redhat.de>
577- fix iproute to build with new glibc
578
579* Fri May 26 2000 Ngo Than <than@redhat.de>
580- update to 2.2.4-now-ss000305
581- add configuration files
582
583* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
584- strip binaries
585
586* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
587- first build
Note: See TracBrowser for help on using the repository browser.